foto2004
Goto Top

ProFTP passive über Port 20, wie?

Hallo Gemeinde,

ich versuche den proFTP auf einem debian11, der hinter einem nginx Proxy ist,
dazu zu bringen dass er für den passive Mod den Port 21 nimmt, leider klappt das nicht so richtig.
wenn ich in der Config angebe,

"PassivePorts 20 20"

motzt er weil er nicht 2 gleiche haben möchte mache ich da was Anderes mit unterschiedlichen rein geht es aber eben nur wenig z. B.:

"PassivePorts 1025 1026"

nun motzen aber die FTP Clients dass diese Ports nicht routbar sind.

An und führ sich funktioniert der FTP halt er nimmt nur nicht die Einstellung für die PassivePorts. Ich schau das mit iptraf nach welche Ports da geöffnet und Verkehr drauf ist.

Nun meine Frage, hab ich da was übersehen?

Content-Key: 71410983004

Url: https://administrator.de/contentid/71410983004

Printed on: July 19, 2024 at 17:07 o'clock

Mitglied: 8585324113
8585324113 Sep 23, 2023 at 10:09:04 (UTC)
Goto Top
Wer , was wo motzt? Der Proxy?
Member: foto2004
foto2004 Sep 23, 2023 at 10:13:33 (UTC)
Goto Top
na wenn ich mit FileZilla die Verbindung aufbaue kommt:

Vom Server gesendete Adresse für den Passiv-Modus ist nicht routingfähig. Benutze stattdessen die Serveradresse.
Member: foto2004
foto2004 Sep 23, 2023 at 10:27:10 (UTC)
Goto Top
wenn ich local zugreife "nicht von aussen über den Proxy" geht es.
Ich vermute dass ich dem proFTP da noch was zusätzliches einstellen muss aber ich finde nichts.

Beim FileZilla Server (andere Installation auf Wind...) musste ich ihm noch die IP vom Proxy sagen dass er davon eine Verbindung im PassiveMod akzeptiert
Mitglied: 8585324113
8585324113 Sep 23, 2023 at 10:53:30 (UTC)
Goto Top
Dass das FTP den Proxy passieren muss, willst du wirklich so haben? Deine Proxy-Konfig ist für den Port korrekt?
Member: LordGurke
Solution LordGurke Sep 23, 2023 at 11:47:04 (UTC)
Goto Top
Ein FTP-Server teilt nicht nur Ports sondern auch IPs mit.
ProfFTPd kennt aber natürlich nur die (lokalen) IP-Adressen, die er selbst gebunden hat und nicht die, die man benutzen müsste um auf den Proxy zu verbinden. Der Client im Internet bekommt jetzt eine IP mitgeteilt, die ProFTPd auf seinem lokalen Interface hat, mit der der Client aber nichts anfangen kann.

Du willst deshalb die Außen-IP deines Proxy in der proftpd-Config mit MasqueradeAddress angeben.
Dann übermittelt der FTP-Server die korrekte IP an den Client.

Die Frage ist aber auch: MUSS es denn wirklich klassisches FTP sein?
Je nach Anwendungsfall wäre es in vieler Hinsicht sinnvoller SFTP zu verwenden. Das benutzt nur einen Port und ist verschlüsselt.

P.S.: Es ist der Passive Mode, nicht "mod" face-wink
Member: aqui
aqui Sep 23, 2023 at 13:35:35 (UTC)
Goto Top
https://support.hostway.com/hc/en-us/articles/360000563730-How-to-enable ...
http://www.proftpd.org/docs/howto/NAT.html
Deutlich besser ist die Lösung von @LordGurke weil du per FTP ungeschützt Daten überträgst.
Alternative wäre noch SCP mit z.B. WinSCP als Client.
Member: foto2004
foto2004 Sep 23, 2023 updated at 19:30:05 (UTC)
Goto Top
Danke für die Tips.
Das mit dem MasqueradeAddress war die Lösung.
Ja leider muss es ein klassisches ftp sein geht nicht anders weil da noch "alte Anwendungen" den benutzen. Ja ich weiß sollte man ändern, nur leider habe ich die Anwendung nicht geschrieben.