Robocopy - Verzeichnisse per Exclude-Datei aussteuern

Robocopy - Verzeichnisse per Exclude-Datei aussteuern

Hallo,

wie kann ich bei Robocopy bestimmte Verzeichnisse aussteuern? Bei xcopy geht dies ja so /exclude:C:\nichtkopieren.txt

Gibt es hierzu auch einen ähnlichen Schalter?

bei /xd kann ich diverse Ordner angeben - geht aber auch eine Datei?

Grüße

Content-Key: 158823

Url: https://administrator.de/contentid/158823

Ausgedruckt am: 28.09.2021 um 23:09 Uhr

Mitglied: TuXHunt3R
TuXHunt3R 17.01.2011 um 15:36:56 Uhr
Goto Top
Tag auch

Wie wärs denn, wenn du das ganze Help lesen würdest?

Auszug aus dem Help:

Mitglied: FRAD
FRAD 17.01.2011 um 16:05:23 Uhr
Goto Top
Hi,

in der Help find ich nichts:

http://technet.microsoft.com/en-us/library/cc733145%28WS.10%29.aspx

Welche Quelle benutzt du?

Habe noch eine andere Frage.

Wenn ich z.B. alle *.bmp Dateien mittels diesem Befehl kopiere "robocopy C:\ D:\Backup\ /s *.bmp

werden 135 Dateien kopiert. Wenn ich aber mit dem Explorer auf C nach BMP Dateien suche, erhalte ich 250 BMP´s. Im Protokoll wurden auch keine Dateien ausgelassen.

Ich frage mich nur, warum robocopy nicht auf die gleiche Anzahl kommt....?

Noch ein Phänomen... Mit diesem Befehl: robocopy C:\ F:\_backupfolder\ /S /R:1 /W:1 *.bmp werden in dem Ordner lauter Ordner "Anwendungsdaten" erstellt. Kann ich mir nicht erklären. Jemand eine Idee?

F:\_backupfolder\Documents and Settings\admin\AppData\Local\Anwendungsdaten\Anwendungsdaten\Anwendungsdaten\Anwendungsdaten\Anwendungsdaten
Mitglied: TuXHunt3R
TuXHunt3R 17.01.2011 um 16:33:40 Uhr
Goto Top
Start => Ausführen => CMD
Dort folgendes eingeben:

Wenn ich z.B. alle *.bmp Dateien mittels diesem Befehl kopiere "robocopy C:\ D:\Backup\ /s *.bmp
werden 135 Dateien kopiert. Wenn ich aber mit dem Explorer auf C nach BMP Dateien suche, erhalte ich 250 BMP´s. Im Protokoll wurden auch keine Dateien ausgelassen.

Das habe ich bei mir kurz probiert und konnte es nicht nachvollziehen.

Noch ein Phänomen... Mit diesem Befehl: robocopy C:\ F:\_backupfolder\ /S /R:1 /W:1 *.bmp werden in dem Ordner lauter Ordner "Anwendungsdaten" erstellt. Kann ich mir nicht erklären. Jemand eine Idee?

Habe gerade auch keine Idee, schaue es mir bei Gelegenheit mal an.
Mitglied: Atomship
Atomship 17.01.2011 um 19:50:44 Uhr
Goto Top
Zitat von @FRAD:
Welche Quelle benutzt du?

Schau mal hier: http://yarcgui.wilkes.es/De/RoboCopy/index.htm

Wenn ich z.B. alle *.bmp Dateien mittels diesem Befehl kopiere "robocopy C:\ D:\Backup\ /s *.bmp
werden 135 Dateien kopiert. Wenn ich aber mit dem Explorer auf C nach BMP Dateien suche, erhalte ich 250 BMP´s. Im Protokoll
wurden auch keine Dateien ausgelassen.

Wie lautet die Suche im Explorer ?? Suchst du nach *.bmp oder einfach nach bmp ?? Schau die 250 Dateien mal an. Sind evtl. Dateien mit besonderen Attributen dabei, zB hidden ?

Noch ein Phänomen... Mit diesem Befehl: robocopy C:\ F:\_backupfolder\ /S /R:1 /W:1 *.bmp werden in dem Ordner lauter Ordner
"Anwendungsdaten" erstellt. Kann ich mir nicht erklären. Jemand eine Idee?

Das liegt daran, dass zB in dem Verzeichnis c:\users ein verlinktes Unterverzeichnis "Anwendungsdaten" vorhanden ist, und dadurch wird eine Endlosschleife erzeugt.
Versuch mal den Parameter /XJD also:
Damit werden dann Abzweigpunkte ignoriert.

Gruß Rainer
Heiß diskutierte Beiträge
general
Frage an die IT-Administratoren in Unternehmen gelöst Fuchor2020Vor 1 TagAllgemeinOff Topic13 Kommentare

Hallo Leute, freue mich hier im Forum dabei sein zu dürfen. Da ich noch relativ neu in der IT Branche bin, befasse ich mich aktuell ...

question
BIOS-Passwort beim Neustart umgehenFreeBSDVor 1 TagFrageEntwicklung14 Kommentare

Hallo zusammen, ich bin gerade auf der Suche nach einer Lösung für folgendes Problem und zwar haben wir in der Firma mehrere Notebooks im Einsatz ...

general
Apache2 Update führt bei Webservern mit Ubuntu 18+20 und Pleask zu einem Fehler 500 mit AH10292 für jede WebseiteStefanKittelVor 14 StundenAllgemeinApache Server

Moin, vieleicht hattet Ihr heute Morgen auch schon einen Schrecken. Ich hatte ganz viele Ausfallmeldungen für Webseiten mit Fehler 500. Im Errorlog steht dann der ...

question
Merkwürdige Meldung im iPhone Safari BrowsermartenkVor 1 TagFrageiOS9 Kommentare

Hallo Gemeinschaft ich bekomme seit kurzem dieses Bild in Safari: Was bedeutet es? ...

question
Fileserverstruktur mit wenig administrativen Aufwandben1300Vor 1 TagFrageWindows Userverwaltung11 Kommentare

Mahlzeit ! aktuell haben wir im Netzwerk einen sehr durchwachsenen Fileserver, welchen ich damals so übernommen habe und mir mittlerweile zu viel wird, bezüglich administrative ...

question
Datenübertragungsrate berechnungLeuis.DavidVor 1 TagFrageHardware18 Kommentare

Die Performance eines Servers entspricht nicht mehr Ihren Erwartungen. Sie führen einen Benchmark-Test durch. Dabei wird für die Systemfestplatte (Serial ATA 6.0 Gbit/s) eine durchschnittliche ...

question
Deutsche Glasfaser immer noch IPv6 ProblemefnbaluVor 1 TagFrageRouter & Routing20 Kommentare

Hallo zusammen, bei uns hat die Deutsche Glasfaser ganz frisch mitte 2021 ausgebaut und ich habe nun deren CG-Nat Leitung mit 400 Mbit, was gegenüber ...

question
Welche Ports öffnen für web.de OnlinespeicherWinfried-HHVor 1 TagFrageCloud-Dienste11 Kommentare

Hallo in die Runde! Hat jemand von euch Erfahrung mit dem Online-Speicher von web.de? Genaugenommen mit dem Windows-Sychronierungsprogramm von web.de? Seit unser Schulträger uns eine ...