kpunkt
Goto Top

RPC-Server nicht verfügbar (Clients)

Tach!

Ich steh' momentan auf dem Schlauch.
Ursprünglich wollte ich remote einen Client umbenennen (Rename-Computer). Da meldete Powershell eben, dass kein RPC-Server verfügbar sei. 0x800706BA
Okay, dann mache ich mich eben auf die Suche danach.

Sollte ja alles über die svchost.exe laufen.
Ich vermute, dass da die Windows-Firewall nö sagt.
Ich finde da aber nicht die richtige Einstellung.
Spontan hätte ich ja gesagt, dass es der Port 135 ist, der beim fraglichen Computer offen sein sollte. Irgendwo im Netz gelesen, dass da auch Port 445 offen sein sollte. Beides jetzt mal für die %systemroot%\system32\svchost.exe zugelassen.
Tut sich immer noch nix. Auch auf der Fortigate sind beide Ports offen.
Netstat meint auch, dass auf den Ports gelauscht wird.

Meine Frage ist: bin ich da komplett auf dem Holzweg oder überseh ich nur irgend etwas?
Ist ja jetzt nicht so, dass ein Get-WMIObject bei den Servern nicht funktionieren würde.

k.

Content-Key: 8039777412

Url: https://administrator.de/contentid/8039777412

Printed on: June 13, 2024 at 14:06 o'clock

Member: Kraemer
Kraemer Aug 03, 2023 at 12:32:42 (UTC)
Goto Top
Member: Bingo61
Bingo61 Aug 03, 2023 at 12:36:33 (UTC)
Goto Top
Servus
Hab da 1 Min, gebraucht es über Suchmaschine zu finden.
Kopie des Textes
Wer grafische Tools bevorzugt, kann zur Prüfung der Verbindung das MMC-Snap-in wmimgmt.msc bemühen. Es bietet unter dem Menüpunkt Aktion den Befehl Verbindung mit anderem Computer herstellen. Nachdem man dies getan hat, öffnet man im linken Fenster das Kontextmenü von WMI-Steuerung und wählt dort Eigenschaften. Der anschließende Dialog startet automatisch eine einfache WMI-Anfrage an den entfernten Rechner.
Oder
Mit Testdaten die anpassen musst
wmic /node:192.168.0.24 path win32_operatingsystem get caption
Member: kpunkt
kpunkt Aug 03, 2023 at 12:49:01 (UTC)
Goto Top

Hört sich einfach und logisch an. Brachte nur leider keinen Erfolg. Der RPC-Server ist immer noch nicht da.


Zitat von @Bingo61:

Servus
Hab da 1 Min, gebraucht es über Suchmaschine zu finden.
Nett, aber ich will keine GUI, sondern das Problem des nicht verfügbaren RPC-Servers lösen.
Funfact: auch per GUI kann keine Verbindung zum Computer aufgebaut werden.
Win32: Zugriff verweigert
Mitglied: 6376382705
6376382705 Aug 03, 2023 at 12:55:24 (UTC)
Goto Top
Hi.

die üblichen Themen wirst Du schon durch haben, oder?

Vergewissern Sie sich, dass TCP/IP NetBIOS-Helfer ausgeführt wird, und legen Sie den automatischen Start nach dem Neustart fest.

Vergewissern Sie sich, dass Remoteregistrierung ausgeführt wird, und legen Sie den automatischen Start nach dem Neustart fest.

Gruß
Member: Bingo61
Bingo61 Aug 03, 2023 at 13:08:23 (UTC)
Goto Top
Win Firewall auf Domänebene ausschalten, da hast ja schon gesucht
Member: kpunkt
kpunkt Aug 03, 2023 at 13:10:17 (UTC)
Goto Top
Jetzt hätte ich mich beinahe in den Hintern gebissen als ich da nochmal nachgeschaut hab, obwohl ich mich da fast zu Beginn schon vergewissert habe.
Dachte erst, die Remoteregistrierung wäre deaktiviert. War aber doch der Remotedesktopdienst.
Die Dienste laufen.
Member: kpunkt
kpunkt Aug 03, 2023 at 13:24:22 (UTC)
Goto Top
Zitat von @Bingo61:

Win Firewall auf Domänebene ausschalten, da hast ja schon gesucht

Habe ich tatsächlich noch nicht gemacht.
Aber jetzt. Und siehe da....Danke für den Schubs.
Meine Anfangsvermutung war schon richtig.
Da muss eine Regel hin, die das erlaubt.
Aber ich weiß jetzt nicht, wie genau.
Ich hatte ja eine gebastelt, die eingehend für svchost.exe auf Port 135 und 445 erlaubt. Das scheint nicht zu reichen.

Hat da jemand eine Anleitung für so eine Regel?

k.
Member: Kraemer
Kraemer Aug 03, 2023 at 13:32:57 (UTC)
Goto Top
Zitat von @kpunkt:

Hat da jemand eine Anleitung für so eine Regel?

Set-NetFirewallRule -Name 'WINRM-HTTP-In-TCP' -RemoteAddress Any  
https://learn.microsoft.com/en-us/powershell/module/netsecurity/set-netf ...
Member: kpunkt
kpunkt Aug 03, 2023 at 14:38:44 (UTC)
Goto Top
Hm...sieht auf den ersten Blick recht spartanisch aus.
Damit hab ich noch so gar nicht rumgespielt. Ich klick mir meine Regeln immer so zusammen. (warums dann wohl auch nicht funktioniert hat)
Wird auf dem Client ausgeführt, oder?

Muss mir das morgen mal genau ansehen.
Member: kpunkt
Solution kpunkt Aug 04, 2023 at 08:50:28 (UTC)
Goto Top
So...heute mal getestet.
Das war auch nicht die Lösung. Hab mir die Regel dann näher angesehen und die behandelt ja einen völlig anderen Port.

Danach etwas weitergesucht und ich bin auf das hier gestoßen:
https://learn.microsoft.com/de-de/windows/security/operating-system-secu ...

Und siehe da....mit den zwei zusätzlichen Regeln klappt es nun auch.

k.