darkzonesd
Goto Top

Samba Gast-Share - NT STATUS ACCESS DENIED

Moin zusammen,

ich musste Heute das erste mal einen Network Share unter ubuntu Server 23.04 anlegen und habe momentan leider ein paar Probleme dabei, ich habe einen Ordner angelegt der nun erreichbar sein soll unter dem Pfad /home/administrator/filebrowserdata.

Hier ist die smb.conf:

[global]
workgroup = WORKGROUP
security = user
map to guest = Bad User
guest account = nobody
guest ok = yes
server string = %h server (Samba, Ubuntu)
log file = /var/log/samba/log.%m
max log size = 1000
logging = file
panic action = /usr/share/samba/panic-action %d
server role = standalone server
obey pam restrictions = yes
unix password sync = yes
passwd program = /usr/bin/passwd %u
passwd chat = *Enter\snew\s*\spassword:* %n\n *Retype\snew\s*\spassword:* %n\n *password\supdated\ssuccessfully* .
pam password change = yes
map to guest = bad user
usershare allow guests = yes
[public]
path = /home/administrator/filebrowserdata
read only = no
guest ok = yes

Wenn ich den Share teste komme ich auch drauf mit:
smbclient //10.0.5.106/public -U guest%
kann dann aber innerhalb des shares nix machen..
smb: \> ls
NT_STATUS_ACCESS_DENIED listing \*

Hier sind noch die Permissions für den Ordner:
drwxr-xr-x 4 administrator administrator 4096 Sep 8 12:07 filebrowserdata

habe kein SELinux oder AppArmor am laufen und die ufw steht auf disabled..

geht aber alles nix, woran könnte es jetzt noch liegen?

Viele Grüße

Flo

Content-Key: 33138034715

Url: https://administrator.de/contentid/33138034715

Printed on: July 19, 2024 at 19:07 o'clock

Member: aqui
Solution aqui Sep 08, 2023 updated at 12:45:02 (UTC)
Goto Top
Das hier (Debian Bookworm) funktioniert in einem gleichen Umfeld fehlerlos:

Gastshare Verzeichnis anlegen Rechte setzen:
mkdir /srv/samba/public
chown -R nobody:nogroup /srv/samba/public/
chmod 2770 /srv/samba/public/ 

Eintrag in der smb.conf Datei:
[public]
    # Gastzugang ohne Passwort
    path = /srv/samba/public/
    comment = Public
    read only = no
    guest ok = yes
    guest only = yes 
Member: DarkZoneSD
DarkZoneSD Sep 11, 2023 updated at 07:59:05 (UTC)
Goto Top
Moin,

funktioniert immer noch nicht face-sad

[public]
    path = /home/administrator/filebrowserdata
    read only = no
    guest ok = yes
    guest only = yes
administrator@BookStackData:~$ sudo chown -R nobody:nogroup /home/administrator/filebrowserdata
administrator@BookStackData:~$ sudo chmod 2770 /home/administrator/filebrowserdata
administrator@BookStackData:~$ smbclient //10.0.5.106/public -U guest%
Try "help" to get a list of possible commands.  
smb: \> ls
NT_STATUS_ACCESS_DENIED listing \*
smb: \>

Ich versuche den Ordner mal in ein anderes Verzeichnis zu legen.

Update

In einem neuen Ordner funktioniert es jetzt..

administrator@BookStackData:/srv/samba/public$ smbclient //10.0.5.106/public -U guest%
Try "help" to get a list of possible commands.  
smb: \> ls
  .                                   D        0  Mon Sep 11 07:55:32 2023
  ..                                  D        0  Mon Sep 11 07:55:32 2023

                15371208 blocks of size 1024. 6306292 blocks available
smb: \>
eventuell lag es daran das es im home Verzeichnis des Users lag und die Berechtigung für den darüberliegenden Ordner gefehlt hat..

mit der Config funktioniert es jetzt zumindest, dankeschön.

Grüße