itshark
Goto Top

Server 2016 - Kein Report nach WSUS

Hallo zusammen,

folgendes Problem: Leider bekomme ich neue Server 2016 nicht zum reporten ins WSUS. Melden tun diese sich gemäß GPO sauber.

Es handelt sich um keinen Klon o.ä. somit sind alle IDs in der registry sauber und eindeutig.
Dienste etc. habe ich alles geprüft.

Ich habe den Server sogar schon einmal komplett neu installiert, allerdings ist das Problem geblieben.

Jemand eine Idee?

Content-Key: 473683

Url: https://administrator.de/contentid/473683

Printed on: May 23, 2024 at 13:05 o'clock

Member: NixVerstehen
NixVerstehen Jul 16, 2019 at 16:02:01 (UTC)
Goto Top
Servus,

hast du auf der Maschine, die nicht reported,
mal per elevated Powershell oder cmd

wuauclt.exe /reportnow

versucht? Dann sollte das eigentlich zeitnah im
WSUS ersichtlich sein.

Gruß NV
Member: jsysde
jsysde Jul 16, 2019 at 21:23:26 (UTC)
Goto Top
N'Abend.

Zitat von @NixVerstehen:
[…]wuauclt.exe /reportnow
Das ^^ wird unter 2016 (oder Windows 10) nix bringen (mal davon abgesehen, dass dazu keine Elevation nötig ist). Der neue Client heisst usoclient.exe: https://www.windows-faq.de/2019/01/10/usoclient-exe-ersetzt-wuauclt-befe ...

Cheers,
jsysde
Member: ArnoNymous
ArnoNymous Jul 16, 2019 at 22:14:27 (UTC)
Goto Top
Reportnow funktioniert meiner Meinung nach noch immer. Zumindest kommt direkt nach Eingabe bisher auch immer ein report beim wsus an. Dazu gibt's imho auch kein Pendant beim USOclient.
Die anderen Parameter funktionieren jedoch nicht mehr.
Member: NixVerstehen
NixVerstehen Jul 17, 2019 at 06:11:05 (UTC)
Goto Top
Guten Morgen,

ich hatte auch den Eindruck, das "wuauclt.exe /reportnow" immer noch funktioniert. Habe gerade mal auf einem Win10 1903, einem Win10 1809 und einem 2016 Essentials getestet. Bei allen drei kam kein Report am WSUS an.

Das wollte ich näher wissen und habe "usoclient.exe StartScan" versucht. Bei dem Win10 1903-Client war der Report nach ca. 5 Sek. da, beim Win10 1809 nach ca. 10 Min. und beim 2016 Essentials kam nichts.

Eine dritte Möglichkeit wäre noch:

$AutoUpdates = New-Object -ComObject "Microsoft.Update.AutoUpdate  
$AutoUpdates.DetectNow()

Das machte zumindest den Win10 1903-Client gesprächig, die beiden anderen Maschinen rührten sich nicht.

Klingt für mich irgendwie nach "Hornberger Schiessen" oder Lotteriespiel. Hier noch zwei Artikel zu dem Thema:

In Windows Server 2016 entfernte oder veraltete Features

Status Report with Windows Server 2016 to WSUS

Hier berichten Winfried Sonntag und Adam J. Marshall, das nur "wuauclt.exe /detectnow" nicht mehr funktioniert. Die anderen Parameter funktionieren.

Gruß NV
Member: ITShark
ITShark Jul 17, 2019 at 06:13:27 (UTC)
Goto Top
Hallo zusammen,

alles versucht. Am Server steht immer das die Updates heruntergeladen werden, allerdings geht der Server nicht über die 0% hinaus.
wuauclt /reportnow klappt beim Server 2016 weiterhin, der usaclient ist allerdings etwas "mächtiger", hilft in dem Fall aber auch nicht weiter.
Member: ITShark
ITShark Jul 17, 2019 at 06:24:24 (UTC)
Goto Top
Das komisch ist das er weiterhin den Kontakt zum WSUS Server sucht, aber eben nicht reporten will und deswegen auch keine Updates bezieht?!?
server2016
Member: NixVerstehen
NixVerstehen Jul 17, 2019 updated at 06:31:37 (UTC)
Goto Top
Bricht die Kiste irgendwann die Suche mit Fehler 0x8024401c ab oder steht der Status dauerhaft bei 0% ?

Edit: Mein 2016 Essentials kam gerade aus dem Quark mit seinem Report. Hat nach "wuauclt.exe /reportnow" knapp 30 Min. gedauert.
Member: ITShark
ITShark Jul 17, 2019 at 06:57:40 (UTC)
Goto Top
Steht durchgehend bei 0% ...

Das komische ist eben, dass auch eine komplette Neuinstallation keine Besserung gebracht hat.
server2016
Member: NixVerstehen
NixVerstehen Jul 17, 2019 at 07:14:48 (UTC)
Goto Top
Öffne mal bitte auf der WSUS-Maschine den Taskmanager und schau dir den IIS Worker Process an, während der zickige 2016 weiter nach Updates sucht.

iisworker

Beobachte mal ein paar Minuten den Prozess und schaue, ob die Nutzung des Arbeitsspeichers spürbar ansteigt. Falls ja, dann wäre es einen Versuch wert, die im WSUS-Anwendungspool die Warteschlangenlänge und das Limit für den privaten Speicher zu erhöhen. Siehe hier:

WSUSPool Warteschlangenlänge und privaten Speicher erhöhen

Mein 2016 Essentials hing genau bei diesem Update in deinem Screenshot fast 4 Std.

Gruß NV
Member: ArnoNymous
ArnoNymous Jul 17, 2019 at 07:36:03 (UTC)
Goto Top
Ich überlege gerade, ob man bei 2016 nicht auch erstmal einen bestmmten Patch installieren musste, damit dieser sich Update vom WSUS holt. Mir war so, als ob da was war...

Läuft der WSUS auch auf 2016?
Member: ITShark
ITShark Jul 17, 2019 at 07:47:02 (UTC)
Goto Top
Also der IIS Worker verändert sich nur marginal, denke also hier ist leider kein Ansatz.
komischerweise hat der Server gerade ein Update installiert, hängt jetzt beim nächsten im gleichen Status (0%) fest und hat immer noch kein Report im WSUS erstellt ...
Member: ITShark
ITShark Jul 17, 2019 at 07:56:19 (UTC)
Goto Top
Jap läuft auch auf 2016
Member: NixVerstehen
NixVerstehen Jul 17, 2019 at 08:00:21 (UTC)
Goto Top
Lass ihn einfach laufen, wenn es betriebstechnisch möglich ist, und schau heute nachmittag mal drauf.
Member: NixVerstehen
NixVerstehen Jul 17, 2019 at 08:44:01 (UTC)
Goto Top
Zitat von @NixVerstehen:
[…]wuauclt.exe /reportnow
Das ^^ wird unter 2016 (oder Windows 10) nix bringen (mal davon abgesehen, dass dazu keine Elevation nötig ist). Der neue Client heisst usoclient.exe: https://www.windows-faq.de/2019/01/10/usoclient-exe-ersetzt-wuauclt-befe ...

Hab das gerade nochmal auf dem WSUS selbst (2019 Standard) getestet. Der Aufruf von "wuauclt.exe /reportnow" hat nach wenigen Sekunden
seinen Report abgeliefert.