erikro
Goto Top

Synology: smbd main process (10144) killed by TERM signal

Moin,

wir haben ein etwas seltsames Problem mit einem Synology DS718+. Das Teil ist in die Domain eingebunden und funktioniert eigentlich so, wie es soll. Nur in einem Abstand von ca. 14 Tagen (manchmal aber auch schon nach zwei) rufen die User an und melden, dass kein Zugriff mehr möglich ist. Vor meinem Urlaub habe ich mir das Teil angeschaut und festgestellt, dass er sich die Zeit nicht beim richtigen Zeitserver holt und deshalb die Uhren auseinandergelaufen sind (NTP auf externe Quellen blockt unsere FW). Da dachte ich, dass das das Problem sei. Heute beschwerten sich die User wieder. Im Web-Interface schien alles in Ordnung zu sein. Trotzdem kein Zugriff. Also habe ich mich per ssh eingeloggt und mir die Logs angeschaut. In /var/log/messages steht:


Das passt auch zu den Ausfallzeiten. Wer oder was killed da immer den smbd? Kennt das jemand? Google gibt mir leider bei der Suche nur fünf Treffer, die mit dem Phänomen nicht wirklich was zu tun haben.

Liebe Grüße

Erik

Content-Key: 477507

Url: https://administrator.de/contentid/477507

Ausgedruckt am: 03.10.2022 um 20:10 Uhr

Mitglied: Bitboy
Bitboy 25.07.2019 um 10:18:36 Uhr
Goto Top
Moin,

Firmware ist aktuell?
Kannst du mal schauen ob du in den Logs von smbd mehr Informationen findest?

mfg
Mitglied: erikro
erikro 25.07.2019 um 13:28:11 Uhr
Goto Top
Moin,

Zitat von @Bitboy:
Firmware ist aktuell?

Jein. Heute kam ein neues Update. Das wird gerade installiert. Insofern war die Kiste bis heute auf dem aktuellen Stand.

Kannst du mal schauen ob du in den Logs von smbd mehr Informationen findest?

Hab ich schon. Leider nein.

Liebe Grüße

Erik
Mitglied: H41mSh1C0R
H41mSh1C0R 25.07.2019 um 15:42:27 Uhr
Goto Top
Zusätzlich RAM nachgerüstet?
Wenn ja, Speichertest gemacht?

VG
Mitglied: erikro
erikro 25.07.2019 um 15:49:34 Uhr
Goto Top
Moin,

Zitat von @H41mSh1C0R:

Zusätzlich RAM nachgerüstet?
Wenn ja, Speichertest gemacht?

Nein, kein zusätzlicher Speicher und das Teil ist gerade mal einen guten Monat alt.

Liebe Grüße

Erik
Mitglied: H41mSh1C0R
H41mSh1C0R 25.07.2019 um 16:18:38 Uhr
Goto Top
Ggf. trotzdem mal ein Speichertest machen, nur um das auszuschließen.

Wird die Synology als reines Datengrab genutzt oder laufen da noch andere Dienste? z.B. LDAP?

VG
Mitglied: Floooh
Floooh 25.07.2019 um 16:39:05 Uhr
Goto Top
Ich würde jetzt auch einfach mal auf den RAM tippen.

Was sagt denn der syslog?
Mitglied: erikro
erikro 25.07.2019 um 16:45:07 Uhr
Goto Top
Speichertest läuft.

Ja, reines Datengrab. Der ist für unsere Marketingabteilung, weil die immer den normalen Fileserver vollgemüllt haben. face-wink
Mitglied: erikro
erikro 25.07.2019 um 17:15:33 Uhr
Goto Top
So, Speichertest ist durch. Keine Fehler. Das hätte mich auch gewundert, da Samba ja ein SIGTERM bekommt und sauber runterfährt. Kaputter Speicher führt ja eher zu unkontrollierten Abstürzen ohne Logeinträge.

Außerdem habe ich mir die Cronjobs angeguckt. (Warum ist da kein normales Linux drauf, bei dem man nicht jeden Befehl nachschlagen muss? face-wink ) Da ist auch nichts, was das auslösen könnte. Aber irgend etwas muss ja SIGTERM an den Sambaprozess schicken. Nur welche Software macht das. Oder wollen mich die Kollegen ärgern? face-wink

Nun ist endlich Feierabend. Bis morgen.
Mitglied: H41mSh1C0R
H41mSh1C0R 25.07.2019 um 17:36:57 Uhr
Goto Top
Im netz schwirren ein paar Fehler mit dem smbd rum die mit Speichern zu tun hatten und bei denen es auch einen SIGTERM für den smbd gab.

Aber wenn der Speicher i.O. ist weiter im Text.

Was steht im Samba log?
Mitglied: erikro
erikro 26.07.2019 um 09:01:24 Uhr
Goto Top
Nur dass Ihr nicht denkt, dass ich Euch die Lösung nicht verraten will. face-wink Wir haben einen Totalausfall der TK-Anlage. Wahrscheinlich geht's mit dem Problem erst Montag weiter.
Mitglied: Floooh
Floooh 26.07.2019 um 09:22:31 Uhr
Goto Top
ggf. auch mal das log level vom samba hochsetzen..
Mitglied: erikro
erikro 26.07.2019 um 13:29:42 Uhr
Goto Top
So, TK-Anlage läuft wieder. face-smile

Loglevel des Samba habe ich auf 3 gesetzt. Die Logs sagen nicht wirklich was Brauchbares aus. Das einzige sind die SIGTERMs, die, wie ich mittlerweile festgestellt habe, nicht nur Samba, sondern auch andere Prozesse bekommen. Woher auch immer. Jetzt warte ich mal, bis das wieder auftritt in der Hoffnung, dass mit den erhöhten Loglevels was drin steht, was zum Fehler führt. Ich werde berichten.

Liebe Grüße und schönes Wochenende

Erik