d-line
Goto Top

Userprofil wird am Abend nicht auf Fileserver geschrieben

Hallo Zusammen

Ich stehe seit Mitte dieser Woche vor einem Problem, und bin mir sicher, dass jemand von euch mir die Lösung dafür sagen kann.

Es geht um einen von ca. 300 Usern im Betrieb eines Kunden. Der User hatte nun schon länger Probleme mit dem Drucker Mapping auf seinem Citrix/TS Profil. Es wurden alte Drucker nicht entfernt bei der Anmeldung, und die Drucker wurden auch viel zu spät gemappt was zur Folge hatte dass der falsche Standarddrucker ausgewählt war.

Ich habe mich dazu entschieden, dem User ein neues TS Profil zu machen. Also User abgemeldet, als Admin auf dem betreffenden Citrix Server angemeldet, den Profilordner des Users unter Benutzer umbenannt mit zwei Bodenstrichen. Dann in der Registry folgende zwei Einträge für den betreffenden User zuerst exportiert und dann gelöscht:

HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Windows NT\CurrentVersion\ProfileList

HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Windows NT\CurrentVersion\ProfileGuid

Danach habe ich auf dem Fileserver im tsprofiles Ordner ebenfalls den Ordner umbenannt.

Anschliessend hat sich der User wieder angemeldet und ich habe die Einstellungen im Profil vorgenommen, unter anderen Desktop Symbole, Taskleistensymbole, diverse Einstellungen in einigen Programmen, Word, Excel und Outlook konfiguriert.

Das Druckermapping funktionierte auch wieder reibungslos. Es waren nur noch die Drucker ersichtlich, welche dem User zugewiesen sind, und auch der Standarddrucker war richtig gesetzt. Als ich mit dem einstellen des Profils fertig war, habe ich den User abgemeldet, um zu schauen ob das Profil auch auf den Fileserver geschrieben wird. Anschliessend habe ich ihn wieder angemeldet und es waren alle Einstellungen noch vorhanden, die Synchronisierung des Profils hat also funktioniert, dachte ich jedenfalls...

Am nächsten Morgen hatmich der User angerufen, seine Desktopsymbole und die Einstellungen im Programm Hardcopy seien verschwunden. Und es war definitiv so... Alle Einstellungen waren wieder weg. Ich habe diese dann nochmals vorgenommen, und den User erneut zweimal abgemeldet und wieder angemeldet. Beide Male ging alles problemlos, das Profil wurde schön synchronisiert.

Und heute Morgen dann wieder ein Anruf vom User, dass die Einstellungen wieder weg sind. Ich habe den User gestern Abend extra nochmals angewiesen, sich unbedingt sachgemäss abzumelden, und dies hat er auch getan.


Nun habe ich mir das Profil mal angesehen auf dem Fileserver, und siehe da: Sämtliche Ordner im servergespeicherten Profil (Dokumente, Desktop, Downloads etc.) haben das Änderungsdatum 04.11.2015, was ja am Mittwoch war wo ich das Profil neu erstellt habe. Nur die Datei ntuser.ini hat das aktuelle Änderungsdatum (06.11.2015).

4eec50bbc88cb90277344c1f637ad5fb


Kann sich da jemand einen Reim drauf machen warum das Profil nur teilsynchronisiert wird?


Ich danke euch schonmal im Voraus üfr eure Hilfe.


Gruss, D-Line

Content-Key: 287682

Url: https://administrator.de/contentid/287682

Printed on: July 18, 2024 at 18:07 o'clock

Member: Pjordorf
Pjordorf Nov 06, 2015 at 11:47:31 (UTC)
Goto Top
Hallo,

Zitat von @D-Line:
habe ich den User abgemeldet, um zu schauen ob das Profil auch auf den Fileserver geschrieben wird
Roaming Profiles / Server gespeicherte Profile?

Synchronisierung des Profils hat also funktioniert, dachte ich jedenfalls...
Also Roaming Profiles. Dem Anwender wird doch gesagt wenn das Profil beim Abmelden oder beim Anmelden nicht gespeichert oder geladen werden kann. Kamm das in der Vergangenheit denn nicht? Steht auch im Ereignisprotokoll.

Beide Male ging alles problemlos, das Profil wurde schön synchronisiert.
Aaahhhhh jjjjaaaaa.

und dies hat er auch getan.
Und es kam keine Meldung das das Profil nicht erfolgreich bzw. komplett gespeichert werden konnte?

Nur die Datei ntuser.ini hat das aktuelle Änderungsdatum (06.11.2015).
Und 06:56 heute morgen hat sich der Benutzer das letzte mal abgemeldet. Ist die Zeit korrekt?

Kann sich da jemand einen Reim drauf machen warum das Profil nur teilsynchronisiert wird?
Wenn es das ist steht dazu auch im Ereignisprotokoll einiges drin. Je nach eurer OSe mal reinschauen (Client)

Gruß,
Peter
Member: D-Line
D-Line Nov 06, 2015 at 12:33:04 (UTC)
Goto Top
Hallo Peter

Vielen Dank für deine Antwort. Wie du schon festgestellt hast handelt es sich um Roaming Profile. Ich weiss eben leider nicht ob der Anwender eine Meldung wegen eines nicht- oder nur Teilsynchronisierten Profils bekommen hat, zumindets hat er nichts gesagt, ist aber auch nicht sehr versiert.. Als ich am 04.11.2015 das Profil neu erstellt und alle Einstellungen gemacht hatte, habe ich den User ja abgemeldet und wieder angemeldet. Damals kam keine Nachricht wegen Profil Synchronisierungsproblemen.

Und als ich dem User gestern (05.11.2015), als er angerufen und gesagt hat dass seine Symbole usw. verschwunden sind, gesagt habe er solle die Symbole und Einstellungen nochmals setzen und sich dann neu anmelden am Server, waren die Symbole usw. ja nach der Neuanmeldung auch wieder da. Dies bringt mich natürlich zu der Frage, warum die Änderungsdaten der einzelnen ordner und Unterordner sich nicht verändert hat und auf 04.11.2015 geblieben ist...

Ich werde gleich bei dem betroffenen User vorbei gehen und alles nochmals mit eigenen Augen testen.


Danke und Gruss, D-Line
Member: Pjordorf
Pjordorf Nov 06, 2015 at 12:54:50 (UTC)
Goto Top
Hallo,

Zitat von @D-Line:
Dies bringt mich natürlich zu der Frage, warum die Änderungsdaten der einzelnen ordner und Unterordner sich nicht verändert hat und auf 04.11.2015 geblieben ist...
Ist doch ganz klar. Die Ordner welche sichern ändern bekommen schon einen neuen Zeit Stempel, Ordner welche keine Änderung erfahren bleiben. Ändern sich die Ordner oder nur deren Inhalt (wenn überhaupt)? Nun rate mal....
Die Ntuser.ini ändert sich bei jeden abmelden weil eben die Benutzer bezogene Registrierungsdatei (viel mehr ist die NTUser.ini nicht) sich ändert. Logisch. Und wenn es beim Speichern oder beim Laden zu Problemen mit Roaming Profiles kommt steht es logischerweise im Ereignisprotokoll vom Client. Mal reingeschaut?

Gruß,
Peter
Member: D-Line
D-Line Nov 06, 2015 at 15:56:57 (UTC)
Goto Top
Hallo Pjodorf

In der Ereignisanzeige stand nichts verwendbares drin. Aber ich habe das Problem nun lösen können, denke ich. Ich werde es am Montag sehen ob es gelöst ist.

Vielen Dank und ein schönes Wochenende


Gruss, D-Line
Member: Pjordorf
Pjordorf Nov 06, 2015 at 20:08:15 (UTC)
Goto Top
Hallo,

Zitat von @D-Line:
Aber ich habe das Problem nun lösen können, denke ich
Dürfen wir erfahren was deine Lösung ist oder ...

Gruß,
Peter
Member: D-Line
D-Line Nov 09, 2015 updated at 06:33:06 (UTC)
Goto Top
Hallo Pjodorf

Wie gesagt, ich wollte erst Heute abwarten und dann die Lösung melden.

Es könnte an zwei Orten gelegen haben. Zum einen hat der betreffende Benutzer seit kurzem eine zweite Citrix Session offen, jedoch nur eine Applikation, ohne einen eigentlichen Desktop. Dies habe ich erst letzte Woche erfahren. Da aber bei uns seit einiger Zeit nun die Seamless Funktion für Applikationen (Adobe Pro, Microsoft Outlook) nicht mehr funktioniert, habe ich erstmal angenommen, dass dies das Problem verursache könnte. Citrix konnte für die Probleme mit der fehlenden Seamless Funktion keine Lösung liefern, es wird jedoch in nächster Zeit eine neue Citrix Farm geben, was das Problem auch beheben wird.

Da nun wegen der Fehlfunktion der Seamless Anwendung ein ganzer Destktop geöffnet wird, wird auch das Profil dadurch beeinflusst. Der User hat also Den Desktop mit der Outlook Applikation erst nach dem Abmelden der eigentlichen Citrix Session geschlossen, wodurch das neu eingerichtete Profil durch das leere ersetzt wurde. Eigentlich hätte die zweite Session das neue Profil vom Server ziehen sollen und dann hätte es auch keine Probleme gegeben. Ich habe nun den User einmal auf allen Servern mit der normalen Session angemeldet, nun funktioniert alles einwandfrei.

Das zweite Problem war, dass wir im Netzwerk plötzlich Probleme mit der Namensauflösung hatten. Einige wichtige Server (Exchange, Fileserver, Printserver) wurden von Citrix aus plötzlich mit einer IPv6 Adresse aufgelöst. Von der lokalen Workstation aus wurden sie jedoch normal per IPv4 Adresse aufgelöst. Ich bin mir jedoch nicht sicher, ob dies auf das oben genannte Problem einen Einfluss hatte, da die Laufwerke ja problemlos gemappt wurden. Die Lösung hierfür war die Deaktivierung von IPv6 auf den betroffenen Servern.


Gruss, D-Line
Member: D-Line
D-Line Nov 11, 2015 at 09:56:14 (UTC)
Goto Top
Hallo zusammen

Das Problem scheint doch noch nicht ganz behoben zu sein. Der User hat mich gerade angerufen und mir mitgeteilt, dass teils Änderungen noch nicht ganz gespeichert werden. Z.B. Links welche im Internet Explorer an die Favoritenleiste angehängt werden oder Taskleistensymbole. Komischerweise ging es jetzt aber zwei Tage gut, und bei meinen Tests funktionierte auch alles einwandfrei. Ich habe den User diverse Male ab- und wieder angemeldet und dabei Änderungen gemacht (Testfile auf Desktop gespeicher und wieder gelöscht, Programmeinstellungen geändert etc.). Alle erstellten und gelöschten Files und auch die Einstellungen in den Programmen wurden jeweils problemlos übernommen.

Ich habe leider immernoch das Gefühl, dass es etwas mit der Zweiten Session zu tun hat in der Outlook als Applikation läuft. Diese Session kann man wie bereits erwähnt nicht sauber abmelden, infolge dessen wird die Sitzung dann in der Citrix Management Konsole als "gestrennt" angezeigt. Dies bedeutet in der regel, dass diese Sitzung im Prinzip wieder aufgenommen werden kann, quasi ein Energiesparmodus für die Sitzung.

Wir machen wöchentlich einen Neustart aller Citrix Server, jeweils am Dienstag Abend. Ich vermute nun, dass durch den Neustart des Servers die Sitzung komplett geschlossen, also abgemeldet wurde und das eigentliche Profil des Users dann damit überschrieben wurde.

Ich habe schon letzte Woche einige Tests gemacht, um das Verhalten des Profilordners eines Users zu überwachen, wenn eine Citrix Sitzung getrennt wird, und wenn eine Sitzung zurückgesetzt, also komplett abgemeldet wird.

Das Ergebnis zeigte dass sich in beiden Fällen das Datum des Profilordners auf dem Fileserver ändert.

Dem User habe ich nun gesagt, er soll testweise ein leeres Textfile auf den Desktop speichern, und schauen, ob es Morgen früh wieder da ist. Mehr kann ich für den User momentan nicht machen, da er nicht auf die zweite Session verzichten will.

Falls ich etwas neues weiss, werde ich dies hier posten.
Member: D-Line
D-Line Nov 13, 2015 at 07:02:50 (UTC)
Goto Top
UPDATE:

So, das leere Textfile war am Morgen danach noch auf dem Desktop vorhanden. Es hat also definitiv mit der Applikations-Session zu tun. Als Abhilfe, beziehungsweise eher als Notlösung, da der User ja so auf seinem zweiten Outlook Fenster beharrt, habe ich ihm nun vorgeschlagen einfach eine komplette zweite Citrix Session aufzumachen. So kann der User zumindest die Session ordentlich abmelden. Welche Session er zuerst abmeldet und welche Änderungen am Profil schlussendlich dann übernommen werden, ist dann schlussendlich sein Problem.


Gruss, D-Line