Top-Themen

Aktuelle Themen (A bis Z)

Administrator.de FeedbackApache ServerAppleAssemblerAudioAusbildungAuslandBackupBasicBatch & ShellBenchmarksBibliotheken & ToolkitsBlogsCloud-DiensteClusterCMSCPU, RAM, MainboardsCSSC und C++DatenbankenDatenschutzDebianDigitiales FernsehenDNSDrucker und ScannerDSL, VDSLE-BooksE-BusinessE-MailEntwicklungErkennung und -AbwehrExchange ServerFestplatten, SSD, RaidFirewallFlatratesGoogle AndroidGrafikGrafikkarten & MonitoreGroupwareHardwareHosting & HousingHTMLHumor (lol)Hyper-VIconsIDE & EditorenInformationsdiensteInstallationInstant MessagingInternetInternet DomäneniOSISDN & AnaloganschlüsseiTunesJavaJavaScriptKiXtartKVMLAN, WAN, WirelessLinuxLinux DesktopLinux NetzwerkLinux ToolsLinux UserverwaltungLizenzierungMac OS XMicrosoftMicrosoft OfficeMikroTik RouterOSMonitoringMultimediaMultimedia & ZubehörNetzwerkeNetzwerkgrundlagenNetzwerkmanagementNetzwerkprotokolleNotebook & ZubehörNovell NetwareOff TopicOpenOffice, LibreOfficeOutlook & MailPapierkorbPascal und DelphiPeripheriegerätePerlPHPPythonRechtliche FragenRedHat, CentOS, FedoraRouter & RoutingSambaSAN, NAS, DASSchriftartenSchulung & TrainingSEOServerServer-HardwareSicherheitSicherheits-ToolsSicherheitsgrundlagenSolarisSonstige SystemeSoziale NetzwerkeSpeicherkartenStudentenjobs & PraktikumSuche ProjektpartnerSuseSwitche und HubsTipps & TricksTK-Netze & GeräteUbuntuUMTS, EDGE & GPRSUtilitiesVB for ApplicationsVerschlüsselung & ZertifikateVideo & StreamingViren und TrojanerVirtualisierungVisual StudioVmwareVoice over IPWebbrowserWebentwicklungWeiterbildungWindows 7Windows 8Windows 10Windows InstallationWindows MobileWindows NetzwerkWindows ServerWindows SystemdateienWindows ToolsWindows UpdateWindows UserverwaltungWindows VistaWindows XPXenserverXMLZusammenarbeit

gelöst VPN zwischen Cisco 1841 Router

Mitglied: windoof1992

windoof1992 (Level 1) - Jetzt verbinden

17.03.2010, aktualisiert 18.10.2012, 7987 Aufrufe, 8 Kommentare

Guten Abend,

ich habe folgendes Problem: Ich soll für ein Projekt im Packet Tracer 3 Netzwerke die durch das WAN getrennt sind, miteinander verbinden. Jeder Standort hat mehrere PC's, Server und einen Cisco 1841 Router.

Ich hab etliche Foreneinträge gelesen doch nichts dazu gefunden was mir weiterhilft. Ich hoffe ihr könnt mich weiterbringen.

Da ich keine großen Kenntnisse in Sachen Cisco habe, wollte ich erstmal eine VPN Verbindung zwischen zwei Netzen herstellen. Nur zum testen ob ich überhaupt dazu in der Lage bin. Diest ist leider nicht der Fall.

Netz A:
Netzwerkadresse: 192.168.1.0/24

Cisco Netz A:
Interface 0/1 (extern): 192.1.1.1
Interface 0/0 (intern): 192.168.1.1


Netz B:
Netzwerkadresse: 192.168.2.0/24

Cisco Netz B:
Interface 0/1 (extern): 193.1.1.1
Interface 0/0 (intern): 192.168.2.1

Beide Router haben einen DHCP Pool der ab 192.168.1.2 startet.
01.
Konfiguration Netz A:
02.

03.
!
04.
version 12.4
05.
no service timestamps log datetime msec
06.
no service timestamps debug datetime msec
07.
no service password-encryption
08.
!
09.
hostname RTRA
10.
!
11.
!
12.
!
13.
!
14.
!
15.
!
16.
crypto isakmp policy 10
17.
 encr aes 128
18.
 authentication pre-share
19.
 group 2
20.
!
21.
crypto isakmp key cisco123 address 193.1.1.1
22.
!
23.
!
24.
crypto ipsec transform-set RTRtran esp-aes esp-sha-hmac
25.
!
26.
!
27.
!
28.
!
29.
!
30.
!
31.
!
32.
!
33.
interface Tunnel0
34.
 ip address 192.168.3.1 255.255.255.0
35.
 tunnel source FastEthernet0/1
36.
 tunnel destination 193.1.1.1
37.
!
38.
!
39.
interface FastEthernet0/0
40.
 ip address 192.168.1.1 255.255.255.0
41.
 duplex auto
42.
 speed auto
43.
!
44.
interface FastEthernet0/1
45.
 ip address 192.1.1.1 255.255.255.0
46.
 duplex auto
47.
 speed auto
48.
!
49.
interface Vlan1
50.
 no ip address
51.
 shutdown
52.
!
53.
router rip
54.
 network 192.168.2.0
55.
 network 192.168.3.0
56.
!
57.
ip classless
58.
ip route 192.168.2.0 255.255.255.0 192.168.3.2 
59.
ip route 192.168.2.0 255.255.255.0 193.1.1.1 
60.
!
61.
!
62.
!
63.
ip dhcp excluded-address 192.168.1.1
64.
!
65.
ip dhcp pool lanA
66.
 network 192.168.1.0 255.255.255.0
67.
 default-router 192.168.1.1
68.
!
69.
!
70.
!
71.
!
72.
!
73.
line con 0
74.
line vty 0 4
75.
 login
76.
!
77.
!
78.
!
79.
end
Konfigruation Cisco Netz B:
01.
!
02.
version 12.4
03.
no service timestamps log datetime msec
04.
no service timestamps debug datetime msec
05.
no service password-encryption
06.
!
07.
hostname RTRB
08.
!
09.
!
10.
!
11.
!
12.
!
13.
!
14.
crypto isakmp policy 10
15.
 encr aes 128
16.
 authentication pre-share
17.
 group 2
18.
!
19.
crypto isakmp key cisco123 address 192.1.1.1
20.
!
21.
!
22.
crypto ipsec transform-set RTRtran esp-aes esp-sha-hmac
23.
!
24.
!
25.
!
26.
!
27.
!
28.
!
29.
!
30.
!
31.
interface Tunnel0
32.
 ip address 192.168.3.2 255.255.255.0
33.
 tunnel source FastEthernet0/1
34.
 tunnel destination 192.1.1.1
35.
!
36.
!
37.
interface FastEthernet0/0
38.
 ip address 192.168.2.1 255.255.255.0
39.
 duplex auto
40.
 speed auto
41.
!
42.
interface FastEthernet0/1
43.
 ip address 193.1.1.1 255.255.255.0
44.
 duplex auto
45.
 speed auto
46.
!
47.
interface Vlan1
48.
 no ip address
49.
 shutdown
50.
!
51.
router rip
52.
 network 192.1.1.0
53.
 network 192.168.3.0
54.
!
55.
ip classless
56.
ip route 192.168.1.0 255.255.255.0 192.168.3.1 
57.
ip route 192.168.1.0 255.255.255.0 192.1.1.1 
58.
!
59.
!
60.
!
61.
ip dhcp excluded-address 192.168.2.1
62.
!
63.
ip dhcp pool lanB
64.
 network 192.168.2.0 255.255.255.0
65.
 default-router 192.168.2.1
66.
!
67.
!
68.
!
69.
!
70.
!
71.
line con 0
72.
line vty 0 4
73.
 login
74.
!
75.
!
76.
!
77.
end
Ich weiß nicht ob noch mehr Informationen gebraucht werden, wenn ja, werde ich sie so schnell wie möglich hinzufügen.

Ziel des ganzen ist es eine einfache Verbindung zwischen Netz A und Netz B herzustellen um beispielsweise einen Ping von A nach B zu senden.
Hoffentlich weiß jemand weiter.


Mit freundlichen Grüßen
Mitglied: builder4242
17.03.2010 um 22:55 Uhr
Ich versteh dein Nezt nicht ganz,
Mit WAN und Co.

Sind also alle Netze unter einem Dach?, wenn sie mit einem WAN verbunden sind?

Oder läuft das doch übers INET, was hast du dann für einen Zugang?

Am besten für sowas ist immer eine Skizze
Bitte warten ..
Mitglied: Dani
17.03.2010 um 23:44 Uhr
@builder
Ganz einfach, er baut im PacketTracer das Netzwerk virtuell auf. Darum auch die privaten IP-Adressen auf den WAN-Schnittstellen - ist ein bisschen verwirrend.

@Windows1992
Hier ist mal eine Schritt-für-Schritt Anleitung von Cisco. Nebenher wird auch noch erklärt was die einzelnen Befehle machen. Nicht erschrecken, sollte bei deinen Router-Modellen auch funktionieren.


Grüße,
Dani

P.S. Ob natürlich PacketTracer diese Befehle alle unterstützt bin ich mir nicht sicher. Ansonsten würde es mit GNS3 auch funktionieren. Damit bilden wir unser Testumgebungen ab.
Bitte warten ..
Mitglied: spacyfreak
18.03.2010 um 05:42 Uhr
Wo ist die Crypto map?
Und die crypto map an ein interface binden.
Die Crypto map fasst die vpn parameter zusammen und wird dann an ein interface gebunden.

ACL?

Ausserdem würd ich von vornerein GNS3 benutzen, packettracer ist ein "simulator", doch GNS3 ist ein "emulator" und lädt "echtes IOS", da geht dann alles.
Bitte warten ..
Mitglied: windoof1992
18.03.2010 um 11:00 Uhr
Hallo Dani,

Leider funktionieren nicht alle Befehle mit dem Packettracer. Problem ist nur, dass die Aufgabe zwingend mit dem PT erledigt werden soll.
Hatte mir schon einige andere Anleitungen durchgelesen in denen man Befehleverwenden sollte die im PT nicht vorhanden waren.

Sehr schade. Danke für die Anleitung.
Bitte warten ..
Mitglied: windoof1992
18.03.2010 um 11:01 Uhr
In der Anleitung die ich hatte war eine crypto map nicht nötig, laut Aussage des Verfassers.

Ich habe leider nicht genug Kenntnisse um dies zu beurteilen.
Bitte warten ..
Mitglied: Dani
18.03.2010 um 13:42 Uhr
Schau dir meinen Link an: Das funktioniert auf jeden Fall. Ohne "CM" geht gar nichts.


Grüße,
Dani
Bitte warten ..
Mitglied: aqui
19.03.2010, aktualisiert 18.10.2012
@Dani
Auch wenn PT3 sicher etwas anders macht, die grundlegende Konfiguration der Router A und B ist schon grundfalsch oben und birgt gravierende Fehler und es ist mehr als logisch das nichts klappt !
Folgende Punkte sind auffällig:
  • Das Interface FA0/1 auf beiden Routern soll wohl vermutlich das WAN Netz sein. (0/0 das lokale LAN). Hier ist auf beiden Routern eine gleiche IP für das WAN Interface konfiguriert ! Im normalen Cisco Leben ist dass vollkommener Unsinn und führt zum sofortigen Fehler, denn diese Router kämen niemals zusammen. Sinnvoll wäre z.B. 192.1.1.1/24 auf Router A und 192.1.1.2/24 auf Router B !
  • Damit sind dann auch die statischen Routen falsch denn die müssten richtigerweise lauten: Router A: ip route 192.168.2.0 255.255.255.0 193.1.1.2 und Router B: ip route 192.168.1.0 255.255.255.0 193.1.1.1
  • Ausserdem ist RIPv1 eingeschaltet, damit sind statische Routen dann so oder so Blödsinn. Oder besser gesagt RIP ist dann Unsinn, denn da die statischen Routen eine bessere Metrik haben machen sie die dynamischen RIP Routen schlicht tot !! Auch da ist die Konfig unsinnig, denn man sollte sich entscheiden entweder statisch oder dynamisch zu routen ! Beides ist Unsinn.
  • Der VPN Tunnel zeigt mit der Tunnel Source und der Tunnel Destination auf ein und dieselbe lokale IP was natürlich ebenso kompletter Unsinn ist, denn wie kann das Source und Destination sein ?! Mit Source und Destination müssen unterschiedliche IPs gesetzt werden nämlich genau der Tunnel Anfang und das Ende und das ist niemals nur eine lokale IP, denn damit wäre ja gar kein Anfang und Ende definiert ! Für Router A wäre das richtigerweise: tunnel source FastEthernet0/1, tunnel destination 193.1.1.2 (WAN IP Router B) und analog für Router B: tunnel source FastEthernet0/1, tunnel destination 193.1.1.1 (WAN IP Router A)

Erst wenn überhaupt erstmal diese grundlegenden Fehler in der IP Adressierung (die nichtmal was mit Cisco Syntax zu tun hat !) beseitigt sind, dann kann man mal weitersehen.
Es ist nicht vorstellbar das auch PT3 mit solch einer in sich grundlegend falschen IP Konfiguration zurechtkommt ! Das muss also erstmal korrigiert werden bevor man dann an den Crypto Tunnel geht !! Spacy's Tip mit GNS3 kann man sich da nur anschliessen !!
Der Crypto Tunnel so wie oben ist auch falsch bzw. unvollständig. Spacyfreak hat da absolut recht !

Wie man den dann richtig konfiguriert kannst du hier nachlesen:
https://www.administrator.de/Vernetzung_zweier_Standorte_mit_Cisco_876_R ...
bzw. ansatzweise auch hier:
https://www.administrator.de/wissen/ipsec-vpn-auf-m0n0wall-oder-pfsense- ...
Bitte warten ..
Mitglied: aqui
23.03.2010 um 11:46 Uhr
Wenns das jetzt war dann bitte auch:
https://www.administrator.de/index.php?faq=32
nicht vergessen !!
Bitte warten ..
Ähnliche Inhalte
Sonstige Systeme
Cisco 1841, dhcp Client keine Adresse
gelöst Frage von rudeboySonstige Systeme33 Kommentare

Mahlzeit! Habe einen Cisco-Router 1841 zum "spielen" bekommen. Erste "Aufgabe" war das secret zurückzusetzen, aber da gibt es ja ...

Router & Routing
VPN Router Cisco Lancom?
gelöst Frage von geforce28Router & Routing42 Kommentare

Hallo Leute, ich bin seit ein paar Tagen stolzer Besitzer einen 200/20 Leitung von meinem Kabelanbieter. Der hat mir ...

Router & Routing
VPN Cisco Router 886VAJ
gelöst Frage von andi.wetzelRouter & Routing5 Kommentare

Hallo liebe Administratoren, seit zwei Wochen versuche ich eine VPN per PPTP oder IPSec einzurichten, leider ohne Erfolg. Ich ...

Router & Routing
Cisco 2951 VPN Problem
gelöst Frage von Serial90Router & Routing20 Kommentare

Moin Moin, ich habe folgendes Problem mit meinem Cisco: Wir haben einen VPN-Tunnel via SVTI Config zu einem anderen ...

Neue Wissensbeiträge
Windows 7
Updategängelung auf Windows 10, die zweite
Information von Penny.Cilin vor 48 MinutenWindows 7

Hallo, da Windows 7 im kommenden Jahr nicht mehr supportet wird, werden Nutzer von Window 7 home premium wieder ...

Internet
EU-Urheberrechtsreform: Zusammenfassung
Information von Frank vor 2 TagenInternet1 Kommentar

Auf golem.de gibt es eine Analyse von Friedhelm Greis, der das Thema EU-Urheberrechtsreform gut und strukturiert zusammenfasst. Zwar haben ...

Microsoft Office

Office365 Schwachstellen bei Sicherheit und Datenschutz

Information von Penny.Cilin vor 3 TagenMicrosoft Office7 Kommentare

Auf Heise+ gibt es einen Artikel bzgl. Office365 Schwachstellen. Das ist noch ein Grund mehr seine Daten nicht in ...

Sicherheit
Schwachstellen in VPN Clients
Tipp von transocean vor 5 TagenSicherheit2 Kommentare

Moin, es gibt Sicherheitslücken bei VPN Clients namhafter Hersteller, wie man hier lesen kann. Gruß Uwe

Heiß diskutierte Inhalte
Tipps & Tricks
Verdammt voll erwischt
Frage von AlchimedesTipps & Tricks23 Kommentare

Folgende Mail habe ich auf meinem Freenet Account erhalten: Nun folgendes Problem: 1) Ich besuche Porno Seiten yep hat ...

Windows 10
Laufwerks-Mapping über Batch - Laufwerke werden zu spät im Explorer angezeigt
Frage von PhilzipWindows 1015 Kommentare

Hallo zusammen, ich habe beim Thema Laufwerksmapping via Batch ein Phänomen, welches ich so noch nicht kannte. Per Batch ...

Vmware
Richtige Einstellungen beim ESXI 6.5 in Sachen CPU Zuweisung bei einer VM
gelöst Frage von zeroblue2005Vmware13 Kommentare

Hallo Zusammen, heute wollte ich mal fragen, wie ich eine VM die richtige Anzahl der von CPUs zuweise. Bin ...

Vmware
ESXI hebt Registrierung von Masschinen auf
Frage von SpitzbubeVmware12 Kommentare

Hallo, nutze seit einiger Zeit für meine IT Projekte einen alten HP G7 Server mit ESXi 6.5 und einem ...