o-marc
Goto Top

Warum gehen die PATH Variablen von Windows XP verloren?

Hallo zusammen,

ich habe ein Problem mit einem Windows XP Client in einer Active Directory Umgebung (Server 2003 R2).

Dieser Client hat nach einem Neustart seine PATH-Variablen "vergessen". Sie tauchen zwar unter den Systemvariablen auf, aber ich kann z.B. aus der Kommandozeile heraus keine Befehle wie "ping" benutzen.

Erst wenn ich in der Kommandozeile

"SET Path=C:\WINDOWS\system32;C:\WINDOWS;C:\WINDOWS\System32\Wbem"

eingebe, funktioniert es wie gewohnt. Nur muss ich das leider nach jedem Neustart tun.


Der Client unterscheidet sich sowohl von den GPOs als auch von der installierten Software und den Patches her nicht von anderen Clients in der Umgebung.

Weiß jemand einen Rat?

Viele Grüße
Marco


Nachtrag:
Die Ereignisanzeigen für Anwendung und System sind blitzsauber.

Content-Key: 161469

Url: https://administrator.de/contentid/161469

Printed on: June 19, 2024 at 09:06 o'clock

Member: LittleFlame
LittleFlame Feb 24, 2011 at 08:17:01 (UTC)
Goto Top
Hallöchen O-Mark,

wenn du bei frisch gestartetem Rechner in dem Kommandozeile "set" eingibst, was erscheint dann unter "PATH"
Ist PATH einfach leer oder durch einen anderen Wert befüllt?
Betrifft dies nur die PATH Variable oder auch andere Variablen?

Grüße,
LF
Member: O-Marc
O-Marc Feb 24, 2011 at 08:31:14 (UTC)
Goto Top
Hallo LF,

die mit SET angezeigten Variablen sehen vollständig und korrekt aus. Für PATH wird folgendes ausgegeben:

Path=SET Path=C:\WINDOWS\system32;C:\WINDOWS;C:\WINDOWS\System32\Wbem


Ist das fett markierte der Fehler weil es überflüssig ist?
Member: LittleFlame
LittleFlame Feb 24, 2011 at 09:05:55 (UTC)
Goto Top
Deine Vermutung ist richtig.

Versuch bitte mal folgendes:

Systemsteuerung - System - Reiter "Erweitert"

Scrolle bei Systemvariablen (Unten) bis du die Path Variable siehst.
Steht hier ebenfalls "SET Path=C:\WINDOWS\system32;C:\WINDOWS;C:\WINDOWS\System32\Wbem"?
Dann liegt der Fehler hier.

Die Frage ist dann nur noch, woher das kommt.

Grüße,
LF
Mitglied: 48507
48507 Feb 24, 2011 at 09:08:30 (UTC)
Goto Top
Wenn man es in der Konsole eingibt, gilt Path dann nur in dieser Session, also nicht systemweit. Mach es stattdessen über Eigenschaften - Arbeitsplatz........ Umgebungsvariablen.... SYSTEMvariablen... oder ähnlich.
Member: O-Marc
O-Marc Feb 24, 2011 at 09:32:54 (UTC)
Goto Top
Habe das bei den Umgebungsvariablen geändert und jetzt funktioniert alles auch nach einem Neustart.
Ich verstehe nur nicht, wie sich da ein Fehler eingeschlichen hat. Der Client wird nur von mir verwendet und mir sind keine Änderungen an Software usw. bewusst.

Vielen Dank für die Hilfe, LittleFlame und spytnik.