totenmann
Goto Top

Webseiten über Iphone nicht abrufbar

Hallo ich bin neu hier und hab gleich meine erste frage.

Meine Webseiten die ich zu Hause auf einem Homelab laufen hab sind übers Internet erreichbar, aber nicht auf meinem iPhone.
Habe Laptops, Pc´s, Android Handys, Tablets usw. versucht. Dort lassen sich die Homepages ganz normal anzeigen.

Das seltsamste ist wenn ich zb einen Hotspot mit meinem iPhone mache, mich dann mit dem Tablet verbinde und die Seiten aufrufe, werden sie auch ganz normal angezeigt.

Komischerweise ist dies erst so seit ich meinen NginX reverse Proxy neu gestartet hab.
Davor hat alles wunderbar funktioniert.

Kann mir jemand einen Tipp geben woran das liegen kann?

Hab am iPhone schon versucht: Neustart, Cache löschen, VERSCHIEDENE BROWSER, Netzwerkeinstellungen zurücksetzen. Hat alles nichts gebracht.

Danke lg.

Content-Key: 8759012338

Url: https://administrator.de/contentid/8759012338

Printed on: May 20, 2024 at 12:05 o'clock

Member: viragomann
viragomann Apr 12, 2024 at 14:59:24 (UTC)
Goto Top
Hallo,

ich tippe auf das DNS. Hast du einen lokalen DNS Server mit Host Overrides, die auf deine Webserver bzw. den Reverse-Proxy zeigen?

iPhones verwenden standardmäßig Apples DoH Server und die lösen deine Hostnamen auf deine öffentliche IP auf, wenn überhaupt im öffentlichen DNS verfügbar.
Eventuell gibt es da ein Problem, dass damit das interne Routing nicht funktioniert.

Grüße
Member: accessViolation
accessViolation Apr 12, 2024 at 15:12:29 (UTC)
Goto Top
Hi.

evtl. Private Relay was dazwischen funkt? Kenne das von Cloudflareseiten, die sowas direkt unterbinden und Du keinen Zugriff darauf bekommst.

Zu Testzwecken mal deaktivieren?

Viele Grüße
Member: totenmann
totenmann Apr 12, 2024 at 16:27:05 (UTC)
Goto Top
Zitat von @viragomann:

Hallo,

ich tippe auf das DNS. Hast du einen lokalen DNS Server mit Host Overrides, die auf deine Webserver bzw. den Reverse-Proxy zeigen?

iPhones verwenden standardmäßig Apples DoH Server und die lösen deine Hostnamen auf deine öffentliche IP auf, wenn überhaupt im öffentlichen DNS verfügbar.
Eventuell gibt es da ein Problem, dass damit das interne Routing nicht funktioniert.

Grüße

Ich versuche gar nicht die Seiten im selben Netzwerk wie vom Server aufzurufen.
Also wenn ich über mobile daten die Domains aufrufen will, funktioniert es auf allen Geräten aber am iPhone nicht. Wie gesagt, seltsamerweise wenn ich mit dem iPhone einen Hotspot mache und die Domains auf anderen Geräten über das iPhone als Hotspot aufrufe, funktionieren diese einwandfrei.

Zitat von @accessViolation:

Hi.

evtl. Private Relay was dazwischen funkt? Kenne das von Cloudflareseiten, die sowas direkt unterbinden und Du keinen Zugriff darauf bekommst.

Zu Testzwecken mal deaktivieren?

Viele Grüße

Hi. Private Relay ist nicht in verwendung.
Member: Globetrotter
Globetrotter Apr 12, 2024 at 17:27:10 (UTC)
Goto Top
Hi..
Heute ist Freitag... Drink mal ein paar Bierchen und lasse Dich von Freund*in verwöhnen...
Dann hast Du den Kopf frei und findest den Fehler... face-smile
Kontrolliere mal Deine Netzwerkeinstellungen... was kommt am Handy raus, was bekommen die anderen..
Und dann lliegen wir zu 99% an einem DNS oder Gatewayproblem...

Gruss Globe!
Member: DivideByZero
DivideByZero Apr 12, 2024 at 18:53:40 (UTC)
Goto Top
Moin,

am iPhone mal ping, nslookup und trace starten, also mal prüfen, zu was Deine Domain aufgelöst wird und wie die Pakete laufen.

Gruß

DivideByZero
Member: aqui
aqui Apr 13, 2024 at 11:19:26 (UTC)
Goto Top
am iPhone mal ping, nslookup und trace starten, also mal prüfen, zu was Deine Domain aufgelöst wird
Was am besten mit den HE.NET Tools aus dem App Store geht.
Member: totenmann
totenmann Apr 13, 2024 at 12:58:52 (UTC)
Goto Top
ok anscheinend liegt es an der ssl Verwaltung des Nginx Proxy Managers.

Ich verwende Proxmox mit verschiedenen Lxc´s.
Hab keine Ahnung von Docker aber NginX mit Debian und Docker nach einem Tutorial installiert und zum laufen gebracht. Nun habe ich das obige Problem.
Im Netz finde ich etliche Posts wegen Proxy´s und ssl Problemen bei WordPress und Nextcloud.
Irgendwie Administriere ich mich schön langsam zu Tode.

Hat jemand eine Idee wie ich am "einfachsten" eine WordPress Seite und eine Cloud von meinem Homelab aus hosten kann ohne so viel administrieren zu müssen?
Member: viragomann
viragomann Apr 13, 2024 at 14:11:24 (UTC)
Goto Top
Zitat von @totenmann:
Im Netz finde ich etliche Posts wegen Proxy´s und ssl Problemen bei WordPress und Nextcloud.

Kannst du dazu ein paar Links posten?

Ich kann mir absolut nicht vorstellen, was der Nginx Proxy da falsch machen soll. Ich kenne diesen zwar nicht, für den Client ist der allerdings nichts weiter als ein Webserver, der eine SSL-Seite bereitstellt. Und ich nehme an, das bekommt Nginx gut hin, sonst wäre der Webserver nicht so weit verbreitet.

Ich verwende Apache als Reverse-Proxy wie auch HAproxy. Damit hatte ich jedenfalls noch keine SSL-Probleme mit iPhones gesehen.

Grüße
Member: aqui
aqui Apr 13, 2024 updated at 15:35:09 (UTC)
Goto Top
Wenn dir selbstsignierte Zertifikate im Nginx reichen:
  • Zertifikat generieren: sudo openssl req -x509 -nodes -days 1095 -newkey rsa:2048 -keyout /etc/ssl/private/nginx-selfsigned.key -out /etc/ssl/certs/nginx-selfsigned.crt
  • 2 Snippets erstellen: sudo nano /etc/nginx/snippets/self-signed.conf Inhalt:
ssl_certificate /etc/ssl/certs/nginx-selfsigned.crt;
ssl_certificate_key /etc/ssl/private/nginx-selfsigned.key;

  • sudo nano /etc/nginx/snippets/ssl-params.conf Inhalt:
ssl_protocols TLSv1.2;
ssl_prefer_server_ciphers on;
ssl_dhparam /etc/ssl/certs/dhparam.pem;
ssl_ciphers ECDHE-RSA-AES256-GCM-SHA512:DHE-RSA-AES256-GCM-SHA512:ECDHE-RSA-AES256-GCM-SHA384:DHE-RSA-AES256-GCM-SHA384:ECDHE-RSA-AES256-SHA384;
ssl_ecdh_curve secp384r1;
ssl_session_timeout 10m;
ssl_session_cache shared:SSL:10m;
ssl_session_tickets off;
add_header X-Frame-Options DENY;
add_header X-Content-Type-Options nosniff;
add_header X-XSS-Protection "1; mode=block";

  • DH Datei erzeugen: sudo openssl dhparam -out /etc/ssl/certs/dhparam.pem 2048
  • Server Konfig anpassen:
server {
    listen 443 ssl;
    listen [::]:443 ssl;
    include snippets/self-signed.conf;
    include snippets/ssl-params.conf;

    server_name example.com www.example.com;

    root /var/www/example.com/html;
    index index.html index.htm index.php;
} 
Für ein automatisches Client Redirect HTTP auf HTTPS fügst du noch dazu:
server {
        listen 80 default_server;
        listen [::]:80 default_server;

        server_name _;
        return 301 https://$host$request_uri;
} 
  • Nginx neu starten...fertisch
Member: totenmann
totenmann Apr 14, 2024 at 12:58:13 (UTC)
Goto Top
ich kann nginx leider so nicht konfigurieren da er in docker läuft und ich nicht weiß wie ich das mache.

Zitat von @viragomann:

Zitat von @totenmann:
Im Netz finde ich etliche Posts wegen Proxy´s und ssl Problemen bei WordPress und Nextcloud.

Kannst du dazu ein paar Links posten?

Ich kann mir absolut nicht vorstellen, was der Nginx Proxy da falsch machen soll. Ich kenne diesen zwar nicht, für den Client ist der allerdings nichts weiter als ein Webserver, der eine SSL-Seite bereitstellt. Und ich nehme an, das bekommt Nginx gut hin, sonst wäre der Webserver nicht so weit verbreitet.

Ich verwende Apache als Reverse-Proxy wie auch HAproxy. Damit hatte ich jedenfalls noch keine SSL-Probleme mit iPhones gesehen.

Grüße

ich hab mal diese anleitung versucht, hat aber nichts gebracht.
LINK
Member: aqui
aqui May 02, 2024 at 11:55:51 (UTC)
Goto Top
Wenn es das denn nun war bitte nicht vergessen deinen Thread dann auch als erledigt zu markieren!
How can I mark a post as solved?
Member: totenmann
totenmann May 02, 2024 at 12:34:03 (UTC)
Goto Top
Nein das war es leider nicht.
Und wie gesagt kenn ich mich mit docker zu wenig aus.