Dieser Beitrag ist schon älter. Bitte vergewissern Sie sich, dass die Rahmenbedingungen oder der enthaltene Lösungsvorschlag noch dem aktuellen Stand der Technik entspricht.

Win2003 Ent. als Router/RAS-Server

Mitglied: 9026
Hallo,


vor einiger Zeit habe ich einen permanenten Internetzugang bekommen. Diesen möchte ich gerne auf mein gesamtes Netzwerk verteilen. Da ich noch einen Windows 2003 Ent. Server stehen habe, der momentan nur kleinere Webserveraufgaben (intern) übernimmt, habe ich mir diesen als Server ausgesucht und auf ihm die Serverkomponente "Routing-/RAS-Server" installiert und eine zweite Netzwerkkarte eingebaut. Die ext. Verbindung zum Internet liegt an der ersten LAN-Karte, die zum internen Netzwerk (Switch) an der zweiten.

Bei den Clients habe ich die Server-IP sowohl als Standard-Gateway als auch als DNS-Server eingetragen. Die Clients können nun auch im Internet über den Server surfen. Nun allerdings das Problem: sporadisch (aller ein paar Seitenaufrufe) bekomme ich - sowohl in Firefox als auch im Internet Explorer - die Meldung, das bspw. "www.google.de" nicht gefunden wurde. Beim Reload klappt dann wieder alles - die Seite wird angezeigt.

Das zweite Problem: Ebenfalls so sporadisch wie das erste Problem bekomme ich eine 404-Fehlermeldung angezeigt. Aufgrund des Footes kann ich erkennen, dass versucht wurde, eine Fehlerseite durch einen Server meiner Internetdomain zu erzeugen.

Bsp.: Ich versuche die Seite http://www.xyz.de/abc.html aufzurufen und bekomme die Fehlermeldung, die ich als Bild angehängt habe. Unten im Footer ist die Zeile "Apache/df-exts. 1.1" zu sehen. Der Zusatz df-exts. 1.1 stammt von dem Webhoster Domainfactory, der einige meiner Internetseiten hostet. Ich weiß aber 100%ig, dass die von mir aufgerufene Seite nicht von Domainfactory gehostet wird.

Ich vermute, dass ich irgendetwas bei meiner Domäne an meinem lokalen Server falsch gemacht habe. Die Domäne, der meine Clients angehören, ist gleich mit einer Domain meiner Internetseiten. Irgendwie wird versucht, die Fehlerseiten auf meine richtigen Internetseiten zu übertragen, mein Hoster generiert dafür die Fehlermeldung....

Für Lösungshilfe bin ich sehr dankbar.

Content-Key: 6284

Url: https://administrator.de/contentid/6284

Ausgedruckt am: 23.06.2021 um 09:06 Uhr

6 Kommentare
Mitglied: 9026
Ich habe gerade bemerkt, dass der 404-Fehler anscheinend doch nicht sporadisch auftritt.... Er taucht gehäuft bei Seiten auf, die aus dem *.de - Raum herausgehen. Aber auch nicht bei allen - mit microsoft.com z.B. hat er keine Probleme.
Mitglied: linkit
Mh...könnte ein DNS Problem sein...


geh mal auf die Kommandozeile und gib ein:

ping www.heise.de /n 100
tracert www.heise.de


schau er den Pinglauf sauber macht und was du für Pingzeit hast.
Schau was beim tracert passiert.
Mitglied: 9026
Hallo,

ich dachte mir auch schon, es könnte ein DNS-Problem sein.

Hier das, was der Ping auswirft:


Und hier der traceroute:



Ich habe die Server-IP als DNS-Server bei allen Clients eingetragen und die DNS-Serverkomponente installiert. Andersweitig habe ich aber dort nichts eingestellt - wüsste nicht was.

In einem Internetforum las ich, ich sollte den DNS-Server, der an meinem Server für die internetseitige Netzwerkkarte eingetragen wurde, per DNS an die Clients weiterleiten, bei den Clients soll weiterhin die IP des Servers stehen bleiben. Wie kann man soetwas anstellen; liegt hierin vielleicht die Ursache des Problems?

Danke schon einmal.


Grüße,

René
Mitglied: linkit
Testen wir.... setze mal einen Ping auf heise.de nur mit der IP ab... wenn es ein DNS Problem ist, dann muß der aufruf nur über die IP reibungslos durchlaufen
Mitglied: 9026
Ich hab jetzt über die IP mehrere hundert Male anpingen lassen. Nur ein Paket insgesamt verloren, aber das kann durchaus durch die Funkstrecke, durch die das Internet angelegt ist, geschehen sein.

Interessant ist, dass ich am Server Internetseiten problemlos aufrufen kann. Alle Arten. Die beiden oben beschriebenen Fehler treten nicht auf. An den Clients ist es wirklich so, dass *.de-Seiten meistens problemlos (nur manchmal der Fehler, der Host würde nicht existieren; gibt sich aber bei Reload), andere Seiten (com, net, com.tw, net...) mit dem 404 beantwortet werden. Hier bringt auch ein Reload nichts.
Mitglied: 9026
Hallo,

ich habe jetzt auf dem Server eine DNS-Weiterleitung auf den DNS- und Gateway-Server der internetseitigen Netzwerkverbindung erstellt --> Die Fehler treten nicht mehr auf.

Aufgrund meiner AD-Domäne (*.de) hat sich mein DNS-Server den kompletten DNS-Stamm der de-Hierarchie gezogen, aber externe Quellen nicht aufgelöst. Die Weiterleitung zwingt den DNS-Server jetzt dazu, externe Weiterleitungen zu bewerkstelligen.

Ich hoffe, dass sich das Problem wirklich dadurch gelöst hat und der Effekt nicht nur temporär ist.

Auf jeden Fall schonmal vielen vielen Dank für deine Hilfe.
Heiß diskutierte Beiträge
general
Vorstellungsgespräch IT Administrator 2nd Level SupportGoldfuchsVor 1 TagAllgemeinWeiterbildung11 Kommentare

Moin ich habe demnächst ein Vorstellungsgespräch in einen Unternehmen für den Bereich des IT Administrators 2nd Level Support. Ich wollte da mal Euer Schwarmwissen abfragen ...

question
Glasfaseranschluss mit 4 Knotenpunkten auf 26 Häuser 1 Büro aufteilenchrisbaliVor 1 TagFrageEntwicklung18 Kommentare

hallo liebe Leute in der alten heimat Ganz vorweg ich Habe erstmal keine Ahnung und kenne den Spruch ...

question
Minimaler Upload durch FritzBox im NetzwerkDoskiasVor 1 TagFrageLAN, WAN, Wireless24 Kommentare

Hallo zusammen, wir haben bei uns in der Firma ein separates Netz aufgebaut, welches einzig und alleine für Videokonferenzen genutzt wird. In der folgenden Darstellung ...

question
Server 2019: vcpus überbuchennixwissenderVor 1 TagFrageWindows Server16 Kommentare

hallo! wir betreiben einen etwas performanteren server mit 12 kernen, 128gb ram und einigen tb an speicherplatz in form vom nvme-platten, der uns als host ...

tip
Powershell Link-Leitfaden für AnfängercolinardoVor 19 StundenTippBatch & Shell9 Kommentare

Da ja immer mal wieder die Frage nach Powershell-Lektüre von Neulingen in der Materie hier aufkommt und ich die Liste nicht in jedem Beitrag posten ...

question
Berechtigung auf letzten Ordner einrichten gelöst MarikaVor 21 StundenFrageBatch & Shell22 Kommentare

Hallo Zusammen, ich suche schon eine ganze Weile nach einer Lösung meines Problems und hoffe Ihr könnt mir helfen. Ich muss auf eine Ordnerstruktur mit ...

question
Gast Wlan GatewayMaxHaxVor 1 TagFrageLAN, WAN, Wireless8 Kommentare

Servus!! Ich verwende zurzeit ein unifi Setup in einem Hotel mit alles unifi Geräte sogar das Gateway. Hab eine mgmt lan und gast vlan(captive Portal) ...

question
Starface SIP AttackenblackarchVor 1 TagFrageTK-Netze & Geräte6 Kommentare

Hallo Zusammen, seit einiger Zeit finden sich im Postfach diese Mails, Und die Blacklist ist voll. Die o.g. von PoneyTelecom.eu, UAB Host Baltic uvm. Teils ...