Dieser Beitrag ist schon älter. Bitte vergewissern Sie sich, dass die Rahmenbedingungen oder der enthaltene Lösungsvorschlag noch dem aktuellen Stand der Technik entspricht.

Windows 2000 Server - Script Fehler? brauche Hilfe

Mitglied: 4386

logon.cmd

hallo ich möchte auf einen Server 2000, in den logon script einen Drucker mit einbinden.und hab folgendes ins script geschrieben:z.B. (net use Anschluss \\server /drucker)net use lexprint \\doco /lexmarkden Erinnerungen nach müsste das korrekt sein aber es funktioniert nicht!?Hat jemand eine Lösung? danke im VorausGruß waldi

Content-Key: 2335

Url: https://administrator.de/contentid/2335

Ausgedruckt am: 26.09.2021 um 09:09 Uhr

Mitglied: linkit
linkit 04.09.2004 um 09:40:59 Uhr
Goto Top
Dieser erwartet als Anschluß beispielsweise LPT1, LPT2 etc.... aber nicht lexprint. Mit Anschluß ist gemeint, wenn der Anschluß angesprochen wird, dann drucke auf den Drucker über das Netz.


Mit net use kriegst du den Drucker nicht ins Windows rein, sondern nur eine Verbindung über den Prompt.

Aber den Problem wurde hier schon mal angesprochen mit einem Skriptbeispiel, schau einfach die alten Beiträge durch, da findest du die Lösung
Mitglied: 4386
4386 06.09.2004 um 11:57:54 Uhr
Goto Top
danke,
hab leider keine alten beiträge gefunden....

waldi
Mitglied: kl-A
kl-A 09.09.2004 um 12:26:18 Uhr
Goto Top
hi,

ist wahrscheinlich keine lösung für dich, aber kannst es dir ja trotzdem mal anschauen.

ich verwende bei mir für das logonscript kixtart (http://www.kixtart.org)

damit sind viele sachen sehr viel einfacher zu realisieren als mit einem cmd script.

gruss d. kl_A
Mitglied: 5274
5274 15.10.2004 um 17:19:28 Uhr
Goto Top
Hi,
mit dem wsh funktioniert das wunderbar, du kannst sogar den Standarddrucker damit setzen.
>>>>snip<<<<
Set WshNetwork = Wscript.CreateObject("WScript.Network")
WshNetwork.AddWindowsPrinterConnection "\\<server>\<drucker>"
WshNetwork.SetDefaultPrinter "\\<server>\<drucker>"
Set WshNetwork = Nothing
>>>>snip<<<<
Alternativ gibt es das tool con2prt.exe aus dem zero administration kit das denselben zweck erfüllt.
gruss
jack
Mitglied: 5274
5274 15.10.2004 um 17:22:10 Uhr
Goto Top
Sorry, da hat sich ein fehler eingeschlichen.
so muss das natürlich lauten:
>>>>snip<<<<
Set WshNetwork = Wscript.CreateObject("WScript.Network")
WshNetwork.AddWindowsPrinterConnection "\\server\drucker"
WshNetwork.SetDefaultPrinter "\\server\drucker"
Set WshNetwork = Nothing
>>>>snip<<<<
Heiß diskutierte Beiträge
general
DSL-Modems am F-Buchse statt N-Buchse - warum?Windows10GegnerVor 22 StundenAllgemeinDSL, VDSL19 Kommentare

Hallo zusammen, es sind jetzt hier die Fernmeldetechniker gefragt. Normalerweise wird ja ein DSL-Modem mit der F-Buchse einer TAE-NFN-Dose verbunden. Was ist der genau Grund ...

general
Autodesk im Jahre 2021-2022dertowaVor 1 TagAllgemeinOff Topic4 Kommentare

Hallo zusammen, mal eine kleine Anekdote, u.a. da heute Freitag ist. Vor einigen Jahren hatte ich mit Autodesk AutoCAD LT zu tun, in der damaligen ...

general
Außergewöhnliche hohe Spamaktivitäten und Angriffe per E-Mail gelöst beidermachtvongreyscullVor 1 TagAllgemeinE-Mail5 Kommentare

Tach Kollegen, liegt das an den bevorstehenden Wahlen? Ich beobachte seit Tagen auf unserer Firewall, dass wir massiven Spamwellen ausgesetzt sind. Bisher kommt zum Glück ...

question
Einrichtung Unify Security Gateway gelöst markaurelVor 18 StundenFrageLAN, WAN, Wireless9 Kommentare

Hallo zusammen und bitte um eure Hilfe! Wie der Titel schon sagt Folgende Situation: Ich hab ein Netzwerk in folgenden IP-Bereich: 192.168.10.x. Als Gateway dient ...

question
Backup-Server, welcher sich selber sichertludakuVor 1 TagFrageBackup6 Kommentare

Moin Zusammen Stellen wir uns kurz folgendes Konstrukt vor: 1x Hypervisor mit 3 VMs: - DC & Fileserver - Webserver - Acronis Backup-Server Ist es ...

question
Sysprep nachträglich virtualisierenalf008Vor 1 TagFrageVmware6 Kommentare

Hallo, ich habe diverse physikalische Server virtualisiert und später sollten diese in eine neue Domäne aufgenommen werden. Leider habe ich beim Virtualisieren erst später (zu ...

question
Wlanprobleme nach Providerwechsel gelöst amsti70Vor 1 TagFrageRouter & Routing8 Kommentare

Hallo alle zusammen! Ich bin neu auf dieser Seite und komme gleich mit einem Problem. Habe jetzt von A1 auf Drei Festnetz gewechselt. Mein System ...

question
Exchange Autodiscover ExternredhorseVor 1 TagFrageExchange Server5 Kommentare

Guten Morgen, bei Heise wird aktuell über eine Problematik berichtet, bei der es bei einem nicht nach Microsoft-Vorgaben konfiguriertem Autodiscover zu einem Sicherheitsproblem kommt: Konkret ...