staybb
Goto Top

Windows 7 - Sie wurden mit einem temporären Profil angemeldet - Kein Benutzerverzeichnis unter C:users vorhanden

Hallo,

ich habe das großbekannte Problem unter WIndows 7 das ein Benutzer sich nur als temporäres Profil anmelden kann.

Das Problem hatte ich schon öfters und eigentlich auch immer lösen können mit folgenden Schritte:

 1- Logon with local admin profile. (or other account different that you want to use, but with admin privileges).
2- Open regedit and go to HKLM\SOFTWARE\Microsoft\Windows NT\CurrentVersion\ProfileList. Here you can see all SIDs of loaded profiles and probably you'll have some of them repeated but with .bak extensions.  
3- So if you want to recover your profile, desktop icons, ect... you only have to delete the profile with no .bak extension and rename the other, deleting only the .bak extension of it:
Ex: In Regedit (HKLM\SOFTWARE\Microsoft\Windows NT\CurrentVersion\ProfileList) I have:

SID-1292428093-343818398-2115-158554 (1º Delete this Key)
SID-1292428093-343818398-2115-158554.bak (2º Rename This Key to SID-1292428093-343818398-2115-158554).

4- Restart your computer or Logoff and Logon with the profile that you want to restore and that's all, your profile will be restored Perfectly."   

Nur ist jetzt das Problem das der Benutzer keinen Ordner unter C:\users\ besitzt und auch in der registry ist kein Wert für sein Benutzer vorhanden.

Warum meldet sich Windows 7 dann mit einem temporären Profil an?

Es ist ein servergespeichertes Profil auf einem Windows Server 2008 R2 AD Server.

Kann ich auf dem Server irgendetwas vornehmen, sodass der Benutzer sich wieder normal an der Maschine anmelden kann?

Weil ich wüsste nicht was ich an der Maschine noch einstellen könnte. Sie ist auch mit der Domäne verbunden.

Vielen Dank

Content-Key: 273211

Url: https://administrator.de/contentid/273211

Printed on: April 16, 2024 at 17:04 o'clock

Member: Pjordorf
Pjordorf May 29, 2015 at 10:48:54 (UTC)
Goto Top
Hallo,

Zitat von @staybb:
Nur ist jetzt das Problem das der Benutzer keinen Ordner unter C:\users\ besitzt
Da wird doch sein jetziges Temporäres Profil verwendet. Das muss dort stehen, außer eure Profile liegen woanders.

Warum meldet sich Windows 7 dann mit einem temporären Profil an?
Weil es eben lokal keinen Hinweis auf sein Ursprüngliches Profil mehr gibt und in seine Lokale Registrierung wohl noch irgendwelcher Müll rumgeistert der es nicht erlaubt die Profildaten neu zu erstellen oder zu nutzen.

Kann ich auf dem Server irgendetwas vornehmen
Nö.

Sie ist auch mit der Domäne verbunden.
Verbunden alleine reicht nicht. Der Rechner muss auch in der Domäne aufgenommen sein. Schmeiß ihn mal raus und wieder rein, ansonsten deine Lokale Registrierung mal durchsuchen wo der User (Roaming) noch überall drin steht....

Mit einen anderen Benutzer klappt das laden der Profile oder dessen Neuerstellung (bei Erstanmeldung)?

Gruß,
Peter
Member: Hajo2006
Hajo2006 May 29, 2015 at 10:50:32 (UTC)
Goto Top
Hi,

ist das bei jedem Windows 7 Client so? Hat das jeder User oder nur bestimmte User?

Gruß
Hajo
Member: vossi31
vossi31 May 29, 2015 updated at 11:37:29 (UTC)
Goto Top
Moin,

versuche erstmal den regulären Weg zum Löschen des Profils:
Systemsteuerung/System/Erweiterte Systemeinstellungen/Benutzerprofile.

Wenn das nicht geht ermittle über das Ereignisprotokoll die SID und lösche den Eintrag in der Registry.

Henning
Member: killtec
killtec May 29, 2015 at 11:35:08 (UTC)
Goto Top
Hi, Schmeiß mal die Registryeinträge von dem Userprofil komplett raus. also nicht nur .bak umbenennen, sondern weg damit. Das hat mir einmal geholfen.
PC Neustarten nicht vergessen.

Gruß
Member: fabgg6
fabgg6 May 29, 2015, updated at May 30, 2015 at 09:48:33 (UTC)
Goto Top
Hallo,

leider macht Windows so etwas manchmal. Eine saubere Lösung ist die, in der Registry (HKLM\Software\Microsoft\WindowsNT\CurrentVersion\ProfileList) den gesamten Zweig zu löschen, der auf das Verzeichnis des Nutzers verweist. Die echten Nutzer haben drei zehnstellige Ziffernblöcke drin und am Ende eine drei- oder vierstellige Zahl. Bei der deutschen Windows-Version wird im Explorer C:\Benutzer anstelle C:\Users angezeigt.

Gibt es diesen Registra-Eintrag bei Deinem Computer? Normalerweise wird auch bei Mitgliedschaft in einer Domäne neben dem Server gespeicherten Profil ein Profilordner auf dem lokalen Rechner geführt. Mitunter sind die Server-Einstellungen so, dass bei Abmeldung das lokal gespeicherte Profil gelöscht und bei Neuanmeldung erneut vom Server kopiert wird. Gibt es hierbei Fehler, wird ein temporäres Profil angelegt.

Anschließend sollte man das Profilverzeichnis auf dem Rechner (falls vorhanden) und auf dem Server löschen. Danach erstellt der User sein Profil komplett neu. Dazu muss seit Vista aber auch der Registryeintrag gelöscht sein. Bei XP ging das noch ohne Registryeingriff.

Wenn man für Office oder andere Programme recht viele Einstellungen gemacht hat, dann kann man diese Ordner (z.B. C:\Users\BENUTZERNAME\AppData\Roaming\inkscape für Einstellungen im Grafikprogramm Inkscape) von der Festplatte oder aus dem Profilverzeichnis auf dem Server erst einmal kopieren und später zurück spielen.

Das Umbenennen der *.bak hilft eher selten. Meist ist irgendwas faul im Profil und beim nächsten Anmeldeversuch versieht Windows den Registryzweig einfach wieder mit einem bak. Löscht man nur den Registry-Eintrag, dann wird ein neuer mit einer anderen ID erstellt, der dann nicht mehr auf das alte Benutzerprofilverzeichnis mit der alten ID zugreifen kann. Also am besten alles von diesem Nutzer löschen.

Alternativ kann man natürlich auch einen neuen User in der Domäne erstellen, dessen Profil bei der Erstanmeldung neu erstellt wird. Hast Du das probiert? Sind damit alle Probleme behoben?

Das Zerschießen von Profilen hatte bei uns folgende Ursache. Unter Windows 8.1 war die "schnelle Anmeldung" aktiviert, bei der offenbar Teile des Profils geöffnet bleiben. Meldet sich der User dann an einem anderen Rechner an, sind anschließend die Profilverzeichnisse auf den beiden Rechnern inkonsistent, was teilweise auf das Server gespeicherte Profil übertragen wird. Beim nächsten Start ist Windows "verwirrt". Die "schnelle Anmeldung" ist unter Windows 8/8.1/8.1U1 standardmäßig aktiviert. Bei Windows 7 ist mir dieses Verhalten nicht aufgefallen. Vielleicht wurde bei Euch etwas Ähnliches aktiviert, was vorher standardmäßig deaktiviert ist.

Gruß, GG.