Windows Server 2003 R2 - DHCP - Probleme beim Öffnen der Reservationen und Leases im Scope

Mitglied: rolemodel91

rolemodel91 (Level 1) - Jetzt verbinden

08.02.2010 um 10:00 Uhr, 7388 Aufrufe, 8 Kommentare

Hallo Zusammen

Seit kurzer Zeit habe ich ein Problem mit dem DHCP Server.
Wie im Titel schon erwähnt wird, handelt es sich um einen Windows Server 2003 R2.

Damit ich einen weitern Drucker im Netzwerk aufnehmen kann muss ich eine DHCP Reservation für die MAC-Adresse vornehmen und verbinde mich deshalb Remotemässig mit dem Server. Anschliessend öffne ich die MMC und mach das DCHP Snap-In auf. Nun wähle ich den Scope aus. Es gibt 2 Scopes, einen mit einer 10.7.6.0 Netzwerkadresse für die Clients und den zweiten Scope mit einer 141.181.216.0 Netzwerkadresse für alle sonstigen Geräte.

Schon beim anwählen des Servers sehe ich neben dem Server-Icon auch einen Blauen Punkt mit einem weissen Ausrufezeichen drin. Gleiches ist bei den beiden Scopes vorhanden. In den 10.7.6.0 Scope komme ich ohne weitere Probleme. Obwohl er zwar angibt 0% freie Adressen zu haben, was zwar nicht stimmt, komme ich trotz allem dort rein.

In den 141.181.216.0 Scope komme ich aber nicht einmal rein. Ich kann zwar die Struktur öffnen und Reservations oder Adress Leases anwählen, bekomme aber bei den Reservations nach einem kuzen Augenblick, auf dem Icon einen roten Punkt mit einem weissen X und als Text "There are no items to show in this view." Und bei den Adress Leases, neben dem roten Icon auch noch einen Fehler, dass die MMC das Snap-In nicht initialisieren konnte. Diese Meldung kann ich mit OK quittieren.

Der Event Viewer gibt lediglich eine Warnung zum DCHPServer raus, dass der 10.7.6.0 Scope 0% freie IPs hat, weiter nichts. EventID davon ist 1020. Bei MS konnte ich nichts brauchbares damit finden.

Nach dem Problem gegoogelt habe ich schon, konnte aber keine nützlichen Infos finden.
Im Forum gibt es einen ähnlichen Eintrag, dieser ist aber ebenfalls nicht geläst und veraltet.

Hat jemand eine Idee oder einen Lösungsvorschlag was gemacht werden kann, damit der DCHP Server wieder so funktioniert, wie er funktionieren sollte?

Besten Dank für eure Hilfe, schon mal im Voraus!

Freundlichen Gruss
Dean
Mitglied: Edi.Pfisterer
08.02.2010 um 11:18 Uhr
Hallo!
Seit wann zeigt Dein Server dieses Verhalten?
Während Schulungen habe ich beobachtet, dass der Microsoft DHCP keine Freude hat, wenn man ihm Scopes unterjubelt, in deren Netzwerk die servereigene IP-Adresse nicht passt.
Er zeigt dann genau das von Dir beschriebene Verhalten (Rufezeichen + Begleiterscheinung)
(Das war jetzt auch kein schönes Deutsch ;-) face-wink

Beispiel:
ServerIP: 10.0.0.1 subnet 255.255.255.0
Scope: 10.0.1.0
Das wird nix! Hat meine Schüler schon jede Menge Nerven gekostet... ;-) face-wink

Damit ich einen weitern Drucker im Netzwerk aufnehmen kann muss ich eine DHCP Reservation für die MAC-Adresse vornehmen und
verbinde mich deshalb Remotemässig mit dem Server. Anschliessend öffne ich die MMC und mach das DCHP Snap-In auf. Nun
wähle ich den Scope aus. Es gibt 2 Scopes, einen mit einer 10.7.6.0 Netzwerkadresse für die Clients und den zweiten
Scope mit einer 141.181.216.0 Netzwerkadresse für alle sonstigen Geräte.


Falls Dein Server also keine 141.181.216.x hat, dann kannst das imho schon mal vergessen. Gleiches gilt für 10.7.6.x
Was meinst du mit "sonstigen Geräte"?

Möglicherweise hast du aber auch einen grundsätzlichen Denkfehler in Deiner Scopeplanung...
(ich kann mir aktuell kein Szenario vorstellen, in dem ich 2 Scopes mit den von Dir erwähnten IP-Adressen-Räumen verwenden würde...
abgesehen davon gehört 141.181.216.x nicht zu den Adressen, die DU vergibst, sondern bestenfalls zum Adressraum, den Dein Providinger vergibt und DU beziehst...)
Aber: vielleicht täusche ich mich auch, das ist in jedem Fall möglich....

lg
Bitte warten ..
Mitglied: Sonnenscheinhasser
08.02.2010 um 11:44 Uhr
Schau mal nach wie viele Reservierungen du in deinem Bereich hast. Wahrscheinlich sind es genau 87.
Der DHCP Server hat ein Problem wenn genau diese Anzahl von Reservierungen vorhanden sind. Ist es eine mehr funktioniert es wieder!

http://support.microsoft.com/Default.aspx?scid=kb%3Ben-us%3B902954& ...

Oder füg eine Reservierung auf Kommandozeile per netsh ein.

Schwarze Grüße,
Tom
Bitte warten ..
Mitglied: Sonnenscheinhasser
08.02.2010 um 11:46 Uhr
Die blauen Ausrufezeichen sind übrigens unbedenklich. Sie sagen lediglich aus, dass keine freien IPs zur Vergabe bereit stehen.
Falls man nur reservierte IPs verteilt, ist dies OK so.

Schwarze Grüße,
Tom
Bitte warten ..
Mitglied: rolemodel91
08.02.2010 um 13:15 Uhr
@urobe73: Danke für deine Antwort. Daran dürfte es aber nicht liegen, da der Server nun doch schon seit min. 3 Jahren so läuft. Zudem ist mir das bekannt, das der DHCP dumm tun würde, wenn er einen Scope deligieren müssten indem er sich nicht befindet. Aber das tut er, da er Virtuell ist und 2 IPs besitzt. Aber Danke für die Hilfe ^-^
Bitte warten ..
Mitglied: Edi.Pfisterer
08.02.2010 um 13:23 Uhr
danke für die Rückmeldung! (kommt hier leider nicht oft vor...).
Dann wirds wohl am Phänomen liegen, das Sonnenscheinhasser beschrieben hat
(das war mir auch neu...)

lg
gutes Gelingen
Bitte warten ..
Mitglied: rolemodel91
08.02.2010 um 13:29 Uhr
@Sonnenscheinhasser: Interessant, und wieso ausgerechnet bei der 87? Ich habe kurz gegoogelt und über netsh eine weitere Reservation hinzugefügt. Das hat geklappt und ich komme nun auch wieder in den Scope rein. Somit ist das Problem vorerst behoben. Aber wir werden nächstens den Server auf SP2 lupfen. Somit Danke für deine Hilfe!

Falls es jemanden interessiert wie man über netsh eine Reservation hinzufügt, hier der Befehl (Wusste ich auch bisher nicht, wie das geht.):

netsh dhcp server \\server1 scope 10.16.2.0 add reservedip 10.16.2.11 0019b92895b2 COMPUTER11.DOMAIN.LOCAL

Info: Server1 steht für den Namen des Servers, der Rest erklärt sich glaub ich mal, von selbst. Wichtig: Funktioniert auf Windows Server 2003 mit DHCP!

Freundlichen Gruss
Dean
Bitte warten ..
Mitglied: rolemodel91
08.02.2010 um 14:40 Uhr
Bitte! ^-^
Echt jetzt? Bin hier zwar nicht oft unterwegs, aber gewisse Dinge gehören sich halt einfach.
Jop, lag daran.
Falls dich noch intressiert, mit "sonsitege Geräte" meine ich Drucker, Switch, Server, spezial PC und alles ausser den Clients.

Nochmals Danke und freundlichen Gruss
Dean
Bitte warten ..
Mitglied: Sonnenscheinhasser
08.02.2010 um 19:42 Uhr
Freut mich, dass es geklappt hat.
Ich stand vor gut 2 Jahren vor dem selben Problem.

Ach ja, bitte noch an https://www.administrator.de/index.php?faq=32 denken.

Schwarze Grüße,
Tom
Bitte warten ..
Heiß diskutierte Inhalte
Zusammenarbeit
Klimaschutz
NebellichtVor 22 StundenTippZusammenarbeit48 Kommentare

Hallo friends, (friends in Anlehnung an die vielen Fs in dem englischen von FFF: fridays for future. Übrigens am 19.03.2021 gibts wieder einen globalen ...

Notebook & Zubehör
Tipp für festgefressene Scharniere bei Lenovo V120 Notebook?
gelöst LochkartenstanzerVor 1 TagFrageNotebook & Zubehör20 Kommentare

Moin Kollegen, Ich habe hier ein Lenovo V120 mit einem laut Internet üblichen Problem von "festgefressenen" Scharnieren. Ich könnte jetzt aufwendig das Notebook zerlegen ...

Microsoft Office
Microsoft365 und Outlook verbinden
ratzekahl1Vor 1 TagFrageMicrosoft Office30 Kommentare

Guten Morgen zusammen, ich habe einige Probleme / Fragen. Ich habe Office 365 auf den ersten Rechnern installiert. Admin angelegt, Benutzer usw. Da ich ...

Microsoft Office
Wechsel von Office - Exchange on premise zu Office 365 - Exchange Online
jann0rVor 1 TagAllgemeinMicrosoft Office14 Kommentare

Moin, ich weiß nicht so richtig, unter welche Überschrift man dieses Thema hier am besten packen kann, daher mal als allg. Beitrag / Erfahrungsbericht. ...

Viren und Trojaner
Ryuk Ransomware Warnzeichen
SchlemihlVor 1 TagFrageViren und Trojaner8 Kommentare

Guten Abend, nachdem ich hier und hier erfahren habe, wie sich die Ransomware Ryuk verhält, musste ich feststellen, dass unser kleines Netzwerk für eine ...

Internet
Sichere Verbindung von zu Hause zu einem Firmenpc
haiflosseVor 1 TagFrageInternet6 Kommentare

Hallo! Ich suche eine Lösung mit der ich eine sichere Verbindung (ohne das ein Virus, Trojaner oder Ransom Virus den Computer bzw. Netzwerk zerstört) ...

Windows 10
Leeres Desktop bei neuen Usern - möglich?
gelöst istike2Vor 1 TagFrageWindows 104 Kommentare

Hallo, in dem aktuellen Windows 10 Image haben wir leider vergessen das Desktop zu bereinigen. Wir haben also bei jedem neuen User einen vollen ...

TK-Netze & Geräte
2 x VPN site-to-site möglich?!
RicoPausBVor 1 TagFrageTK-Netze & Geräte6 Kommentare

Moin aktuell haben wir hier ein site-to-site vpn via IPsec. Das ganze läuft stabil aber langsam mit 2 x AVM6490 an Vodafone-Anschlüssen. Nun gibt ...