Dieser Beitrag ist schon älter. Bitte vergewissern Sie sich, dass die Rahmenbedingungen oder der enthaltene Lösungsvorschlag noch dem aktuellen Stand der Technik entspricht.

WMI Filterung auf Subnet einer bestimmten Netzwerkkarte

Mitglied: Vip0r
Guten morgen liebe Sorgen. Hier mal eine kurze Beschreibung meines Problems:

Ich möchte eine Gruppenrichtlinie für unseren mobilen Arbeitsplätze anwenden, mit der Filterung darauf ob der Notebook gerade bei uns im Netz, also vor Ort, oder über VPN eingeloggt ist.

Gesagt getan, ich hab einen WMI-Filter geschrieben der wie folgt aussieht:

SELECT * FROM Win32_NetworkAdapterConfiguration WHERE NOT IPSubnet='21.254'

Der Plan war das die Gruppenrichtlinie angewendet wird sobald das IP-Subnet NICHT 21.254 ist... es gab allerdings einen kleinen Denkfehler in der ganzen Geschichte... durch VPN ist eine NIC trotzdem in dem Subnet und deswegen zieht der Filter nicht.

Gibt es keine Möglichkeit auf das Subnet eines einzelnen bestimmten Devices zu filtern: Also nach dem Motto:

Wenn Netzwerkkarte2345.IP-Subnet=21.254 ....

Oder fällt euch gar gleich eine ganz andere Möglichkeit ein um zwischen VPN Einwahl und normalen Login zu unterscheiden, ein?

Content-Key: 66690

Url: https://administrator.de/contentid/66690

Ausgedruckt am: 29.11.2021 um 12:11 Uhr

Mitglied: Egbert
Egbert 05.09.2007 um 14:34:00 Uhr
Goto Top
Hallo,

wenn Du ein kommerzelles Werkzeug wie PolicyMaker (auch von Microsoft) einsetzt ist dies möglich. Auf die WMI Filter würde ich mich in dem Fall nicht verlassen.

Es kommt darauf an was Du in Abhängigkeit von der Netzwerkzugehörigkeit machen willst. Wenn es eine Endgerätesteuerung und ablaufen von Prozessen sein soll käme auch DriveLock in frage, hier kannst Du Netzwerkprofile definieren und in Abhängigkeit von diesen auch Richtlinien und Aktionen definieren. Alles über GPO's und den entsprechenden Extensions.

Gruß
Egbert
Heiß diskutierte Beiträge
question
Adminpasswort löschenaleks08Vor 1 TagFrageWindows 79 Kommentare

Bei einem Kollegen hat jemand den Rechner eingerichtet und dabei ein Adminpasswort vergeben. Das Adminpasswort kennt er aber nicht und der Einrichter ist nicht mehr ...

question
Medienwandler für Glasfaser gelöst Reamer76Vor 1 TagFrageHardware9 Kommentare

Guten Tag liebe Admins, ich bräuchte mal Eure Hilfe für die Anschaffung eines Medienwandlers. Wir werden nächsten Monat freigeschaltet, Anbieter ist Wemacom. Ich habe die ...

question
Ethernet-LAN und DSL über Telefonkabel gelöst 150103Vor 1 TagFrageNetzwerke10 Kommentare

Hallo Administrator-Forum, ich habe hier ein ungewöhnliches Szenario, dass ich euch gerne näher bringen würde. Auf einem Grundstück gibt 2 Häuser (H1 und H2). Im ...

question
AD Server von 2012 R2 auf Server 2019 R2 hochgesetzt. Domänenlevel noch 2012 Aber nun geht kein LDAPS . LDAP geht gelöst itititVor 21 StundenFrageWindows Server13 Kommentare

Hallo zusammen, wir haben die Server 2012 R2 mit Server 2019 R2 ersetzt. Neue Server kein Inplace. Die neuen DCs haben IP und Name gleich ...

question
"Nicht identifiziertes Netzwerk" bei VPN VerbindungKatachi29Vor 1 TagFrageDSL, VDSL5 Kommentare

Hallo zusammen, ich habe seit einiger Zeit das Problem, dass, wenn ich mich daheim bei meinem Sophos SSL VPN Client anmelde, immer die Meldung: "Nicht ...

question
Euro Zeichen geht nicht mehrGwaihirVor 18 StundenFrageWindows 1013 Kommentare

Hallo zusammen, bei einem User geht das Euro-Zeichen nicht mehr. Er kann es nur noch über Copy&Paste aus der Zeichentabelle einfügen. Auch STRG+ALT+E klappt nicht. ...

question
Dauernd gesperrter User in der ADChristianIT2021Vor 1 TagFrageWindows Server3 Kommentare

Hallo zusammen, Ich habe ein riesen Problem ich habe einen User der wird immer wieder gesperrt. Über die Eventlgs habe ich schon herausgefunden aus welcher ...

question
Bitlockerpartition versehentlich gelöscht Läppi findet nach Partitiosformatierung mbr gpt die Partition nicht wiederPCChaosVor 16 StundenFrageWindows 1010 Kommentare

Hallo zusammen, Ich habe ein riesen Problem, das mir sonst einfach erschien. Ich hatte eine Bitlocker Partition D: auf meinem C: Laufwerk installiert. Weil Windows ...