greenhorn101
Goto Top

Wordpress: Contact Form 7 funktioniert nicht

Hallo liebe community,

ich habe mittlerweile alles in meiner Macht stehende versucht um das Problem zu lösen, es aber bisher nicht geschafft.
Ich habe bei Wordpress das Plug-in
Contact Form 7
installiert. Ich benutzte Wordpress 4.0.
Wenn ich nun mein Formular nach meinen belieben angepasst habe und ich es dann das erste mla testen möchte funktioniert es nicht.
Es zeigt alle Felder so an wie ich möchte, also Layout-technisch ist alles in Ordnung.
Ich fülle dann die gesamten Felder aus und wenn ich nun auf "Senden" drücke, kommt die Fehlermeldung, dass die nachricht derzeit nicht gesendet werden kann.

Kann mir jemand von Euch helfen?

Vielen Dank und beste Grüße
greenhorn101

Content-Key: 251474

Url: https://administrator.de/contentid/251474

Printed on: December 4, 2023 at 10:12 o'clock

Member: janzendi
janzendi Oct 10, 2014 at 06:23:55 (UTC)
Goto Top
Hab es gerade bei mir, mit der selben Konfiguration getestet und es funktioniert.
Sprich dieses Problem liegt wahrscheinlich nicht am Plugin.

Was für ein Anbieter hast du und hat er gegeben falls ein Update durchgeführt?
Welche Ordnerberechtigung hat das Script? Sprich kann es das Script überhaupt ausführen?

Das sind paar Anhaltspunkte, an denen ich letztes Jahr dran war und es dann durch dieses Vorgehen lösen konnte.
Member: greenhorn101
greenhorn101 Oct 10, 2014 at 07:02:39 (UTC)
Goto Top
Guten morgen janzendi,

der Anbieter ist Goneo.
Mhhh das ist eine gute Frage. Muss ich dann die Rechte des Plug-Ins ändern per FTP?
Member: janzendi
janzendi Oct 10, 2014 at 07:18:06 (UTC)
Goto Top
Nur die Ordner Rechte. Ich glaub dass ich des damals einfach nur auf "chmod 750" gesetzt habe per "WebFTP".

Weil dies sofort funktioniert hat, jedoch sollte ich mir es vielleicht noch einmal anschauen. ^^

Das sind Ordnerrechte (Datei) nicht Wordpress. Ich hoffe dass du es verstanden hast.
Member: greenhorn101
greenhorn101 Oct 10, 2014 at 08:53:59 (UTC)
Goto Top
Okay Danke. Ich glaube die habe ich anders eingestellt.
Danke für die Info, ich werde da dann mal nachschauen und mich melden ;)
Member: d4shoerncheN
d4shoerncheN Oct 10, 2014 updated at 10:32:19 (UTC)
Goto Top
Hallo Greenhorn,

bist du dir denn sicher das es direkt am Plugin liegt? Verschickt er das normale Kontaktformular denn?

Es könnte in deinem Fall auch falsch konfigurierte Mailserver Einstellungen in deinem Wordpress sein, oder aber gesperrte Funktionen seitens Goneo. Denn Contact Form arbeitet mit "additional_parameters" in der PHP-Funktion "mail". Und die könnte ggf. deaktiviert worden sein, kannst dir ja mal eine php_info erstellen und nachschauen. Hier könntest du in deiner Contact Form Konfiguration die Variable [your_mail] durch deine wirkliche E-Mail im Feld "Von" austauschen. Hier sollte eine E-Mail Adresse eingetragen werden, die den gleichen Domain-Namen aufweist.

Das Problem ist einfach das viele Mailprovider (in deinem Fall nun Goneo) verbieten, Mails in einem anderen Namen zu verschicken. Da genau dies geschieht bei einem Kontaktformular, denn der Absender ist ja nicht der Server, sondern die E-Mail Adresse die eingegeben wurde. Hier kannst du das Problem umgehen, indem du die Mails bei deinem Wordpress über SMTP verschickst, da gibt es sogar ein Plugin für:
https://wordpress.org/plugins/wp-mail-smtp/

Gruß
Toni