Top-Themen

Aktuelle Themen (A bis Z)

Administrator.de FeedbackApache ServerAppleAssemblerAudioAusbildungAuslandBackupBasicBatch & ShellBenchmarksBibliotheken & ToolkitsBlogsCloud-DiensteClusterCMSCPU, RAM, MainboardsCSSC und C++DatenbankenDatenschutzDebianDigitiales FernsehenDNSDrucker und ScannerDSL, VDSLE-BooksE-BusinessE-MailEntwicklungErkennung und -AbwehrExchange ServerFestplatten, SSD, RaidFirewallFlatratesGoogle AndroidGrafikGrafikkarten & MonitoreGroupwareHardwareHosting & HousingHTMLHumor (lol)Hyper-VIconsIDE & EditorenInformationsdiensteInstallationInstant MessagingInternetInternet DomäneniOSISDN & AnaloganschlüsseiTunesJavaJavaScriptKiXtartKVMLAN, WAN, WirelessLinuxLinux DesktopLinux NetzwerkLinux ToolsLinux UserverwaltungLizenzierungMac OS XMicrosoftMicrosoft OfficeMikroTik RouterOSMonitoringMultimediaMultimedia & ZubehörNetzwerkeNetzwerkgrundlagenNetzwerkmanagementNetzwerkprotokolleNotebook & ZubehörNovell NetwareOff TopicOpenOffice, LibreOfficeOutlook & MailPapierkorbPascal und DelphiPeripheriegerätePerlPHPPythonRechtliche FragenRedHat, CentOS, FedoraRouter & RoutingSambaSAN, NAS, DASSchriftartenSchulung & TrainingSEOServerServer-HardwareSicherheitSicherheits-ToolsSicherheitsgrundlagenSolarisSonstige SystemeSoziale NetzwerkeSpeicherkartenStudentenjobs & PraktikumSuche ProjektpartnerSuseSwitche und HubsTipps & TricksTK-Netze & GeräteUbuntuUMTS, EDGE & GPRSUtilitiesVB for ApplicationsVerschlüsselung & ZertifikateVideo & StreamingViren und TrojanerVirtualisierungVisual StudioVmwareVoice over IPWebbrowserWebentwicklungWeiterbildungWindows 7Windows 8Windows 10Windows InstallationWindows MobileWindows NetzwerkWindows ServerWindows SystemdateienWindows ToolsWindows UpdateWindows UserverwaltungWindows VistaWindows XPXenserverXMLZusammenarbeit

ZUgriff von extern - Sharepoint 2013 - HTTP Error 400 Bad Request - Invalid Hostname

Mitglied: skullflower

skullflower (Level 1) - Jetzt verbinden

17.10.2013, aktualisiert 18.10.2013, 3579 Aufrufe, 2 Kommentare

Hallo Zusammen,

ich werde langsam wahnsinnig

Es geht um folgendes....

Windows Server 2012
Sharepoint 2013
SQL Server 2012
Fritzbox7390

1und1
subdomain.Domain..de:80-> Frameweiterleitung auf feste ip Router 7390

7390 Portweiterleitung 80 auf 192.168.0.3 (sharepoint server 2012)

iis binding eingerichtet mit
typ http
ip adresse: keine zugewiesen
port 80
hostname: subdomain.Domain..de

Sharepointserver
alternative zugriffsordnung eingerichtet
standard ist http://subdomain.domain.de:80
intranet: server2012 (auch schon rausgenommen)
benutzerdefiniert festeip:80(auch schon rausgenommen)

Intern geht alles....nur aus dem Internet heraus nicht...also extern...

Habe auch schon eine neue Webanwendung mit einem komplett neuen Port angelegt...das geht einwandfrei.

Ich habe im Netz noch einen sharepoint server 2007....mit dem ging alles einwandfrei..auch über port 80...

Hat jemand noch eine Idee? Werde wahnsinnig

Das ganze funktiuoniert wenn ich eine test domain für die zentraladministration anlege mit dem port 45266...warum?
Ich habe jetzt nochmal eine komplett neue Seite erstellt mit neuer Inhaltsdatenbank...neuenm Port...bekomme da ebenfalls den Fehler 400 Bad Request.

Danke Euch!
Mitglied: aqui
18.10.2013, aktualisiert um 11:55 Uhr
Du schreibst oben: "7390 Portweiterleitung 2791 auf 192.168.0.3 "
Das ist dann klar das das nicht klappen kann, denn dafür fehlt eine "2" in der Portnummer.

Spannend wäre dann (wenn obiges korrigiert ist) mal zu erfahren ob die TCP 27912 Pakete auch wirklich von der FritzBox geforwardet werden.
Das kann man schnell nachkontrollieren wenn man auf dem Server da mal mit einem Wireshark oder dem MS NetMonitor mal nachsieht.
http://www.microsoft.com/en-us/download/details.aspx?id=4865
http://www.wireshark.org
So kannst du wenigstens erstmal genau eingrenzen ob der Server oder der Router der böse Buhmann hier ist !!
(Kommt man auch eigentlich von selber drauf...?!)
(P.S.: Das Umbiegen des Servers auf den TCP Port wäre übrigens nicht nötig gewesen, denn die FB supportet Port Translation.)
Bitte warten ..
Mitglied: skullflower
18.10.2013, aktualisiert um 12:56 Uhr
Hi also der Datenverker kommt an..

Ich habe jetzt wieder alles auf den Standardport 80 umgestell...also Portforwarding port 80 auf den Sharepoint Server

Im Sharepoint habe ich als alternative Zugriffsordnung folgendes eingetragen

standard de subdomain.domain.de
intranet http://server2012
internet die fest öffentliche ip

IIS indungen
typ http
ip keine zugewiesen
port 80
hostname subdomain.domain.de

jetzt kommt folgende meldung beim aufruf der seite bzw ip

Not Found
HTTP Error 404. The requested resource is not found.


wenn ich die öffentluche ip nicht hinterlege kommt:
HTTP Error 400 Bad Request - Invalid Hostname


wenn ich das ganze für die zentraladministation einrichte über port 45123 geht alles...habe auch schon diesen port verwendet ohne erfolg und gleiche Fehlermeldung...

Habe jetzt noch im IIS unter Default Website eine neue Seite Sharepoint angelegt...und einen Ordner zugewiesen c:\sharepoint darin liegt eine index.html diese kann ich ohne Probleme von extern sehen...
Bitte warten ..
Ähnliche Inhalte
Apache Server
Apache Webserver HTTP 500 Error
gelöst Frage von ClepToManixApache Server7 Kommentare

Hallo an alle hier :) ich habe auf meinem Ubuntu 16.04 einen Apache Webserver laufen. Wollte mir jetzt OSTicket ...

Microsoft
SharePoint 2013 Installation
gelöst Frage von tomolpiMicrosoft30 Kommentare

Hallo, ich habe folgendes Problem: ich möchte auf meinem Server (2012 R2) den SharePoint Server 2013 Installieren. Also, iso ...

Exchange Server
Exchange 2013 OWA ECP Bad Request
gelöst Frage von Manuel.NeujahrExchange Server3 Kommentare

Hallö! Ich habe einen Exchange 2013, der war kaputt weil die Festplatte vollgelaufen ist. Nu hab ich ihn gefixt ...

Microsoft Office
Workflow Sharepoint 2013 - Hilfe
Frage von ImTrainingMicrosoft Office2 Kommentare

Guten Tag liebe Community! Ich benötige für einen Kunden, für Ihre SharePoint Seite 2 Workflows, 1) Eine Dokumenten-Bibliothek für ...

Neue Wissensbeiträge
iOS
IOS hat nen Cursor !!!
Tipp von Criemo vor 8 StundeniOS

Nette Funktion im iOS. iPhone-Mauszeiger aktivieren „Nichts ist nerviger, als bei einem Tippfehler zu versuchen, den iOS-Cursor an die ...

Off Topic
Avengers 4: Endgame - Erster Trailer
Information von Frank vor 2 TagenOff Topic1 Kommentar

Ich weiß es ist Off Topic, aber ich freue mich auf diesen Film und vielleicht geht es anderen hier ...

Webbrowser
Microsoft bestätigt Edge mit Chromium-Kern
Information von Frank vor 2 TagenWebbrowser5 Kommentare

Microsoft hat nun in seinem Blog bestätigt, dass die nächste Edge Version kein EdgeHTML mehr für die Darstellung benutzen ...

Sicherheit

MikroTik: Sicherheitslücke wird ausgenutzt obwohl ein Update seit langem verfügbar ist

Information von sabines vor 2 TagenSicherheit

Obwohl ein Update, dass die nun massenhaft ausgenutzte Lücke schließt, seit langem (März 2018) verfügbar ist, wird es offensichtlich ...

Heiß diskutierte Inhalte
Exchange Server
Exchange Server 2010: Keine Eingehenden E-MAils
Frage von gabeBUExchange Server15 Kommentare

Hallo Zusammen Ich habe das kurzen auf dem Exchange 2010 Server das Problem, dass ich keine externen E-Mails mehr ...

Rechtliche Fragen
Systemhaus auf Abwegen
Frage von rocco61Rechtliche Fragen13 Kommentare

Hallo zusammen, bin derzeit ratlos bei dem folgenden Scenario: In einen Seniorenheim wurde beschlossen, die IT an eine andere ...

Router & Routing
MikroTik - Routing, Bridging, Switching
gelöst Frage von Alex29Router & Routing9 Kommentare

Hallo in die Runde, als Hobby-Admin würde ich bitte mal wieder Eure Hilfe benötigen. Seit der Umstellung auf RouterOS ...

Outlook & Mail
Kalendersync mit Android und Outlook
Frage von Stefan007Outlook & Mail8 Kommentare

Hi Leute, kennt jemand eine Möglichkeit um Termine zwischen installiertem Outlook auf dem PC und dem Kalender auf einem ...