Top-Themen

Aktuelle Themen (A bis Z)

Administrator.de FeedbackApache ServerAppleAssemblerAudioAusbildungAuslandBackupBasicBatch & ShellBenchmarksBibliotheken & ToolkitsBlogsCloud-DiensteClusterCMSCPU, RAM, MainboardsCSSC und C++DatenbankenDatenschutzDebianDigitiales FernsehenDNSDrucker und ScannerDSL, VDSLE-BooksE-BusinessE-MailEntwicklungErkennung und -AbwehrExchange ServerFestplatten, SSD, RaidFirewallFlatratesGoogle AndroidGrafikGrafikkarten & MonitoreGroupwareHardwareHosting & HousingHTMLHumor (lol)Hyper-VIconsIDE & EditorenInformationsdiensteInstallationInstant MessagingInternetInternet DomäneniOSISDN & AnaloganschlüsseiTunesJavaJavaScriptKiXtartKVMLAN, WAN, WirelessLinuxLinux DesktopLinux NetzwerkLinux ToolsLinux UserverwaltungLizenzierungMac OS XMicrosoftMicrosoft OfficeMikroTik RouterOSMonitoringMultimediaMultimedia & ZubehörNetzwerkeNetzwerkgrundlagenNetzwerkmanagementNetzwerkprotokolleNotebook & ZubehörNovell NetwareOff TopicOpenOffice, LibreOfficeOutlook & MailPapierkorbPascal und DelphiPeripheriegerätePerlPHPPythonRechtliche FragenRedHat, CentOS, FedoraRouter & RoutingSambaSAN, NAS, DASSchriftartenSchulung & TrainingSEOServerServer-HardwareSicherheitSicherheits-ToolsSicherheitsgrundlagenSolarisSonstige SystemeSoziale NetzwerkeSpeicherkartenStudentenjobs & PraktikumSuche ProjektpartnerSuseSwitche und HubsTipps & TricksTK-Netze & GeräteUbuntuUMTS, EDGE & GPRSUtilitiesVB for ApplicationsVerschlüsselung & ZertifikateVideo & StreamingViren und TrojanerVirtualisierungVisual StudioVmwareVoice over IPWebbrowserWebentwicklungWeiterbildungWindows 7Windows 8Windows 10Windows InstallationWindows MobileWindows NetzwerkWindows ServerWindows SystemdateienWindows ToolsWindows UpdateWindows UserverwaltungWindows VistaWindows XPXenserverXMLZusammenarbeit

gelöst Zwei Switches, zwei VLANs

Mitglied: SonneLacht

SonneLacht (Level 1) - Jetzt verbinden

17.04.2016 um 21:11 Uhr, 1344 Aufrufe, 13 Kommentare

Hallo,

ich habe hier eine verzwickte Situation.

Ich habe zwei WAN-Anbindungen, jeweils Erstweg und Zweitweg, macht also vier WAN-Router.

Bisher wurden die vier WAN-Router mit vier Leitungen zum Raum mit den Firewalls geleitet. Dort standen zwei Switches (0815, ohne jede Konfiguration), an denen jeweils zwei Firewalls und die zwei WAN-Router angeschlossen waren. Das hat tadellos funktioniert.


Jetzt habe ich, um zwei Leitungen zwischen den WAN-Routern und den vier Firewalls einzusparen, zwei identische Switches HP 1910-8 eingeschaltet. Ich haben einen Switch im Raum 1 mit den WAN-Routern und einen weiteren im Raum 2 bei den Firewalls platziert.

Ich habe auf jedem Switch identisch zwei VLANs konfiguriert (VLAN 10 und VLAN 20) und die Ports 1, 3, 5 und 7 der Switches dem VLAN 10 und die Ports 2, 4, 6 und 8 dem VLAN 20 zugeordnet (alles untagged).

Switch 1:
Ich verbinde VLAN 10 mit den beiden WAN-Routern der ersten Internetanbindung.
Ich verbinde VLAN 20 mit den beiden anderen WAN-Routern der zweiten Internetanbindung.

Switch 2:
Ich verbinde VLAN 10 mit zwei Firewalls der ersten Internetanbindung.
Ich verbinde VLAN 20 mit zwei anderen Firewalls der zweiten Internetanbindung .

Dazwischen:
Ich verbinde VLAN 10 der beiden Switche miteinander (erste Internetanbindung).
Ich verbinde VLAN 20 der beiden Switche miteinander (zweite Internetanbindung).

Aus für mich unerfindlichen Gründen funktioniert mal VLAN 10 und mal VLAN 20 nicht. Entweder können die Firewalls am VLAN 10 keine Verbindung zum WAN-Router herstellen (pingen) oder die Firewalls am VLAN 20. Es scheint davon abzuhängen, welches VLAN nach einem Factory-Reset des Switches und Neukonfiguration zuerst angesteckt wird. Dieses wechselhafte Verhalten spricht ja für eine Fehlkonfiguration durch mich.


Ich habe mich gefragt, ob ich einen Port taggen muss. Meiner Meinung nach muss ich das nicht, da über eine Leitung zwischen den VLAN 10 beider Switche nur ein VLAN übertragen wird. Erst wenn ich statt zwei Leitungen nur eine nutzen möchte, müsste ich zwischen den Switchen taggen. Oder?

Damit das jetzt erst mal funktioniert, habe ich im Raum 2 einen zweiten Switch aufgestellt. Genau so konfiguriert wie der andere. Das funktioniert tadellos.

Versteht das jemand?

Jens
snag-0000 - Klicke auf das Bild, um es zu vergrößern
snag-0001 - Klicke auf das Bild, um es zu vergrößern
Mitglied: Reini82
LÖSUNG 17.04.2016, aktualisiert um 21:34 Uhr
Guten Abend,

Tagged brauchst du bei dem Aufbau nicht. Ich würde mal die Konfiguration der Ports genau anschauen ob diese auf Access gesetzt sind und die PVID richtig ist. Da bin ich bei der 1910er auch mal reingefallen dass ich die Ports auf Access hatte aber das PVID nicht richtig gesetzt war.

Alternativ könntest die 2 Leitungen auch bündeln dann hättest eine redundanz und einen Lastenausgleich.


Gruß Reini
Bitte warten ..
Mitglied: aqui
LÖSUNG 18.04.2016 um 08:34 Uhr
Normal sollte das so gehen.
Kann es ggf. sein das die beteiligten Endgeräte irgendeine Art von Spanning Tree sprechen die mit dem Spanning Tree der HP Billiggurken nicht kompatibel ist ??
HP Kann nur ein global Span Verfahren. Wenn Endgeräte irgendeine Art von PVST Verfahren sprechen kann es zu genau solch einem Verhalten kommen was du siehst.
Check das mal. Ein Wireshark Sniffer hilft hier und klärt das sofort.
Bitte warten ..
Mitglied: BernhardMeierrose
LÖSUNG 18.04.2016 um 17:16 Uhr
Moin,

ich kenn die HP-Teile nicht genau, aber wenn die kein PVST können ( und da würde ich aqui mal spontan glauben) werden die ein Problem mit den 2 Links zwischen den Switchen haben und per Spanning-Tree einen Link abschalten.
Der Link zwischen beiden Switchen müsste also entweder Trunk oder Access für beide VLANs sein. Redundanz dann über Link-Aggregation in irgendeiner Form.

Gruß
Bernhard
Bitte warten ..
Mitglied: aqui
19.04.2016, aktualisiert um 09:14 Uhr
Ich kenn die HP-Teile nicht genau,
Ist wohl auch besser so !
aber wenn die kein PVST können
Können sie de facto nicht und konnten sie auch noch nie.
Bitte warten ..
Mitglied: Reini82
19.04.2016 um 12:55 Uhr
Ich kenn die HP-Teile nicht genau,
Ist wohl auch besser so !

Hab 5 von denen noch im Einsatz
Bitte warten ..
Mitglied: BernhardMeierrose
19.04.2016 um 13:16 Uhr
Zitat von Reini82:

Hab 5 von denen noch im Einsatz

Tja, jeder von uns hat sein Päckchen zu tragen
Bitte warten ..
Mitglied: Reini82
22.04.2016 um 22:21 Uhr
... werden die ein Problem mit den 2 Links zwischen den Switchen haben und per Spanning-Tree einen Link abschalten.

Das könnte man aber über Port Details bzw. den internen Syslogs dann einfach mal kontrollieren
Bitte warten ..
Mitglied: SonneLacht
23.04.2016 um 12:34 Uhr
Hallo,

vielen Dank, das war die richtige Idee. Die beiden Switchen sehen die beiden Verbindungen, auch wenn sie in unterschiedlichen VLANs konfiguriert sind, als Loop an und schalten einen Link ab. Ich habe jetzt etwas mit der Antwort gebraucht, weil ich das erst probieren musste. Ich habe natürlich HP Billiggurken gelesen und hatte schon zwei neue (teurere) HP-Switches im Auge. Bevor ich auf "Bestellen" gedrückt habe, habe ich aber nochmal zwei (ehemals schweineteure) 3COM-48G-Switches probiert. Ich habe einen Testaufbau mit zwei Laptops, die WAN-Router "spielen" und zwei Laptops, die Firewall spielen und dazwischen die beiden Switches aufgebaut und VLANs konfiguriert. Und auch die schalten einen Link ab. Mit dem Unterschied, dass das sich bei Trennung einer Leitung selbst "repariert". Damit war klar, es liegt nicht an den Switches. Ich habe dann auf eine Leitung reduziert und die Ports, die die Switches verbinden, auf Tagged und Member in beiden VLAN gestellt. Funktioniert tadellos.
Bitte warten ..
Mitglied: SonneLacht
23.04.2016 um 12:36 Uhr
Hallo,

vielen Dank, das war die richtige Idee. Ich habe auf eine Leitung zwischen den Switches reduziert und die Ports, die die Switches verbinden, auf Tagged und Member in beiden VLAN gestellt. Funktioniert tadellos.
Bitte warten ..
Mitglied: Reini82
23.04.2016 um 19:35 Uhr
Wie schon gesagt kannst ja trotzdem beide Leitungen als Trunk und LACP verwenden dann hättest zumindest noch ne Redundante Leitung

Gruß
Bitte warten ..
Mitglied: aqui
24.04.2016 um 13:49 Uhr
hatte schon zwei neue (teurere) HP-Switches im Auge.
HP solltest du besser ganz aus deinem Switch Horizont entfernen...!
Mit dem Unterschied, dass das sich bei Trennung einer Leitung selbst "repariert".
Sowas nennt der Netzwerker dann Spanning Tree !!!
Bitte warten ..
Mitglied: Freak-On-Silicon
27.09.2018 um 14:16 Uhr
Also heißt das jetzt dass der HP Switch,
obwohl die zwei "Uplinks" per VLAN getrennt sind,
diese per SpanningTree regelt?
Bitte warten ..
Mitglied: aqui
27.09.2018 um 15:59 Uhr
diese per SpanningTree regelt?
Nein, das ist Blödsinn und du rätst hier gerade rum im freien Fall !
Vermutlich weisst du gar nicht wirklich was Spanning Tree wirklich ist, oder ?

Spanning Tree ist ein Feature zur Loop Verhinderung, sprich das du keinen Loop (Kurzschluss) in dein Netzwerk steckst.
Vergiss das, das hat mit VLANs und VLAN Tagging nicht das geringste zu tun.
Bitte warten ..
Ähnliche Inhalte
Switche und Hubs
Switch VLAN einrichten
gelöst Frage von TastuserSwitche und Hubs8 Kommentare

Hallo, ich habe einen Switch mit VLAn-Funktion, verstehe jedoch nicht ganz wie das funktioniert. Folgende Punkte sind vorhanden: - ...

Switche und Hubs
Switch mit Switch verbinden (VLAN)
gelöst Frage von NurWeilEsGehtSwitche und Hubs5 Kommentare

Halloooo, ich habe mal eine Frage zu meinem „neuen“ Switch von Netgear. Vorher habe ich einen 8-Port Switch von ...

Netzwerke

Poe Switch an einem Vlan-Switch L3 oder Vlan-Router

gelöst Frage von decehakanNetzwerke5 Kommentare

Hallo Zusammen, ich hab vor ein Access Point, der mehrere SSID und Vlanzuordnung beherrscht, über Poe an meinem Vlan-fähigen ...

LAN, WAN, Wireless

HP Switch VLAN Konfiguration

Frage von staybbLAN, WAN, Wireless12 Kommentare

Hallo, ich möchte eine bereits bestehende Netzwerkstruktur mit VLANs erweitern. Und zwar ist folgendes Szenario vorhanden: HP Layer 2 ...

Neue Wissensbeiträge
Humor (lol)

"Linux und 5 Gründe Warum man kein Windows verwenden sollte sondern Ubuntu Linux"

Tipp von Snowbird vor 1 TagHumor (lol)8 Kommentare

Gerade gefunden. Ja, ist etwas älter, aber irgendwie lustig?

Humor (lol)

"Warum Linux in einer vernetzten Welt einfach keinen Komfort bietet!"

Tipp von Snowbird vor 2 TagenHumor (lol)13 Kommentare

Ein interessanter Einblick warum Linux nichts für Geräteübergreifende Arbeit ist :)

Humor (lol)
Zuviel Speicher ist ungesund. :-)
Tipp von Lochkartenstanzer vor 3 TagenHumor (lol)17 Kommentare

Moin Kollegen, Heute hatte ich ein ungewöhnliches Aha-Erlebnis: Über das Wochenende habe ich einen einen 6 Jahre alten Bare-Metal ...

Windows Update

KB4517297 verfügbar, behebt Fehler in VB6 VBA VBScript

Information von sabines vor 3 TagenWindows Update

Das Update behebt mögliche Fehler in VB6, VBA und VBScript, die durch das Update KB4512486 vom August entstanden sind. ...

Heiß diskutierte Inhalte
Router & Routing
Deinstalliertes Geräte wird in FritzBox noch immer als verbundenes Gerät angezeigt
gelöst Frage von imebroRouter & Routing18 Kommentare

Hallo, in meiner FritzBox 7490 wird im Bereich "Funknetz" ein Gereät bei den verbundenen Geräten angezeigt, wobei ich nicht ...

Windows 10
Windows 10 druckt nicht mehrere Kopien?
Frage von StefanKittelWindows 1016 Kommentare

Hallo, ich hatte gerade einen Anruf eines Kunden. Sein neuer PC (Win 10 1903) druckt nicht mehr mehrere Seiten ...

Microsoft
Windows 10 - Kombination von lokalen Benutzerkonten und Benutzern aus einer Domäne
Frage von PappnaseVxVVMicrosoft15 Kommentare

Hi, würde gerne folgendes realisieren, von dem ich gern wüsste, ob es geht. Ich habe einen Raum mit 3 ...

Verschlüsselung & Zertifikate
Mit BitLocker verschlüsselte Festplatte löschen?
gelöst Frage von SnowbirdVerschlüsselung & Zertifikate14 Kommentare

Hallo, ich habe eine mit Bitlocker verschlüsselte externe Festplatte. Diese möchte ich gerne löschen sodass nichts mehr auffindbar ist. ...