colinardo
Goto Top

Mikrotik - mDNS Repeater erstmalig in der aktuellen Beta von RouterOS

Servus Kollegen.

Mikrotik hatte es vor ca. 1 Jahr angekündigt:

(normis) MikroTik Support : MikroTik is working on mDNS repeater, but that will come together with a global DNS overhaul and it will be an improvement in all areas, not just this one. This is also why it takes some time to make.

Nun wurde das Kind geboren (RouterOS 7.16 beta3)
https://mikrotik.com/download/changelogs#tab-testing

What's new in 7.16beta3 (2024-Jun-27 08:33):
*) dns - added support for mDNS proxy (CLI only);

Zur Zeit ist dieser erst einmal nur über die Konsole nutzbar mit folgender Anweisung (Interfaces sind natürlich anzupassen)

/ip dns set mdns-repeat-ifaces=vlan100,vlan200

Bitte die Firewall nicht vergessen! Diese muss mDNS Traffic natürlich auf allen beteiligten Interfaces in der Input-Chain zulassen damit der mDNS Proxy diesen Traffic auch sehen und weiterleiten kann:

/ip firewall filter
add action=accept chain=input dst-address=224.0.0.251 dst-port=5353 in-interface=vlan100 protocol=udp place-before=0
add action=accept chain=input dst-address=224.0.0.251 dst-port=5353 in-interface=vlan200 protocol=udp place-before=0

In einem ersten Test funktioniert das Repeating der mDNS Multicasts zwischen den angegebenen Interfaces einwandfrei. Damit wird der Docker-Container oder zusätzliche Devices für das Repeating endlich überflüssig.

Gruß @colinardo

Content-Key: 3936888204

Url: https://administrator.de/contentid/3936888204

Printed on: July 16, 2024 at 20:07 o'clock

Member: Visucius
Visucius Jul 01, 2024 at 10:49:43 (UTC)
Goto Top
Goil face-wink