Dieser Beitrag ist schon älter. Bitte vergewissern Sie sich, dass die Rahmenbedingungen oder der enthaltene Lösungsvorschlag noch dem aktuellen Stand der Technik entspricht.

Acronis Linux Agent Installation

Mitglied: Masterraven9
Hy,

ich wollte mal Acronis 9.1 Enterprise testen.
Nun habe ich ein Problem mit dem Linux Agent.
Ich wollte den Agent auf meinem Debian System installieren mit folgendem Befehl:

dkms build -m snapapi26 -v 0.7.5 --config /boot/config-2.6.18-4-686 --arch i686 --kernelsourcedir /usr/src/

Doch es kommt die Fehlermeldung:

Error! Your kernel source for kernel 2.6.18-4-686 cannot be found at
/lib/modules/2.6.18-4-686/build or /lib/modules/2.6.18-4-686/source.
You can use the --kernelsourcedir option to tell DKMS where it's located.

Weiß einer was ich nun machen muss damit ich die Installation vollenden kann?

thx

Content-Key: 68241

Url: https://administrator.de/contentid/68241

Ausgedruckt am: 25.07.2021 um 23:07 Uhr

Mitglied: Alphavil
Alphavil 08.10.2007 um 17:51:29 Uhr
Goto Top
Das Problem hab ich hier auch auf meinem Ubuntu.

Das Problem ist das Fehlen bestimmter Packete:

- Kernel-Quellcode
- verschiedene C/C++ Bibliotheken


In der Firma haben wir vor ab alle möglichen Packete installiert, danach ging es.

Allerdings war das ein SLES 9, müsste aber auf Debian genauso gehn ;-) face-wink


Also nach dem bestimmte Packete nachinstalliert sind, müsste es gehn

Viel Erfolg



Greetz André
Mitglied: StukaRT
StukaRT 10.10.2007 um 09:09:37 Uhr
Goto Top
Ich hatte das Problem auch. Habe es dadurch gelößt, dass ich die Sourcen für meinen Kernel per apt neu runtergeladen habe. Das Archiv habe ich dann in ein Verzeichniss entpackt und dieses dann angegeben bei --kernelsourcedir.

So sah es bei mir auf einem Testsystem aus:
Den Installer des Agents ausführen. Bis zur Fehlermeldung, dann "ok" und den Rest von Hand:

dkms build -m snapapi26 -v 0.7.9 --config /boot/config-2.6.18-4-686 --arch i686 --kernelsourcedir /usr/src/linux-source-2.6.18

dkms install -m snapapi26 -v 0.7.9 --config /boot/config-2.6.18-4-686 --arch i686 --kernelsourcedir /usr/src/linux-source-2.6.18

Nun läuft der Agent wunderbar, und auch die COnsole findet den Rechner nun. Leider kann ich mich noch nicht einloggen, da ich nicht weiß mit welchem Benutzernamen und die vorhandenen alle nicht funktionieren.

Gruß
René
Mitglied: beowulf1980
beowulf1980 30.03.2008 um 23:50:08 Uhr
Goto Top
Hi ch weiss ja der Beitrag ist schon älter,

aber ich habe bei der aktuellen Version von Acronis dasselbe Problem. Der Linux Agent wird angezeigt aber ich kann mich nicht connecten.

Kannst du mir vielleicht sagen wie du das gelöst hast Stukart ?

Grüße
Beowulf
Mitglied: StukaRT
StukaRT 31.03.2008 um 08:39:17 Uhr
Goto Top
Leider muss ich sagen haben wir irgendwann aufgegeben.

Nach mehreren Beiträgen im Acronis Support Forum die mehr oder minder nur mit standart Antworten beantworten wurden (Update auf neue Version) und eigenem Rumprobieren haben wir es damals sein gelassen und beißen seither in den saueren Apfel unser Gateway am Wochenende mal eine Stunde herunterzufahren für das Backup... :( face-sad Was sich so reauskristalliert hat ist, das es entweder direkt läuft oder man es kaum zum laufen bekommt.

Habe es mit Echo noch nicht ausprobiert. Vielleicht gibt es ja dort eine Änderung.
Mitglied: 42503
42503 24.09.2008 um 23:05:21 Uhr
Goto Top
ich habe das Problem gerade bei openSUSE 11.

Ich habe den Kernel:

Linux version 2.6.25.16-0.1-default (geeko@buildhost) (gcc version 4.3.1 20080507 (prerelease) [gcc-4_3-branch revision 135036] (SUSE Linux) ) #1 SMP 2008-08-21 00:34:25 +0200

Sourcen sind installiert.

Nun habe ich diesen Befehl versucht:

dkms build -m snapapi26 -v 0.6.2 --config /boot/config-2.6.25.16-0.1-default --arch i686 --kernelsourcedir

/usr/src/linux-2.6.25.16-0.1

Leider nichts erfolgreiches. Hat jemand einen Tipp?
Mitglied: StukaRT
StukaRT 25.09.2008 um 10:53:18 Uhr
Goto Top
Hast du die Kernelsourcen runtergeladen und an dem angebenem Ort entpackt/gespeichert?

Ich erinner mich auch erst probleme gehabt zu haben, da die sourcen an einem anderem Ort lagen, ein paar links haben geholfen.
Heiß diskutierte Beiträge
question
RAM-Zugriff auf einem neuen High-Performance Server, teilweise um Welten langsamer als auf einer WorkstationMysticFoxDEVor 1 TagFrageBenchmarks53 Kommentare

Moin Zusammen, mir ist gestern beim Optimieren eines neuen Servers eine Sonderheit aufgefallen, die ich mir so beim besten Willen, momentan absolut nicht erklären kann. ...

question
2U Home-Server Frage zur HardwaremossoxVor 1 TagFrageServer-Hardware13 Kommentare

Hallo zusammen, ich habe in den letzten Jahren auf die Systeme von Synology gesetzt. Im Wesentlichen ging es immer nur um simple CIFS Dienste, nichts ...

question
Firmengelände Glasfaser mehrere GebäudeTonLichtVideoVor 1 TagFrageNetzwerke5 Kommentare

Hallo zusammen, Ist Zustand: Firmengelände mit mehreren großen Hallen die zentral per Glasfaser verbunden werden sollen. Längen zwischen 100 und 400 Metern. Aufgrund der Zukunftssicherheit ...

question
Powershell Ordner löschen die älter als x Tage sind gelöst sascha46Vor 1 TagFrageEntwicklung7 Kommentare

Hallo Ich würde gerne in einem Verzeichnis alle Ordner die älter als X Tage sind löschen. Aber irgendwie bekomme ich das nicht hin. Bisher habe ...

report
Erfahrungsbericht Vodafone - Die endlose VertragsänderunganteNopeVor 11 StundenErfahrungsberichtFlatrates12 Kommentare

Hallo zusammen, natürlich ist es öffentlich bekannt, dass Vodafone nicht gerade der "beste" Anbieter ist. Für mich persönlich ist Vodafone an Inkompetenz nicht zu überbieten ...

question
Seltsame Dateisperrungen beim NASSarekHLVor 1 TagFrageWindows 106 Kommentare

Hallo zusammen, ich gebe mal eine Anfrage aus unserem Gemeindebüro weiter: für einige Vorgänge, wie zum Beispiel das Erstellen des monatlichen Mitteilungsblattes, arbeiten Frau X ...

question
Cisco 2702 Autonomous Mode gelöst interface31Vor 1 TagFrageLAN, WAN, Wireless5 Kommentare

Hi, habe gerade paar 2702 AP im Auto Mode an Netz gehängt. Mir kommt es vor das diese mit ihrer SSID aber nicht sichtbar sind. ...

question
Aruba iAP Airwave aktivinterface31Vor 1 TagFrageLAN, WAN, Wireless9 Kommentare

Hi, habe ein paar Aruba iAP an denen der Airwave Management noch aktiv ist. Sprich nach ein paar Minuten zieht dieser sich die Info vom ...