Active Sync Exchange 2016

Mitglied: DelPiero

DelPiero (Level 1) - Jetzt verbinden

08.01.2016 um 11:34 Uhr, 12079 Aufrufe, 7 Kommentare

Hallo zusammen

Ist es zwingend notwendig ein offizielles SSL-Zertifikat zu verwenden, wenn man ActiveSync nutzen will mit einem Exchange 2016?
Beim Exchange 2010 konnte man das Konto am Handy trotzdem einrichten.

Ich habe einen Exchange 2016 Server aufgesetzt und Active-Sync für die Benutzer aktiviert.
Ich kann das Benutzerkonto am iPhone einrichten, doch empfange keine E-Mails mit dem Fehler: Server nicht erreichbar.

Da sich das konnto anbinden, sowie der Server pingen lässt, kann ich mir nicht vorstellen, dass der Server tatsächlich nicht erreichbar ist.


Danke & Gruss
DelPiero
Mitglied: 122990
122990 (Level 2)
08.01.2016, aktualisiert um 13:14 Uhr
Moin,
ist es zwingend notwendig ein offizielles SSL-Zertifikat zu verwenden, wenn man ActiveSync nutzen will mit einem Exchange 2016?
Nein, selbstverständlich kann auch weiterhin ein selbstsigniertes Zertifikat verwendet werden, wenn die CA auf dem Client vorher importiert wurde. Aber Autodiscover und alle intern sowie extern verwendeten URLs und das DNS müssen fehlerlos konfiguriert sein, das ist essentiell für das Funktionieren für OL2016!

Mit diesem Skript vergisst du keine dieser essentiellen URLs:
Powershell: Konfigurieren der internen und externen URLs von Exchange Server 2013, 2016

Ob dein Exchange korrekt eingerichtet kannst du hier überprüfen:
https://testconnectivity.microsoft.com/

Scheint die Kracherfrage 2016 zu werden, ich weiß nicht wie oft jetzt schon Threads zum selben Thema hier eingelaufen sind.

Gruß grexit
Bitte warten ..
Mitglied: StefanKittel
08.01.2016 um 13:12 Uhr
Zitat von @122990:
Ob dein Exchange korrekt eingerichtet kannst du hier überprüfen:
http://testconnectivity.microsoft.com/

Hallo,

schön dass die Seite von MS HTTPS verwendet.
Wäre sogar noch schöner wenn sie PFS unterstützen würden und nicht mehr TLS 1.0 und RSA nutzen würden....

Stefan
Bitte warten ..
Mitglied: DelPiero
08.01.2016 um 14:39 Uhr
Zitat von @122990:

Moin,
ist es zwingend notwendig ein offizielles SSL-Zertifikat zu verwenden, wenn man ActiveSync nutzen will mit einem Exchange 2016?
Nein, selbstverständlich kann auch weiterhin ein selbstsigniertes Zertifikat verwendet werden, wenn die CA auf dem Client vorher importiert wurde. Aber Autodiscover und alle intern sowie extern verwendeten URLs und das DNS müssen fehlerlos konfiguriert sein, das ist essentiell für das Funktionieren für OL2016!

Mit diesem Skript vergisst du keine dieser essentiellen URLs:
Powershell: Konfigurieren der internen und externen URLs von Exchange Server 2013, 2016

Ob dein Exchange korrekt eingerichtet kannst du hier überprüfen:
https://testconnectivity.microsoft.com/

Scheint die Kracherfrage 2016 zu werden, ich weiß nicht wie oft jetzt schon Threads zum selben Thema hier eingelaufen sind.

Gruß grexit

Hallo

Danke für deine Anwort.
Die URLs habe ich alle konfiguriert.
An einem Notebook kann ich die Konten per Autodiscover hinzufügen ohne Probleme und es funktioniert.
Lediglich bei Smartphones wird das Konto erfolgreich verbunden, aber hat danach keine Verbindung zum Server.

Macht mir im Moment überhaupt keinen Sinn.

Hängt das mit MAPI over HTTPS zusammen? Früher war es RPC over HTTPS, oder hat das gar keinen Einfluss auf Active Sync?

Gruss DelPiero
Bitte warten ..
Mitglied: 122990
122990 (Level 2)
08.01.2016, aktualisiert um 15:07 Uhr
Welchen Weg nimmt das Autodiscover bei euch ?
  • Über die Hauptdomain ?
  • Über die Autodiscoverdomain ?
  • über _SRV Record ?
  • oder HTTP Umleitung ?

Wenn Ihr nur mit _SRV Record arbeitet und dir vorherigen Methoden nicht verfügbar sind wäre mir klar das es nicht läuft. Denn die meisten Smartphone-Clients können die Methode per _SRV Record nicht nutzen.
Hängt das mit MAPI over HTTPS zusammen? Früher war es RPC over HTTPS, oder hat das gar keinen Einfluss auf Active Sync?
MAPI over HTTPS ist Optional, sollte aber bei Verwendung von neueren Clients die es auch unterstützen am Server aktiviert werden, denn sonst macht z.B. Outlook 2016 mucken.
RPC over HTTPs wird natürlich weiterhin unterstützt, Mapi o. Https ist aber wesentlich effizienter und schneller.

aber hat danach keine Verbindung zum Server.
ActiveSync ist auch für den Client aktiviert worden und läuft am Server ?
Bitte warten ..
Mitglied: DelPiero
11.01.2016 um 12:56 Uhr
Zitat von @122990:

Welchen Weg nimmt das Autodiscover bei euch ?
  • Über die Hauptdomain ?
  • Über die Autodiscoverdomain ?
  • über _SRV Record ?
  • oder HTTP Umleitung ?

Ich bin mir nicht ganz sicher was du meinst.
Wir haben eine interne Domain intern.local und eine externe extern.de
Alle externen URLs habe ich angepasst auf die Domain extern.de, die internen URLs habe ich auf intern.local stehen gelassen.
Für die Domain extern.de habe ich eine Forward Lookup Zone erstellt mit einem SRV-Eintrag.
Zusätzlich habe ich auf dem IIS eine HTTP-Umleitung erstellt, welche alle HTTP anfragen auf HTTPS umleitet.
Die DNS-Einträge für MX und Autodiscover sind ebenfals erstellt.

Wenn ich am iPhone ein neues Mail-Konto hinzufüge klappt das auch. Lediglich die Informationen aus dem Konto werden nicht geladen, als wäre das Konto leer. Keine Mails, keine Kalendereinträge, gar nichts.

Wenn Ihr nur mit _SRV Record arbeitet und dir vorherigen Methoden nicht verfügbar sind wäre mir klar das es nicht läuft. Denn die meisten Smartphone-Clients können die Methode per _SRV Record nicht nutzen.
Hängt das mit MAPI over HTTPS zusammen? Früher war es RPC over HTTPS, oder hat das gar keinen Einfluss auf Active Sync?
MAPI over HTTPS ist Optional, sollte aber bei Verwendung von neueren Clients die es auch unterstützen am Server aktiviert werden, denn sonst macht z.B. Outlook 2016 mucken.
RPC over HTTPs wird natürlich weiterhin unterstützt, Mapi o. Https ist aber wesentlich effizienter und schneller.

aber hat danach keine Verbindung zum Server.
ActiveSync ist auch für den Client aktiviert worden und läuft am Server ?

Ich habe ActiveSync für alle zugelassen. Als dies nicht funktioniert hat, habe ich ActiveSync in den Quarantäne-Modus gestellt und das E-Mail-Konto am iPhone nochmals angebunden. Doch das iPhone taucht nichtmal in der Quarantäne-Liste nicht auf.

Das Ganze ergibt für mich keinen Sinn.

Vielleicht ligt das Problem auch am Netzwerk. Das ist meine erste Umgebung bei der Eine Fritzbox vor der Firewall (SonicWall) steht, in der ein Exchange-Server läuft.
Bei der Fritzbox habe ich als exposed Host die SonicWall eingetragen.
Bei der SonicWall habe ich die entsprechenden NAT-Regeln gesetzt. HTTPS sollte ja reichen für ActiveSync.
Die NAT-Regel funktioniert auch, wenn ich über die externe Domain zugreife, komme ich aufs OWA.
Der IIS ist auch nicht eingeschränkt.

Gruss DelPiero
Bitte warten ..
Mitglied: DelPiero
11.01.2016 um 14:30 Uhr
Das Problem ist nun gelöst.

Aus welchem Grund auch immer, waren es Berechtigungs-Probleme.
Ich habe folgende Schritte durchgeführt und danach hat es funktioniert:

- ActiveDirectory geöffnet
- Doppelklick auf entsprechenden User
- unter dem Tab "Sicherheit" auf "Erweitert"
- Vererbung aktiviert

Das wars.

Kennt ihr dieses Problem?

Gruss DelPiero
Bitte warten ..
Mitglied: 114757
114757 (Level 4)
LÖSUNG 11.01.2016, aktualisiert um 17:40 Uhr
Moin.
Zitat von @DelPiero:
- ActiveDirectory geöffnet
- Doppelklick auf entsprechenden User
- unter dem Tab "Sicherheit" auf "Erweitert"
- Vererbung aktiviert
Kennt ihr dieses Problem?
Zufällig ein administrativer User, oder in administrativen Gruppen Mitglied, der betroffen ist/war ?
AD Permissions : The AdminSDHolder Mechanism

Gruß jodel32
Bitte warten ..
Heiß diskutierte Inhalte
Netzwerkgrundlagen
Frage der anderen Art
NeuerleVor 1 TagFrageNetzwerkgrundlagen16 Kommentare

Hi an alle, Ich bin InformatikStudi. Habe Ende des Monats Klausur im Fach Netzwerke zu schreiben und komme gar nicht klar. Entweder ich bin ...

CPU, RAM, Mainboards
CPU Lüfter ausbauen
gelöst ben1300Vor 1 TagFrageCPU, RAM, Mainboards9 Kommentare

Hallo zusammen, ich habe mir damals einen Fertig PC gekauft. Ich würde gerne den Arbeitsspeichern austauschen, allerdings muss ich dafür - so wie es ...

Windows Userverwaltung
Account Aktivierung über VPN
Phill93Vor 1 TagFrageWindows Userverwaltung3 Kommentare

Hallo, ich muss mir für eine RDP Umgebung für einen Verein eine Lösung für die Account Aktivierung ausdenken. Meine Idee ist die folgende: 1. ...

Switche und Hubs
Suche Deutsche Sprachdatei für D-Link DGS-1210-24 D1 Switch
gelöst Oggy01Vor 22 StundenFrageSwitche und Hubs8 Kommentare

Hallo, ich habe einen D-Link DGS-1210-24 Vers. D1 Switch bekommen und suche für diesen eine Deutsche Sprachdatei. Die Firmware ist auf dem aktuellen Stand ...

Soziale Netzwerke
Anzahl Postings auslesen
gelöst r2d2r3poVor 1 TagFrageSoziale Netzwerke13 Kommentare

Hallo, habe seit 2014 eine Fanpage und wir posten jeden Tag. Kennt jemand einen Weg wie man die Anzahl der Postings seit 2014 auslesen ...

Windows 10
Lizenzfrage WDS mit Windows 10 OEM und E3 für Enterprise
noodellsVor 1 TagFrageWindows 107 Kommentare

Hallo Zusammen, ich habe mal eine generelle Lizenzfrage zum Thema WDS. Ich möchte mehrere PCs installieren, die schon vom Hersteller eine funktionierende Windows 10 ...

Video & Streaming
Videoaufnahme funktioniert nur bis zum ersten Reboot (0x80040217)
IllusionFACTORYVor 17 StundenFrageVideo & Streaming10 Kommentare

Ich nehme über eine Video-Software von einem USB-Hardware-Encoder Video auf. Das funktioniert exakt bis zum ersten Reboot - danach bekomme ich beim Starten der ...

Hardware
COM-Ports verstellen sich immer wieder
gelöst hanheikVor 1 TagFrageHardware6 Kommentare

Hallo, an 3 neuen Windows 10-Rechnern sind Strichcode-Scanner (mit RS232-Schnittstelle) per USB-Com-Adapter angeschlossen. Die anzusprechende Schnittstelle COMx ist jeweils in der Kassensoftware hinterlegt. Leider ...