blackmann
Goto Top

BIOS Pieptöne

N'Abend @all,

ich bin neu hier und brauche mal eure Hilfe:

Es geht um einen Rechner mit ASRock FM2A88X Pro+ mit einem AMD A6-6400K APU with Radeon und 2 x 4 Gbyte Geil RAM. Das ganze lief 10 Jahre rund und mein Freund meinte, dass mit dem Drücken der 'Mondtaste' an der Tastatur der Rechner nicht mehr läuft.

Und so ist es auch wirklich, gleich nach dem Drücken von Power erhalte ich Beep Töne:
tut=(ganz)kurz

tut-tut-tut---tut-tut-tut---------tut-tut-tut-----------tut-tut-tut-----------tut-tut-tut usw.
Also 2x3kurz - Pause - 1x3kurz - Pause - 1x3kurz usw.

Weil es ein AMI-BIOS ist kann ich micht dieser Tonfolge so gar nichts anfangen.

Zum Vergleich RAM mal entfernt und ich bekomme: --> tuuut .. tuuut ...tuuut in einer ganz anderen Tonhöhe,
aber so wie ich sie auch bisher immer kannte.

Was ich bisher gemacht habe: CMOS resetet, neue 2032, Netzteil getestet/getauscht, RAM getausch, alle Perepherie entfernt.

Nur EINMAL lief er noch fehlerfrei hoch, er hatte nach den ersten 6 Tönen dann den Startbildschirm angezeigt und teilte mit, dass eben Zeit usw. fehlten. Er lief aber in's Betriebssystem hoch.

Kennt jemand diese andere Tonfolge? Ich bin fast der Meinung die kommt NICHT vom BIOS.
Kann das was mit dem Keyboardkontroller zu tuen haben?

Danke für Euren Input .. Erfahrung.

BG BM

Content-Key: 6153474769

Url: https://administrator.de/contentid/6153474769

Printed on: May 26, 2024 at 06:05 o'clock

Member: DarkZoneSD
DarkZoneSD Feb 27, 2023 at 18:44:21 (UTC)
Goto Top
Moin,

verzeih die Verwirrung aber was meinst Du mit nach dem drücken der Mondtaste? Beim booten die Taste drücken oder im laufenden Betrieb?

Gruß

Flo
Member: DarkZoneSD
DarkZoneSD Feb 27, 2023 updated at 18:48:21 (UTC)
Goto Top
Zusätzlich hier noch eine Liste mit den Beep Codes von AMI, ist ein bisschen schwer das aus dem Text raus zu erkennen ;)
Member: WoenK0
WoenK0 Feb 27, 2023 at 19:02:15 (UTC)
Goto Top
Kann kein Morsecode, aber war das nicht SOS ?
Ich glaube, nach 10 Jahren darf ein Rechner auch endlich in Silicon Heaven.
Klar kann man versuchen bei Ebay Ersatzteile zu holen, die vielleicht funktionieren...aber wenns nicht wirklich ein erhaltenswerter Rechner den man in ein Museum stellen könnte...
Glaub nicht das die "Mondtaste" was verursacht hat (wahrscheinlich nur irgendein Energiesparmodus), sondern das es einfach nur das Alter ist.
Alles über 5 Jahre ist schön, aber für 10 Jahre waren die Dinger nicht ausgelegt.
Member: Blackmann
Blackmann Feb 27, 2023 at 19:06:11 (UTC)
Goto Top
Hallo @DarkZoneSD, danke erstmal

- Mondtaste --> in den Ruhezustand gehen? Auf seiner Taste ist ein 'Mond' abgebildet.

- Beeps: Ok, lässt sich auch schwer in Wort fassen ... Also

- Testweise fehlende RAM --> 3x Beep in der mir bekannten Tonhöhe/Frequenz, normale Abstand

- Fehler --> 3 schnelle/höhere Beep, (kurze Pause) ,3 schnelle/höhere Beep, (längere Pause) ,3 schnelle/höhere Beep, (längere Pause) ,3 schnelle/höhere Beep,

Bissel besser ??
Member: Blackmann
Blackmann Feb 27, 2023 at 19:18:44 (UTC)
Goto Top
Vielleicht auch so am besten:

3xkurz, 3xkurz, Pause, 3xkurz, Pause, 3xkurz, Pause, 3xkurz usw.

Hallo @WoenK0, da es meiner Meinung nach NICHT die original Beep Töne des BIOS sind, will ich dem auf den Grund gehen.

BG MB
Member: MirkoKR
MirkoKR Feb 27, 2023 at 19:44:13 (UTC)
Goto Top
Hi.
Offensichtlich hast du deinen Rechner in den Ruhezustand geschickt - also den Speicherinhalt des RAM auf HDD/SSD gespeichert, der sich dann abschaltet.

Damit hat dein BIOS/UEFI wohl ein Problem, z.B. das der Modus Ruhezustand im BIOS gespeichert ist und versucht, das gespeichertte RAM-Image zu laden, aber nicht kann ...

Versuche mal ein BIOS-Reset:
... mit aller Hardware eingebaut, weil da ist m.E. nichts defekt.

- Power-Taste 10 Sekunden gedrückt halten ,das initialisiert ein unbedingtes Hardware-AUS ...
... das könnte im BIOS wieder den Normalstart aktivieren ...

Nicht?

- EINFG-Taste gedrückt halten und Power-Taste zum Einschalten drücken ...
das lädt meist die BIOS-Default-Einstellungen, geänderte und Status sind weg ...

Mit etwas Glück startet der wieder normal, wahrscheinlicher kommst du nur ins BIOS und musst deine bisherigen Einstellungen wieder herstellen.
Dazu nochmal ein BIOS-Reset also Laden der Default-Einstellungen, im BIOS durchführen.

Klapppt das nicht?

- Ob das Mainboard einen BIOS-Reset-Switch - "RST-Jumper" - hat, weiß ich grad nicht
- auf jedenfall werden geänderte BIOS-Einstellungen gelöscht, wenn die CMOS- "2032" Batterie entfernt wird....

... bei Nichtstun kann es was länger dauern. bis der Batterie-Puffer im CMOS leer ist und die Einstellungen verloren gehen....

... Ohne Stromzufuhr und ohne 2032-Batterie die Power-Taste ein paar Sekunden gedrückt halten saugt den Batterie-Puffer sofort leer.

Jetzt solltest du mindestens ins BIOS kommen und deine Einstellungen wieder anpassen können ...

.
Member: cykes
cykes Feb 28, 2023 at 05:28:31 (UTC)
Goto Top
Moin,

bei so betagter Hardware würde ich außerdem mal das Board einer optischen Kontrolle unterziehen, ob aufgeblähte bzw. -geplatzte Kondensatoren ersichtlich sind. Ggf. auch mal den CPU-Kühler und CPU ausbauen, CPU und Kühler säubern und mit neuer Wärmeleitpaste wieder einbauen.
Außerdem sämtliche Lüfter checken, ob die noch anlaufen und das schnell genug - ggf. austauschen. Ggf. kommt das Signal auch von der Lüfterüberwachung.

Gruß

cykes
Member: cykes
cykes Feb 28, 2023 at 05:40:00 (UTC)
Goto Top
P.S. Außerdem habe ich noch das gefunden: https://superuser.com/questions/1606749/3-beeps-pause-3-beeps-on-boot - ebenfalls ein Asrock Board und da weist jemand auf fehlerhaftes RAM hin. Also das auch mal tauschen. Eine Grundreinigung des PCs kann aber auch nicht schaden. face-wink
Member: Blackmann
Blackmann Feb 28, 2023 updated at 08:52:23 (UTC)
Goto Top
Hallo @all, vielen Dank erst noch mal für Eure Hinweise

Zitat von @cykes:

P.S. Außerdem habe ich noch das gefunden: https://superuser.com/questions/1606749/3-beeps-pause-3-beeps-on-boot - ebenfalls ein Asrock Board und da weist jemand auf fehlerhaftes RAM hin. Also das auch mal tauschen. Eine Grundreinigung des PCs kann aber auch nicht schaden. face-wink

Der Fehler in dem Link beschreibt in etwa auch die Fehler bei diesem Rechner. Genau wie dort lief der Computer auch einmal wieder in das BIOS und dann in's Betriebssystem hoch.

Wie oben schon beschrieben habe ich schon eine Menge an Teilen ausgetauscht (Netzteil/RAM), CMOS resettet, Batterie ersetzt usw. eine Grafikkarte eingebaut .... aber nichts greifbares gefunden. Nur CPU und MB sind nicht getauscht wurden.

Eine optische Prüfung ergab keine geplatzten Kondensatoren, der Rechner ist drinnen auch sauber (da kenne ich andere), ist ein raucherfreier Haushalt ...

... eine Nachfrage ergab folgendes Szenario:

- nach langem Stand mal wieder den Rechner gestartet
- Eingabe des Windows PW und dabei verschrieben
- Mein Freund wollte Neustarten und hat da auf der Tastatur die Taste für 'Ruhezustand' (Mond) gedrückt

Seitdem bootet er nicht mehr und gibt diese Töne aus, die ich SO auch nicht im AMI BIOS Link finde.

Werde jetzt mal den CPU-Lüfter neu aufsetzen ....

... brachte nichts ....

LG BM
Member: WoenK0
WoenK0 Feb 28, 2023 at 10:45:07 (UTC)
Goto Top
Was verstehst du unter "nicht original BIOS Töne" ?
Nachdem man nicht mal mehr ins BIOS kommt, kann es kaum Windows sein.
Und je nach dem wie bei ASRock bei der BIOS Version die Beep Codes implementiert wurden, können die auch variieren . Kann sein eine die etwas abgeänderte Variante dann auf ein Timing Fehler des Speichers hindeutet, weil sich einige Entwickler dachten das hilft ihnen schneller um Speicherfehler beim Testen zu finden.

Der Keyboardcontroller wirds kaum sein, PS2 wird schon sehr lange über USB in der Southbridge emuliert.
Drei Beeps deuten auf Speicher hin, wenns mit neuen Speicher nicht geht kann das auch bedeuten das entweder die CPU einen Hau weg hat, die Soutbridge, ein Kondensator oder ein kleiner IC zur Ansteuerung.
Die Schlummermodus Taste wird kaum was kaputt gemacht haben, kan sein das dem Rechner der Zustand nicht wirklich geschmeckt hat, aber wenn dann war da eher schon vorher ein Defekt der dadurch erst auffiel.
Member: MirkoKR
MirkoKR Feb 28, 2023 at 10:53:50 (UTC)
Goto Top
Zitat von @WoenK0:

Der Keyboardcontroller wirds kaum sein, PS2 wird schon sehr lange über USB in der Southbridge emuliert.

Schreib das nich so pauschal.
Ich hatte auch schon jüngere PCs, wo man mit einem USB-Keyboard Nicht ins BIOS kam.

Ein PS/2-Keyboard am noch sehr oft vorhandenen PS/2-Anschluss brachte mich dann ins BIOS.

Nach Laden der Default-Einstellungen ging das dann auch wieder mit dem USB-Keyboard ...
Member: WoenK0
WoenK0 Mar 01, 2023 at 14:51:33 (UTC)
Goto Top
Zitat von @MirkoKR:

Zitat von @WoenK0:

Der Keyboardcontroller wirds kaum sein, PS2 wird schon sehr lange über USB in der Southbridge emuliert.

Schreib das nich so pauschal.
Ich hatte auch schon jüngere PCs, wo man mit einem USB-Keyboard Nicht ins BIOS kam.

Ein PS/2-Keyboard am noch sehr oft vorhandenen PS/2-Anschluss brachte mich dann ins BIOS.

Nach Laden der Default-Einstellungen ging das dann auch wieder mit dem USB-Keyboard ...

Ich meinte einen dedizierten PS2 Controller,,,,der ist meines Wissens seit über 20 Jahren in die Southbridge integriert und wir per Emulation bereitgestellt.
Kann schon passieren das der USB Port beim Booten nicht geht, sind ganz andere Bedingungen, aber echte Controller Chips für PS2 ?
Member: Blackmann
Solution Blackmann Mar 01, 2023 updated at 18:47:59 (UTC)
Goto Top
Zitat von @WoenK0:

Was verstehst du unter "nicht original BIOS Töne" ?
...

zu DOS-Zeiten war der Umgang mit den BIOS Codes ja wichtig um Probleme zu lösen, hatte mir damals auch Unterlagen zugelegt, um die verschiedensten BIOS-Typen (AMI, Phoenix usw.) zu verstehen.

Aber eines hatte ich mir gemerkt: Für jedes BIOS gab es eindeutige Töne: Kurz, Lang, kleine/große Pause aber immer in mit EINER Frequenz/Tonhöhe pro BIOS Typ.

Im MB das nun nicht mehr will kann ich bei Ausbau des RAM genau diese BIOS-Töne heraushören ... 3xBeep.

RAM wieder rein, starten und es kommen dann die von mir beschriebenen Töne, ABER anderst als wie erwartet:
Sie sind schneller und von der Tonlage höher.

Wie schon oben schon angedeutet kann ASRock natürlich das ganze implementieren wie sie wollen, doch solch Unterschiede?


Nun ja, Danke an alle die Geholfen haben, aber ich glaube diesem MB/CPU kann man kein Leben mehr einhauchen.

LG BM

Edit: Hatte PS2 und auch USB Tastatur dran.
Member: WoenK0
WoenK0 Mar 02, 2023 at 00:28:47 (UTC)
Goto Top
Zitat von @Blackmann:

Wie schon oben schon angedeutet kann ASRock natürlich das ganze implementieren wie sie wollen, doch solch Unterschiede?

naja, 3 Mal ist immer noch RAM , aber die Töne sind eigentliche schon länger nicht mehr so relevant, weil die wenigsten Anwender heute noch direkt einen Lautsprecher ans Mainboard angeschlossen haben. Aber selbst wenn du wüsstest das 3 Mal schnell auf ein Timing Fehler der RAM hindeutet, wie willst du das korrigieren ? :D

ZU DOS Zeiten waren die ganze Sachen noch so gross, da konnten selbst Grobmotoriker wie ich noch mit nen Multimeter was ausmessen und mit nen Lötkolben was austauschen :D

Würde an deiner Steller trotzdem das defekte Ding aufheben wenn Platz ist, in 30 Jahren könnte es ein Museumsstück sein :D