kosh
Goto Top

Cisco Catalyst 3750 InterVLAN Routing

Guten Abend Leute.

ich sitze hier vor einer echten (zumindest für mich) problemstellung.

ich habe einen cisco catalyst 3750, und auf diesem vlans konfiguriert.
aber aus irgendeinem grund routet er zwischen den vlans nicht.
ich hab nun zB die ip: 192.168.2.200 (default vlan) und als gateway: 192.168.2.253 (den catalyst)
wenn ich nun meinen dhcp server 192.168.3.9 anpinge (ein server der direkt am switch hängt, port ist auf VLAN_3 konfiguriert)

ip-adressen beziehen vom dhcp funktionert auch nicht, obwohl ich einen neuen multicastbereich am dhcp angelegt habe.

anbei mal die config:

interface Vlan1
 ip address 192.168.2.253 255.255.255.0
 ip helper-address 192.168.3.255
!
interface Vlan3
 ip address 192.168.3.253 255.255.255.0
!
interface Vlan4
 ip address 192.168.4.1 255.255.255.0
 ip helper-address 192.168.3.255
!
ip default-gateway 192.168.3.1
ip classless
ip route 0.0.0.0 0.0.0.0 192.168.3.1
ip http server

bitte um rasche hilfe.

Content-Key: 51919

Url: https://administrator.de/contentid/51919

Printed on: June 13, 2024 at 13:06 o'clock

Member: brammer
brammer Feb 16, 2007 at 22:22:51 (UTC)
Goto Top
Guten Abend Leute.

ich sitze hier vor einer echten (zumindest
für mich) problemstellung.

ich habe einen cisco catalyst 3750, und auf
diesem vlans konfiguriert.
aber aus irgendeinem grund routet er
zwischen den vlans nicht.
ich hab nun zB die ip: 192.168.2.200
(default vlan) und als gateway: 192.168.2.253
(den catalyst)
wenn ich nun meinen dhcp server 192.168.3.9
anpinge (ein server der direkt am switch
hängt, port ist auf VLAN_3
konfiguriert)

ip-adressen beziehen vom dhcp funktionert
auch nicht, obwohl ich einen neuen
multicastbereich am dhcp angelegt habe.

anbei mal die config:

> interface Vlan1
>  ip address 192.168.2.253 255.255.255.0
>  ip helper-address 192.168.3.255


wieso nimmst du die Broadcast adresse als helper adresse ???
nimm mal die .254


> !
> interface Vlan3
>  ip address 192.168.3.253 255.255.255.0
> !
> interface Vlan4
>  ip address 192.168.4.1 255.255.255.0
>  ip helper-address 192.168.3.255
> !
> ip default-gateway 192.168.3.1
> ip classless
> ip route 0.0.0.0 0.0.0.0 192.168.3.1
> ip http server
> 
> 

bitte um rasche hilfe.
Member: aqui
aqui Feb 16, 2007 at 22:52:48 (UTC)
Goto Top
Die .254 als Helper Adresse zu nehmen ist vollkommener Unsinn ! Auf der Adresse gibt es ja gar keinen Host ! Broadcasts die über die Helper Adresse vom Switch dahin geforwardet werden landen also im Nichts....
Wenn, dann muss es die 192.168.3.9 sein, denn das ist ja dein physischer DHCP Server für den wirklich diese BOOTP Broadcasts (DHCP) bestimmt sind !!
Eigentlich kannst du beides machen denn der Cisco forwardet den DHCP Request auf das .3.0er Segment als Multicast wenn du die .255 nimmst. Es kann aber sein das dein Server das nicht mag, also gib erstmal besser die dedizierte Adresse des DHCP Servers an, also die 192.168.3.9, dann wird das als Unicast direkt an den DHCP Host gesendet.
(Vorher mit "no ip help..." die .255 entfernen, sonst wird es doppelt geforwardet !)

Als 2ter Punkt ist deine default Route nicht ganz korrekt also entweder default Gateway oder default Route !!!
Das default Gateway solltest du weglöschen, die default Route reicht !

Ansonsten ist die Konfig korrekt. Leider ist deine Beschreibung WIE du das Routing testest etwas dürftig !!??
Vermutlich hast du 2 PCs in den unterschiedlichen VLANs .2.0 und .4.0 ?! Es sollte klar sein das die jeweilegen default Gateway Einträge dieser PCs auf die entsprechnde IP Addresse des Vlanx Interfaces zeigen sollte in dem sich diese PCs befinden !!!

Ein Ping an das Vlanx Interface muss erfolgreich sein. Ist es das nicht, steckst du vermutlich im falschen VLAN und hast die Portzuordnung zu den VLANs falsch gemacht.
Um nicht von DHCP abhängig zu sein solltest du diesen Test erstmal mit statischen IP Adressen machen.
Damit sollte ein Routing von VLAN zu VLAN problemlos möglich sein.

Ein Multicastbereich musst du am DHCP Server nicht einrichten...was soll das sein ???
Vermutlich meinst du ein weiteres Subnetz !?
Du musst natürlich 2 eintragen nämlich 192.168.2.0/24 und 192.168.4.0/24. Die Gateways die mitgegeben werden sind dann logischerweise immer die VLAN IPs des Switches passend zum Subnetz bzw. VLAN !!!
Member: Kosh
Kosh Feb 16, 2007 at 23:18:49 (UTC)
Goto Top
ahoi.

als erstes mal danke für die schnellen antworten.
ich wollte nur mal anmerken dass ich, wie es wohl vielen anderen auch schon mal passiert ist, den wald vor lauter bäumen nicht gesehen habe.

problem war:
ich hatte zwar bei vlan_4 bei den clients als gateway das vlan_4 interface des 3750ers, aber bei den vlan_3 clients (die ja noch die settings vom dhcp server bekamen) noch die 192.168.3.1 als gateway drin.

man glaubt gar nicht wie schnell das funktioniert wenn man dann erst am dhcp-server das richtige gateway einstellt ; )

also nochmal danke an alle, für die hilfe (vor allem zu so später stunde)

Grüsse

Kosh