Cisco Switch antwortet nicht auf Ping zeitweise

hausrocker
Goto Top
Ich habe insgesamt 3 SG220-26 26-Port Switche mit firmware 1.2.0.3, die ab und zu, ca. 10 Minuten lang nicht auf ping antworten. Egal von wo aus. Also sowohl unser Nagios als auch mein Client kriegen dann keine Antwort auf ping. Das Webinterface funktioniert aber und ich kann mich da problemlos auch einloggen, es sieht auch nicht langsam aus, die Clients am Switch haben auch wunderbar auf alles Zugriff. Nur der Switch antwortet dann nicht auf ping.

Das Log hat ab und zu diese Nachricht:

2 May 17 2022 08:42:03 info GigabitEthernet21 STP port state is set to Forwarding
3 May 17 2022 08:41:47 info GigabitEthernet21 STP port state is set to Learning
4 May 17 2022 08:41:28 info GigabitEthernet21 STP port state is set to Blocking

Und verbunden ist der Switch über ein paar Rangierungen per LWL mit einem CBS350-8S-E-2G auf dem alle LWL zusammenlaufen.

Woran kann das liegen mit den ping Aussetzern?

Content-Key: 2806938126

Url: https://administrator.de/contentid/2806938126

Ausgedruckt am: 29.06.2022 um 05:06 Uhr

Mitglied: unbelanglos
unbelanglos 17.05.2022 um 10:04:09 Uhr
Goto Top
Die hast ein link flapping dass das STP triggert.
Kabel und Buchsen würde ich zuerst prüfen.
Mitglied: hausrocker
hausrocker 17.05.2022 um 11:39:44 Uhr
Goto Top
Danke für den Hinweis. Kurioser Weise habe ich das auf der Gegenseite nicht als Fehler im Log. Muss das nicht auf beiden Seiten dann ein Problem sein?
Kabel und Buchse tauschen? Kann das auch vom SFP Modul kommen?
Mitglied: unbelanglos
unbelanglos 17.05.2022 um 12:07:21 Uhr
Goto Top
Was steckt den auf GE21?
Mitglied: hausrocker
hausrocker 17.05.2022 um 13:45:42 Uhr
Goto Top
Ein SFP Uplink zu einem anderen Cisco Switch, einem CBS350-8S-E-2G. Auf dem habe ich nachgesehen im Log.
Mitglied: JoeToe
JoeToe 17.05.2022 um 13:54:03 Uhr
Goto Top
Moin.

[...] die Clients am Switch haben auch wunderbar auf alles Zugriff. Nur der Switch antwortet dann nicht auf ping.

Vermutlich instabile Verbindung über LWL. Laufen Telefonate (zeitkritische Anwendung) über die fraglichen Switches, merkst du die Aussetzer/Störungen schon.

Ich würde bei OSI 1 anfangen und zuerst die SFP-Module samt LWL-Patchkabel erneuern.

Gruß
JoeToe
Mitglied: hausrocker
hausrocker 17.05.2022 um 15:24:00 Uhr
Goto Top
Es telefonieren ca. 30 Personen über diese Glasfaserverbindungen und von denen hat sich zumindest trotz HD Telefonie noch nie jemand beschwert.
Und wie hoch ist denn die Wahrscheinlichkeit, dass das das Pingproblem verursacht?

Wo ich das schon ganz vielleicht merke ist, manchmal mit Teamviewer friert die Verbindung ein. RDP ist kein Ding. Das könnte natürlich auch am Internet einfach liegen war so meine Erklärung.

Ich habe auch eine Sternverbindung von diesem zentralen CBS350 auf mind. 6 weitere SG220. Davon sind 3 Geräte Kandidaten, bei denen Nagios dann manchmal Probleme meldet und Ping Timeout. Webinterface geht dann aber ping auch von meinem PC aus nicht.
Ich habe schon aus der Not heraus überlegt den Check von ping auf http umzustellen. Aber schön ist das ja auch nicht, wenn man da die Ursache nicht erklären kann.
Mitglied: Tjelvar
Tjelvar 17.05.2022 um 17:40:12 Uhr
Goto Top
Heyo,

tausch doch testweise mal die GBICs der beiden Switche miteinander. Wenn das Problem dann auch beim CBS350 auftaucht, ist der GBIC wahrscheinlich kaputt.

Gruß,
Tjelvar
Mitglied: NordicMike
NordicMike 18.05.2022 um 07:33:59 Uhr
Goto Top
4 May 17 2022 08:41:28 info GigabitEthernet21 STP port state is set to Blocking

Ich lese aus dem Log nichts anderes als dass der Port wegen STP (Spanning Tree Protokoll) geblockt wurde. So etwas passiert, wenn sich Pakete im Netzwerk verirren, z.B. wenn ein Loop gebaut wurde oder zwei Switch Ports miteinander verbunden wurden.