DHCP mit VLAN und Win2008 R2 Server als Relay über WLAN AP

Mitglied: KnowSlayes

KnowSlayes (Level 1) - Jetzt verbinden

28.01.2016, aktualisiert 07.02.2016, 1836 Aufrufe, 8 Kommentare

Guten Nabend liebe Gemeinschaft...

Hier vorab das Konstrukt von mir.
Server Win2008 R2 auf XenServer als Virutelle Maschine.
2 Physikalische Netzwerkkarten NIC 1 und NIC 2
Daraus habe ich 3 Virutelle Netzwerkkarten gemacht:
"Extern" Ohne VLAN an NIC 1
"Intern" Ohne VLAN an NIC 2
"LAN_10" mit VLAN ID 10 an NIC 2
Im XenServer kann ich jeder Virutellen Netzwerkkarte ein VLAN ID eintragen

Als switch ist ein ZyXEL GS1900-48 im Einsatz. Der zwar VLAN kann, aber keinen DHCP-Relay (IP Helper) einstellen kann.
Als Management VLAN ist der ID 1 gewählt. Und Standard gemäß alle Ports auch in VLAN 1 drin. Was ich hier mal als Ohne VLAN beschreibe.
Port 1 -> NIC 1 Server (also auch Virtuelle Netzwerkkarte Extern) Ohne VLAN
Port 2 -> NIC 2 Server (Intern und LAN_10 virtuelle Netzwerkkarte) Mit VLAN 10

Accespoint von TP-Link wo jeder SSID ein VLAN bekommt (hat auch kein DHCP-Relay)
SSID Mitarbeiter VLAN 1
SSID Gast VLAN 10

Auf dem Server läuft Routing und RAS.
"Extern" hat eine öffentliche IP Adresse und Gateway
"Intern" hat die Feste IP 192.168.20.11/24 Ohne Gateway
"LAN_10" hat die Feste IP 10.0.0.11/8 Ohne Gateway
Beide Schnittstellen sind als DHCP Relay im Routing und RAS eingetragen und die Addressen 192.168.20.11 und 10.0.0.11

Der DHCP hat zwei Bereiche
192.168.20.100 - 192.168.20.199 / 24
und
10.10.0.0 - 10.10.255.255 / 8

Folgendes passiert nun. Verbinde ich mich mit SSID Mitarbeiter funktioniert alles. Client bekommt eine IP Adresse aus dem DHCP Pool.
Wähle ich allerdings den SSID Gast, bekomme ich keine IP Addresse. Vergebe ich am am Client eine eigene IP Adresse Beispiel 10.0.99.99 mit Gateway 10.0.0.11 funktioniert auch alles wie es soll. Der Client kommt ins Internet und kann auf keinen Rechner aus VLAN 1 (IP Bereich192.168.20.xxx) zugreifen.
Wenn ich im Switch Selber kein DHCP Relay eintragen kann, wo muss das passieren??? Auf dem Router habe ich es ja. Sprich der Windows 2008 R2 Server.
Oder müssen alle DHCP Bereiche die gleichen Host anteile haben? Also 192.168.1.xxx/24 für Ohne VLAN und 192.168.10.xxx/24 für VLAN 10. Ich gehe davon aus, das wie ich das Subnet mache, doch egal sein sollte.

Dieses Problem habe ich so noch nicht bei Onkel Google gefunden. Auch keine Anleitung wie ich den Router von Windows Server VLAN technisch einstellen soll, bei DHCP Relay.

Ich bin über jeden Denkanstoss dankbar. Da ich jetzt 4 Woche alles versucht habe, bevor ich hier schreiben.

Grüße,
Marc
Mitglied: catachan
29.01.2016, aktualisiert um 06:51 Uhr
Hi

Wo läuft der DHCP ? Das überlese ich jetzt irgendwie ? Wenn der Server schon in beiden Netzen hängt (ist das so gewollt ?) dann mach doch den DHCP auf den Server drauf mit. Wenn er dort schon laufen sollt, dann benötihgst du keinen DHCP Relay. Du musst nru schauen dass der DHCP auf beide NICs gebunden ist

LG

EDIT: Siehe heir https://technet.microsoft.com/de-at/library/dd296626%28v=ws.10%29.aspx
Bitte warten ..
Mitglied: BirdyB
29.01.2016 um 08:05 Uhr
Hi,

wenn du einen Multihomed-DHCP betreiben willst, brauchst du dir eigentlich über die Helper keine Gedanken machen.
Es genügt den DHCP-Server entsprechend zu konfigurieren und fertig. Siehe hier: https://technet.microsoft.com/en-us/library/cc770650.aspx

Beste Grüße!


Berthold
Bitte warten ..
Mitglied: aqui
29.01.2016 um 12:59 Uhr
Der zwar VLAN kann, aber keinen DHCP-Relay (IP Helper) einstellen kann.
Das ist eigentlich fast nicht zu glauben. Jeder managebare Baumarkt Switch hat das eigentlich. Es ist schon zeifelhaft das ein angesehener Hersteller wie Zyxel so eine banale Funktion wie DHCP Relay nicht supportet.
Alle Grundlagen zur VLAN Kommunikation oder IP Routing zwischen Segmenten allgemein behandeln diese Forum Tutorials:
https://www.administrator.de/wissen/vlan-routing-802-1q-trunk-ms-linux-s ...
bzw.
https://www.administrator.de/wissen/routing-2-netzwerkkarten-windows-u-l ...
Das gilt identisch auch für dein Design.

Übrigens... Die Zyxel Kiste kann DHCP Relay
http://www.manualslib.com/manual/561282/Zyxel-Communications-Gs1910.htm ...
Bitte warten ..
Mitglied: KnowSlayes
29.01.2016 um 14:09 Uhr
Vergessen zu schreiben. der Windows Server 2008 spielt DHCP.
Die Bindung ist eingestellt. Unter Eigenschaften von Serverbindung. Sind beide IP Adressen ausgewählt. Oder bin ich da falsch. Ist die einzige Bindung die ich kennen....
Bitte warten ..
Mitglied: KnowSlayes
29.01.2016 um 14:15 Uhr
Zitat von @aqui:

Übrigens... Die Zyxel Kiste kann DHCP Relay
http://www.manualslib.com/manual/561282/Zyxel-Communications-Gs1910.htm ...

Danke für die Tutorials, habe ich schon viel von genommen.
Aber die Anleitung ist wohl für den 1910 nicht für den 1900... Bin ich auch schon drauf reingefallen.
Hier mein Menü aus dem ZyXEL mit aktueller Firmware.
http://goo.gl/9yRs2V
Bitte warten ..
Mitglied: aqui
LÖSUNG 29.01.2016, aktualisiert 07.02.2016
Bitte lasse den Unsinn mit externen Bilderlinks und dortiger Zwangswerbung hier im Forum ! :-( face-sad
Das Forum hat selber eine wunderbare Bilder Upload Funktion. Die kann dir nicht entgangen sein beim Erstellen deines Beitrags, es sei denn du hast Tomaten auf Selbigen ?!
Wenn man die FAQs liest ist es kinderleicht:
  • Deinen Originalthread mit "Meine Inhalte - Fragen" auswählen und auf "Bearbeiten" klicken !
  • Nun kannst du oben den Button "Bilder" nicht übersehen. Anklicken und dein Bild hochladen
  • Den nach dem Upload erscheinenden Bilder Link mit einem Rechtsklick und Copy und Paste sichern.
  • Diesen Bilder Link kannst du hier in jeglichen Text bringen ! Ja, auch Antworten..! Statt des Links kommt dann ...et voila.. Dein Bild im Browser!
Kann man übrigens wunderbar auch noch nachträglich machen und die Forumscommunity hier wird es dir danken.

Zurück zum Thema !
Leider ist der FTP Server von Zyxel so lahm das man das 1900er manual nicht runterladen kann :-( face-sad
ftp://ftp.zyxel.com/GS1900-48/user_guide/GS1900-48_V2.1_Ed2.pdf
Ächz...endlich durch.
OK, nach Lektüre des manuals ist klar warum das nicht geht.
Der Switch ist NICHT L3 fähig, kann also NICHT Routen zwischen den VLANs !
Das ist ein reiner Layer 2 VLAN Switch und damit ist dann DHCP Relay auch logischerweise vollkommen obsolet auf solcher Hardware !
Du brauchst dann einen externen Router oder musst über den server routen mit einem .1q Trunk wie oben im Tutorial beschrieben.
Winblows und Linux supporten jeweils auch DHCP Relay und externe Router ebenso...wenn man die richtigen verwendet.
https://www.administrator.de/wissen/vlan-installation-routing-pfsense-mi ...
Bitte warten ..
Mitglied: KnowSlayes
07.02.2016 um 22:06 Uhr
Aqui vielen Dank für deine Antwort - Die mich dann auf die Lösung gebracht hat. Den Port am ZyXEL, an dem der Server angschlossen ist, auf untaged zu stellen. Und schon lief es. Wundert mich zwar das ich durch pingen konnte, aber keiner Verbidung bekam. Aber es läuft nun.

OFF TOPIC:
Dieses Forum hat aber auch eine wunderbare "Link hinzufüge" Funktion. Ich kann keine Werbung sehen bei einen Link auf eine Google Drive Datei. Daher kann ich deine Bedenken nicht nachvollziehen. Dafür gibt es Cloud Systeme. Der Anbieter muss ja nicht jeden gefallen. Bilder dann in die Editieren Frage zu packen, fördert nicht gerade der Übersicht der Inhalte und Antworten. Aber bin gerne berreit mich vom Gegenteil überzeugen zu lassen. Dann gerne PN.

Grüße,
KnowSlayes
Bitte warten ..
Mitglied: aqui
09.02.2016 um 20:55 Uhr
Die Lösung klingt wirr. Sorry aber der Switch kann ja nicht routen, damit ist eine inner VLAN Kommunikation ohne ein Layer 3 Device unmöglich, aber vielleicht ist das ja auch gar nicht gewollt.
Alternativ kannd er Server schon tagged in den VLANs arbeiten.
Wenn du das planst steht hier wie es genau geht:
https://www.administrator.de/wissen/vlan-routing-802-1q-trunk-ms-linux-s ...

Zu den Bildern nur so viel: Warum die Forumscommunity mit Extra Klicks hier zwingen wenn man die Bilder einfach auch in die Threads embedden kann. Sowas muss ja nicht sein wenn das Forum solche Option hat.
Wie immer im leben...Geschmackssache ;-) face-wink
Bitte warten ..
Heiß diskutierte Inhalte
Netzwerke
Was passiert wenn ich zeitgleich PoE und Strom vom Netzteil an einen Access Point (Mikrotik) lege?
kartoffelesserVor 1 TagFrageNetzwerke3 Kommentare

Hallo Experten und Admins Ich habe einen Mikrotik wAP ac (RB-WAPG-5HACD2HND) an einem Laptopwagen im Einsatz. Leider ist die vorhandene Stromversorgung für den AP ...

Windows Server
Infrastruktur für Firma
brainwashVor 19 StundenFrageWindows Server7 Kommentare

Hallo zusammen, kurze Erklärung zu meinem Problem Wir sind eine kleine Firma mit zwei Standorten im Bereich Brandschutz. Zur Zeit nutzen wir für unsere ...

Netzwerkprotokolle
Proxy Zugang von Extern
gelöst Jannik2018Vor 1 TagFrageNetzwerkprotokolle17 Kommentare

Hallo zusammen, ich habe mir einen Squid Proxy auf einer Linux VM aufgesetzt und möchte das man aus allen netzen drauf zugreifen kann allerdings ...

Windows Server
Windows 10 VM auf Server 2019 Essentials
jhuedderVor 1 TagFrageWindows Server10 Kommentare

Hallo, einer meiner Kunden möchte aus Kostengründen einen Windows Server 2019 (direkt auf einer physikalischen Maschine installiert) erwerben und dort für einen Außendienstler mit ...

Server-Hardware
Verkaufe RX300 S7 Server von Fuijutsu
HolzBrettVor 20 StundenAllgemeinServer-Hardware9 Kommentare

Hi, Ich wohne in Aachen und habe die Server von der Firma umsonst erhalten. Ich habe sie bereits überprüft (es geht alles). Ich möchte ...

Windows Server
Veeam Endpoint Backup FREE zur Sicherung eines DCs
gelöst takvorianVor 1 TagFrageWindows Server7 Kommentare

Hallo zusammen, ich habe hier bei mir 1 Hypervisor mit 4 VMs (darunter 1 DC) welche ich mittels backupAssist alle wegsichere. Klappt soweit auch ...

LAN, WAN, Wireless
WLan-unterstütztes Telefonieren iOS, Unifi
VisuciusVor 1 TagFrageLAN, WAN, Wireless8 Kommentare

Hallo. Ich bins (wieder) ;-) Guten Morgen, ich beobachte seit einer Umstellung ein "komisches Verhalten" und kann mir das gerade nicht erklären. Und vielleicht ...

LAN, WAN, Wireless
Heimnetzwerk mit VLAN - getrennter Internetzugang
gelöst anyibkVor 1 TagFrageLAN, WAN, Wireless5 Kommentare

Hallo liebe Community! Ich bastle seit einiger Zeit an einem recht besonderen Heimnetzwerkproblem. Wir haben einen neuen Glasfaseranschluss ins Haus (3 Parteien) bekommen und ...