123290
Goto Top

Einbindung Adaptec 6805 in ESXi 6.5 Update 1

Guten morgen, folgende Problematik:

Ein Adaptec 6805 Controller soll in einem ESXi 6.5 Update 1 (Version 2.7.17) überwacht werden. Folgendes habe ich getan:

1. Controller auf die neueste Firmware aktualisiert - läuft.
2. vmware-esxi-drivers-scsi-aacraid-600.6.2.1.52011.-1.0.6.2494585.x86_64 Treiber ins VMware intergriert - läuft. Logisches Laufwerk ist da.
3. vmware-esx-provider-arc-cim-provider und vmware-esx-provider-arcconf ins VMware integriert. Versionen jeweils die neuesten von der Adaptec Seite. Ob läuft - keine Ahnung, Community Level wurde gesetzt und sie wurden beide erfolgreich installiert.
4. Den aktuellsten MaxView Manager GOS (für Guest-OS) installiert, bei der Einrichtung die IP, Benutzer/Pass des ESXi Host angebeben.

und nun - keine Controller gefunden face-confused Was fehlt? Oder ist ESXi 6.5 nicht kompatibel? Habe auch eine MaxView Appliance gefunden, findet auch keine Controller

Content-Key: 345416

Url: https://administrator.de/contentid/345416

Printed on: June 15, 2024 at 13:06 o'clock

Member: Vision2015
Vision2015 Aug 04, 2017 at 06:57:17 (UTC)
Goto Top
Zitat von @123290:
moin..

Guten morgen, folgende Problematik:

Ein Adaptec 6805 Controller soll in einem ESXi 6.5 Update 1 (Version 2.7.17) überwacht werden. Folgendes habe ich getan:
ok...

1. Controller auf die neueste Firmware aktualisiert - läuft.
ok
2. vmware-esxi-drivers-scsi-aacraid-600.6.2.1.52011.-1.0.6.2494585.x86_64 Treiber ins VMware intergriert - läuft. Logisches Laufwerk ist da.
ok..
3. vmware-esx-provider-arc-cim-provider und vmware-esx-provider-arcconf ins VMware integriert. Versionen jeweils die neuesten von der Adaptec Seite. Ob läuft - keine Ahnung, Community Level wurde gesetzt und sie wurden beide erfolgreich installiert.
ok
4. Den aktuellsten MaxView Manager GOS (für Guest-OS) installiert, bei der Einrichtung die IP, Benutzer/Pass des ESXi Host angebeben.
ok..

und nun - keine Controller gefunden face-confused Was fehlt? Oder ist ESXi 6.5 nicht kompatibel? Habe auch eine MaxView Appliance gefunden, findet auch keine Controller
ist der DNS richtig eindreichtet... wird der hostname im Netz aufgelöst ?

Frank
Mitglied: 123290
123290 Aug 04, 2017 at 07:02:14 (UTC)
Goto Top
ist der DNS richtig eindreichtet... wird der hostname im Netz aufgelöst ?

Ja, DNS Auflösung funktioniert. Da der MaxView Manager auf "localhost" zugreift, entfällt das wohl leider. Die IP des Hosts wurde bereits eingerichtet
Member: Vision2015
Vision2015 Aug 04, 2017 at 10:33:43 (UTC)
Goto Top
ok..

und der CIM Server rennt auch ? schau mal unter Dienste nach!

Frank
Member: sivsert
sivsert Mar 15, 2019 at 14:28:02 (UTC)
Goto Top
Hallo,
ich weis der Thread ist schon älter. Hänge aber im Moment am selben Problem.
Mein RAID Kontroller ist ein Adaptec SmartRAID 3154-8i. Treiber und vibs alle von der microsemi homepage heruntergeladen.

Folgendes ist bis jetzt gemacht worden:

- Der Server ist mit ESXi 6.7.0 installiert.
- Danach habe ich dem ESXi eine neue VM gegeben (Server 2016). Hier in der Host-Datei unter ...windows/system32/drivers/etc meine IP vom
ESXi und den Namen meines ESXi eingetragen.
- Ping über IP und Name erfolgt von der VM problemlos.
- danach im ESXi, SSH aktivert, über WINSCP, drei .vib Dateien(arcconf, provider und treiber) auf den ESXi hochgeladen.
- Über Putty mit folgenden Befehl die vibs installiert:
esxcli software vib install --no-sig-check -v /vmfs/volumes/HDD_RAID/cim/arcconf.vib (bzw. provider.vib und treiber.vib)
ich habe die .vib absichtlich abgeändert im Namen.
Die Installation läuft auch durch und nach einem Neustart sehe ich im ESXi unter Host- >Überwachen->Hardware->Speicher auch diverse Einträge.
- Ich habe auch unter Host->Verwalten->Dienste geprüft ob der CIM-Server läuft. Dies tut er. Nun habe ich meine VM gestartet und den/das MSM installiert. Verlief auch Problemlos. Allerdings kann ich meinen ESXi nicht finden. Ich kann mich mit dem MSM nur lokal auf meine VM aufwählen. Pingen per IP und Name zum ESXi ist immer noch problemlos möglich.

Was ich nicht verstehe. Im ESXi unter Netzwerk und Firewall wird der watchdog-Dienst (CIM-Server) als http mit Port 5988 und als https mit Port 5989 hinterlegt.
In der MSM Installation wurde der Port 8443 angegeben. Ich hab auch das MSM schon mehrfach neu installiert und auch die Ports hinterlegt welche mir der ESXi in der Firewall anzeigt. Jedoch immer ohne Erfolg.

In einem Forum habe ich gelesen, dass man in der VM mal die Eingabeaufforderung starten soll und prüfen soll ob der RAID-Controller überhaut "da" ist. Folgender befehl wurde verwendet:
"arcconf getconfig 1 ad"
Da bekomme ich die Meldung: "controller found: 0 // Invalid controller Number."
Also komme ich nachweislich nicht von meiner VM auf den RAID-Kontroller welcher sich im Server befindet, oder???.


Ich habe schön öfter Server konfiguriert und es gab weder mit LSI noch mit Adaptec Kontrollern irgendwelche Probleme.
Bin mit meinem Wissen schon über das Ende hinausgeschossen ;)
Evtl. sehe ich den Wald auch vor lauter Bäumen nicht und es ist ein kleiner Denkfehler der sich hier eingeschlichen hat.

Lieb Grüße und danke schon mal an alle die das hier lesen, Pierre
Member: Vision2015
Vision2015 Mar 15, 2019 at 15:32:50 (UTC)
Goto Top
Moin...

wiso willst du mit einem LSI MSM auf einen Adaptec zugreifen? .+.+.+.+KOPFKRATZ.#.#.#.#.#
dat geht nicht....
du brauchst den MaxView Storage Manager...
oder lese ich was falsch?
Member: sivsert
sivsert Mar 15, 2019 at 15:46:15 (UTC)
Goto Top
Da hab ich mich ja mal super idiotisch ausgedrückt. ;) SORRY

natürlich rede ich vom MaxViewRaidManager. Dieser ist ja auch auf der Downloadseite von Microsemi zu dem RAID-Kontroller aufgerührt.
Da merkt man wieder wie das Hirn zermartert ist wenn man zulange an einem Problem sitzt ;)
Member: sivsert
sivsert Mar 18, 2019 at 13:46:01 (UTC)
Goto Top
So Problem hat sich eben gelöst.

Nach Rücksprache mit dem Server-Hersteller, habe ich erfahren, dass VMWare dies aktuell nicht unterstützt. Würde ich also auf eine "ältere" ESXi Version umsteigen, gäbe es keine Probleme.
Mit ESXi 6.7 läuft das leider noch nicht. Man kann zwar nach korrekter Installation der VIBs die Hardware im ESXi einsehen, jedoch kann über den "MaxView Storage Manager" keine Infos abgerufen werden, da der ESXi, von seiten der VM, keine Einsicht in die Hardwareebene zulässt.

WICHTIG: Laut Aussage des Supports betrifft dies wohl auch LSI im Moment. Garantieren kann ich das nicht, hab es nicht getestet.
Es soll wohl ein Update oder ein Patch erscheinen, jedoch konnte mir nicht gesagt werden wann.
Also warten wir ein bissi ab, denn unser Kunde wünscht einen ESXi 6.7.

Danke fürs lesen und danke an Vision2015 für die Richtigstellung.

Liebe Grüße Pierre
Member: cola
cola Apr 06, 2019 at 05:13:33 (UTC)
Goto Top
Hallo sivsert

Danke für deine Erklärung, hab bereits etliche Stunden damit verbracht!
Hast du einen case offen bei Adaptec welchen man verfolgen könnte? Würde gerne wissen sobald dies für ESXi 6.7 funktioniert, habe genau dasselbe Problem...
Member: sivsert
sivsert Jun 13, 2019 at 10:59:44 (UTC)
Goto Top
Hey cola,

sorry die lange Wartezeit. Einen Case habe ich nicht offen.
Ich habe zwischenzeitlich mit Dell und Fujitsu gesprochen. Die kennen das Problem auch. Bei Dell schaue ich nun über die DRAC auf die HDDs, das funktioniert sehr gut, auch wenn die Platten hinter einem Kontroller hängen.
Fujitsu hat wohl ein Tool dafür, dass habe ich noch nicht getestet. Steht auf meinem ToDo, sobald ich Luft dafür habe.

LG
Member: Dr.Bit
Dr.Bit Oct 25, 2020 at 14:42:24 (UTC)
Goto Top
Moinsens,

ist zwar schon älter, aber immer noch aktuell. Ich versuch seit eingen Tagen, es zum Laufen zu bekommen (hätte ja auch gleich hier gucken können ich Depp). Wie dem auch sei: das Problem besteht immer noch. Der ESXI wird im MaxView zwar angezeigt, aber es wird kein Controller erkannt. Ich glaube nicht, das da noch was kommt.

đź––
Member: cola
cola Oct 28, 2020 at 05:49:03 (UTC)
Goto Top
hab einen workarround, überwache per ssh den status

SSHPASS='pass' sshpass -e ssh user@ip /opt/pmc/arcconf getconfig 1 pd|egrep "Device #|State\>|Reported Location|Reported Channel|S.M.A.R.T. warnings"