Top-Themen

Aktuelle Themen (A bis Z)

Administrator.de FeedbackApache ServerAppleAssemblerAudioAusbildungAuslandBackupBasicBatch & ShellBenchmarksBibliotheken & ToolkitsBlogsCloud-DiensteClusterCMSCPU, RAM, MainboardsCSSC und C++DatenbankenDatenschutzDebianDigitiales FernsehenDNSDrucker und ScannerDSL, VDSLE-BooksE-BusinessE-MailEntwicklungErkennung und -AbwehrExchange ServerFestplatten, SSD, RaidFirewallFlatratesGoogle AndroidGrafikGrafikkarten & MonitoreGroupwareHardwareHosting & HousingHTMLHumor (lol)Hyper-VIconsIDE & EditorenInformationsdiensteInstallationInstant MessagingInternetInternet DomäneniOSISDN & AnaloganschlüsseiTunesJavaJavaScriptKiXtartKVMLAN, WAN, WirelessLinuxLinux DesktopLinux NetzwerkLinux ToolsLinux UserverwaltungLizenzierungMac OS XMicrosoftMicrosoft OfficeMikroTik RouterOSMonitoringMultimediaMultimedia & ZubehörNetzwerkeNetzwerkgrundlagenNetzwerkmanagementNetzwerkprotokolleNotebook & ZubehörNovell NetwareOff TopicOpenOffice, LibreOfficeOutlook & MailPapierkorbPascal und DelphiPeripheriegerätePerlPHPPythonRechtliche FragenRedHat, CentOS, FedoraRouter & RoutingSambaSAN, NAS, DASSchriftartenSchulung & TrainingSEOServerServer-HardwareSicherheitSicherheits-ToolsSicherheitsgrundlagenSolarisSonstige SystemeSoziale NetzwerkeSpeicherkartenStudentenjobs & PraktikumSuche ProjektpartnerSuseSwitche und HubsTipps & TricksTK-Netze & GeräteUbuntuUMTS, EDGE & GPRSUtilitiesVB for ApplicationsVerschlüsselung & ZertifikateVideo & StreamingViren und TrojanerVirtualisierungVisual StudioVmwareVoice over IPWebbrowserWebentwicklungWeiterbildungWindows 7Windows 8Windows 10Windows InstallationWindows MobileWindows NetzwerkWindows ServerWindows SystemdateienWindows ToolsWindows UpdateWindows UserverwaltungWindows VistaWindows XPXenserverXMLZusammenarbeit

gelöst Einrichtung und Erweiterung meines Netzwerkes problemlos möglich?

Mitglied: AbstrackterSystemimperator

AbstrackterSystemimperator (Level 1) - Jetzt verbinden

13.08.2019 um 16:45 Uhr, 557 Aufrufe, 48 Kommentare, 2 Danke

Hallo, dank eurer Hilfe und viel Nervennahrung, konnte ich mein Netzwerk zum laufen bringen. Siehe hier. VLAN - Netzwerke

Nun möchte ich mein Wissen erweitern und meinen Wissensdurst stillen und mein "Netzwerkprojekt" erweitern.

Wie bereits erkannt und erwähnt, bin ich auf diesem Gebiet absoluter "blutiger Anfänger", weshalb ich euch um Rat frage, ob meine "Grundidee" überhaupt realisierbar wäre.

Ich möchte mein Netzwerk, um zwei weitere Netzwerke erweitern, welche nicht im selben Netzwerksegment liegen.

1x Netzwerk mit dem Namen "Lager"
-2x Lagerclients
-1x DHCP-Server
-1x Switch

Zwischen diesen beiden Netzwerken hängt ein Router, da ich gerne vom Lagernetzwerk zum Versandnetzwerk routen möchte.

1x Netzwerk mit dem Namen "Versand"
-4x Versandclients
-1x DHCP - Server
-2x Switche

Vorab die Fragen:
Mit einem DHCP - Server kann ich bestimmt nicht umsetzen, dass beide Netzwerke unterschiedliche IP-Adressen erhalten, richtig? Daher bräuchte ich für jedes Netzwerk einen eigenen DHCP-Server.

Zum Aufbau:

Netzwerklager:
DHCP - Server mit dem Switch verbinden
Clients mit dem Switch verbinden
Switch mit dem Router verbinden, welcher das Netzwerk "Versand" verbindet.

Netzwerkversand:
DHCP - Server mit dem Switch verbinden
Clients mit dem Switch verbinden
Switch to Switch, sehe ich gerade, ist dumm.
Daher auch Switch mit dem Router verbinden, welcher dann sich mit dem Switch vom privaten Netzwerk verbindet.

Dieses Mal möchte ich nicht mit den VLANs arbeiten, sondern es mal ohne versuchen.

Wäre das so in Ordnung oder ist total dämlich?

LG
test - Klicke auf das Bild, um es zu vergrößern
48 Antworten
Mitglied: erikro
13.08.2019 um 16:57 Uhr
Moin,
Zitat von AbstrackterSystemimperator:
Vorab die Fragen:
Mit einem DHCP - Server kann ich bestimmt nicht umsetzen, dass beide Netzwerke unterschiedliche IP-Adressen erhalten, richtig? Daher bräuchte ich für jedes Netzwerk einen eigenen DHCP-Server.

Jein. Du kannst auch einen DHCP-Forwarder einrichten, der für eins der beiden Netze sich die Daten vom DHCP-Server des anderen Netzes holt. Auf dem DHCP-Server richtest Du dann zwei Bereiche mit den beiden Netzen ein. Da Du ja sowieso zwischen den Netzen einen Router einsetzen musst, kannst Du auch gleich eine Box anschaffen, die das auch kann.

hth

Erik
Bitte warten ..
Mitglied: AbstrackterSystemimperator
13.08.2019 um 17:03 Uhr
Zitat von erikro:

Moin,
Zitat von AbstrackterSystemimperator:
Vorab die Fragen:
Mit einem DHCP - Server kann ich bestimmt nicht umsetzen, dass beide Netzwerke unterschiedliche IP-Adressen erhalten, richtig? Daher bräuchte ich für jedes Netzwerk einen eigenen DHCP-Server.

Jein. Du kannst auch einen DHCP-Forwarder einrichten, der für eins der beiden Netze sich die Daten vom DHCP-Server des anderen Netzes holt. Auf dem DHCP-Server richtest Du dann zwei Bereiche mit den beiden Netzen ein. Da Du ja sowieso zwischen den Netzen einen Router einsetzen musst, kannst Du auch gleich eine Box anschaffen, die das auch kann.

hth

Erik

hi,

danke für die Info! Über DHCP-Forwarder mache ich mich mal schlau!

LG
Bitte warten ..
Mitglied: aqui
LÖSUNG 13.08.2019, aktualisiert um 17:51 Uhr
Mit einem DHCP - Server kann ich bestimmt nicht umsetzen, dass beide Netzwerke unterschiedliche IP-Adressen erhalten, richtig?
Nein, falsch !
Du gefährdest schon wieder deinen Helden Status aus dem oben zitierten Thread !! Da wurde dir das doch mehrfach und haarklein mit den unsäglichen Helper Adressen erklärt. Du hast es sogar richtig verstanden und auch bestätigt. Warum also diese überflüssige Frage ?
Ja, du kannst und MUSST auch unterschiedliche IP Adressen benutzen, denn IP Segment Adressen müssen immer einzigartig sein im Netzwerk. Das lernen die Grundchüler in der IP Grundschule als Erstes.
Um es zu wiederholen... Du hast 2 Optionen:
  • Zentrale Vergabe auf einem einzigen zentralen DHCP Server. Erfordert dann die Helper IP auf desen Server.
  • Dezentrale Vergabe auf dem jeweiligen Router so wie es im zitierten Thread von dir ja auch gemacht wurde
Dieses Mal möchte ich nicht mit den VLANs arbeiten, sondern es mal ohne versuchen.
Dann lässst du schlicht und einfach die Subinterfaces weg auf deinem Erstprojekt und gehst an die dedizierten Interfaces des Routers ohne 802.1q Subinterfaces.
Der Rest ist exakt genau so wie in deinem Erstprojekt !!
Dafür hätte doch nun wahrlich nicht eines neuen Threads bedurft, oder ?!
Über DHCP-Forwarder mache ich mich mal schlau!
Hatten wir auch alles schon...das sind die Helper Adressen !! Dzzzzz... Du vergisst leider zu schnell das mühsam Erlernte
Die banale Konfig dazu sieht so aus (mit dezentralem DHCP):
!
ip dhcp binding cleanup interval 600
ip dhcp excluded-address 10.1.1.1 10.1.1.100
ip dhcp excluded-address 10.1.1.200 10.1.1.254
!
ip dhcp excluded-address 10.2.2.1 10.2.2.100
ip dhcp excluded-address 10.2.2.200 10.2.2.254
!
ip dhcp pool Versand
network 10.1.1.0 255.255.255.0
default-router 10.1.1.1
dns-server 9.9.9.9
domain-name versand.home.arpa
!
ip dhcp pool Lager
network 10.2.2.0 255.255.255.0
default-router 10.2.2.1
dns-server 9.9.9.9
domain-name lager.home.arpa
!
interface GigabitEthernet0/0
description Lokales LAN Versand
ip address 10.1.1.1 255.255.255.0
!
interface GigabitEthernet0/1
description Lokales LAN Lager
ip address 10.2.2.1 255.255.255.0
!

Fertisch
Switches klemmst du einfach an die Ports Gig0/0 und Gig0/1 an und gut iss...
Bitte warten ..
Mitglied: AbstrackterSystemimperator
13.08.2019 um 17:44 Uhr
Zitat von aqui:
Fertisch
Switches klemmst du einfach an die Ports Gig0/0 und Gig0/1 an und gut iss...

Ähm...joar.. well... ich bin sprachlos. Mehr fällt mir dazu gerade nicht ein.


Nur für mein Verständnis: Ich klemm die tatsächlich einfach nur an? Es ist das eine und das selbe Projekt. Nur, oben sind die VLANs und unten die ohne VLAN.

Ich merke schon, ich denke viel zu kompliziert....
Bitte warten ..
Mitglied: aqui
13.08.2019, aktualisiert um 17:56 Uhr
ich bin sprachlos. Mehr fällt mir dazu gerade nicht ein.
Netzwerk Helden sind eigentlich nicht sprachlos...!
Ich klemm die tatsächlich einfach nur an?
Ja, kannst sogar die billigsten ungemanagten China Plastik Dödel Switches vom Blödmarkt Grabbeltisch nehmen !
Du hast doch selber gesagt: (Zitat) "Dieses Mal möchte ich nicht mit den VLANs arbeiten, sondern es mal ohne versuchen. "
Dann halte dich auch an deine Vorgaben. Ohne VLANs brauchst du auch keine intelligenten Switches geschweige denn eine Konfig auf diesen ! Solltest du aber mittlerweile doch wissen...?!
Ich merke schon, ich denke viel zu kompliziert....
Jepp, so ist es ! Keep it simple stupid...
Bitte warten ..
Mitglied: AbstrackterSystemimperator
13.08.2019, aktualisiert um 17:56 Uhr
Zitat von aqui:

ich bin sprachlos. Mehr fällt mir dazu gerade nicht ein.
Netzwerk Helden sind eigentlich nicht sprachlos...!

Na doch, gerade wenn es so unkomplenziert einfach geht!


Ich klemm die tatsächlich einfach nur an?
Ja, kannst sogar die billigsten ungemanagten China Plastik Dödel Switches vom Blödmarkt Grabbeltisch nehmen !
Du hast doch selber gesagt: (Zitat) "Dieses Mal möchte ich nicht mit den VLANs arbeiten, sondern es mal ohne versuchen. "
Ohne VLANs brauchst du auch keine intelligenten Switches geschweige denn eine Konfig auf diesen ! Solltest du aber mittlerweile doch wissen...?!

Dann nochmal einen Schritt zurück:

Also, es mir tatsächlich um das eine und selbe Projekt. Einziger Unterschied soll sein, dass das Lager und der Versand nicht im VLAN sind.
Die anderen Netze sollen so bleiben wie sie sind. Also ein VLAN und ein Nichtvlan Netz, daher die Frage, ob ich die so direkt dort anklemmen kann.

Ja, alle "billigen" / "dummen" Switche können gar nichts. Das ist mir klar.
Bitte warten ..
Mitglied: aqui
13.08.2019, aktualisiert um 18:05 Uhr
Also, es mir tatsächlich um das eine und selbe Projekt.
Also das mit den Routern Beer und Heim ??
OK das bleibt dann alles so wie es ist.
Sollen die beiden Netzwerk Segmente beide an einen Router ??
Wenn ja, dann nimmst du 2 freie GiG Interfaces an dem Router und flanscht die Konfig von oben mit dazu.
Dein OSPF Router erkennt die IP Netzadressen automatisch und propagiert sie auch automatisch auf den anderen Router.
Du kannst auch ein Netz am Heim und das andere an den Beer Router legen. Auch das geht...

Ohne VLANs musst du lediglich nur das Kommando "encapsulation dot1Q x" vom Interface weglassen, denn das fügt die VLAN Tags hinzu. Da du diese jetzt ja nicht willst einfach wechlassen und fertig ist der Lack.
Der Rest ist wie gehabt.
Einfacher gehts nicht... Brauchst du noch eine Beispielkonfig ??
Bitte warten ..
Mitglied: AbstrackterSystemimperator
13.08.2019 um 18:16 Uhr
Zitat von aqui:

Also, es mir tatsächlich um das eine und selbe Projekt.
Also das mit den Routern Beer und Heim ??
OK das bleibt dann alles so wie es ist.
Sollen die beiden Netzwerk Segmente beide an einen Router ??

Ich bin "grottenschlecht" in Erklärungen, daher noch mal ein Screenshot vom Abbild im Anhang, wie ich mir das ganze vorstelle.

Ich dachte, ich könnte den Router0 an den Router6 stecken und dann den Router 6 zum Switch von Heim, merke aber gerade selbst, das macht gar kein Sinn und wäre nur dumm...

Mir ist es nur wichtig gewesen, das ich mit dem Netzwerk Versand (192.168.25.0 /24) und dem Netzwerk Lager (172.16.0.0 /16 - wäre hier ein /16er Präfix in Ordnung? Möchte gerne mal eines verwenden).
mit dem Heim / Beer Netzwerk funktionieren.

Hoffentlich ist jetzt einiges "klarer" ^^
netzwerke - Klicke auf das Bild, um es zu vergrößern
Bitte warten ..
Mitglied: aqui
14.08.2019, aktualisiert um 09:45 Uhr
Deine Zeichnungen machen alles nur noch schlimmer und unverständlicher weil sie nicht rein die Infrastruktur zeigen. Endgeräte intereieren einen Netzwerker nicht wirklich wenn es nur um die Darstellung der Netzwerk Segmente geht. Das ursprüngliche Netz mit dem Beer und Heim Router findet man nicht wieder
Das soll ja weiterhin Basis sein, oder ?
Also nochmal... Dort nimmst du dir 2 freie Gig Interfaces und konfigurierst die wie oben...fertig sind deine beiden Versand und Lager Netze !!
und dem Netzwerk Lager (172.16.0.0 /16 - wäre hier ein /16er Präfix in Ordnung?
Ohh, man !!! Noch so ein Ding und du bekommst deinen Helden Status wieder aberkannt !!!
Denk doch mal bitte selber etwas nach was du da fragst !!!
Dein Beer Netzwerk benutzt doch schon ein 172.16.x.y Netzwerk, gesubnettet mit einem /24er Prefix !! Wenn du jetzt das gleiche Netzwerk woanders mit einem /16er Prefix vergibst gibt es Adress Chaos. Logisch, denn beide Netze überschneiden sich doch und damit hast du KEINE einzigartige IP Adressierung mehr die eine saubere Wegefindung im Netzwerk garantiert. Mal ganz davon abgesehen das /16er Prefixe sinnfrei sind denn 65534 Endgeräte kann man niemals praxistauglich in einem flachen, unsegmentierten Layer 2 Netzwerk Segment betreiben.
Fazit:
Hier nimmst du für das Lager Netzwerk auch ein 172.16.x.y Subnetz mit einer /24er Maske z.B. 172.16.200.0 /24 dann passt das doch wieder. Das kannst du auch für den Versand machen mit 172.16.100.0 /24 z.B.
Groschen gefallen ??
IP Adressierung Grundschule, erste Klasse !
Bitte warten ..
Mitglied: AbstrackterSystemimperator
14.08.2019, aktualisiert um 10:48 Uhr
Hallo,

meine andere Frage stelle ich hinten an;

Vielleicht ist die "Übersicht" nun besser. DIe IP-Adressen hatte ich gestern nur zum "Probieren" verwendet.

Die werde ich nach deinem Vorschlag anpassen.

Zu meinem Aufbau:

Das Netzwerk "Lager" hat den IP-Bereich von 192.166.222.0 /24. Die Adressvergabe läuft innerhalb dieses Netzwerkes über einen DHCP-Server. Der Server soll diese Adressen verwalten.

Innerhalb dieses Netzwerkes sollen laut Theorie nur zwei Clients stehen. Eine Erweitung ist im Lager nicht vorgehsehen, da die Arbeit mit zwei Leuten realisierbar ist.

Das Lagernetzwerk ist weiterhin mit einem Router verbunden. Dieser LG-Router (Lager-Router) hat eine Verbindung mit einem weiteren Router, dem Router Versand (VS-Router).

Das Netzwerk "Versand" hat von mir den Adressbreich "192.16.0.0 /24" bekommen. Auch hier steht ein DHCP-Server welcher die Adressen nur für den Versand verwalten möge. Im Versandbereich befinden sich 4xClients, welche bereits die Adressen vom DHCP-Server (Versand) erhalten.

So weit bin ich erst Mal gekommen.

Abschließend möchte ich noch eine Verbindung herstellen, die wie folgt aussieht:

Sowohl Lager, als auch Versand können mit dem Firmennetzwerk kommunizieren. Das private Netzwerk soll ausschließlich mit dem Firmennetzwerk kommunizieren. Höchstens per Mail soll es dem privaten Netzwerk möglich sein, der Versandabteilung eine Mail zu schreiben. Mehr auch nicht.

LG
netzwerke - Klicke auf das Bild, um es zu vergrößern
Bitte warten ..
Mitglied: aqui
14.08.2019, aktualisiert um 11:37 Uhr
Das passt soweit und kann man so machen.
Frage ist nur warum du es so aufwendig machst mit den extra Routern und diese beiden Netze nicht schlicht und einfach mit an die Router "Heim" und/oder "Beer" mit anflanschst.
Oder wllst du damit simulieren das diese beiden Netze nicht lokal sondern irgendwo an abgesetzten Standorten liegen ? Dann wäre das OK.
Allerdings ist ja dann Versand und Lager ja auch immer an einem Standort und dann würde ja ein einzelner, dritter Router reichen an den beide Netze angeschlossen und der dann wieder eine Verbindung zu Heim oder Beer hat. Idealerweise natürlich je einen Link auf beide zur Redundanz !

So sähe das dann ungefähr aus:

tracersimu - Klicke auf das Bild, um es zu vergrößern
Bitte warten ..
Mitglied: erikro
14.08.2019 um 11:12 Uhr
Moin,

Zitat von AbstrackterSystemimperator:
Das Netzwerk "Lager" hat den IP-Bereich von 192.166.222.0 /24. Die Adressvergabe läuft innerhalb dieses Netzwerkes über einen DHCP-Server. Der Server soll diese Adressen verwalten.

Tippfehler? Das soll doch wohl eher 192.168.222.0/24 sein, oder?

Das Lagernetzwerk ist weiterhin mit einem Router verbunden. Dieser LG-Router (Lager-Router) hat eine Verbindung mit einem weiteren Router, dem Router Versand (VS-Router).

Wozu zwei Router, um zwei Netze zu verbinden? Da reicht einer.

Das Netzwerk "Versand" hat von mir den Adressbreich "192.16.0.0 /24" bekommen.

Da fehlt hoffentlich die 8.

Sowohl Lager, als auch Versand können mit dem Firmennetzwerk kommunizieren. Das private Netzwerk soll ausschließlich mit dem Firmennetzwerk kommunizieren. Höchstens per Mail soll es dem privaten Netzwerk möglich sein, der Versandabteilung eine Mail zu schreiben. Mehr auch nicht.

Dann richtest Du in dem einen Router noch zwei weitere Netze ein, zwischen denen Du routest und dann noch den Internetzugang routest. Wer mit wem wohin kommunizieren darf, regelst Du dann mit der Firewall. Sprich, Du musst beim Routerkauf darauf achten, dass der auch so viele Netze bedienen kann.

hth

Erik
Bitte warten ..
Mitglied: AbstrackterSystemimperator
14.08.2019 um 11:17 Uhr
Zitat von aqui:

Oder wllst du damit simulieren das diese beiden Netze nicht lokal sondern irgendwo an abgesetzten Standorten liegen ? Dann wäre das OK.

Richtig, so möchte ich das umsetzen. Eigentlich wollte ich das die Außenstelle, also das entfernte Firmennetzwerk, komplett im europäischen Ausland ist. Ob das realisierbar wäre und ob das der Packet Tracer kann idk.


Allerdings ist ja dann Versand und Lager ja auch immer an einem Standort und dann würde ja ein einzelner, dritter Router reichen an den beide Netze angeaschlossen und der dann wieder eine Verbindung zu Heim oder Beer hat. Idealerweise natürlich je einen Link auf beide zur Redundanz !
´
Stimmt. Ohne Lager, kein Versand. Ohne Versand, kein Lager. Um meine "Vorstellung" perfekt zu machen, werde ich wohl das private Netz nicht mehr als private Netz bezeichnen, sondern als tatsächliches Firmennetz. Wer hat schon daheim eine solche Unterteilung?

ZUsätzlich "baue" ich mir dann ein Heimnetzwerk, welches dann außschließlich mit dem Firmennetz (Privates Netz) und der Außenstelle vom Firmennetzwerk kommuniziert.
Bitte warten ..
Mitglied: AbstrackterSystemimperator
14.08.2019 um 11:21 Uhr
Zitat von erikro:
Sprich, Du musst beim Routerkauf darauf achten, dass der auch so viele Netze bedienen kann.

Erik

Hi Erik,

ich kaufe nichts. Es handelt sich hier um meine "Projektarbeit via Packet Tracer" von der Berufsschule. Ich simuliere hier nur gewisse bzw. versuche hier reale Situation nachzubilden, da die eigentliche Vorbereitung und "Schulung" der Grundlagen "bescheiden" gewesen ist.

Ich habe zusätzlich im Laufe der Zeit gemerkt, dass ich solche Netzwerkkonfigurationen toll / viel Spaß daran empfinde zu basteln und zu probieren.

Mein Arbeitskollege macht solche Konfigs seit X Jahren und er gab mir den Tipp das ich auch mal mehr über den Tellerrand schauen sollte und vorallem sich eigenständig weiterzubilden.

LG
Bitte warten ..
Mitglied: aqui
14.08.2019, aktualisiert um 11:45 Uhr
Richtig, so möchte ich das umsetzen.
Siehe Design von oben !!
Passt das dann so ungefähr wie du dir das vorstellst ? Vorteil: Redundanz im WAN und automatisches Failover mit OSPF.
Wenn du Versand und Lager wirklich noch trennen musst dann hast du eben 4 Router im Core mit OSPF.
Bitte warten ..
Mitglied: AbstrackterSystemimperator
14.08.2019 um 11:44 Uhr
Zitat von aqui:

Richtig, so möchte ich das umsetzen.
Siehe Design von oben !!
Passt das dann so ungefähr wie du dir das vorstellst ?

Bingo! Genau so möchte ich es umsetzen. Nur der Versand ist rechts und das Lager ist links .

Wenn ich das so hinbekomme, bin ich absolut happy und zufrieden!!! )))
Bitte warten ..
Mitglied: aqui
14.08.2019 um 11:48 Uhr
Nur der Versand ist rechts und das Lager ist links
Kosmetisch...!
Wenn ich das so hinbekomme, bin ich absolut happy und zufrieden
Na ja, du weisst ja jetzt wie man das macht !!
  • Versand/Lager Router mit 4 Ports
  • 2 Interfaces gehen als Punkt zu Punkt Links zu je Heim und Beer. Adressierung siehst du oben
  • 2 Interfaces sind jeweils das Versand und Lager Netz. (Ohne Tags wie die oben gepostete Konfig)
  • OSPF aktivieren und P2P Links anpassen
  • Fertisch
Jetzt bist du wieder dran...
Bitte warten ..
Mitglied: AbstrackterSystemimperator
14.08.2019 um 12:01 Uhr
Zitat von aqui:
Jetzt bist du wieder dran...

Der Druck steigt!

Eine technische Verständnisfrage vorab:

Habe ich das tatsächlich richtig verstanden, dieser Aufbau lässt sich mit einem weiterem Router umsetzen? Ich habe jetzt meine zwei weiteren Router entfernt, wodurch ich nur auf 3 Router komme.

Zwischen dem Netzwerk "Versand" und "Lager" befindet sich der Router.
Der Port Fa9/0 ist mit dem Switch vom Versand verbunden.
Der Port Fa7/0 ist mit dem Router "Heim" verbunden.
Der Port Fa6/0 ist mit dem Router "Beer" verbunden
Der Port Fa8/0 ist mit dem Switch vom Lager verbunden.

Ist das so korrekt?
Bitte warten ..
Mitglied: aqui
LÖSUNG 14.08.2019, aktualisiert um 13:49 Uhr
Habe ich das tatsächlich richtig verstanden, dieser Aufbau lässt sich mit einem weiterem Router umsetzen?
Er lässt sich auch mit 2 weiteren Routern machen oder ganz OHNE weiteren Router.
Da du ja aber vorgegeben hast deine neue Infrastruktur Lager/Versand ist an einen gemeinsamen anderen Standort kann man das dann so machen wie oben in der L3 Skizze zu sehen ist !
Ein Bild sagt mehr als 1000 Worte !!!
Ich habe jetzt meine zwei weiteren Router entfernt, wodurch ich nur auf 3 Router komme.
Ähhh ja...! Wenn ich auf die obige L3 Skizze sehe zähle ich...eins...zwei...drei Router ! Passt also !
Wo ist jetzt dein Problem ??
Zwischen dem Netzwerk "Versand" und "Lager" befindet sich der Router.
Nöö, da hatten wir uns doch geeinigt das wir das mit einem machen, da Versand und Lager ja doch immer an einem Standort sind, oder ? Wenn du willst ghets aber auch mit 4 Routern ?!?
Ist das so korrekt?
Jau ! Bezogen auf die o.a. Skizze absolut korrekt !
Und hier ist die Konfig dazu, nicht das das wieder schief geht mit dir...:
!
ip dhcp binding cleanup interval 600
ip dhcp excluded-address 172.16.0.1 172.16.0.100
ip dhcp excluded-address 172.16.0.200 172.16.0.254
!
ip dhcp excluded-address 172.16.1.1 172.16.1.100
ip dhcp excluded-address 172.16.1.200 172.16.1.254
!
ip dhcp pool Versand
network 172.16.0.0 255.255.255.0
default-router 172.16.0.1
dns-server 9.9.9.9
domain-name versand.home.arpa
!
ip dhcp pool Lager
network 172.16.1.0 255.255.255.0
default-router 172.16.1.0
dns-server 9.9.9.9
domain-name lager.home.arpa
!
interface FastEthernet6/0
description Link zum Beer Router
ip address 10.0.0.10 255.255.255.252
!
interface FastEthernet7/0
description Link zum Heim Router
ip address 10.0.0.6 255.255.255.252
!
interface FastEthernet8/0
description Lokales LAN Lager
ip address 172.16.1.1 255.255.255.0
!
interface FastEthernet7/0
description Lokales LAN Versand
ip address 172.16.0.1 255.255.255.0
!
router ospf 1
log-adjacency-changes
passive-interface default
no passive-interface FastEthernet6/0
no passive-interface FastbitEthernet7/0
auto-cost reference-bandwidth 10000
network 0.0.0.0 255.255.255.255 area 0
!

Fertsch...
Denk dran am Beer und Heim Router noch ein Interface für den P2P Link freizuschaufeln.
Sieht dann so aus:
!
interface GigabitEthernet x/0
description Link zum Versand/Lager Router
ip address 10.0.0.5 255.255.255.0
!
router ospf 1
log-adjacency-changes
passive-interface default
no passive-interface GigabitEthernet0/0
no passive-interface GigabitEthernet x/0
<== kommt dazu !
auto-cost reference-bandwidth 10000
network 0.0.0.0 255.255.255.255 area 0
!

Analog auf dem anderen.
Bitte warten ..
Mitglied: AbstrackterSystemimperator
14.08.2019, aktualisiert um 13:12 Uhr
Zitat von aqui:

Habe ich das tatsächlich richtig verstanden, dieser Aufbau lässt sich mit einem weiterem Router umsetzen?
Er lässt sich auch mit 2 weiteren Routern machen oder ganz OHNE weiteren Router.

Ich habe mich nur auf die Skizze bezogen. Ja, das Lager und der Versand sind an einem gleichem Standort. 1.OG Versand & im Keller ist z.B. das Lager.

Danke für die Konfiguration. Da werde ich mir die gängigsten Befehle unbedingt mal aufschreiben.

Und ja, es wäre tatsächlich etwas schiefgelaufen, da ich nur ein paar Befehle von solchen Konfigs im Kopp habe.

kurze technische Verständnisfrage:

interface FastEthernet6/0
description Link zum Beer Router
ip address 10.0.0.10 255.255.255.252

&

interface FastEthernet7/0
description Link zum Heim Router
ip address 10.0.0.6 255.255.255.0

weshalb gebe ich am Port 7/0 die Subnetzmaske 255.255.255.0 an und nicht 252?
versandlager - Klicke auf das Bild, um es zu vergrößern
Bitte warten ..
Mitglied: aqui
14.08.2019, aktualisiert um 13:25 Uhr
Jupp, jetzt stimmt die Zeichnung.
ich nur ein paar Befehle von solchen Konfigs im Kopp habe.
Und das nach der Orgie mit dem VLAN Post ?! Da sollte sich dir das doch in den peicher eingemeißelt haben. Du siehst ja das es immer und immer wieder die gleichen 6-7 Kommandos sind aus denen sowas besteht ! Die sollte man sich doch merken können, oder ?
Bitte warten ..
Mitglied: AbstrackterSystemimperator
14.08.2019, aktualisiert um 13:41 Uhr
Zitat von aqui:

Denk dran am Beer und Heim Router noch ein Interface für den P2P Link freizuschaufeln.
Sieht dann so aus:
!
interface GigabitEthernet x/0
description Link zum Versand/Lager Router
ip address 10.0.0.5 255.255.255.0
!
router ospf 1
log-adjacency-changes
passive-interface default
no passive-interface GigabitEthernet0/0
no passive-interface GigabitEthernet x/0
<== kommt dazu !
auto-cost reference-bandwidth 10000
network 0.0.0.0 255.255.255.255 area 0
!

Analog auf dem anderen.

P2P = Peer to Peer oder Point to Point? (PPP) Letztes kenne ich so noch gar nicht.

Si,
auf dem Interface vom Heim habe ich den Port "Fa6/0" gewählt, da dieser noch frei war.

"HEIM(config-if)#description Link zum Versand/Lager Router
HEIM(config-if)#ip address 10.0.0.5 255.255.255.0
% 10.0.0.0 overlaps with GigabitEthernet0/0"

Ich speicher meine Arbeit als Backup mal, um selbst nachzudenken wo der Fehler ist.

Zitat von aqui:

Jupp, jetzt stimmt die Zeichnung.
ich nur ein paar Befehle von solchen Konfigs im Kopp habe.
Und das nach der Orgie mit dem VLAN Post ?! Da sollte sich dir das doch in den peicher eingemeißelt haben. Du siehst ja das es immer und immer wieder die gleichen 6-7 Kommandos sind aus denen sowas besteht ! Die sollte man sich doch merken können, oder ?

Hast recht. Es wiederholt sich tatsächlich alles wieder und wieder. Wenn sich das Rad so gut wie nie neu erfindet, sollte ich auch das hinbekommen. Ich vermute, je mehr ich damit arbeite, desto fixer werde ich die Befehle merken können. Quasi als wenn ich Vokabeln lernen würde.

LG

Edit:
Wenn das ganze Konstrukt läuft, wollte ich nicht ständig die IP-Adresse der jeweiligen Geräte eintragen, sondern das ganze über DNS laufen lassen.

Da wollte ich nur mal in Erfahrung bringen was besser ist:
Einen DHCP - Server und einen DNS - Server oder ein DHCP&DNS Server?
Bitte warten ..
Mitglied: aqui
14.08.2019, aktualisiert um 13:52 Uhr
P2P = Peer to Peer
Sorry, nein das soll "Peer to Peer" heissen. Klar, denn dort werkeln ja /30 er IP Netze die haben immer nur 2 IP Interface Adressen. Deshalb Punkt zu Punkt oder "Peer to Peer" auf neudeutsch.
% 10.0.0.0 overlaps with GigabitEthernet0/0"
Ohh man, geht das schon wieder los !!!
FALSCHE Subnetzmaske !!!
Wenn man dir schon eine fertige Konfig postest solltet du sie auch mal ansehen....
Bitte warten ..
Mitglied: AbstrackterSystemimperator
14.08.2019 um 14:01 Uhr
Zitat von aqui:
Ohh man, geht das schon wieder los !!!
FALSCHE Subnetzmaske !!!
Wenn man dir schon eine fertige Konfig postest solltet du sie auch mal ansehen....

Merci. Jetzt habe ich es endlich begriffen. Tu mir einen Gefallen. Wenn ich wieder solche dummen Frage stelle.. reagier nicht drauf... da war ich einfach nur dumm...
Bitte warten ..
Mitglied: AbstrackterSystemimperator
14.08.2019 um 14:10 Uhr
Zum Abschluss;

Ihr seid die Besten! Herzlichen Dank für die Unterstützung bei der Durchführung meines "kleines" Projektes. Hat mir viel Spaß gemacht daran zu arbeiten.

Jetzt schau ich mal was ich hier und da noch verbessern kann. Z.B. die Kommunikation via Mail und oder das nicht jeder Teilnehmer, Zugriff auf alles hat oder oder... da sind rein von der Theorie her, vieles möglich.

Und danke auch für die ehrlichen Rückmeldung!
Bitte warten ..
Mitglied: aqui
14.08.2019, aktualisiert um 14:49 Uhr
oder das nicht jeder Teilnehmer, Zugriff auf alles hat
Hier sind Access Listen dann dein bester Freund !

Damit du mal was zu spielen damit hast:
!
interface GigabitEthernet9/0.100
description Privates Netz
encapsulation dot1Q 100
ip address 192.168.10.1 255.255.255.0
!
interface GigabitEthernet9/0.200
description Netz Administration
encapsulation dot1Q 200
ip address 192.168.20.1 255.255.255.0
ip access-group kein-privat in
!
interface GigabitEthernet9/0.300
description Netz Verwaltung
encapsulation dot1Q 300
ip address 192.168.30.1 255.255.255.0
!
ip access-list extended kein-privat
deny ip 192.168.20.0 0.0.0.255 192.168.10.0 0.0.0.255
permit ip 192.168.20.0 0.0.0.255 any

!

Das bewirkt das aus dem "Administrations" Netz keiner mehr auf das Private Netz kommt am Heim Router
Viel Spaß beim Testen !
Bitte warten ..
Mitglied: AbstrackterSystemimperator
14.08.2019, aktualisiert um 15:21 Uhr
Ich habe doch noch die eine oder andere Frage zum weiteren Vorgehen:

Mich juckt es in den Fingern mein Netzwerk soweit zum Laufen zu bringen, so dass die Netze untereinander per Mail kommunizieren können. Als nice to have wäre es super, wenn ich die DNS Auflösung konfiguriert bekomme. Ich möchte nämlich nicht ständig die IP-Adresse bei einem Ping, angeben. Aktuell ist es soweit möglich, dass ich per Ping + IP Adresse der jeweiligen Clients, eine Rückmeldung bekomme. Wenn ich z.B. Ping Richter oder PC-Richter eintrage, klappt dieses nicht. Ist mir auch klar warum. Die Namensauflösung ist noch nicht konfiguriert.

Die Konfiguration möchte ich als erstes beim privaten Netzwerk durchführen und nach erfolgreicher Konfiguration auf die anderen Netze übertragen.

Wie könnte ich diese Umsetzung am Besten realisieren? Hier habe ich bereits einen DNS&DHCP - Server, sowie einen eigenständigen Web&Mailserver. Sollte ich, in den jeweiligen anderen Netzen, auch einen DNS&DHCP und Web&Mailserver einrichten oder wäre es auch kein Problem, den Mailverkehr über den Web&Mailserver und DNS&DHCP Server vom "privaten Netzwerk" zu nutzen?

Ich stell mir gerade dazu folgende Situation vor:

Das private Netzwerk ist kein privates Netzwerk, sondern eine Firma "Beer and Vino GmbH" in bespw. NRW. Mein "entferntes Netzwerk" ist die Außenstelle von der Firma im Standort Niedersachsen. In Niedersachsen befindet sich ebenso das Lager und der Versand. Nur ein paar Orte weiter.

Bei der Außenstelle ist ebenso ein DHCP&DNS Server vorhanden und ein Server für den Mailverkehr. Nur die Abteilung Versand und Lager, hat einen DHCP-Server.

So viel dazu.

Ich habe im privaten Netzwerk, bevor ich das ganze Konstrukt erweitert hatte, bereits den Mailverkehr eingerichtet und beim DNS Server die jeweiligen Geräte hinzugefügt. Wenn ich jetzt eine Mail verschicke, wird immer der DNS-Server "9.9.9.9" genutzt, anstatt die IP vom DNS Server. Ist mir auch klar, da ich die "9.9.9.9" bei der Konfig eingetragen habe.

Wenn ich bei den jeweiligen Clients den DNS-Server ändere, kann ich jeweils nur die Zeile ändern oder muss ich die gesamte Konfig eintragen?

Denn der DNS - Server befindet sich um VLAN 100 und die Geräte im VLAN 200 und 300., falls das etwas ausmacht.

LG
Bitte warten ..
Mitglied: aqui
15.08.2019, aktualisiert um 10:52 Uhr
so dass die Netze untereinander per Mail kommunizieren können.
Aber das können sie doch !
Dein Routing ist doch voll transparent und damit klappt das. Du hängst in irgendeins der IP Segmente einen Mail Server z.B. einen Raspberry Pi:
https://www.heise.de/ct/ausgabe/2013-17-Raspberry-Pi-als-privater-LAMP-u ...
Und in irgend ein anderes deiner Netzwerke packst du den Client. Thunderbird, Outlook, egal was.
Und schon kannst du mailen bis der Arzt kommt.
Wo bitte ist denn da jetzt dein Problem ???
Wenn ich z.B. Ping Richter oder PC-Richter eintrage, klappt dieses nicht.
Das ist auch klar, denn dazu muss dein Cisco Switch oder Router ja auch den Namen "Richter" auflösen können und dazu braucht er einen DNS Server.
Was geht ist das du das auf jeder Komponente statisch einträgst mit: ip host Richter 192.168.10.10
Dann kannst du auch ping Richter auf dem Cisco machen, denn so weiss er ja nun das sich hinter dem Hostnamen Richter die IP Adresse 192.168.10.10 befindet.
Wenn du aber nun 10 Komponenten im netz hast wird das lästig, denn dann musst du das auf jedem einzend eintragen. Und wenn sich was ändert auf allen 10 wieder ändern... Nicht besonders effektiv.
Sinnvoller ist dann einen zentralen DNS Server zu nutzen und mit ip name-server a.b.c.d ihm die IP des zentralen DNS beizubringen. Dann fragt der Cisco bei Namen immer den DNS Server.
Z.B. kannst du das oben mit zusätzlich auf deinem kleinen Raspberry Pi installieren:
https://www.heise.de/select/ct/2017/21/1507502426899459
https://www.ionos.de/digitalguide/server/konfiguration/so-machen-sie-aus ...
Oder gleich supertoll noch mit Trojaner, Malware und Werbefilter:
https://administrator.de/wissen/raspberry-pi-zero-w-pi-hole-adblocker-45 ...
Der RasPi kann ganz nebenbei natürlich auch noch Dzentraler DHCP Server sein für ALLE deine Netze. Damit entfällt dann auch das lästige Konfigurieren der DHCP Server auf den Ciscos und du kannst endlich mit den Helper Adressen arbeiten !!! Guckst du hier:
https://administrator.de/wissen/netzwerk-management-server-raspberry-pi- ...

So, nun hast du was zu basteln...!!!
Ein 20 Euro Raspberry Zero WLAN reicht allemal dafür:
https://buyzero.de/collections/boards-kits/products/neu-pi-zero-w-essent ...
Bitte warten ..
Mitglied: AbstrackterSystemimperator
15.08.2019 um 12:01 Uhr
Zitat von aqui:

so dass die Netze untereinander per Mail kommunizieren können.
Aber das können sie doch !

Hi, danke für die ausführliche Erklärungen . Da ich mich immer noch nur in der Theorie befinde und mich auf mein Cisco Packet Tracer "Heim-Beer - Netzwerk" beziehe, können sie es noch nicht, aber auch dafür habe ich nach langen google.de endlich eine Lösung gefunden

Sinnvoller ist dann einen zentralen DNS Server zu nutzen und mit ip name-server a.b.c.d ihm die IP des zentralen DNS beizubringen. Dann fragt der Cisco bei Namen immer den DNS Server.

Genau, so werde ich es umsetzen. Dann konfiguriere ich den DNS - Server so.

Z.B. kannst du das oben mit zusätzlich auf deinem kleinen Raspberry Pi installieren:
https://www.heise.de/select/ct/2017/21/1507502426899459
So, nun hast du was zu basteln...!!!
Ein 20 Euro Raspberry Zero WLAN reicht allemal dafür:
https://buyzero.de/collections/boards-kits/products/neu-pi-zero-w-essent ...

So eine kleine Anschaffung ist die Überlegung allemal wert. Wusste gar nicht, da ich mich mit einem PI auch nie beschäftigt habe, was ein solches kleines Gerät alles kann.

LG
Bitte warten ..
Mitglied: patrickebert
15.08.2019 um 14:45 Uhr
Zitat von AbstrackterSystemimperator:

Zitat von aqui:
Sinnvoller ist dann einen zentralen DNS Server zu nutzen und mit ip name-server a.b.c.d ihm die IP des zentralen DNS beizubringen. Dann fragt der Cisco bei Namen immer den DNS Server.

Genau, so werde ich es umsetzen. Dann konfiguriere ich den DNS - Server so.

Warum so kompliziert?
Sinnvoller ist dann einen zentralen DNS Server zu nutzen und im DHCP Pool statt 9.9.9.9 den zentralen DNS Server zu nutzen..
So hättest du auch eine Namensauflösung bei den Endgeräten...
Der IP name-server muss jedoch trotzdem auf den Switchen konfiguriert werden, da du sonst keine Auflösung auf den Switchen hättest.

LG
Patrick
Bitte warten ..
Mitglied: AbstrackterSystemimperator
15.08.2019, aktualisiert um 16:10 Uhr
Edit: Ich werde mich hier mal weiter eigenständig belesen. Habe die eine oder andere Fehlerquelle ausfindig machen können.


LG
Bitte warten ..
Mitglied: aqui
15.08.2019, aktualisiert um 17:17 Uhr
Dank an das Feedback vom Kollegen @patrickebert Es ist richtig das du dann ip name-server a.b.c.d auf die DNS Server IP in deinem Netz setzen musst die dann a.b.c.d lautet.
Mit so einem Server können dann die DHCP Konfigs von den Routern logischerweise verschwinden.
So eine kleine Anschaffung ist die Überlegung allemal wert.
Dann macht das Basteln noch mehr Spaß. Zumal du den RasPi auch zum Cisco Router mit Cisco Syntax machen kannst:
https://administrator.de/wissen/netzwerk-management-server-raspberry-pi- ...
DNS und zentralen DHCP Server und auch Mail kann er ja so oder so noch nebenbei.
da ich mich mit einem PI auch nie beschäftigt habe, was ein solches kleines Gerät alles kann.
Ein fataler Fehler wie du siehst !!
Bitte warten ..
Mitglied: AbstrackterSystemimperator
16.08.2019 um 12:54 Uhr
Zitat von patrickebert:

Zitat von AbstrackterSystemimperator:

Zitat von aqui:
Sinnvoller ist dann einen zentralen DNS Server zu nutzen und mit ip name-server a.b.c.d ihm die IP des zentralen DNS beizubringen. Dann fragt der Cisco bei Namen immer den DNS Server.

Genau, so werde ich es umsetzen. Dann konfiguriere ich den DNS - Server so.

Warum so kompliziert?
Sinnvoller ist dann einen zentralen DNS Server zu nutzen und im DHCP Pool statt 9.9.9.9 den zentralen DNS Server zu nutzen..
So hättest du auch eine Namensauflösung bei den Endgeräten...
Der IP name-server muss jedoch trotzdem auf den Switchen konfiguriert werden, da du sonst keine Auflösung auf den Switchen hättest.

LG
Patrick


Hallo,
nach weiteren Recherchen, welche leider ohne Erfolg gewesen waren, frage ich euch noch mal im Rat.

Also;
Mein DHCP - Pool im VLAN 300 - Verwaltung habe ich den DNS-Server auf die "192.168.10.1" gesetzt, da dieser Server im VLAN 100 ist.
Auf dem Switch habe ich per "ip name-server" die "192.168.10.1" eingetragen.

Auf dem DNS - Server habe ich im Packet Tracer den DNS - Service eingeschaltet. Wenn ich dort A-Records mit der jetzigen IP der Clients eintrage, funktioniert es soweit, aber da ich auf dem Server ebenso DHCP nutze, komme ich hier nicht weiter.

Im Netz finde ich auch nur Anleitungen für einen DNS und einem DHCP - Server, jedoch keine passende für DNS&DHCP im einem Gerät.

Oder eine solche, wo der Router für DNS eingerichtet wird.

LG
Bitte warten ..
Mitglied: aqui
16.08.2019, aktualisiert um 13:24 Uhr
habe ich den DNS-Server auf die "192.168.10.1" gesetzt
Richtig !
Auf dem Switch habe ich per "ip name-server" die "192.168.10.1" eingetragen.
Auch richtig !
Auf dem DNS - Server habe ich im Packet Tracer den DNS - Service eingeschaltet.
Bahnhof ? Ägypten ?
Das ist nicht ganz klar was du damit meinst.
Switch und auch alle Clients erwarten jetzt das hinter der IP Adresse 192.168.10.1 ein aktiver Name Server werkelt, der ihre angefragten Namen auflösen kann. Da MUSS also was hinter sein was DNS kann und...was eine Weiterleitung auf einem Internet Router hat um außer internen DNS Namen auch externe Namen aus dem Internet auflösen kann.
Auf einem Client kannst du z.B. mit nslookup www.heise.de dediziert diesen Name Server dann fragen und sehen ob er das auflöst.
Erstmal ggf. nur mit internen Namen. Ein nslookup Richter sollte dann also die IP des Richter PC zurückliefern. Dann ist alles sauber, was es bei dir scheinbar ja auch ist. Also alles richtig gemacht bis dahin....

Um DHCP Adressen auf dynmaische Namen zu mappen oder umgekehrt musst du DNS und DHCP verheiraten. Das sind immer 2 unterschiedliche Prozesse.
Wie man das mit einem Raspberry macht wird z.B. hier erklärt:
https://www.admin-magazin.de/Online-Artikel/Automatische-DNS-Updates-per ...
https://wiki.debian.org/DDNS
Heisst in der Regel DDNS. Hast du vermutlich an der falschen Stelle gesucht.
Bitte warten ..
Mitglied: AbstrackterSystemimperator
16.08.2019 um 13:55 Uhr
Zitat von aqui:
Bahnhof ? Ägypten ?
Das ist nicht ganz klar was du damit meinst.
Switch und auch alle Clients erwarten jetzt das hinter der IP Adresse 192.168.10.1 ein aktiver Name Server werkelt, der ihre angefragten Namen auflösen kann. Da MUSS also was hinter sein was DNS kann und...was eine Weiterleitung auf einem Internet Router hat um außer internen DNS Namen auch externe Namen aus dem Internet auflösen kann.
Auf einem Client kannst du z.B. mit nslookup www.heise.de dediziert diesen Name Server dann fragen und sehen ob er das auflöst.
Erstmal ggf. nur mit internen Namen. Ein nslookup Richter sollte dann also die IP des Richter PC zurückliefern. Dann ist alles sauber, was es bei dir scheinbar ja auch ist. Also alles richtig gemacht bis dahin....

Bilder sagen mehr als 1000 Worte. Oder kann das der Packet Tracer ansich gar nicht umsetzen, wie ich es mir vorstelle?
Nicht das es daran scheitert.

Beim DNS-Server muss ich noch etwas eintragen oder nicht? Ich die Eintragungen nur gemacht, da diese bei einem YT - Video gemacht wurden, wo es geklappt hatte. "Try and Error". Bei mir hat es kein Erfolg gebracht. Habe die Eintragung nur vergessen rauszunehmen.

Bei Richter-PC erhalte ich:
PC>nslookup richter

Server: [192.168.10.1]
Address: 192.168.10.1
DNS request timed out.
timeout was 15000 milli seconds.
DNS request timed out.
timeout was 15000 milli seconds.
DNS request timed out.
timeout was 15000 milli seconds.
* Request to 192.168.10.1 timed-out

Am DNS - Server gar nicht:

SERVER>nslookup richter

Server: [192.168.10.1]
Address: 192.168.10.1
* UnKnown can't find richter: Non-existent domain.

Um DHCP Adressen auf dynmaische Namen zu mappen oder umgekehrt musst du DNS und DHCP verheiraten. Das sind immer 2 unterschiedliche Prozesse.
Wie man das mit einem Raspberry macht wird z.B. hier erklärt:
https://www.admin-magazin.de/Online-Artikel/Automatische-DNS-Updates-per ...
https://wiki.debian.org/DDNS
Heisst in der Regel DDNS. Hast du vermutlich an der falschen Stelle gesucht.

Ah, ja. Dynamic DNS also.. ist mir auch Begriff

LG
dns - Klicke auf das Bild, um es zu vergrößern
netzwerk-heim - Klicke auf das Bild, um es zu vergrößern
nslookup-richter - Klicke auf das Bild, um es zu vergrößern
serverns - Klicke auf das Bild, um es zu vergrößern
Bitte warten ..
Mitglied: AbstrackterSystemimperator
16.08.2019 um 14:40 Uhr
Edit:

ich habe mich gerade umentschieden: Ich lasse den Packet Tracer, Packet Tracer sein, beschäftige mich nun mit GNS3.

Habe es mir gerade mal heruntergeladen und wollte es zum Laufen bringen.

Brauche ich tatsächlich
Dynamips
Cpulimit
Npcap

für das Programm?

LG
Bitte warten ..
Mitglied: aqui
16.08.2019 um 17:34 Uhr
Oder kann das der Packet Tracer ansich gar nicht umsetzen, wie ich es mir vorstelle?
Ich kenne den Packet Tracer nicht, aber wenn der einen kompletten DNS Server emulieren kann dann sollte das gehen.
Beim DNS-Server muss ich noch etwas eintragen oder nicht?
Oha ja ! Sieh dir hier die Konfig Dateien an was da einzutragen ist:
http://www.raspberry-pi-geek.de/Magazin/2014/03/RasPi-als-DHCP-und-DNS- ...
Windows
https://www.tech-faq.net/dns-server-einrichten/
Brauche ich tatsächlich....
Welches Betriebsystem ?
Bitte warten ..
Mitglied: patrickebert
16.08.2019, aktualisiert um 20:27 Uhr
Zitat von AbstrackterSystemimperator:
Bei Richter-PC erhalte ich:
PC>nslookup richter

Server: [192.168.10.1]
Address: 192.168.10.1
DNS request timed out.
timeout was 15000 milli seconds.
DNS request timed out.
timeout was 15000 milli seconds.
DNS request timed out.
timeout was 15000 milli seconds.
* Request to 192.168.10.1 timed-out

Am DNS - Server gar nicht:

SERVER>nslookup richter

Server: [192.168.10.1]
Address: 192.168.10.1
* UnKnown can't find richter: Non-existent domain.
Ah, ja. Dynamic DNS also.. ist mir auch Begriff

LG


Wie soll das auch funktionieren?
Du musst schon noch auf dem DNS Server unter Name "richter" eingeben, Type "A Record" undxunter Adresse musst du die IP von PC Richter eingeben.
Du hast hier nur den HOST A Eintrag für DNS und DHCP eingegeben, die du nicht brauchst. Du kannst aber mal probieren, ob diese funktionieren.
Wenn du jetzt "nslookup dns" oder "nslookup DHCP" löst er dir die Adresse 192.168.10.1 auf.
Bitte warten ..
Mitglied: AbstrackterSystemimperator
17.08.2019 um 11:29 Uhr
Zitat von patrickebert:
Wie soll das auch funktionieren?
Du musst schon noch auf dem DNS Server unter Name "richter" eingeben, Type "A Record" undxunter Adresse musst du die IP von PC Richter eingeben.
Du hast hier nur den HOST A Eintrag für DNS und DHCP eingegeben, die du nicht brauchst. Du kannst aber mal probieren, ob diese funktionieren.
Wenn du jetzt "nslookup dns" oder "nslookup DHCP" löst er dir die Adresse 192.168.10.1 auf.

Hi,
sorry für die "blöde" zwischenfrage: Ja, wenn ich die IP Adresse 192.168.30.150 eintrage, klappt es auch. Und bei 192.168.30.151 kann ich mit "Ping Dennis" auch den PC anpingen. Aber dann habe ich doch statische IP-Adressen oder? Da ich doch DHCP nutze, können sich die Adressen jederzeit ändern, oder habe ich hier den Denkfehler?

LG
Bitte warten ..
Mitglied: aqui
17.08.2019 um 11:37 Uhr
Aber dann habe ich doch statische IP-Adressen oder?
Nein !
Jedenfalls nicht wenn der pingende Rechner erst den zentralen DNS Server nach der IP von "Dennis" oder "Richter" per DNS fragen muss.
Statische IPs bzw. Namen hast du nur wenn du den Namen auch statisch in der Hosts Datei einträgst wie es z.B. hier beschrieben ist:
http://www.administrator.de/index.php?content=104978#396040
Bitte warten ..
Mitglied: AbstrackterSystemimperator
17.08.2019 um 11:57 Uhr
Zitat von aqui:
Brauche ich tatsächlich....
Welches Betriebsystem ?

Pardon, übersehen. Windows 8.1 / Windows 10. Wollte mich tatsächlich mit GNS beschäftigen, da es doch 1:1 identisch mit der Hardware von Cisco ist.

Sind die Befehle eigentlich so gut wie identisch? Bisher bin ich nur mit Aruba in Kontakt gekommen.

Zitat von aqui:

Aber dann habe ich doch statische IP-Adressen oder?
Nein !
Jedenfalls nicht wenn der pingende Rechner erst den zentralen DNS Server nach der IP von "Dennis" oder "Richter" per DNS fragen muss.
Statische IPs bzw. Namen hast du nur wenn du den Namen auch statisch in der Hosts Datei einträgst wie es z.B. hier beschrieben ist:
http://www.administrator.de/index.php?content=104978#396040

Stark. Per NSlookup funktioniert es! Besten dank!
Bitte warten ..
Mitglied: aqui
17.08.2019 um 12:36 Uhr
Sind die Befehle eigentlich so gut wie identisch?
Was ist zu wem identisch ??? HP Syntax zu Cisco IOS ?! Ja, zu 98%. Ruckus Switches nutzen es ebenfalls.
Stark. Per NSlookup funktioniert es! Besten dank!
Dann hast du auch alles richtig gemacht !! 👍
Bitte warten ..
Mitglied: AbstrackterSystemimperator
17.08.2019 um 17:21 Uhr
Hi,

bevor ich mit dem Projekt "Packet Tracer - Netzwerk" abschließe habe ich nur zu den jeweiligen Befehlen die eine oder andere Verständnisfrage.

Ich bin die fertige Konfigurationen mehrmals durchgegangen, wobei mir aufgefallen ist, dass ich tatsächlich den roten Pfaden nachvollziehen kann. Die Befehle sind mir soweit klar und auch warum ich diese Befehle benötige, verstehe ich. Eigentlich habe ich, wie bereits gesagt gehabt, viel zu viel eigenständig weitergemacht. Wobei, in der Berufssschule wäre mir dieser Umfang nie wirklich verständlich beigebracht geworden. Merke ich vorallem daran, das ich IP-Helper Adressen benutzt habe, die eigentlich gar kein Sinn ergeben oder das leidige Thema "Klasse...".

Jedenfalls, ein paar Befehle innerhalb der Konfigs sind mir noch nicht 100%ig geläufig bzw. ich verstehe diese noch nicht richtig.

encapsulation dot1Q

Habe ich es richtig verstanden, wenn ich VLANs einrichte, brauche ich diesen Befehl, da die Pakete von "untagged" zu "tagged" gewandelt werden? Falls ja, würde ich daraus schließen, dass ein Router im VLAN Port (Kann man das so sagen?) nur getagged Pakete empfangen kann und ungetaggte verwirft?

router ospf 1
(1) log-adjacency-changes
(2) auto-cost reference-bandwidth 10000

(1) "Use the log-adjacency-changes command to display high-level changes to the state of the OSPF neighbor relationship. This command is on by default but only reports the up/down (full/down) events if you do not use the detail keyword."
"To configure the router to send a syslog message when the state of an Open Shortest Path First (OSPF) neighbor changes, use the log-adjacency-changes command."

Sagt mir dieser Befehl aus, dass ich dadurch der Status von einem meiner OSPF - Router ändert, ich eine Nachricht erhalte? Bzw. nur darüber informiert werde, ob "Up/down"?

(2)Auto-cost Reference Bandwidth is the command used to modify the OSPF metric

Auto-cost reference bandwidth is used to modify the OSPF metric
The OSPF metric is cost

Metriken entsprechen der Kritikerien.
Die Bewertung der Route erfolgt über die Metrik der Route. Bei den Routingprotokollen geht es immer um die Metriken. Je geringer die Metrik einer Router ist, umso besser ist die Route.

Wäre das so richtig?


ip classless

When Cisco routers have to forward packets, they will check their routing table and they use longest prefix matching to find the best match. If you don’t have a best match then the router will use a default route (if you have one). Otherwise, the packet will be dropped.

Die Erklärung dazu sagt mir leider gar nichts. Ich kann mit prefix matching to find the best match, nichts anfangen...

Wiederum verstehe ich diese Erklärung eher

Classless Routing is performed by protocols that send subnet mask information in the routing updates. Classless routing allows VLSM (Variable Length Subnet Masking) E.g.: RIP V2, EIGRP, & OSPF.

D.h diese Erklärung dürfte dazu passen oder?

Also Classful war die "alte" Einteilung der IP-Ranges.
Class A = 0.0.0.0 bis 127.255.255.255 (=binär alles was mit 0... beginnt)
Class B = 128.0.0.0 bis 191.255.255.255 (=binär alles was mit 10... beginnt)
Class C = 192.0.0.0 bis 223.255.255.255 (=binär alles was mit 110... beginnt)
usw.

Wenn ein Router in Classes "denkt" dann ist für ihn die Subnetmask irrelevant weil er für jede IP die standard Subnetmask verwendet.
Class A = 255.0.0.0
Class B = 255.255.0.0
Class C = 255.255.255.0

Mit "ip classless" sagt man ihm, dass er auf dieses alte "klassen-denken" verzichten soll. Das hat früher vielleicht mal Sinn gemacht aber heute routet man eben nicht alles in diesen teilweisen riesen Subnets sondern verwendet VLSM (Variable Length Subnet Mask)


passive-interface default
no passive-interface GigabitEthernet0/0

So wie ich das verstehe wird der Port am gig0/0 keine Routing-Updates erhalten. Wenn es sich dabei um OSPF handelt?

Ganz im Gegensatz zu RIP - dort werden nämlich auch auf einem passive-interface Routing-Updates angenommen, nur keine rausgesendet. Für alle Protokolle gilt aber: die Netze, die in den Routing-Prozess aufgenommen werden, bleiben von "passive-interface" völlig unbeeinflusst.

Wäre das soweit richtig oder eher nicht?

LG
Bitte warten ..
Mitglied: aqui
LÖSUNG 18.08.2019, aktualisiert um 12:00 Uhr
encapsulation dot1Q
Ja, das hast du zu 99% richtig verstanden. Genau das macht der Befehl.
Allerding akzeptiert er auch ungetaggte Pakete, denn die werden immer über das physische Interface geroutet ! Also so:
!
interface GigabitEthernet1/0
description Untagged Pakete (physischer Port)
ip address 192.168.0.1 255.255.255.0
!
interface GigabitEthernet1/0.10
description Tagged VLAN 10 (Subinterface)
encapsulation dot1Q 10
ip address 192.168.10.1 255.255.255.0
!
interface GigabitEthernet1/0.20
description Tagged VLAN 20 (Subinterface)
encapsulation dot1Q 20
ip address 192.168.20.1 255.255.255.0
!

Siehe auch dies Tutorial: https://administrator.de/wissen/vlan-installation-routing-pfsense-mikrot ...
router ospf 1
Schaltet das OSPF Routing Protokoll global ein. Die "1" ist eine Idex Nummer. Man kann mehrere OSPF Instanzen auf einem Router laufen lassen z.B. bei der Verwendung von VRFs.
log-adjacency-changes
Loggt im Router Log mit wenn es Veränderungen bei den OSPF Nachbarn gibt (Überwachung)
auto-cost reference-bandwidth 10000
Setzt die automaische Metric bei OSPF neu. Ohne das wäre de Metric bei 1 Gig, 10Gig usw. also allen schnelleren Interfaces als 1Gig die Metric gleich und OSPF könnte dann nicht mehr zwischen ihnen und dem besten und schnellsten Pfad unterscheiden würde man es nicht setzen.
Also beides fast richtig verstanden.
ip classless
Jetzt bitte NICHT wieder diese Klassen Diskussion anfangen. Gibt es nicht mehr !!! Hier steht warum:
https://de.wikipedia.org/wiki/Classless_Inter-Domain_Routing
Das sagt dem Router das er modern und klassenlos ist. (Ganz im Gegensatz zu deinen Lehrern !)
passive-interface default
Schaltet das Senden von OSPF Paketen auf diesen Interfaces ab. Klar, denn du möchtest nicht das dir auf lokalen LANs irgendeiner ungefragt OSPF Routing Updates sendet und deine Routing Tabelle durcheinander bringt !
Deshalb "passiviert" man diese Interfaces.
no passive-interface GigabitEthernet0/0
Das ist der Koppellink zw. den Router. Hier will man ja explizit OSPF haben damit die Router ihre Routen austauscxhen. Also nimmt man das vom Passivieren aus !
Ja, hast du alles richtig verstanden !
Bitte warten ..
Mitglied: AbstrackterSystemimperator
18.08.2019, aktualisiert um 13:31 Uhr
Zitat von aqui:

encapsulation dot1Q
Ja, das hast du zu 99% richtig verstanden. Genau das macht der Befehl.
Allerding akzeptiert er auch ungetaggte Pakete, denn die werden immer über das physische Interface geroutet ! Also so: //

Merci! Schon wieder was dazugelernt! Ich hätte gedacht bzw. bin davon ausgegangen, das wenn ich ein Port für VLAN nutze, ich den selben Port nicht mehr für das physische Interface nutzen kann.

Aber der Wiki-Eintrag zu VRF Instanz hat's wunderbar erklärt
Bitte warten ..
Mitglied: AbstrackterSystemimperator
18.08.2019 um 15:12 Uhr
Hi,
ich bin es noch mal... eine wirklich letzte technische Verständnisfrage habe ich noch.. wenn ich das richtig verstehe können ohne Einstellungen am Router meine VLANs nicht kommunizieren. Ich bin gerade auf der Suche nach dem Befehl innerhalb der Konfiguration, wessen es ermöglicht das meine VLANS untereinader kommunizieren können.

Dann habe ich auch soweit alles was ich benötige.

LG
Bitte warten ..
Mitglied: patrickebert
19.08.2019 um 10:02 Uhr
Hi,

ich denke du meinst den Befehl "ip routing", obwohl dieser Standardmäßig bei Router gesetzt ist und dies nur bei Layer3 Switchen gesetzt werden muss.

LG
Patrick
Bitte warten ..
Mitglied: aqui
19.08.2019 um 12:59 Uhr
wenn ich das richtig verstehe können ohne Einstellungen am Router meine VLANs nicht kommunizieren.
Kommt darauf an WIE du das jetzt genau meinst ???
Normal macht man das ja auf einem Layer 3 Switch ohne Router.
Aber du beziehst dich auf deine Konfig von oben mit L2 VLAN Switch der die VLANs auf einem Router terminiert um dann zwischen ihnen zu kommunizieren, richtig ??

Du musst dann ledglich die Router Interfaces mit dem "encapsulation dot1Q " Kommando versehen sofern du die VLANs mit einem Tagged Uplink vom Switch an den Router bringst.
Theoretisch kannst du natürlich auch pro VLAN untagged Port eine einzelne Strippe auf ein physisches Rouer Interface ziehen. Das geht natürlich auch. Macht aber bei mehr als 3 VLANs recht wenig Sinn....
Wenn du es also mit "encapsulation dot1Q " eingerichtet hast musst du rein gar nix auf dem Router enstellen. Kommunikation funtionert dann so. Da der Router ja per se ein Router ist routet er auch !!
Wie Kollege @patrickebert oben schon richtig sagt musst du natürlich mit dem globalen Konfig Kommamndo "ip routing" das Routing im Router aktivieren.
Bitte warten ..
Ähnliche Inhalte
Netzwerkmanagement
Netzwerk erweiterung
Frage von Alexstarx3Netzwerkmanagement19 Kommentare

Hallo, ich heiße Alex und bin seit 1 Jahr als IT-Techniker ausgelernt. Ich brauche eure Hilfe bei der Netzwerkerweitung, ...

Netzwerkmanagement
Erweiterung Klasse C Netzwerk
Frage von Fitzel69Netzwerkmanagement21 Kommentare

Hallo zusammen, aufgrund eines Firmeninternen Projekts wurde ich mit der Erweiterung unser Firmennetzwerkes beauftragt Zur Info: Wir haben einen ...

Vmware
Einrichtung VMware Netzwerk
gelöst Frage von niLuxxVmware6 Kommentare

Liebe Comunity, ich hätte ein paar kurze Fragen euch. Ich versuche derzeit bei VSphere Client verschiedene Netzwerke einzurichten. Wir ...

Windows Server

Win cleanmgr Fehlerberichterstattungsdatei problemlos löschen?

Frage von cramtroniWindows Server1 Kommentar

Guten Tag zusammen, ich habe gerade auf unserem Exchange-Server eine Reinigung mit dem cleanmgr gemacht und dabei ist mir ...

Neue Wissensbeiträge
Humor (lol)
Zuviel Speicher ist ungesund. :-)
Tipp von Lochkartenstanzer vor 6 StundenHumor (lol)8 Kommentare

Moin Kollegen, Heute hatte ich ein ungewöhnliches Aha-Erlebnis: Über das Wochenende habe ich einen einen 6 Jahre alten Bare-Metal ...

Windows Update

KB4517297 verfügbar, behebt Fehler in VB6 VBA VBScript

Information von sabines vor 8 StundenWindows Update

Das Update behebt mögliche Fehler in VB6, VBA und VBScript, die durch das Update KB4512486 vom August entstanden sind. ...

Viren und Trojaner

Staatstrojaner soll auch per Einbruch installiert werden können

Information von transocean vor 1 TagViren und Trojaner3 Kommentare

Moin, Bundesinnenminister Horst Seehofer will dem Verfassungsschutz Wohnungseinbrüche erlauben, um den geplanten Staatstrojaner zu installieren. Gruß Uwe

Windows 7
Win7 Update scheitert KB4512506
Information von infowars vor 2 TagenWindows 7

Falls jemand auch das Problem hat mit dem: Monatliches Sicherheitsqualitätsrollup für Windows 7 für x64-basierte-Systeme (KB4512506) Das scheint mit ...

Heiß diskutierte Inhalte
Switche und Hubs
Glasfaser-Anschluss Telekom muss verteilt werden
Frage von cansoniSwitche und Hubs34 Kommentare

Vorweg: Bin nur Anwender und kein Experte Die Situation: Der Vermieter stellt einen Glasfaseranschluss in der Wohnung bereit. Wir ...

Hyper-V
Bei Neuaufbau auf Core-Server setzen?
gelöst Frage von dertowaHyper-V32 Kommentare

Hallo zusammen, ich habe vor einigen Monaten die Verantwortung für eine EDV-Landschaft übernommen die seit Jahren von einem Dienstleister ...

Hyper-V
VMs von Hyper-V auf externer Festplatte
gelöst Frage von SnowbirdHyper-V18 Kommentare

Hallo, ich möchte gerne von VirtualBox auf Hyper-V umsteigen und würde auch gerne weiterhin meine VMs auf der externen ...

Festplatten, SSD, Raid
SSDs durch Lagerung ohne Strom nach 6 Monaten defekt?!?
gelöst Frage von GlobetrotterFestplatten, SSD, Raid18 Kommentare

Moin Gemeinde Ich hatte gerade nen Trauerspiel Habe hier etliche NAS-Geräte herumfahren welche ich mal auf die Seite gelegt ...