Top-Themen

Aktuelle Themen (A bis Z)

Administrator.de FeedbackApache ServerAppleAssemblerAudioAusbildungAuslandBackupBasicBatch & ShellBenchmarksBibliotheken & ToolkitsBlogsCloud-DiensteClusterCMSCPU, RAM, MainboardsCSSC und C++DatenbankenDatenschutzDebianDigitiales FernsehenDNSDrucker und ScannerDSL, VDSLE-BooksE-BusinessE-MailEntwicklungErkennung und -AbwehrExchange ServerFestplatten, SSD, RaidFirewallFlatratesGoogle AndroidGrafikGrafikkarten & MonitoreGroupwareHardwareHosting & HousingHTMLHumor (lol)Hyper-VIconsIDE & EditorenInformationsdiensteInstallationInstant MessagingInternetInternet DomäneniOSISDN & AnaloganschlüsseiTunesJavaJavaScriptKiXtartKVMLAN, WAN, WirelessLinuxLinux DesktopLinux NetzwerkLinux ToolsLinux UserverwaltungLizenzierungMac OS XMicrosoftMicrosoft OfficeMikroTik RouterOSMonitoringMultimediaMultimedia & ZubehörNetzwerkeNetzwerkgrundlagenNetzwerkmanagementNetzwerkprotokolleNotebook & ZubehörNovell NetwareOff TopicOpenOffice, LibreOfficeOutlook & MailPapierkorbPascal und DelphiPeripheriegerätePerlPHPPythonRechtliche FragenRedHat, CentOS, FedoraRouter & RoutingSambaSAN, NAS, DASSchriftartenSchulung & TrainingSEOServerServer-HardwareSicherheitSicherheits-ToolsSicherheitsgrundlagenSolarisSonstige SystemeSoziale NetzwerkeSpeicherkartenStudentenjobs & PraktikumSuche ProjektpartnerSuseSwitche und HubsTipps & TricksTK-Netze & GeräteUbuntuUMTS, EDGE & GPRSUtilitiesVB for ApplicationsVerschlüsselung & ZertifikateVideo & StreamingViren und TrojanerVirtualisierungVisual StudioVmwareVoice over IPWebbrowserWebentwicklungWeiterbildungWindows 7Windows 8Windows 10Windows InstallationWindows MobileWindows NetzwerkWindows ServerWindows SystemdateienWindows ToolsWindows UpdateWindows UserverwaltungWindows VistaWindows XPXenserverXMLZusammenarbeit

gelöst Einrichtungsproblem: Port-Forward fuer SSH auf Bintec x2302 Router

Mitglied: 35093

35093 (Level 1)

08.09.2006, aktualisiert 17.09.2006, 9361 Aufrufe, 4 Kommentare

Hallo,

wir haben einen Linux-Server hinter einem Bintec x2302 Router, der per SSH auch von außen erreichbar sein soll.
Intern ist der SSH-Zugriff problemlos moeglich, im Router wurde ein Eintrag im Bereich "Requests from OUTSIDE" eingerichtet (Protokoll tcp, ext. IP, ext. Port, int. IP, int. Port und Hostmasks alles eingestellt...), anschließend die Konfiguration gespeichert und der Router neu gestartet.
Leider klappt der Verbindungsaufbau von außen aber nicht. Der Client bricht dann irgendwann mit Timeout ab, in der Debug-Ausgabe vom Router tauchen diverse Hinweise auf den Verbindungsaufbau auf, aber es tut sich halt nichts.

Gibt es irgendwelche Tricks, wie man das hinbiegen kann?

Danke und viele Grueße
Stephan
Mitglied: nopain
08.09.2006 um 08:14 Uhr
Moin,

evtl. wäre es mal interessant zu wissen was im log genau erscheint.... dann könnte evtl. auch geholfen werden.


Grundsätzlich, du nutzt NAT, d.h. der Router übernimmt Netzanfragen in seinem Namen für die Rechner hinter ihm. Somit kann nur der Router direkt angesprochen werden. D.h. die jeweils gültige externe IP des Routers, welche vom Provider immer wieder neu vergeben wird. Da der Router selber auf Port 22 nicht funkt, muß er wissen an welchen Rechner er sich im internen Netz, also hinter ihm wenden soll, wenn solche Anfragen kommen. Das nennt sich dann Port-forwarding und ist in etwa wohl das, was bei dir "Requests from Outside" heißt.

Nun prüfe doch mal ob die korrekten IPs angesprochen werden und ob Deine Einstellungen logisch richtig und nachvollziehbar sind.

Wenn das alles grün sein sollte, dann mal bitte die Angaben aus den Logs posten.

Gruß
nopain
Bitte warten ..
Mitglied: 35093
08.09.2006 um 08:24 Uhr
Hallo,

erstmal ganz herzlichen Dank fuer die schnelle Antwort!

Der Router bekommt keine neue IP, das ist eine feste von T-Online.
Daher sind die Einstellungen aus meiner Sicht auch alle logisch.
Es gibt auch einen weiteren Eintrag in der Tabelle, der fuer den Webserver im internen Netz bestimmt ist. Den habe leider nicht ich eingerichtet, aber es funktioniert schon seit laengerem.

Was die Logs angeht, so werde ich die nachreichen, wenn ich wieder rankomme. Bin heute leider "extern" und der SSH-Zugang funktioniert ja noch nicht

Gruß
Stephan
Bitte warten ..
Mitglied: nopain
08.09.2006 um 08:30 Uhr
Moin,

Es gibt auch einen weiteren Eintrag in der
Tabelle, der fuer den Webserver im internen
Netz bestimmt ist. Den habe leider nicht ich
eingerichtet, aber es funktioniert schon seit
laengerem.

...na dann gibt es ja Hoffnung! Unter diesen Umständen sollte das Problem doch leicht zu beheben sein.


Was die Logs angeht, so werde ich die
nachreichen, wenn ich wieder rankomme. Bin
heute leider "extern" und der
SSH-Zugang funktioniert ja noch nicht

Interessant wären in diesem Fall Logeinträge die einen erfolgreichen Zugriff auf den Webserver zeigen und diese, die die Fehlersituation beim SSH-Zugang aufzeigen. Es müßte bis zu einem Punkt Gleichnisse geben und an einer bestimmten Stelle die Differenz, bzw. die Fehlersituation. Na dann mal noch viel Spaß und schönes WE.

Gruß
nopain
Bitte warten ..
Mitglied: 35093
17.09.2006 um 11:33 Uhr
Hallo,

etwas verspaetet moechte ich mich nochmal zu dem Problem aeußern.
Ich habe beim erneuten durchsehen der Logs festgestellt, dass da ein Filter (fuer den Webserver) auftauchte, den offenbar jemand von Hand benamt hatte.
Die Suche danach war schließlich refolgreich im Menue "Security -> Stateful Inspection", wo ich ueber "Edit Filters" einen Filter mit der Aktion "accept" fuer den entsprechenden Rechner und den SSH-Port hinzufuegen konnte.
Seit dem laeuft es wunderbar.

Herzlichen Dank fuer die Unterstuetzung!

Stephan
Bitte warten ..
Ähnliche Inhalte
Router & Routing
PFsense Port Forward und NAT
gelöst Frage von m.reegerRouter & Routing11 Kommentare

Hallo, folgendes Problem bei einer PFSense 2.3.4_1. Die PFsense ist eine VM auf einem Hyper-V Host. Der Hyper-V Host ...

Debian

SSH über Webinterface Port 80 u. 443

gelöst Frage von ModdryDebian17 Kommentare

Guten Abend! Bei uns in der Schule sind nach außen nur 80 und 443 offen, noch nicht mal ICMP ...

Server

SSH-Verbindung zum Server ohne Port-Forwarding

Frage von FeveniusServer14 Kommentare

Hallo! Ich bin momentan in folgender Situation: Rechner A befindet sich in einem Netzwerk, bei dem ich kein Port-Forwarding ...

Batch & Shell

Rsync mit einen anderen SSH-Port ausführen

Tipp von FrankBatch & Shell1 Kommentar

Benutzt der SSH-Daemon einen anderen Port als 22 muss man für den rsync Befehl den "e"-Parameter anwenden: Bei $portNumber ...

Neue Wissensbeiträge
Windows 7

Windows 7 u. Server 2008 (R2) SHA-2-Update kommt am 12. März 2019

Information von kgborn vor 6 StundenWindows 73 Kommentare

Kleine Info für die Admins der oben genannten Maschinen. Ab Juli 2019 werden Updates von Microsoft nur noch mit ...

Firewall
PfSense 2.5.0 benötigt doch kein AES-NI
Information von ChriBo vor 2 TagenFirewall2 Kommentare

Hallo, Wie sich einige hier erinnern werden hat Jim Thompson in diesem Aritkel beschrieben, daß ab Version 2.5.0 ein ...

Internet
Copyright-Reform: Upload-Filter
Information von Frank vor 3 TagenInternet1 Kommentar

Hallo, viele Menschen reden aktuell von Upload-Filtern. Sie reden darüber, als wären es eine Selbstverständlichkeit, das Upload-Filter den Seitenbetreibern ...

Google Android

Blokada: Tracking und Werbung unter Android unterbinden

Information von AnkhMorpork vor 3 TagenGoogle Android1 Kommentar

In Ergänzung zu meinem vorherigen Beitrag: Blokada efficiently blocks ads, tracking and malware. It saves your data plan, makes ...

Heiß diskutierte Inhalte
Hyper-V
Intel MSC Raid 5 Rebuild
Frage von DannysHyper-V16 Kommentare

Hallo Community, Ich habe einen Modul Server von Intel in Betrieb. Dort ist eine Festplatte aus dem Raid 5 ...

Backup
Wo installiert man Veeam bei SoHo?
Frage von EDVMan27Backup16 Kommentare

Hallo, nachdem ich die neue Veeam CE bei mir getestet habe, wollte ich es einmal bei einem Kunden testen. ...

Windows Server
DFSR - Dateireplikationseinstellung - Festplattenauslastung zu hoch - optimale Einstellungsfrage
Frage von Kamelle01Windows Server12 Kommentare

Hallo liebe Mitglieder, ich habe einen Windows Server 2016 mit 4TB 7200U 256MB SATA Festplatten in RAID10 und einem ...

CPU, RAM, Mainboards
Kann eine "virtuelle CPU" bei VMware die Leistung einer phys. CPU entsprechen ?
Frage von Troja71CPU, RAM, Mainboards11 Kommentare

Eine Software fordert im Betrieb 8 CPU mit x GHz Taktung. Verfügbar ist "nur" eine VM mit 8 vCPUs ...