Einrichtungsproblem: Port-Forward fuer SSH auf Bintec x2302 Router

Mitglied: 35093

35093

08.09.2006, aktualisiert 17.09.2006, 9522 Aufrufe, 4 Kommentare

Hallo,

wir haben einen Linux-Server hinter einem Bintec x2302 Router, der per SSH auch von außen erreichbar sein soll.
Intern ist der SSH-Zugriff problemlos moeglich, im Router wurde ein Eintrag im Bereich "Requests from OUTSIDE" eingerichtet (Protokoll tcp, ext. IP, ext. Port, int. IP, int. Port und Hostmasks alles eingestellt...), anschließend die Konfiguration gespeichert und der Router neu gestartet.
Leider klappt der Verbindungsaufbau von außen aber nicht. Der Client bricht dann irgendwann mit Timeout ab, in der Debug-Ausgabe vom Router tauchen diverse Hinweise auf den Verbindungsaufbau auf, aber es tut sich halt nichts.

Gibt es irgendwelche Tricks, wie man das hinbiegen kann?

Danke und viele Grueße
Stephan
Mitglied: nopain
08.09.2006 um 08:14 Uhr
Moin,

evtl. wäre es mal interessant zu wissen was im log genau erscheint.... dann könnte evtl. auch geholfen werden.


Grundsätzlich, du nutzt NAT, d.h. der Router übernimmt Netzanfragen in seinem Namen für die Rechner hinter ihm. Somit kann nur der Router direkt angesprochen werden. D.h. die jeweils gültige externe IP des Routers, welche vom Provider immer wieder neu vergeben wird. Da der Router selber auf Port 22 nicht funkt, muß er wissen an welchen Rechner er sich im internen Netz, also hinter ihm wenden soll, wenn solche Anfragen kommen. Das nennt sich dann Port-forwarding und ist in etwa wohl das, was bei dir "Requests from Outside" heißt.

Nun prüfe doch mal ob die korrekten IPs angesprochen werden und ob Deine Einstellungen logisch richtig und nachvollziehbar sind.

Wenn das alles grün sein sollte, dann mal bitte die Angaben aus den Logs posten.

Gruß
nopain
Bitte warten ..
Mitglied: 35093
35093 (Level 1)
08.09.2006 um 08:24 Uhr
Hallo,

erstmal ganz herzlichen Dank fuer die schnelle Antwort!

Der Router bekommt keine neue IP, das ist eine feste von T-Online.
Daher sind die Einstellungen aus meiner Sicht auch alle logisch.
Es gibt auch einen weiteren Eintrag in der Tabelle, der fuer den Webserver im internen Netz bestimmt ist. Den habe leider nicht ich eingerichtet, aber es funktioniert schon seit laengerem.

Was die Logs angeht, so werde ich die nachreichen, wenn ich wieder rankomme. Bin heute leider "extern" und der SSH-Zugang funktioniert ja noch nicht ;-) face-wink

Gruß
Stephan
Bitte warten ..
Mitglied: nopain
08.09.2006 um 08:30 Uhr
Moin,

Es gibt auch einen weiteren Eintrag in der
Tabelle, der fuer den Webserver im internen
Netz bestimmt ist. Den habe leider nicht ich
eingerichtet, aber es funktioniert schon seit
laengerem.

...na dann gibt es ja Hoffnung! Unter diesen Umständen sollte das Problem doch leicht zu beheben sein.


Was die Logs angeht, so werde ich die
nachreichen, wenn ich wieder rankomme. Bin
heute leider "extern" und der
SSH-Zugang funktioniert ja noch nicht ;-) face-wink

Interessant wären in diesem Fall Logeinträge die einen erfolgreichen Zugriff auf den Webserver zeigen und diese, die die Fehlersituation beim SSH-Zugang aufzeigen. Es müßte bis zu einem Punkt Gleichnisse geben und an einer bestimmten Stelle die Differenz, bzw. die Fehlersituation. Na dann mal noch viel Spaß und schönes WE.

Gruß
nopain
Bitte warten ..
Mitglied: 35093
35093 (Level 1)
17.09.2006 um 11:33 Uhr
Hallo,

etwas verspaetet moechte ich mich nochmal zu dem Problem aeußern.
Ich habe beim erneuten durchsehen der Logs festgestellt, dass da ein Filter (fuer den Webserver) auftauchte, den offenbar jemand von Hand benamt hatte.
Die Suche danach war schließlich refolgreich im Menue "Security -> Stateful Inspection", wo ich ueber "Edit Filters" einen Filter mit der Aktion "accept" fuer den entsprechenden Rechner und den SSH-Port hinzufuegen konnte.
Seit dem laeuft es wunderbar.

Herzlichen Dank fuer die Unterstuetzung!

Stephan
Bitte warten ..
Heiß diskutierte Inhalte
Windows 10
PDF automatisch auf zwei Drucker aufteilen
hannes.pVor 1 TagFrageWindows 109 Kommentare

Hallo zusammen, ich suche verzweifelt nach einer Möglichkeit, ein von einer Web-Anwendung generiertes PDF automatisch auf zwei Drucker drucken zu lassen. Das PDF Dokument ...

Microsoft
Erwerb von M365 Lizenzen, Partner Autorisierung für Azure AD - Globaler Administrator wirklich nötig?
NidavellirVor 1 TagFrageMicrosoft4 Kommentare

Hi zusammen, bitte entschuldigt den etwas sperrigen Titel, aber ein knapperer wollte mir nicht einfallen. :D Wir wollen bei einem Systemhaus M365 Lizenzen (Business ...

Windows 10
Sperrbildschirm nach 5 min
ZeppelinVor 1 TagFrageWindows 1012 Kommentare

Hallo zusammen, ich wende mich mit meinem anliegen an euch weil ich mit meinen Möglichkeiten am Ende bin. Wenn innerhalb von 5 min. keine ...

Speicherkarten
Welchen USB Stick für Bootstick?
gelöst dlnkrgVor 1 TagFrageSpeicherkarten6 Kommentare

Hallo, Ich bin auf der Suche nach USB - Sticks, auf denen ich Linux Ubuntu installieren kann und praktisch als Festplatte für das Betriebssystem ...

Off Topic
BKA und der Bundestrojaner
brammerVor 1 TagInformationOff Topic3 Kommentare

Hallo, habe kurz überlegt ob das unter Off Topic allgemein oder Off Topic LOL gehört brammer

Windows Netzwerk
Sporadisch kein Netz auf mehreren Win10-Maschinen
SolarflareVor 19 StundenFrageWindows Netzwerk6 Kommentare

Hallo, ich habe seit Monaten einen eigenartigen Effekt in unserem Windows-Netz. Windows-Domäne mit ca. 100 Maschinen, alle Clients aktuelles Windows 10. Die Maschinen hängen ...

Sicherheit
Emails als Nur Text
Jessica98Vor 1 TagFrageSicherheit4 Kommentare

Hallo zusammen, macht es Sinn E-Mails als nur Text einzustellen, um sich vor schädlichen HTML-Code zu schützen? Meines Erachtens wird ein Benutzer diese Email ...

Windows 7
Userpfad Problem nach Aenderung des Computernamens
BernerVor 1 TagFrageWindows 78 Kommentare

In einem Netzwerk von 9 PCs sind 9 Ersatz-PCs eingebunden, bei denen im Bedarfsfall vor dem Einsatz nur der Computername und die IP-Adresse angepasst ...