Top-Themen

Aktuelle Themen (A bis Z)

Administrator.de FeedbackApache ServerAppleAssemblerAudioAusbildungAuslandBackupBasicBatch & ShellBenchmarksBibliotheken & ToolkitsBlogsCloud-DiensteClusterCMSCPU, RAM, MainboardsCSSC und C++DatenbankenDatenschutzDebianDigitiales FernsehenDNSDrucker und ScannerDSL, VDSLE-BooksE-BusinessE-MailEntwicklungErkennung und -AbwehrExchange ServerFestplatten, SSD, RaidFirewallFlatratesGoogle AndroidGrafikGrafikkarten & MonitoreGroupwareHardwareHosting & HousingHTMLHumor (lol)Hyper-VIconsIDE & EditorenInformationsdiensteInstallationInstant MessagingInternetInternet DomäneniOSISDN & AnaloganschlüsseiTunesJavaJavaScriptKiXtartKVMLAN, WAN, WirelessLinuxLinux DesktopLinux NetzwerkLinux ToolsLinux UserverwaltungLizenzierungMac OS XMicrosoftMicrosoft OfficeMikroTik RouterOSMonitoringMultimediaMultimedia & ZubehörNetzwerkeNetzwerkgrundlagenNetzwerkmanagementNetzwerkprotokolleNotebook & ZubehörNovell NetwareOff TopicOpenOffice, LibreOfficeOutlook & MailPapierkorbPascal und DelphiPeripheriegerätePerlPHPPythonRechtliche FragenRedHat, CentOS, FedoraRouter & RoutingSambaSAN, NAS, DASSchriftartenSchulung & TrainingSEOServerServer-HardwareSicherheitSicherheits-ToolsSicherheitsgrundlagenSolarisSonstige SystemeSoziale NetzwerkeSpeicherkartenStudentenjobs & PraktikumSuche ProjektpartnerSuseSwitche und HubsTipps & TricksTK-Netze & GeräteUbuntuUMTS, EDGE & GPRSUtilitiesVB for ApplicationsVerschlüsselung & ZertifikateVideo & StreamingViren und TrojanerVirtualisierungVisual StudioVmwareVoice over IPWebbrowserWebentwicklungWeiterbildungWindows 7Windows 8Windows 10Windows InstallationWindows MobileWindows NetzwerkWindows ServerWindows SystemdateienWindows ToolsWindows UpdateWindows UserverwaltungWindows VistaWindows XPXenserverXMLZusammenarbeit

gelöst EMail-Weiterleitung scheitert vermutlich am Lotus Domino-Server

Mitglied: Ignatia

Ignatia (Level 1) - Jetzt verbinden

29.10.2016 um 10:35 Uhr, 1112 Aufrufe, 8 Kommentare

Guten Morgen!
Es ist zwar Wochenende aber ich hoffe jemand nimmt sich dennoch meinem Problem an.

Ich verwalte für einen Betriebssportverein den Internetauftritt samt EMail.

Das ganze auf einem Linuxserver mit Ubuntu 14.04 der weitgehend mit Plesk 12.5 verwaltet wird.
Als SMTP-Server wird Postfix genutzt.

Für das Sammelpostfach des Vereins steht ein EMail-Konto zur Verfügung das eine Eingangsbestätigung versendet (Abwesenheitsbenachrichtigung) und einige Weiterleitungen unter anderem an verschiedene EMail-Adressen innerhalb des Betriebes.

In dem Betrieb wird über mehrere Server und Außenstellen ein Lotus Domino-Server betrieben an dem einige tausend Lotus Notes Clients hängen.
Innerhalb des Betriebes habe ich keinerlei administrative Rechte und ich gehe davon aus das von Seiten des Betriebes keine Änderungen vorgenommen werden um das Problem zu beheben.
Zudem fehlt mir Erfahrung mit den Lotus-Produkten.

Es besteht im Betrieb aber immerhin ein Postkorb auf den die Mails vom Vereins-Server weitergeleitet werden sollen.

Solange der Mail-Absender von außerhalb (extern) kommt (nicht aus dem Betrieb) funktioniert alles reibungslos.

Versucht nun aber jemand aus dem Betrieb die Vereins-EMail anzuschreiben passiert folgendes:
- Die Mail geht raus und kommt auch auf dem Vereinsserver an.
- Der Vereinsserver versendet die Abwesenheitsnachricht unter dem Mailkonto des Vereins; diese Mail erhält dann der Mitarbeiter im Betrieb, soweit OK

Jetzt kommt der Punkt an dem es kurios wird:
Der Vereinsserver versendet nun unter seinem Namen vereinserver.de mit dem Absender mitarbeiter@im.Betrieb als Weiterleitung an die gewünschten Weiterleitungs-Adressen im Betrieb.
Diese Mails kommen jetzt aber nicht mehr an.
Der Mitarbeiter im Betrieb erhält für jede Weiterleitungsadresse innerhalb des Betriebs eine Mail mit dem Hinweis auf einen Zustellungsfehler:
Weiterleitung an vereinspostkorb@im.Betrieb Fehler 554.5.7.1 <mitarbeiter@im.Betrieb> Sender adress rejected: Access denied

Jetzt zu meiner eigentlichen Frage.

Ich vermute das die sender adress gesperrt wird weil sie von dem Vereinsserver kommt und daher innerhalb des Betriebs gesperrt wird.

Konnte ich mit dieser Vermutung richtig liegen?

Hat jemand evtl. kreative Ideen wie man eine Lösung herbeiführen könnte?

LG

Ignatia



Mitglied: AndreasHoster
LÖSUNG 29.10.2016 um 20:59 Uhr
Es ist völlig normal, daß ein Mailserver einer Domain keine Mails von extern annimmt, die behaupten von seiner Domain zu kommen.
Schliesslich ist er selber der einzige, der autorisiert ist diese Domain zu versenden.

Es ist also nicht das Problem das sie vom Vereinsserver kommen, sondern das sie von extern kommen und behaupten als Absender @im.Betrieb zu sein.

Lösung:
Als Absender nicht @im.Betrieb nehmen, sondern was vom Verein.
Falls Antworten an den Originalabsender gehen sollen, dann den Originalabsender im Header ins ReplyTo Feld eintragen.
Bitte warten ..
Mitglied: Ignatia
31.10.2016 um 19:46 Uhr
Zitat von AndreasHoster:
Es ist völlig normal, daß ein Mailserver einer Domain keine Mails von extern annimmt, die behaupten von seiner Domain zu kommen.
Schliesslich ist er selber der einzige, der autorisiert ist diese Domain zu versenden.

Hallo
Evtl. habe ich mich unklar ausgedrückt, so ist das ja nun auch nicht.

Es handelt sich um eine ganz normale Mail Weiterleitung SMTP-Sender ist mailer-daemon@vereins.server.
Empfänger ist dann eben To: Mitarbeiter@betrieb

Die Mail kommt im Betrieb an .. dreht dann einige Runden über die internen Server und dann bekommt nicht der Vereins-Mailserver eine Mitteilung über die Ablehnung der Mails, sondern der Mitarbeiter im Betrieb. Letzteres geht irgendwie gar nicht
Der Mitarbeiter selbst hat gar nicht versucht die Mails an die Weiterleitungsadressen zu senden, bekommt aber den bericht mit dem Zustellungsfehler. Die Weiterleitungen nehmen alle anderen Server an auf denen Konten liegen die benachrichtigt werden. Nur in dem Betrieb nicht. Evtl. hat es auch etwas damit zu tun das interne und externe Mail im Lotus Notes nicht identisch sind.

Offensichtlich scheint hier aber kein Lotus Admin aktiv zu sein, der helfen könnte.

Darauf hatte ich etwas gehofft.

LG

Ignatia
Bitte warten ..
Mitglied: AndreasHoster
LÖSUNG 01.11.2016 um 00:01 Uhr
Das habe ich so aus Deiner Beschreibung nicht rausgelesen.

Aber dann werden wir zur Fehlersuche von Beschreibungen auf Fakten zurückkehren müssen.
Hast Du die Chance, Dir vom Mitarbeiter die MIME Darstellung der Fehlermeldung schicken zu lassen? Kriegt man im Notes Client über Ansicht -> Anzeigen -> Seitenquelltext bzw. im iNotes über Rechte Maustaste -> Mehr -> MIME vollständig anzeigen.

Aus der Fehlermeldung sollte sich was rauslesen lassen und zwar mehr als nur Access Denied.

Und die MIME Darstellung einer Mail die von Eurem Vereinsserver rausgeht und Fehler verursacht wäre auch interessant. Den Body (also Inhalt der Mail) braucht man nicht, aber die Header.

Und was die Mailfehlermeldung angeht, die bekommt immer derjenige, der in der Mail als Absender drinsteht. Und das dürfte bei Deiner Weiterleitung eben jener Mitarbeiter sein (oder er leitet unter seinem Namen nochmals weiter).
Bitte warten ..
Mitglied: Ignatia
01.11.2016 um 11:57 Uhr
Zitat von AndreasHoster:
Und was die Mailfehlermeldung angeht, die bekommt immer derjenige, der in der Mail als Absender drinsteht. Und das dürfte bei Deiner Weiterleitung eben jener Mitarbeiter sein (oder er leitet unter seinem Namen nochmals weiter).

Hallo,
erstmal danke für deine Bemühungen.
Der Mitarbeiter leitet nicht weiter.

Ich versuche das nochmal kurz als workflow darzustellen.
Externer Mailversender (gmail,gmx,web,etc.) > Mailserver(Verein) > Posfach Vereinsadr. > autom. Weiterleitung > Vereinspostkorb.imBetrieb, ggf. weitere Weiterleitungen externe oder weitere in den Betrieb.

Funktioniert alles reibungslos. Alles kommt dort an wo es hin soll.

Ersetzt du am Beginn des Workflows den Mailversender extern durch einen Mitarbeiter aus dem Betrieb, kommt innerhalb des Betriebs nichts mehr an mit Ausnahme des Zustellungsfehlers für jede Weiterleitungsadresse im Betrieb.

Folgenden Inhalt hat die Mail mit dem Zustellungsfehler:

01.
Return-Path: <AbsenderimBetrieb@externeNotesaddr>
02.
Received: from mx1.BETRIEB
03.
		....
04.
Received: from irgendwas.imBetrieb
05.
		 by mx1.BETRIEB (Postfix) with ESMTP id xxxxx
06.
		 for <AbsenderimBetrieb@externeNotesaddr>; Tue,  1 Nov 2016 08:39:03 +0100 (CET)
07.
Received: from localhost 
08.
		 by mx1.BETRIEB (Postfix) with ESMTP id xxxxxxxxx
09.
		 for <AbsenderimBetrieb@externeNotesaddr>; Tue,  1 Nov 2016 08:39:03 +0100 (CET)
10.
Received: from mx1.BETRIEB ([127.0.0.1])
11.
		 by localhost (mx1.BETRIEB [127.0.0.1]) (amavisd, port nnnn)
12.
		 with ESMTP id iiiiiii for <AbsenderimBetrieb@externeNotesaddr>;
13.
		 Tue,  1 Nov 2016 08:39:02 +0100 (CET)
14.
Received: from Mailserver.im.Verein (Mailserver.im.Verein [ip.ver.ein.mail])
15.
		 (using TLSv1.2 with cipher AES256-SHA (256/256 bits))
16.
		 (No client certificate requested)
17.
		 by mx1.BETRIEB (Postfix) with ESMTPS
18.
		 for <AbsenderimBetrieb@externeNotesaddr>; Tue,  1 Nov 2016 08:39:02 +0100 (CET)
19.
Received: by Mailserver.im.Verein (Postfix)
20.
		 id iiiiiiiF; Tue,  1 Nov 2016 08:39:01 +0100 (CET)
21.
DomainKey-Status: no signature
22.
X-Spam-Checker-Version: SpamAssassin 3.4.0 (2014-02-07) on
23.
		 Mailserver.im.Verein
24.
X-Spam-Level: 
25.
X-Spam-Status: No, score=-2.7 required=7.0 tests=RCVDxxxx,
26.
		 RP_MATCHES_RCVDxxx version=3
27.
X-Original-To: Vereins@mail.adresse
28.
Delivered-To: Vereins@mail.adresse
29.
Received-SPF: none (no valid SPF record)
30.
Subject: ZUSTELLUNGSFEHLER: 554 5.7.1 <AbsenderimBetrieb@externeNotesaddr>: Sender address
31.
   rejected: Access denied
32.
X-KeepSent: krypto;
33.
 type=4; flags=0; name=$KeepSent
34.
To: AbsenderimBetrieb@externeNotesaddr
35.
From: MAILER-DAEMON@Mailserver.im.Verein (Mail Delivery System)
36.
MIME-Version: 1.0
37.
X-TNEFEvaluated: 1
38.
Message-ID: <krypto.xxx@betri.eb>
39.
Date: Tue, 1 Nov 2016 08:39:01 +0100
40.
X-MIMETrack: Itemize by SMTP Server on Rechner/Server/Betrieb-Extern(Release x.x.xxx|November
41.
  22, 2015) at 01.11.2016 08:39:06,
42.
		 Serialize by Notes Client on Mitarbeiter/Abt/Betrieb(Release x.x.xxx|September
43.
 29, 2010) at 01.11.2016 10:41:14,
44.
		 Serialize complete at 01.11.2016 10:41:14
45.
Content-Type: multipart/report; report-type=delivery-status; boundary="krypto"
46.

47.
krypto
48.
Content-Type: text/plain; charset=UTF-8
49.
Content-Transfer-Encoding: base64
50.

51.
krypto64
52.

53.
krypto
54.
Content-Type: message/delivery-status
55.

56.
Reporting-MTA: dns; Mailserver.im.Verein
57.
X-Postfix-Queue-ID: iiiiiii
58.
X-Postfix-Sender: rfc822; AbsenderimBetrieb@externeNotesaddr
59.
Arrival-Date: Tue,  1 Nov 2016 08:39:00 +0100 (CET)
60.

61.
Final-Recipient: rfc822; AbsenderimBetrieb@externeNotesaddr
62.
Action: failed
63.
Status: 5.7.1
64.
Remote-MTA: dns; mx1.BETRIEB
65.
Diagnostic-Code: smtp; 554 5.7.1 <AbsenderimBetrieb@externeNotesaddr>: Sender address
66.
    rejected: Access denied
67.

68.
krypto
69.
Content-Type: message/rfc822
70.

71.
Return-Path: <AbsenderimBetrieb@externeNotesaddr>
72.
Received: by Mailserver.im.Verein (Postfix, from userid 30)
73.
		 id xxx; Tue,  1 Nov 2016 08:39:00 +0100 (CET)
74.
Received: from mx2.Betrieb (mx1.BETRIEB [ip.ip.ip.ip])
75.
		 by Mailserver.im.Verein (Postfix) with ESMTPS id xxx
76.
		 for <Vereins@mail.adresse>; Tue,  1 Nov 2016 08:38:55 +0100 (CET)
77.
Received: from Kennung (Kennung [127.0.0.1])
78.
		 by mx2.im.Betrieb (Postfix) with ESMTP id xxx
79.
		 for <Vereins@mail.adresse>; Tue,  1 Nov 2016 08:33:44 +0100 (CET)
80.
Received: from Kennung.betrieb (unknown [ip,ip,ip,ip])
81.
		 by mx2.im.Betrieb (Postfix) with ESMTP id xxx
82.
		 for <Vereins@mail.adresse>; Tue,  1 Nov 2016 08:33:44 +0100 (CET)
83.
DomainKey-Status: no signature
84.
X-Spam-Checker-Version: SpamAssassin 3.4.0 (2014-02-07) on
85.
		 Mailserver.im.Verein
86.
X-Spam-Level: 
87.
X-Spam-Status: No, score=-2.7 required=7.0 tests=RCVDxxx,
88.
		 RP_MATCHES_RCVDxxx version=3
89.
X-Original-To: Vereins@mail.adresse
90.
Delivered-To: Vereins@mail.adresse
91.
Received-SPF: none (no valid SPF record)
92.
Subject: Mailversuch
93.
X-KeepSent: 3krypto-block;
94.
 type=4; flags=0; name=$KeepSent
95.
To: Vereins@mail.adresse
96.
From: AbsenderimBetrieb@externeNotesaddr
97.
MIME-Version: 1.0
98.
Bcc: AbsenderimBetrieb@externeNotesaddr
99.
X-TNEFEvaluated: 1
100.
Message-ID: <krypto@Betrieb>
101.
Date: Tue, 1 Nov 2016 08:33:40 +0100
102.
X-MIMETrack: Itemize by SMTP Server on Kennung/Server/Betrieb-Extern(Release x.x.xxxx|November
103.
  22, 2015) at 01.11.2016 08:39:06,
104.
		 Serialize by Notes Client on Mitarbeiterr/Abt/Betrieb(Release x.x.xxxx|September
105.
 29, 2010) at 01.11.2016 10:41:14,
106.
		 Serialize complete at 01.11.2016 10:41:14
107.
Content-transfer-encoding: quoted-printable
108.
Content-type: text/plain; charset=ISO-8859-1
109.

110.

111.
mail an Verein von intern
112.

113.

114.
krypto
115.

LG

Ignatia
Bitte warten ..
Mitglied: AndreasHoster
LÖSUNG 01.11.2016 um 22:04 Uhr
Wenn ich mir den Mailheader so anschaue, dann passt doch genau das, was ich im ersten Posting geschrieben habe.

Der MA schickt eine Mail an Euren Vereinsserver. Absender (FROM) ist MA@imBetrieb
Euer Vereinsserver leitet die Mail weiter, lässt den Absender aber stehen, d.h. die Mail die in den Betrieb zurückgeht hat immer noch als Absender MA@imBetrieb
Der Betriebsserver kriegt die Mail und sagt: Eine Mail von draussen, die angeblich von uns (@imBetrieb) ist? Kann nicht sein, lehnen wir ab.

Außerdem sieht man im Header, das der mx1.BETRIEB der es ablehnt ein Postfix Mailserver ist, nix mit Domino Problemen.

Ab Zeile 69 kommt die weitergeleitete Email, in Zeile 96 sieht man, daß der Absender (From: AbsenderimBetrieb@externeNotesaddr) die Betriebsadresse ist.
Und in Zeile 65/66 steht, daß diese (Ab)Sender Adresse nicht erlaubt ist.

Also bleibt, ohne Änderung des Postfix Servers (was die wohl nicht machen wollen), nur die von mir im ersten Posting geschriebenen Lösungen übrig:
Als Absender nicht @im.Betrieb nehmen, sondern was vom Verein.
Falls Antworten an den Originalabsender gehen sollen, dann den Originalabsender im Header ins ReplyTo Feld eintragen.
Bitte warten ..
Mitglied: Ignatia
02.11.2016 um 08:03 Uhr
Zitat von AndreasHoster:
Wenn ich mir den Mailheader so anschaue, dann passt doch genau das, was ich im ersten Posting geschrieben habe.

Hallo ...

nochmals vielen Dank das du dir die Mühe gemacht hast dir das anzuschauen.
Ist das jetzt ein Problem unseres Mailserver? In der Regel haben wir ja kein Problem mit anderen Absendern/Empfängern.
Über die Verwaltungsoberfläche von Plesk sehe ich keine Möglichkeit die Vorgaben zu ändern.
Damit sind meine Möglichkeiten leider auch erschöpft.

Das lässt sich dann vermutlich nur über die config-files von Postfix lösen?

Das kann ich natürlich versuchen weiterzugeben, aber dazu wäre natürlich eine Begründung hilfreich das eine Weiterleitung wie sie jetzt vorgegeben ist gar nicht zulässig ist (Originalabsender im Header ins ReplyTo Feld eintragen).
Ansonsten könnte ich das ja immer nur selbst weiterleiten.

LG

Ignatia
Bitte warten ..
Mitglied: AndreasHoster
LÖSUNG 02.11.2016 um 21:07 Uhr
Das ist jetzt nicht wirklich ein "Problem" Eures Mailservers, es ist durchaus zulässig den Absender stehenzulassen, aber es ist auch eine übliche Anti-Spam Maßnahme Absender der eigenen Domain von extern nicht zuzulassen (dann kann von extern schon nicht so einfach jemand die Email-Adresse vom Geschäftsführer nehmen und eine Überweisung an XYZ versuchen zu veranlassen).

Ich bin jetzt in der Postfix Konfiguration nicht firm, vermute aber, daß es sich über die Config die Umschreibung schon realisieren liesse.

Und das es nur eine Firma betrifft kommt halt von den Anti-Spam Einstellungen. Die einen filtern schärfer als die anderen, haben andere Kriterien etc.
Aber bei uns in der Firma kämen die Mails auch nicht an, wir nehmen von extern auch keine mit unserer Domain an.
Bitte warten ..
Mitglied: Ignatia
03.11.2016 um 07:36 Uhr
Hallo,
Oki, dann nochmals vielen Dank.
Ich werde schauen ob ich Bewegung hineinbekomme in die Änderung der Postfix-Konfiguration.

LG

Ignatia
Bitte warten ..
Ähnliche Inhalte
Exchange Server
Exchange 2010 - Email Weiterleitung
Frage von JuckieExchange Server4 Kommentare

Hallo an alle, im Exchange Server 2010 habe ich ja unter den Zustellungsoptionen der Nachrichtenübermittlungseinstellungen eines Postfaches die Möglichkeit, ...

E-Mail

Absender E-Mail Adresse ändern in Lotus Notes (Domino Server)

gelöst Frage von Hendrik2586E-Mail2 Kommentare

Hallo @ all! Ich hab da mal wieder eine Frage die wohl etwas umfangreicher ist. wir nutzen in der ...

Netzwerke

Remotedesktopverbindung scheitert

Frage von nixxokNetzwerke9 Kommentare

in meinem Büro steht ein Zyxel P-662H und dahinter mein ArbeitsPC mit Windows 7, wo ich die Remotedesktop aktiviert ...

Exchange Server

Email Weiterleitung im Outlook klappt nicht, nur im Exchange

gelöst Frage von SyosseExchange Server4 Kommentare

Hallo Zussammen und erstmal sehr tolles Board, mal ein Board das auch für weitgehende Themen wie Exchange,Server etc Community ...

Neue Wissensbeiträge
Sicherheits-Tools

TrendMicro Worry-Free Business Security 10.0 SP1 - Jetzt in Deutsch verfügbar! (Windows 10 1903 Support)

Tipp von TrinXx vor 3 StundenSicherheits-Tools

Moin! Nach wochenlangem Warten wird Trend Micro das SP1 für WFBS 10 voraussichtlich am 26.08.19 veröffentlichen. Ich habe das ...

Hyper-V
Setup VM W2016 startet nicht in Hyper-V 2016
Erfahrungsbericht von keine-ahnung vor 1 TagHyper-V4 Kommentare

Moin, sitze gerade über meinem neuen Server und versuche, die VM auf den Host zu prügeln. Jetzt wollte ich ...

Server-Hardware

HPE Proliant ML350P Gen8 Probleme mit Zugriff auf Raid-Volumes

Erfahrungsbericht von goscho vor 1 TagServer-Hardware1 Kommentar

Hallo Leute, das Problemgerät: HPE ML350P G8 Windows Server 2012R2 HyperV-Host 8 x 300 GB 10K SAS HDD (1 ...

Humor (lol)

"Linux und 5 Gründe Warum man kein Windows verwenden sollte sondern Ubuntu Linux"

Information von Snowbird vor 3 TagenHumor (lol)8 Kommentare

Gerade gefunden. Ja, ist etwas älter, aber irgendwie lustig?

Heiß diskutierte Inhalte
Grafikkarten & Monitore
Grafikkarten Angebot auf Amazon
gelöst Frage von NudellordGrafikkarten & Monitore22 Kommentare

Hallo Community, ich suche eine neue Grafikkarte und bin auf die Nvidea Gforce GTX 1080 ti gestoßen. Und dabei ...

Hyper-V
Keine Netzwerkverbindung W2016 VM
gelöst Frage von keine-ahnungHyper-V19 Kommentare

Moin, ich verliere gleich meine contenance ;-). Ich versuche gerade, auf einem Hyper-V 2016 GUI eine W2016-VM (Generation 2 ...

Batch & Shell
Powershell - Webseite auslesen und Abspeichern ein paar Probleme
gelöst Frage von kime203Batch & Shell18 Kommentare

Hallo alle miteinander, ich hab die Aufgabe eine Webseite auszulesen um Einsatzdaten der Feuerwehr daraus zu gewinnen. Das habe ...

Windows 7
Systemwiederherstellung mittel Console und Schattenkopie?
Frage von Kerbel3rdWindows 717 Kommentare

Moin, leider hat mir das Update auf Framework 4.8 meinen Rechner bzw mein Framework zerschossen. Nach tagelangen Reparaturversuchen mittels ...