bitnarrator
Goto Top

Excel: WENN mit FINDEN verschachteln

Hallo,

ich habe hier ein kleines Problem mit Excel und hoffe eine Lösung zu finden.

Im Grunde baut sich die Tabelle so auf:

Beschreibung Obstname
Äpfel-schneiden
Birnen-schneiden
Bananen-schälen

Und ich möchte nun in der Spalte "Obstname" den Names des Obstes rauskriegen.

Also,

Wenn in Zelle A2/A3/A4 "Äpfel" gefunden wird, dann soll in B2/B3/B4 "Apfel" stehen
Wenn in Zelle A2/A3/A4 "Birnen" gefunden wird, dann soll in B2/B3/B4 "Birne" stehen.

Und das alles am besten in einer Formel, da es hier um ca. 30000 Datensätze geht.

Eigentlich hilft mir da diese Funktion:

=WENN(FINDEN("Äpfel";A2;1));"Apfel";"")   
, nur ich bekomme die nicht vernünftig verschachtelt.

Vielleicht weiß ja hier einer die Lösung.

VG
bitnarrator

Content-Key: 3388975944

Url: https://administrator.de/contentid/3388975944

Printed on: April 19, 2024 at 16:04 o'clock

Member: em-pie
em-pie Jul 20, 2022 at 15:17:44 (UTC)
Goto Top
Moin,

dir fehlt die Prüfung bzw. ist diese unvollständig:
=WENN(FINDEN("Äpfel";A1;1)=1;"APFEL";"")  

Gruß
em-pie
Member: erikro
Solution erikro Jul 21, 2022 at 07:42:51 (UTC)
Goto Top
Zitat von @em-pie:

Moin,

dir fehlt die Prüfung bzw. ist diese unvollständig:
=WENN(FINDEN("Äpfel";A1;1)=1;"APFEL";"")  

Gruß
em-pie

Nö, er hat einfach die Klammer zu früh geschlossen.

=WENN(FINDEN("Äpfel";A2;1));"Apfel";"")  #Falsch, da schließende Klammer von WENN zu früh  

=WENN(FINDEN("Äpfel";A2;1);"Apfel";"") #So geht's  

Liebe Grüße

Erik
Member: em-pie
em-pie Jul 21, 2022 at 07:47:18 (UTC)
Goto Top
@erikro
jetzt, wo du es sagst, fällt es mir auch auf ^^

hab das nicht per C&P nachgestellt, sondern schön brav zu Fuß in Excel eingetippt face-smile
Member: bitnarrator
bitnarrator Jul 25, 2022 at 10:49:23 (UTC)
Goto Top
Hallo,

danke erstmal.

Wenn Ihr mir jetzt noch sagen könntet wie ich das richtig verschachteln kann, damit er bei "Birnen-schneiden" auch in die nächste Spalte "Birnen" einfügt, wäre es perfekt....

Danke!

VG
bitnarrator
Member: em-pie
Solution em-pie Jul 25, 2022 at 11:14:45 (UTC)
Goto Top
Wenn Ihr mir jetzt noch sagen könntet wie ich das richtig verschachteln kann ..
In dem du einfach anstatt des "" an der dritten Option eine neue Wenn...Dann einbaust.:
 =WENN(FINDEN("Äpfel";A2;1);"Apfel";WENN(FINDEN("Birnen";A2;1);"Birnen";""))  

Bei 250 Variationen wird das aber Spannend, da müsste man das irgendwie mit einer Referenztabelle bauen.
Member: bitnarrator
bitnarrator Jul 25, 2022 at 11:19:15 (UTC)
Goto Top
Dankeschön. Ich werde probieren. Variationen sind es circa 30 Stück....