Top-Themen

Aktuelle Themen (A bis Z)

Administrator.de FeedbackApache ServerAppleAssemblerAudioAusbildungAuslandBackupBasicBatch & ShellBenchmarksBibliotheken & ToolkitsBlogsCloud-DiensteClusterCMSCPU, RAM, MainboardsCSSC und C++DatenbankenDatenschutzDebianDigitiales FernsehenDNSDrucker und ScannerDSL, VDSLE-BooksE-BusinessE-MailEntwicklungErkennung und -AbwehrExchange ServerFestplatten, SSD, RaidFirewallFlatratesGoogle AndroidGrafikGrafikkarten & MonitoreGroupwareHardwareHosting & HousingHTMLHumor (lol)Hyper-VIconsIDE & EditorenInformationsdiensteInstallationInstant MessagingInternetInternet DomäneniOSISDN & AnaloganschlüsseiTunesJavaJavaScriptKiXtartKVMLAN, WAN, WirelessLinuxLinux DesktopLinux NetzwerkLinux ToolsLinux UserverwaltungLizenzierungMac OS XMicrosoftMicrosoft OfficeMikroTik RouterOSMonitoringMultimediaMultimedia & ZubehörNetzwerkeNetzwerkgrundlagenNetzwerkmanagementNetzwerkprotokolleNotebook & ZubehörNovell NetwareOff TopicOpenOffice, LibreOfficeOutlook & MailPapierkorbPascal und DelphiPeripheriegerätePerlPHPPythonRechtliche FragenRedHat, CentOS, FedoraRouter & RoutingSambaSAN, NAS, DASSchriftartenSchulung & TrainingSEOServerServer-HardwareSicherheitSicherheits-ToolsSicherheitsgrundlagenSolarisSonstige SystemeSoziale NetzwerkeSpeicherkartenStudentenjobs & PraktikumSuche ProjektpartnerSuseSwitche und HubsTipps & TricksTK-Netze & GeräteUbuntuUMTS, EDGE & GPRSUtilitiesVB for ApplicationsVerschlüsselung & ZertifikateVideo & StreamingViren und TrojanerVirtualisierungVisual StudioVmwareVoice over IPWebbrowserWebentwicklungWeiterbildungWindows 7Windows 8Windows 10Windows InstallationWindows MobileWindows NetzwerkWindows ServerWindows SystemdateienWindows ToolsWindows UpdateWindows UserverwaltungWindows VistaWindows XPXenserverXMLZusammenarbeit

Exchange 2016: Kein Empfang externer Emails, Autodiscover klappt nicht richtig

Mitglied: Kabuntel

Kabuntel (Level 1) - Jetzt verbinden

21.11.2019 um 13:20 Uhr, 257 Aufrufe, 8 Kommentare, 4 Danke

Hallo Community,

habe in meinem Heimnetzwerk einen Exchange am laufen. Läuft in einer Win Srv 2016 VM. In einer weiteren VM läuft ein DC. Die Installation verfiel fehlerfrei. Im DNS auf dem DC ist ein Host-Eintrag für Exchange gesetzt, sowie ein Eintrag für den FQDN des DynDNS.
Damit mein Exchange von außen erreichbar ist, habe ich einen DynDNS Eintrag bei meinem Domainanbieter hinterlegt. Weiter habe ich auf meiner FritzBox Port-Freigaben für 25, 443, 587, 993. und auch den entsprechenden DynDNS-Eintrag.
Versenden geht über einen Smart-Host, das tut soweit, Emails landen beim Empfänger nicht im Spam.

Soweit zum Setup...Falls ich was vergessen haben sollte, reiche ich die benötigte Info nach.

Was nicht geht:

Erste Frage:

Ich kann auf meinen Email-Accounts keine Emails empfangen. Intern funktioniert. Am Empfangs-Connector habe ich die Default-Einstellungen und laut Microsoft sollte der Empfang damit klappen.
Daher meine Frage woran könnte es liegen, dass keine Emails von extern empfangen werden?

Meine zweite Frage ist:

Warum Autodiscover nicht geht? Auf dem DynDNS-Eintrag ist Autodiscover aktiviert. Ich konnte es zwar im Standard Email-Client Mail von Win 10 manuell hinzufügen, aber dann kam ständig ein Popup zum erneuten Eingeben des PW.

Hab es gerade über Outlook versucht. Folgende Meldung kommt:

2019-11-21 12_57_06-e-mail-konto-einrichtung - Klicke auf das Bild, um es zu vergrößern

Nach Zulassen kommt dann die Meldung "Da hat was nicht geklappt", was, wäre schön zu wissen.

Ich freue mich auf Eure Beiträge

Viele Grüße,
Kabuntel
Mitglied: Vision2015
21.11.2019 um 13:26 Uhr
Moin...

schalte mal das autoconfig bei strato ab, und lege autodiscover auf deine ip zuhause...


Frank
Bitte warten ..
Mitglied: NordicMike
21.11.2019 um 13:30 Uhr
Mach auch den Exchange Online Analyzer von Microsoft. Er sagt Dir ganz genau wo es nicht mehr klappt.
Bitte warten ..
Mitglied: Kabuntel
21.11.2019 um 13:37 Uhr
Daran bin ich schon gestolpert im Internet. Nur was ich ja anscheinend nicht machen kann bei der FirtzBox einen zweiten DynDNS-Eintrag für Autodiscover setzen.

Oder meinst Du was anderes???
Bitte warten ..
Mitglied: Kabuntel
21.11.2019 um 13:56 Uhr
Hi NordicMike,

eben einen Inbound SMTP Email test auf https://testconnectivity.microsoft.com/ gemacht.

Test verlief erfolgreich....

der Test für Autodiscover schlug fehl. Ich habe auch anhand der Info herausgefunden, dass die URLs, die der Test verwendet hat nicht mit der übereinstimmt, die ich in der Exchange Management Shell manuell eingegeben habe mit:

Get-ClientAccessService EXCHANGE | Set-ClientAccessService -AutoDiscoverServiceInternalUri "https://...."

Kann es vielleicht auch daran liegen, dass ich kein gültiges Zertifikat für die URL habe????
Bitte warten ..
Mitglied: Komabaer
21.11.2019 um 14:43 Uhr
Es gibt in Exchange zwei Autodiscover URL, einmal für intern und für extern.

Für extern muss natürlich im Internet bekannt sein, da reicht es nicht den Eintrag im Exchange vorzunehmen.
Das macht man normalerweise an der gleichen Stelle an der auch der MX Eintrag hinterlegt ist.

Alternativ kannst du auch die externe URL auf dem Exchange intern eintragen.

Was den Empfang angeht brauchst ja nur ein Telnet auf deine dyndns Adresse auszuführen und schauen ob dein Exchange Server antwortet.
Wenn ja dann liegt das Problem an einer anderen Stellen, wenn nein dann kann der Server nicht erreicht werden.
Bitte warten ..
Mitglied: Kabuntel
21.11.2019 um 15:18 Uhr
Hallo Komabaer,

danke für Deine hilfreiche Antwort!

Das mit dem MX Eintrag irritiert mich jetzt etwas. Ich habe zwei Einträge im DNS Manager am DC hinterlegt von Type A. Einmal für den exchange selber mit seiner statischen IP und ein zweiten für den FQDN für das DynDNS beim Domainanbieter. Beim Domainanbieter habe ich für diesen FQDN einen DynDNS-Eintrag gemacht. Dort konnte ich auch ein Häckchen setzen für Autodiscover.

Telnet funkt soweit auf den Ports 25 und 587, hier der Banner:

01.
220 EX.example.com Microsoft ESMTP MAIL Service ready at Thu, 21 Nov 2019 15:13:27 +0100
Bitte warten ..
Mitglied: Komabaer
21.11.2019 um 16:27 Uhr
Okay, ich gehe davon aus das dein Domainanbieter den MX Eintrag für dich besitzt (Muss er ja). Wenn du einen Haken setzen konntest für den Autodiscover gehe ich davon aus das dieser auch vom Domainanbieter gesetzt ist.

Kannst du prüfen mit

CMD Fenster öffnen
nslookup
q=mx
Deine E-Mail domain z.b. gmail.com oder autodiscover.deinedomain.de

Ich mein den Autodiscover brauchst letztendlich ja nur dafür wenn sich Clients mit dem Exchange verbinden wollen.

Gut wenn dein Exchange Server per Telnet erreichbar ist, dann liegt es an was anderem wie z.b. TLS Verschlüsselung oder Zertifikate.
Schau mal in den Protokollen vom Exchange SMTP Receiver nach ob du dort etwas dazu findest.

https://docs.microsoft.com/en-us/exchange/mail-flow/transport-logs/trans ...
https://docs.microsoft.com/en-us/exchange/mail-flow/connectors/protocol- ...
Bitte warten ..
Mitglied: Kabuntel
22.11.2019 um 09:02 Uhr
Morgen Komabaer,

dank für deine hilfreiche Stellungnahme.

Werde das noch prüfen!

Hab aber gestern einen ehemaligem Kollegen, der sich auf dem Gebiet sehr gut auskennt, dazu überreden können sich mal das ganze anschaut.

Viele Grüße,
Kabuntel
Bitte warten ..
Ähnliche Inhalte
Exchange Server

Exchange 2016 und Öffentliche Ordner, kein Empfang von extern

Frage von EdaseinsExchange Server8 Kommentare

Hallo Leute, Ich verzweifel an einem neu aufgesetzten Exchange 2016. Erstmal Bestandsaufnahme: -> Exchange Server 2016 -> Windows Server ...

Microsoft Office

Verteilergruppe in o365 - Empfang von extern

gelöst Frage von takvorianMicrosoft Office1 Kommentar

Hallo zusammen, ich habe eine Verteilergruppe im EAC von o365 angelegt und dort 3 Mitglieder hinzugefügt. Teste ich nun ...

Apache Server

OsTicket Email versenden klappt nicht

gelöst Frage von ClepToManixApache Server5 Kommentare

Hallo, ich habe mir auf meinem Webserver das Ticket System OsTicket installiert. Das läuft soweit auch alles Reibungslos, nur ...

Exchange Server

Exchange und Outlook 2016 extern

gelöst Frage von Florian86Exchange Server17 Kommentare

Hallo, wir haben einen Exchangeserver 2013. Hier komme ich von extern über die Weboberfläche ohne Problem rein. Nutze ich ...

Neue Wissensbeiträge
Windows Installation

Windows Install ISO mit übergroßer Install.wim auf FAT32 übertragen

Tipp von Lochkartenstanzer vor 2 TagenWindows Installation9 Kommentare

Moin Kollegen, Viele von euch werden sicher aus praktischen Gründen nicht nur DVDs oder "virtuelle" CD-Laufwerke (Zalman, IODD) zum ...

Datenschutz

Gehe zurück auf Los, ziehe keine 4.000 Mark. E-Privacy (erstmal) gescheitert

Information von certifiedit.net vor 3 TagenDatenschutz

Webbrowser

Firefox 71 verfügbar mit Picture in Picture Funktion

Information von sabines vor 3 TagenWebbrowser2 Kommentare

Die neue Firefox Version 71 unterstützt, zunächst nur für Windows, Picture in Picture. Damit kann ein Video in einem ...

E-Mail
SPF beim Versenden testen
Tipp von StefanKittel vor 5 TagenE-Mail3 Kommentare

Hallo, wenn man einen SPF für einen Exchange, oder anderen Mail-Server, konfigiruert muss man das ja auch testen. Ganz ...

Heiß diskutierte Inhalte
Server-Hardware
Hetzner Dedicated-Server für Terminalserver - RDSH 5 Benutzer gesucht
gelöst Frage von ra-user10Server-Hardware37 Kommentare

Hallo liebe IT-Fachleute! Ich möchte für unseren kleinen Betrieb einen Terminalserver aufsetzen und dafür das Angebot von Hetzner nutzen. ...

Switche und Hubs
PoE in erster und zweiter Instanz
Frage von moinmoin2016Switche und Hubs27 Kommentare

Moin. Ich habe versucht zum folgenden Sachverhalt ein Beitrag zu suchen, konnte aber nichts passendes finden. Folgender Sachverhalt: Ein ...

E-Business
Brainstorming: Zeiterfassungs- oder gesamtes Abrechnungssystem
Frage von certifiedit.netE-Business13 Kommentare

Guten Abend, alles neu macht der, naja, schon lange nicht mehr, Mai Zum Ende des Jahres, besser zum Beginn ...

Entwicklung
Powershell-Skript und Organisationseinheiten auskludieren
gelöst Frage von informatikkfmEntwicklung13 Kommentare

Hallo, ich habe ein Powershell-Skript, ähnlich wie das folgende. Ich möchte dabei, dass alle Benutzer unterhalb der OUs in ...