For-Schleife Probleme mit Anführungszeichen

Mitglied: Django.Durano

Django.Durano (Level 1) - Jetzt verbinden

18.01.2021 um 18:19 Uhr, 510 Aufrufe, 2 Kommentare

Hallo,

ich habe folgendes Problem.

Ich versuche folgende For-Schleife auszuführen

Das Problem dabei ist nun der zweite Pfadblock mit der temp 22.mkv.

Wenn ich die For-Schleife so ausführe bekomme ich jedes mal den Fehler das die Syntay für Dateiname usw nicht passt.
Entferne ich nun die Anführungszeichen um den Pfad und bennene die Datei um, das kein Leerzeichen mehr vorhanden ist funktioniert das Ganze ohne Probleme.

So funktioniert es.

Ich habe mir auch schon die Variable %pfadtemp% über echo ausgeben lassen, dort sind auch keine " " oder ähnliches enthalten.
Habe mir auch die For schleife mal per echo ausgeben lassen,

Verstehe nicht warum es hier so Probleme macht den Pfad in " " zu setzen.
Mitglied: Friemler
LÖSUNG 18.01.2021 um 23:09 Uhr
Hallo @Django.Durano,

da bist Du auf einen der vielen Fallstricke (um nicht zu sagen Bugs) im Batchscript-Interpreter gestoßen. Setze einen CALL-Befehl vor den Aufruf von ffprobe.exe, dann klappt das.

Siehe auch den Abschnitt Verarbeiten der Ausgabe eines Programms/Befehls in meinem Tutorial zur FOR-Schleife.

Grüße
Friemler
Bitte warten ..
Mitglied: Django.Durano
21.01.2021 um 16:25 Uhr
Hallo Friemler,

danke für die Antwort. Hat mit dem Call Befehl sofort funktioniert.


Grüße
Django
Bitte warten ..
Heiß diskutierte Inhalte
Linux
Installation Grammm Server
smeclntVor 1 TagFrageLinux13 Kommentare

Hallo zusammen, meine Linux Kenntnisse sind sehr rudimentär trotzdem suche ich eigentlich ständig nach einer Alternative zu MS Exchange. Bis jetzt gab es nichts ...

Switche und Hubs
Probleme im Netzwerk Switche teilweise nicht erreichbar
hukimanVor 10 StundenFrageSwitche und Hubs29 Kommentare

Guten Morgen, seit Monaten haben wir hier immer wieder Probleme mit dem Netzwerk, das Problem konnte ich leider aber noch immer nicht finden. Es ...

Erkennung und -Abwehr
Einer Malware auf der Spur. Benötige Sherlock Holmes!
streamVor 22 StundenFrageErkennung und -Abwehr7 Kommentare

Guten Abend Wenn ich meine Windows-10-Kiste starte, so gibt mir mein Router eine Meldung aus, dass eine bestimmte IP-Adresse wegen Bösartigkeit geblockt wurde. Auf ...

Windows 10
Windows 10 interes Mikro ohne Funktion
TPH125Vor 1 TagFrageWindows 1011 Kommentare

Hallo zusammen, Ich verzweifelt bald. Besitze einen Medion Akoya MD 97110. Habe Windows 10 installiert, seit dem funktioniert das inigrierte Mikrofon nicht mehr. Gerät ...

Batch & Shell
Tabellarische Ausgabe der Netzwerkschnittstellen
gelöst dysti99Vor 9 StundenFrageBatch & Shell18 Kommentare

Mit - ip a - werden ja die Netzwerkschnittstellen angezeigt. Ich möchte mit ein Batchscript folgende Ausgabe erreichen: 1 eth0 192.168.1.1 AD:13:67:56:14:D1 2 eth1 ...

Festplatten, SSD, Raid
(USB) Festplatten laut ?
TomEngelVor 1 TagFrageFestplatten, SSD, Raid6 Kommentare

Ich grüsse Sie Alle. Eine Frage eines engagierten Laien Habe mehrere 3,5 " Festplatte. Einige schon recht alt 8 Jahre, andere ca 2-3 jahre ...

Ubuntu
Mailserver Test Provider IP
gelöst it-blzVor 1 TagFrageUbuntu9 Kommentare

Hallo, ist es möglich einen "Mailserver" (Imap + smtp) in einer Virtual Box mit einer Provider IP (dynamisch - ist allerdings konstant) zu testen? ...

Hardware
DisplayPort zu USB-C Adapter Converter
gelöst felixhuth-itVor 1 TagFrageHardware11 Kommentare

Hallo liebe Gemeinde Ich habe da ein kleines Problemchen. Der Kunde wollte einen 14 Zoll Monitor mit Touch in Verbindung mit einem Mini PC ...