Dieser Beitrag ist schon älter. Bitte vergewissern Sie sich, dass die Rahmenbedingungen oder der enthaltene Lösungsvorschlag noch dem aktuellen Stand der Technik entspricht.

Wie GRUB reparieren?

Mitglied: sysad
Hallo,

auf meinem Wartungslaptop taucht regelmässig folgendes Problem auf:

Sowohl bei der Verwendung von GRUB als auch Acronis OS Selector kann ich nach Rücksichern einer Partition nicht mehr von Linux booten: Meldung ist GRUB stage 1.5. loading und dann ist nix mehr.

Es sind 4 Partitionen drauf: 1. XPpro(bootbar), 2. Daten, 3. W2003Server (bootbar), 4. Knoppix (bootbar).

Wenn ich Linux neu installiere, geht es wieder bis zum nächsten Restore. Wie kann ich von der LiveCD von Knoppix booten und GRUB bzw. dessen Parameter reparieren?

-Danke!

Content-Key: 32917

Url: https://administrator.de/contentid/32917

Ausgedruckt am: 30.11.2021 um 10:11 Uhr

Mitglied: Guenni
Guenni 21.05.2006 um 14:00:50 Uhr
Goto Top
@sysad

Hi,

habe 2 Programme auf meinem Server gefunden:

- mkboot
- grub-install

mkboot erstellt eine Bootdiskette, die das installierte System startet.

grub-install boot-device installiert grub auf die mit boot-device angegebene
Partition.

Mehr Info findest du, wenn du man mkboot bzw. man grub-install aufrufst.

Ob und wie das Ganze jetzt funktioniert, wollte ich jetzt nicht unbedingt
an meinem Server testen, das kannst du besser mit einem deiner Backup's machen :-) face-smile

Good Luck
Günni
Mitglied: sysad
sysad 21.05.2006 um 16:11:43 Uhr
Goto Top
Danke,

habs hingekriegt, aber durch googeln. Der Laptop hat kein Floppy, sonst wärs ja einfach....
Mitglied: Guenni
Guenni 21.05.2006 um 16:40:57 Uhr
Goto Top
@sysad

Hi,

"Danke, habs hingekriegt, aber durch googeln...."

Schöne Antwort, schöner wäre die Veröffentlichung eines Lösungswegs.

Damit auch die User was davon haben, die mit ihrer Nase auf die
Suchfunktion gestoßen werden, wenn irgendwann irgendjemand
irgendwo irgendwie mal das gleiche Problem hat :-) face-smile

Gruß
Günni
Mitglied: sysad
sysad 21.05.2006 um 18:00:29 Uhr
Goto Top
Hast ja recht.

Also so geht es (zumindest bei Knoppix):

1. Booten von der CD mit Parameter 'knoppix 2'. Dann spart man sich den Grafikstart. Dabei wird man root.
2. Am Prompt: mount -o dev /mnt/hda4 (oder die Partition wo Linux drauf ist).
3. /boot/grub/menu.lst bearbeiten wie man es braucht, ich nehme dazu mc
4. Am Prompt: chroot /mnt/hda4 grub-install /dev/hda

Das hat bei mir geklappt, es wird dabei ein neuer Bootloader in den MBR geschrieben.
Heiß diskutierte Beiträge
question
Adminpasswort löschenaleks08Vor 1 TagFrageWindows 79 Kommentare

Bei einem Kollegen hat jemand den Rechner eingerichtet und dabei ein Adminpasswort vergeben. Das Adminpasswort kennt er aber nicht und der Einrichter ist nicht mehr ...

question
Medienwandler für Glasfaser gelöst Reamer76Vor 1 TagFrageHardware9 Kommentare

Guten Tag liebe Admins, ich bräuchte mal Eure Hilfe für die Anschaffung eines Medienwandlers. Wir werden nächsten Monat freigeschaltet, Anbieter ist Wemacom. Ich habe die ...

question
Ethernet-LAN und DSL über Telefonkabel gelöst 150103Vor 1 TagFrageNetzwerke10 Kommentare

Hallo Administrator-Forum, ich habe hier ein ungewöhnliches Szenario, dass ich euch gerne näher bringen würde. Auf einem Grundstück gibt 2 Häuser (H1 und H2). Im ...

question
AD Server von 2012 R2 auf Server 2019 R2 hochgesetzt. Domänenlevel noch 2012 Aber nun geht kein LDAPS . LDAP geht gelöst itititVor 23 StundenFrageWindows Server13 Kommentare

Hallo zusammen, wir haben die Server 2012 R2 mit Server 2019 R2 ersetzt. Neue Server kein Inplace. Die neuen DCs haben IP und Name gleich ...

question
Euro Zeichen geht nicht mehr gelöst GwaihirVor 21 StundenFrageWindows 1014 Kommentare

Hallo zusammen, bei einem User geht das Euro-Zeichen nicht mehr. Er kann es nur noch über Copy&Paste aus der Zeichentabelle einfügen. Auch STRG+ALT+E klappt nicht. ...

question
"Nicht identifiziertes Netzwerk" bei VPN VerbindungKatachi29Vor 1 TagFrageDSL, VDSL5 Kommentare

Hallo zusammen, ich habe seit einiger Zeit das Problem, dass, wenn ich mich daheim bei meinem Sophos SSL VPN Client anmelde, immer die Meldung: "Nicht ...

question
Bitlockerpartition versehentlich gelöscht Läppi findet nach Partitiosformatierung mbr gpt die Partition nicht wiederPCChaosVor 19 StundenFrageWindows 1010 Kommentare

Hallo zusammen, Ich habe ein riesen Problem, das mir sonst einfach erschien. Ich hatte eine Bitlocker Partition D: auf meinem C: Laufwerk installiert. Weil Windows ...

question
Dauernd gesperrter User in der ADChristianIT2021Vor 1 TagFrageWindows Server3 Kommentare

Hallo zusammen, Ich habe ein riesen Problem ich habe einen User der wird immer wieder gesperrt. Über die Eventlgs habe ich schon herausgefunden aus welcher ...