Hyper-V, DPM, Consistency Checks nach Reboot der Nodes

Mitglied: jsysde

jsysde (Level 3) - Jetzt verbinden

25.11.2015, aktualisiert 13:55 Uhr, 1506 Aufrufe, 6 Kommentare

Moin zusammen.

Ich beobachte hier schon länger ein Phänomen, für das ich keinerlei Erklärung finde - evtl. hat ja einer von euch ne Idee dazu.

Umgebung:
Hyper-V 2012 R2 Cluster (drei Stück; zwei Mal vier Nodes, ein Mal zwei Nodes) und DPM 2012 R2. In den Clustern viele, viele VMs, alles Windows Server Maschinen (2008 R2/2012/2012 R2), die per VSS-Snapshot vom DPM gesichert werden.

Problem:
Klappt soweit alles prima, mit einer (leider immer wiederkehrenden) Ausnahme:
Wenn ich die Nodes mit Updates versorgt und neu gestartet habe, schlagen reproduzierbar die nächsten Recovery Points auf dem DPM fehl, es folgt immer ein Consistency Check _aller_ VMs im jeweiligen Cluster.

Wir haben auch noch einige Standalone Hyper-V Nodes, bei denen tritt das nicht auf; die kann ich rebooten, wie ich will, die Backups per DPM laufen stressfrei durch, ohne Consistency Check.

VSS-Logs hab ich schon vor und zurück gewälzt, hier gibt es keinerlei Probleme, alles sieht gut aus. Auf dem DPM finde ich ebenfalls keinerlei Hinweise, ausser dieser Standardfehlermeldung:

Damit komme ich allerdings auch nicht weiter, die Ergebnisse einer google-Suche dazu sind sehr diffus und beziehen sich in aller Regel auf Hyper-V 2008 (R2) und DPM 2010.

Den Clustern selbst geht es ebenfalls gut, Validation klappt und auch die Cluster-Logs liefern keine brauchbaren Hinweise.

Hat jemand eine ähnliche Umgebung und kennt dieses Verhalten?

Sachdienliche Hinweise werden dankend entgegengenommen. ;-) face-wink
Grazie Mille!

Cheers,
jsysde
Mitglied: -ricardo-
25.11.2015 um 14:00 Uhr
Ist bei dir das Clusterfähige Aktualisieren aktiv?
Bitte warten ..
Mitglied: jsysde
25.11.2015 um 14:15 Uhr
Moin.
Zitat von @-ricardo-:
Ist bei dir das Clusterfähige Aktualisieren aktiv?
Nope. Wir machen das noch "manuell". :-) face-smile

Cheers,
jsysde
Bitte warten ..
Mitglied: jsysde
26.11.2015 um 09:58 Uhr
Moin.

Habe gestern noch ein wenig "gespielt":
Zwei-Node-Cluster, Node2 leergeräumt und neu gestartet, dann die VMs wieder auf Node2 geschoben. Im DPM einen Recovery Point gemacht => Fehler => Consistency Check. Auf Node1, der nicht neu gestartet wurde, klappen Recovery Points erwartungsgemäss.

Vorher wild VMs zwischen Nodes migriert, VMs neu gestartet, Owner der CSVs geändert - alles ohne Auswirkungen auf's Backup, es liegt also reproduzierbar am Neustart der Cluster-Nodes.

Anyone? ;-) face-wink

Cheers,
jsysde
Bitte warten ..
Mitglied: -ricardo-
26.11.2015 um 12:01 Uhr
Da muss ich passen :D sorry
Bitte warten ..
Mitglied: jsysde
05.01.2016 um 21:23 Uhr
N'Abend.
Zitat von @-ricardo-:
Ist bei dir das Clusterfähige Aktualisieren aktiv?
Habe mich -da ich den Urlaub ja ein wenig produktiv nutzen muss *g*- mal ein wenig in CAU eingelesen und werde mal schauen, ob mir das weiterhilft.

Cheers,
jsysde
Bitte warten ..
Mitglied: jsysde
09.04.2016 um 09:58 Uhr
Moin moin.

So, noch ein bisschen Input von mir, vielleicht hat ja noch jemand ne Idee.
Wir betreiben mehrere Hyper-V Cluster an verschiedenen Standorten, mit unterschiedlicher Hardware.

Der oben beschriebene Fehler tritt nur am Hauptstandort auf, dort ist eine NetApp in Betrieb und der ClusterStorage liegt auf eben dieser. Die Cluster-Nodes sind allesamt DELL Blade Server (M610e, M620e), die allesamt in einer M1000e stecken.

An anderen Standorten laufen die Hyper-V Cluster auf DELL VRTX Systemen -teils Server 2012, teils 2012R2- und dort tritt der Fehler nicht auf.
Auch an den Kleinst-Standorten, an denen nur ein einzelner (DELL) Server als Hyper-V Host läuft und kein Cluster vorhanden ist, tritt kein Fehler auf, wenn ich den Host neugestartet habe.

Ich mutmaße jetzt also, dass es in irgendeiner Form mit der M1000e/den Blade Servern und/oder der NetApp zu tun haben muss - denn das sind die einzigen Unterschiede, die ich im Vergleich zu den anderen Hyper-V Clustern feststellen kann.

Vorschläge? Ideen? Irgendjemand?

Danke und Cheers,
jsysde
Bitte warten ..
Heiß diskutierte Inhalte
Festplatten, SSD, Raid
Festplatte aus defekten Notebook ausgebaut - wird nicht erkannt - Wie gelange ich an meine Daten?
gelöst 1nCoreVor 1 TagFrageFestplatten, SSD, Raid15 Kommentare

Hallo liebe Community, nach 7 Jahren hat mein XMG Notebook seinen Geist aufgegeben In dem Notebook waren zwei Festplatten verbaut (eine für System und ...

Erkennung und -Abwehr
Wie geschickt sich Malware verstecken kann - Ein Beispiel aus der Praxis eines Security Experts
colinardoVor 22 StundenTippErkennung und -Abwehr5 Kommentare

Servus Kollegen und Mitstreiter, da ja in letzter Zeit die Exchange-Lücken die Admin-Landschaft ziemlich aufgewirbelt haben und dabei auch immer mal wieder "sogenannte" Admins ...

Internet
Woher holt sich Android die Kontaktdaten von unbekannten Rufnummern?
gelöst anteNopeVor 1 TagFrageInternet8 Kommentare

Hallo zusammen, seit einiger Zeit merke ich, dass mir mein Android Gerät Namen und Informationen zu mir unbekannten Teilnehmern präsentiert. Soll heißen eine nicht ...

Windows Netzwerk
MS Lizenzierung - externe Scandienstleistung
monstermaniaVor 1 TagFrageWindows Netzwerk9 Kommentare

Hallo Allerseits, ich habe da mal eine Frage an die MS Lizenzspeziallisten. Eine externe Firma soll Scandienstleistungen für uns erledigen. Dazu ist angedacht, dass ...

Exchange Server
Exchange Update CU19 auf CU20 Fehler - Eine weitere Version dieses Produkts ist bereits installiert
gelöst StefanKittelVor 1 TagFrageExchange Server6 Kommentare

Hallo, ich habe hier einen Exchange 2016 mit CU19 (15.1.2176.2). Darauf wollte ich nun CU20 installiert. Download Es erscheint Eine weitere Version dieses Produkts ...

Windows Server
Hat Microsoft die WindowsServerSicherung oder diskpart zerpatcht?
anteNopeVor 17 StundenFrageWindows Server3 Kommentare

Hallo, kann es eventuell sein, dass Microsoft mit seinen letzten Updates die WindowsServerSicherung bzw. diskpart zerschossen hat? Es häufen sich bei mir seit gestern ...

Windows 10
Windows 10 Updates im Abgesicherten Modus nicht möglich!
gelöst Yuuto.LucasVor 1 TagFrageWindows 1016 Kommentare

Hallo, ich habe aktuell ein Problem bei einem Kunden Rechner. Bei diesem gibt es Probleme mit dem Soundkarten Treiber hdaudio.inf wegen dem der PC ...

Windows 10
Lokales Profil wird beim Herunterfahren gelöscht!
Yuuto.LucasVor 1 TagFrageWindows 1011 Kommentare

Hallo, ich habe aktuell folgendes Problem. An einem Kundenrechner ist aktuell ein Lokales Profil eingerichtet (vorher ein Server Profil bei dem das gleiche Problem ...