Top-Themen

Aktuelle Themen (A bis Z)

Administrator.de FeedbackApache ServerAppleAssemblerAudioAusbildungAuslandBackupBasicBatch & ShellBenchmarksBibliotheken & ToolkitsBlogsCloud-DiensteClusterCMSCPU, RAM, MainboardsCSSC und C++DatenbankenDatenschutzDebianDigitiales FernsehenDNSDrucker und ScannerDSL, VDSLE-BooksE-BusinessE-MailEntwicklungErkennung und -AbwehrExchange ServerFestplatten, SSD, RaidFirewallFlatratesGoogle AndroidGrafikGrafikkarten & MonitoreGroupwareHardwareHosting & HousingHTMLHumor (lol)Hyper-VIconsIDE & EditorenInformationsdiensteInstallationInstant MessagingInternetInternet DomäneniOSISDN & AnaloganschlüsseiTunesJavaJavaScriptKiXtartKVMLAN, WAN, WirelessLinuxLinux DesktopLinux NetzwerkLinux ToolsLinux UserverwaltungLizenzierungMac OS XMicrosoftMicrosoft OfficeMikroTik RouterOSMonitoringMultimediaMultimedia & ZubehörNetzwerkeNetzwerkgrundlagenNetzwerkmanagementNetzwerkprotokolleNotebook & ZubehörNovell NetwareOff TopicOpenOffice, LibreOfficeOutlook & MailPapierkorbPascal und DelphiPeripheriegerätePerlPHPPythonRechtliche FragenRedHat, CentOS, FedoraRouter & RoutingSambaSAN, NAS, DASSchriftartenSchulung & TrainingSEOServerServer-HardwareSicherheitSicherheits-ToolsSicherheitsgrundlagenSolarisSonstige SystemeSoziale NetzwerkeSpeicherkartenStudentenjobs & PraktikumSuche ProjektpartnerSuseSwitche und HubsTipps & TricksTK-Netze & GeräteUbuntuUMTS, EDGE & GPRSUtilitiesVB for ApplicationsVerschlüsselung & ZertifikateVideo & StreamingViren und TrojanerVirtualisierungVisual StudioVmwareVoice over IPWebbrowserWebentwicklungWeiterbildungWindows 7Windows 8Windows 10Windows InstallationWindows MobileWindows NetzwerkWindows ServerWindows SystemdateienWindows ToolsWindows UpdateWindows UserverwaltungWindows VistaWindows XPXenserverXMLZusammenarbeit

Hyper-V - VM fährt nicht sauber herunter

Mitglied: KodaCH

KodaCH (Level 1) - Jetzt verbinden

07.12.2019 um 16:15 Uhr, 595 Aufrufe, 11 Kommentare

Hallo zusammen

Ich habe das Problem, wenn der Hypervisor neustartet, oder wenn ich in der Hyper-V Verwaltung eine VM Neustarte, dass diese nicht sauber neugestartet wird.

Dies gibt mir zwei Einträge im Eventlog der VM:
6008: Das System wurde zuvor am ‎07.‎12.‎2019 um 15:37:14 unerwartet heruntergefahren.
41: Das System wurde neu gestartet, ohne dass es zuvor ordnungsgemäß heruntergefahren wurde. Dieser Fehler kann auftreten, wenn das System nicht mehr reagiert hat oder abgestürzt ist oder die Stromzufuhr unerwartet unterbrochen wurde.

Danach erscheint immer die Ereignisanzeige da das System nicht sauber heruntergefahren wurde. Diese erscheint dann aber IMMER. Egal was ich mache.

Ich habe schon vieles gesucht, aber noch keine Lösung gefunden.

Zur Ereignisanzeige habe ich herausgefunden das Windows einen Registry Eintrag nicht sauber herauslöscht. (siehe https://social.technet.microsoft.com/Forums/de-DE/2c86fc85-3994-4e8c-897 ...). Wenn ich diesen Entferne ist wieder gut. Wenn ich dann die VM direkt auf der VM neustarte klappt es und die Meldung kommt nicht mehr. Sobald der Hypervisor neustartet oder ich über die Hyper-V Verwaltung eine VM Neustarte fängt das Spiel wieder von Vorne an.

Unter Integrationsdienste ist folgendes aktiviert:
Herunterfahren des Betriebssystems
Zeitsynchronisierung (Ausser auf dem DC)
Datenaustausch
Takt
Sicherung (Volumenschattenkopie)

Deaktiviert ist Gastdienste (Standardmässig)

Hat ggf jemand einen Lösungsansatz?

Eine Frage nebenbei: Benötigt es die Prüfpunkte wenn die VM's mittels Veeam gesichert werden sollen? Die Prüfpunkte habe ich aktuell deaktiviert und keine Probleme feststellen können.

Gruss und Danke

Koda
Mitglied: Henere
07.12.2019 um 17:43 Uhr
Servus. Um welche Gastbetriebssysteme handelt es sich ?
Typ1 oder Typ2 Gäste ?

Henere
Bitte warten ..
Mitglied: keine-ahnung
07.12.2019 um 19:34 Uhr
Moin,

Hyper-V 2008? Gastbetriebssysteme Win 3.1? In dieser Kombi ist das Problem bekannt und als unlösbar deklariert ...

Unter Integrationsdienste ist folgendes aktiviert:
Zeitsynchronisierung (Ausser auf dem DC)

Warum macht man sowas?

LG, Thomas
Bitte warten ..
Mitglied: KodaCH
07.12.2019 um 21:52 Uhr
Guten Abend

Bitte entschuldigt. Windows Server 2016. Es sind Generation 2 VM's. Gastbetriebssysteme sind Linux und Windows, aber die Ereignisanzeige nach dem Neustart ist bei Windows (Gibt es das bei Linux überhaupt?)

Warum macht man was? Die Zeitsynchronisierung deaktivieren? Weil ich das mal so gelernt habe und auch sogar in mehreren Tutorials zu lesen ist das bei einem Virtualisierten DC die Zeitsynchronisation deaktiviert werden sollte da die beiden DCs als Zeitgeber fungieren. Oder hab eich deine Frage falsch verstanden?

Gruss

Koda
Bitte warten ..
Mitglied: Henere
07.12.2019 um 23:24 Uhr
Je nach Linux musst Du noch die Gast-Treiber installieren.
Hier als Beispiel für Ubuntu:
https://decatec.de/home-server/ubuntu-server-18-04-lts-als-hyper-v-gasts ...

Für Windows braucht es keine Treiber.

Kann es sein, dass Deine HDDs zu langsam sind und die VMs daher in den Runterfahrtimeout laufen und dann vom Host abgeschaltet werden ? Was passiert, wenn Du die vor dem Neustart des Bleches einzeln herunterfährst ?
Bitte warten ..
Mitglied: KodaCH
08.12.2019 um 07:26 Uhr
Danke für deine Antwort.

Das System läuft auf SSD Festplatten die schnell genug sind. Selbst wenn ich in der Hyper-V Verwaltung nur mal einen Server neustarte gibt es das selbe Problem.

Gruss

Koda
Bitte warten ..
Mitglied: Dani
08.12.2019 um 13:54 Uhr
Moin,
Eine Frage nebenbei: Benötigt es die Prüfpunkte wenn die VM's mittels Veeam gesichert werden sollen? Die Prüfpunkte habe ich aktuell deaktiviert und keine Probleme feststellen können.
Kannst du hier nachlesen.

Warum macht man was? Die Zeitsynchronisierung deaktivieren? Weil ich das mal so gelernt habe und auch sogar in mehreren Tutorials zu lesen ist das bei einem Virtualisierten DC die Zeitsynchronisation deaktiviert werden sollte da die beiden DCs als Zeitgeber fungieren
So ist, die Zeitsyncronisation soll auf jeder VM deaktiviert werden!

Je nach Linux musst Du noch die Gast-Treiber installieren.
Hier als Beispiel für Ubuntu:
https://decatec.de/home-server/ubuntu-server-18-04-lts-als-hyper-v-gasts ...
Primär immer an das Doc von Hersteller halten.

Ich habe das Problem, wenn der Hypervisor neustartet...
Hast du in den Einstellungen der VMs angegeben, dass diese heruntergefahren werden sollen?

...oder wenn ich in der Hyper-V Verwaltung eine VM Neustarte, dass diese nicht sauber neugestartet wird.
Da bin ich mir nicht sicher, ob ein Neustart nicht einfach ein Cold Boot ist. Evtl. kann das jemand bestätigen bzw. prüfen.


Gruß,
Dani
Bitte warten ..
Mitglied: KodaCH
08.12.2019 um 15:18 Uhr
Danke für deine Antworten. Aktuell ist die Standardaktion auf Stopppen eingestellt. Ich werde es aber mal mit Herunterfahren versuchen.
Bitte warten ..
Mitglied: Spirit-of-Eli
08.12.2019 um 16:50 Uhr
Zitat von Dani:
Da bin ich mir nicht sicher, ob ein Neustart nicht einfach ein Cold Boot ist. Evtl. kann das jemand bestätigen bzw. prüfen.

Das ist zumindest ohne Gastintegration ein Cold-Boot. Daher würde ich die Funktion nicht einsetzen.
Wenn die Option "Herunterfahren" gewählt ist, fahren die VMs herunter. Windows Server zeigen danach nur das Popup fürs unerwartete Herunterfahren an. Ist aber nicht weiter tragisch.

Fährt man den gesamten Host runter, wartet dieser bis die VMs beendet sind wenn die Option zum Herunterfahren gesetzt ist.
Bitte warten ..
Mitglied: Dani
08.12.2019 um 17:50 Uhr
Moin,
Danke für deine Antworten. Aktuell ist die Standardaktion auf Stopppen eingestellt.
die Aktion "Stoppen" ist vergleichbar mit dem Rechner den Stromstecken ziehen. Dahre auch die Meldung nachdem Hochfahren der VMs, dass das System nicht sauber heruntergefahren wurde.
Bitte warten ..
Mitglied: Dani
08.12.2019 um 17:50 Uhr
@Spirit-of-Eli
Das ist zumindest ohne Gastintegration ein Cold-Boot. Daher würde ich die Funktion nicht einsetzen.
Das ist klar. Die Frage ist doch, ob Guest Services etwas am den Verhalten ändert - ich meine nämlich nicht.


Gruß,
Dani
Bitte warten ..
Mitglied: Spirit-of-Eli
08.12.2019, aktualisiert um 18:06 Uhr
Ich meine das zumindest eine Windows VM neustartet. Müsste ich auch testen.

Edit: Habe es gerade getestet. Das führt immer zu einem Cold-Boot.
Bitte warten ..
Ähnliche Inhalte
Hyper-V
Hyper-V VM Umzug
Frage von BytedreherHyper-V3 Kommentare

Hallo zusammen, ich möchte meinen virtuellen DC (Server2012) von aktuell Hyper-V Host (Server2012) auf meinen neuen Hyper-V Host (Server2012R2) ...

Hyper-V
Hyper V VM verkleinern
gelöst Frage von bytetixHyper-V2 Kommentare

Hallo zusammen, einer unserer Hyper V Hostserver hat nur noch 150 GB freien Space, daher wollte ich von einer ...

Hyper-V
Netzwerkaussetzer in Hyper-V VM
gelöst Frage von SnuffchenHyper-V8 Kommentare

Hallo zusammen, ich habe hier eine Testmaschine mit Intel Xeon E5 2620 v2 auf einem Supermicro X9SRRH-7F/7TF Mainboard. Netzwerkkarte ...

Hyper-V
Hyper-V Einstellungen Arbeitsspeicher VM
gelöst Frage von MartyMcFlurry90Hyper-V4 Kommentare

Hallo alle zusammen! Ich sitze gerade vor dem Hyper-V und stelle mir eine Frage bei der ich in TechNet ...

Neue Wissensbeiträge
Viren und Trojaner
Emotet: IT-Totalschaden beim Kammergericht Berlin
Information von StefanKittel vor 1 TagViren und Trojaner7 Kommentare

Interne Daten wurden geklaut und "ein kompletter Neuaufbau der IT-Infrastruktur wird angeraten", heißt es im forensischen Bericht zum ...

Viren und Trojaner
Avast verkauft anscheinend browserdaten
Tipp von magicteddy vor 1 TagViren und Trojaner14 Kommentare

Moin, da es immer wieder Anfragen zu Virenscannern gibt denke ich das der Artikel von Heise Avast verkauft Bowserdaten ...

Router & Routing

Statische Route dauerhaft einrichten unter Ubuntu 18.04 LTS

Erfahrungsbericht von the-buccaneer vor 3 TagenRouter & Routing2 Kommentare

"Kann ja nicht so schwer sein, unter Ubuntu 18.04 LTS ne statische Route einzurichten", denkt der Windows-Admin und gelegentliche ...

Microsoft

Effect on customer websites and Microsoft services and products in Chrome version 80 or later

Information von Dani vor 3 TagenMicrosoft

Guten Abend zusammen, The Stable release of the Google Chrome web browser (build 80, scheduled for release on February ...

Heiß diskutierte Inhalte
LAN, WAN, Wireless
Installation USG
Frage von jo23487LAN, WAN, Wireless47 Kommentare

Hallo zusammen, nach den beiden anderen Fragen habe ich mir den Cloud Key und auch ein USG gekauft - ...

Microsoft
All-Cloud für KMU (Management, Backup, etc.)
Frage von NRGNRGMicrosoft20 Kommentare

Hallo zusammen, kurze Interessensfrage an Euch in die Runde, da ich hierzu gerade interessante Diskussionen mit Kollegen habe: Szenario: ...

Router & Routing
NAS im VPN zu langsam mit FritzBox 7490
Frage von holger3208Router & Routing19 Kommentare

Hallo, ich habe eine Telekom VDsl Leitung mit einer 50/10 Leitung. Einen Qnap NAS TS-231P2 (4GB RAM) Eine FritzBox ...

TK-Netze & Geräte
Empfehlung DSL Modem
Frage von CorraggiounoTK-Netze & Geräte18 Kommentare

Hi Leute, könntet ihr mir eine Empfehlung für ein DSL Modem aussprechen? Provider ist die Telekom dahinter steht gleich ...