jsysde
Goto Top

JRE8u65 - exe installiert sich silent?

N'Abend.

Wollte heute wie gewohnt die MSI aus der .exe von JRE extrahieren (fürs Deployment per SCCM), also den Offline-Installer von JRE 8 Update 65 (i586, also 32-Bit) runtergeladen und die .exe "als Administrator" ausgeführt. Und dann staunte ich nicht schlecht:
Das Setup läuft ohne jede weitere Nachfrage durch und installiert u65 zusätzlich zur bereits vorhandenen JRE8u60!

Mein erster Gedanken war nun:
Beim Deployment von u60 bestimmt was nicht so gelaufen, wie es sollte, daher läuft das Ding jetzt einfach durch (getestet auf nem Win7 Pro SP1 x64).
Also jetzt hier daheim unter Windows 10 Pro die runtergeladene .exe "als Administrator" ausgeführt (mein Rechner hier hat noch nie JAVA gesehen!) und auch hier das gleiche Spiel, Installation erfolgt sofort ohne weitere Nachfrage und Installationsdialog!

Ich bin grad etwas ratlos. Kann dieses Verhalten jemand bestätigen/reproduzieren?

Thx and Cheers,
jsysde

Content-Key: 286277

Url: https://administrator.de/contentid/286277

Printed on: February 25, 2024 at 04:02 o'clock

Member: Kuemmel
Kuemmel Oct 21, 2015 at 20:08:05 (UTC)
Goto Top
Hi,
kann ich mysteriöserweise genau so bestätigen! Offline-Installer der aktuellen Version geladen, doppelklick auf die .exe, Admin-Benutzer angegeben und dann nichts weiter. Nach einem Blick auf Systemsteuerung-> Programme ist die Version in der Liste vorhanden!
Ob das gewollt ist? Ein Statement habe ich bis dato nicht gefunden! Aber irgendwie auch beruhigend das ich nicht der Einzige bin! face-smile

Gruß
Kümmel
Member: Meierjo
Meierjo Oct 22, 2015 at 06:57:41 (UTC)
Goto Top
Hallo

Kann ich so bei mir nicht bestätigen.
Windows 7 / 64 Bit Professional, Domänen-Rechner.

Ein Doppelclick auf die jre-8u65-windows-i586.exe, öffnet wie gewohnt
991afd1c7d8b937a584d1b9bd4f160cc

Nach einem Klick auf ausführen
9b66c46a8ee8365b0c872e3d4385a161

Dann ist, wie gewohnt die MSI in "c:\Users\%username%\AppData\LocalLow\Oracle\Java\jre1.8.0_65\jre1.8.0_65.msi zu finden.

Allerdings muss ich hier nicht "Ausführen als Administrator" wählen, da ich auf dem Rechnet Admin Rechte besitze.

Gruss Urs
Member: jsysde
jsysde Oct 22, 2015 at 07:42:39 (UTC)
Goto Top
Moin.
Zitat von @Kuemmel:
kann ich mysteriöserweise genau so bestätigen!
Danke, hab' schon an mir gezweifelt.

Ob das gewollt ist?
Ich hoffe nicht - wobei ich Oracle alles zutraue.

Cheers,
jsysde
Member: jsysde
jsysde Oct 22, 2015 at 07:45:18 (UTC)
Goto Top
Moin.
Zitat von @Meierjo:
Allerdings muss ich hier nicht "Ausführen als Administrator" wählen, da ich auf dem Rechnet Admin Rechte besitze.
Ich habe alle Varianten durchprobiert:
-Admin-User und einfach doppelklicken
-Admin-User und Rechtsklick => Als Admin....
-Standard-User und Rechtsklick => Als Admin...
-UAC an/aus mit den drei Kombinationen

Das Ergebnis ist überall gleich, ganz egal, ob der Rechner zum AD gehört oder nicht, ganz egal, ob er schon mal JRE installiert hatte oder nicht, .... - es ist zum Mäusemelken! face-confused-alt

Cheers,
jsysde
Member: jsysde
jsysde Nov 17, 2015 at 11:02:27 (UTC)
Goto Top
Moin.

Um das hier zum Abschluss zu bringen:
Installation läuft silent durch, aber danach gibt's unter \user\username\appdata\locallow\Oracle\Java entsprechende Ordner samt MSI-Files darin. Und mit diesen MSI-Files klappt auch das Deployment beinah wie gewohnt.

JRE8 deinstalliert im Gegensatz zu JRE7 die Vorgängerversionen _NICHT!_ mehr automatisch, daher habe ich mein Skript entsprechend angepasst und entferne einfach alle installierten JRE-Versionen, bevor ich das jeweils aktuelle Paket ausrolle.

Cheers,
jsysde