Top-Themen

Aktuelle Themen (A bis Z)

Administrator.de FeedbackApache ServerAppleAssemblerAudioAusbildungAuslandBackupBasicBatch & ShellBenchmarksBibliotheken & ToolkitsBlogsCloud-DiensteClusterCMSCPU, RAM, MainboardsCSSC und C++DatenbankenDatenschutzDebianDigitiales FernsehenDNSDrucker und ScannerDSL, VDSLE-BooksE-BusinessE-MailEntwicklungErkennung und -AbwehrExchange ServerFestplatten, SSD, RaidFirewallFlatratesGoogle AndroidGrafikGrafikkarten & MonitoreGroupwareHardwareHosting & HousingHTMLHumor (lol)Hyper-VIconsIDE & EditorenInformationsdiensteInstallationInstant MessagingInternetInternet DomäneniOSISDN & AnaloganschlüsseiTunesJavaJavaScriptKiXtartKVMLAN, WAN, WirelessLinuxLinux DesktopLinux NetzwerkLinux ToolsLinux UserverwaltungLizenzierungMac OS XMicrosoftMicrosoft OfficeMikroTik RouterOSMonitoringMultimediaMultimedia & ZubehörNetzwerkeNetzwerkgrundlagenNetzwerkmanagementNetzwerkprotokolleNotebook & ZubehörNovell NetwareOff TopicOpenOffice, LibreOfficeOutlook & MailPapierkorbPascal und DelphiPeripheriegerätePerlPHPPythonRechtliche FragenRedHat, CentOS, FedoraRouter & RoutingSambaSAN, NAS, DASSchriftartenSchulung & TrainingSEOServerServer-HardwareSicherheitSicherheits-ToolsSicherheitsgrundlagenSolarisSonstige SystemeSoziale NetzwerkeSpeicherkartenStudentenjobs & PraktikumSuche ProjektpartnerSuseSwitche und HubsTipps & TricksTK-Netze & GeräteUbuntuUMTS, EDGE & GPRSUtilitiesVB for ApplicationsVerschlüsselung & ZertifikateVideo & StreamingViren und TrojanerVirtualisierungVisual StudioVmwareVoice over IPWebbrowserWebentwicklungWeiterbildungWindows 7Windows 8Windows 10Windows InstallationWindows MobileWindows NetzwerkWindows ServerWindows SystemdateienWindows ToolsWindows UpdateWindows UserverwaltungWindows VistaWindows XPXenserverXMLZusammenarbeit

gelöst Linux und Internet

Mitglied: Ghostman27185

Ghostman27185 (Level 1) - Jetzt verbinden

23.07.2011, aktualisiert 18.10.2012, 3586 Aufrufe, 11 Kommentare

Hallo,

eine kurze frage bitte,

wie ist es möglich das ich meinen Linuxrechner mit CentOs 6 als NAT benützen kann, ich aber auf dem Rechner selber kein Internet habe ?

Konfiguration:

eth0 - 192.168.0.254 - hängt am Internet bzw. Router 192.168.0.1
-I-

LINUX Rechner mit CentOS 6 als NAT mit Firewall

-I-
eth1- 10.10.10.254 - CoreLan für Virtuelle Netzwerkumgebung



subnetz 1 #10.10.10.2 - Router 1 - 192.168.100.0 => DC - FS - EX


subnetz 2 #10.10.10.3 - Router 2 - 192.168.200.0 => -DHCP WIRLESS für CLIENTS-


ps: ich schreibe geradeaus einem der subnetze... also hab ich ja I-net
Mitglied: Ghostman27185
24.07.2011 um 12:04 Uhr
Das hilft mir leider auch nicht weiter! ich weis was ich konfigurieren muss ich hab nur das komische Phänomen das ich im Netzwerk dahinter internetzugriff habe aber nicht vom Linux/NAT aus selber!
Ich habe die beiden datein in /etc/sysconfig/network-scripts/ifcfg-eth0 und eth1 mit BOOTPROTO="static" ; GATEWAY=192.168.0.1; IPADDR=192.168.0.254 für eth0 und 10.10.10.254.für eth1
in der resolv.conf habe ich beide DNS Server eingegeben intern und extern vom anbieter!
in der sysctl.conf wurde der parameter auf 1 gesetzt
die iptables wurden zur packet weiterleitung konfiguriert!
ich kann zb. die 213.153.32.129 pingen...... komm aber nicht ins inet
Bitte warten ..
Mitglied: aqui
24.07.2011 um 12:24 Uhr
Kannst du denn den Internet Router an der 192.168.0.1 anpingen ?
Was sagt ein Traceroute und ein Ping auf eine nackte IP Adresse im Internet z.B. heise.de mit der 193.99.144.85 ??
Bitte warten ..
Mitglied: Ghostman27185
24.07.2011 um 13:00 Uhr
Hallo,

ja kann ich alles anpingen

httpd dienst laüft auch er meldet zwar "Could not reliably determine the server´s fully quallity domain name, using ::1 for server name" aber das dürfte egal sein....
ich kann von meinem Virtuellen router der auf der IP 10.10.10.2 steht die IP 192.168.0.1 anpingen aber nicht die 193.99.144.85...
und ich kann vom linux aus also 192.168.0.254 die 193.99.144.85 anpingen nathürlich auch die 192.168.0.1

Danke schon mal in voraus...
Bitte warten ..
Mitglied: aqui
24.07.2011 um 16:22 Uhr
OK, wenn du das alles anpingen kannst ist das keinesfalls ein Netzwerkproblem, hat also mit der IP Connectivity rein gar nichts zu tun sonst könntest du diese Internet IP nicht erreichen !
Ins Internet kommst du also...in so fern ist deine o.a.Behauptung "...ich kann zb. die 213.153.32.129 pingen...... komm aber nicht ins inet" also schlicht falsch bzw. Unsinn, denn du kommst ja ins Internet wie man an den öffentlichen Internet IPs ganz klar sehen kann !
Wenn du von den 10er Subnetzen bzw. mit einen 10er Absender IP nicht pingen kannst, dann werden die 10er Adressen vermutlich im NAT ignoriert. Oder...wenn du kein NAT im Linux machst durch fehlende statische Routen im Internet Router (siehe Tutorial !)
Die Frage ist jetzt ob du nativ routest auf dem Linux Rechner ohne NAT oder ob du dort am 192.168.0.254er Interface auch NAT machst für alle lokalen Subnetze, damit der Internet Router rein gar nichts von diesen Subnetzen sieht.
In der Beziehung ist deine Beschreibung sehr schwammig...
Machst du NAT am 192.168.0.254er Interface am Linux Host, dann musst du in den IP tables natürlich logischerweise das Masquerading für alle diese Subnetze die hinter dem 192.168.0.254er Interface liegen aktivieren, sonst wird das ignoriert und nativ geroutet.
Wenn du dann am Internet Router 192.168.0.1 keine statischen Routen in diese Subnetze mit dem Next Hop 192.168.0.254 eingetragen hast (siehe Tutorial) gehen deine Pakete aus diesen Subnetzen ins Nirwana mit dem Effekt den du siehst....
Wie gesagt...die Kardinalsfrage ist NAT oder nicht NAT aktiviert am Linux Rechner ??
Im Zeifelsfall einen Wireshark Sniffer in das 192.168.0er Segment zum Internet Router klemmen und die Pakete aus diesen 10er Absender Subnetzen ansehen wenn die da durch laufen !
Dann siehst du es sofort schwarz auf weiss !
Bitte warten ..
Mitglied: Lochkartenstanzer
24.07.2011 um 17:17 Uhr
  • Routingtabellen überprüfen.
  • NAT-regeln checken.
  • iptables durchchecken. Eventuell ist da alles bis auf die Grundfunktionen (z.B. ICMP) geblockt.
Bitte warten ..
Mitglied: Ghostman27185
24.07.2011 um 18:11 Uhr
Tut mir leid das meine Beschreibung Mist ist, ich arbeite noch nicht lange auf Linux.... dahinter (hinter 10.10.10.254 also im Servernetzwerk befinden sich an den Subnetzknoten jeweils 2 virtuelle Server die als Router fungieren, diese verständigen sich untereinander mit RIP v2, am LINUX NAT selber wurde die datei route-eth1 erstellt in der die 2 subnetze beschrieben sind und ja es steht ne 1 in der ip_forward.....
Und was ich mit ich komm nicht ins internet gemeint habe ist "Über meinen Webbrowser läuft nichts" !!!
Bitte warten ..
Mitglied: Lochkartenstanzer
24.07.2011 um 21:30 Uhr
Zitat von Ghostman27185:
Und was ich mit ich komm nicht ins internet gemeint habe ist "Über meinen Webbrowser läuft nichts" !!!

Was passiert, wenn Du
 telnet server.den.du.erreichen.willst.tld 80 
oder
 nmap -p 80  server.den.du.erreichen.willst.tld 
eintippst? Klappt die Verbindung, oder was gibt nmap aus?
Bitte warten ..
Mitglied: aqui
26.07.2011 um 15:39 Uhr
Sind mit 99%ider Sicherheit die NAT (Masquerading) Regeln die in den iptables fehlen für diese Subnetze !
Bitte warten ..
Mitglied: Ghostman27185
27.07.2011 um 15:41 Uhr
Hallo,

ich hatte 3 nameserver in der resolv.conf stehn.
ich habe den internen gelöscht - und momentan ging es!

komisch das er da einen routing fehler macht?

Danke für die guten tipps.
Bitte warten ..
Ähnliche Inhalte
Linux Tools
Linux übers Internet starten
gelöst Frage von winlinLinux Tools10 Kommentare

ist es möglich ein LinuxOS über eine Website zu starten? Sprich kann ich in einem Browser ne Adresse eingeben ...

Linux Netzwerk

Linux CentOS DNS: Failed to start Berkeley Internet Name Domain (DNS)

Frage von Patrick-ITLinux Netzwerk3 Kommentare

Hallo zusammen, ich habe mir auf dem CentOS7 einen DNS Server aufgesetzt und konfiguriert, leider startet dieser nicht, wenn ...

Samba

Linux Server und Windows Linux Client

gelöst Frage von 137898Samba17 Kommentare

Hallo, ich bräuchte dringend bei der Aufgabe etwas Hilfe. Die Firma XYZ besteht auf zwei Abteilungen Logistik und Technik ...

Debian

Linux Tablet

gelöst Frage von djevil-adDebian12 Kommentare

Hi, ich möchte mir gerne ein günstiges, gebrauchtes Tablet (50€) in der Bucht schiessen, auf dem ich ein BELIEBIGES ...

Neue Wissensbeiträge
Internet

CDU Propaganda: Urheberschutz im Internet - Ende des digitalen Wild-West

Information von Frank vor 19 StundenInternet3 Kommentare

Hallo Administratoren, aus einem Kommentar heraus habe ich folgenden Beiträge von Herr Sven Schulze und Axel Voss (beide CDU ...

Router & Routing

Zyxel VMG 1312 B30A - Firmwareupdate nur im "privaten" Firefox Modus möglich

Tipp von the-buccaneer vor 1 TagRouter & Routing2 Kommentare

Hatte hier ein Zyxel 1312 das ums verrecken kein Firmwareupdate durchführen wollte. Datei ist auswählbar, dann kommt der Fortschrittskreisel ...

Windows 7

Windows 7 u. Server 2008 (R2) SHA-2-Update kommt am 12. März 2019

Information von kgborn vor 2 TagenWindows 75 Kommentare

Kleine Info für die Admins der oben genannten Maschinen. Ab Juli 2019 werden Updates von Microsoft nur noch mit ...

Firewall
PfSense 2.5.0 benötigt doch kein AES-NI
Information von ChriBo vor 4 TagenFirewall2 Kommentare

Hallo, Wie sich einige hier erinnern werden hat Jim Thompson in diesem Aritkel beschrieben, daß ab Version 2.5.0 ein ...

Heiß diskutierte Inhalte
Hardware
PC im Selbstbau, Workstation, mittelklasse Gaming
gelöst Frage von MrRobot1997Hardware21 Kommentare

Hallöchen Leute, ich bin seit einigen Jahren leider nicht mehr wirklich im Bild, wenn es um die Hardware und ...

Datenbanken
PHP Fatal error: Uncaught Error: Call to undefined function oci connect
Frage von PlanitecXDatenbanken20 Kommentare

Hallo Zusammen, ich sitze seit Tagen am Problem das ich keine PHP Anwendung mit Anbindung zu Oracle zum laufen ...

Hardware
Welchen Shop Großhandel für EDV?
Frage von opc123Hardware17 Kommentare

Hallo, ich finde kein passendes Thema. Ich suche einen Großhändler für alltägliche EDV Ausstattung: Ethernet Kabel, Switche, Stromverteiler, Handy´s, ...

Windows Server
User auf Server Install-Rechte geben
gelöst Frage von killtecWindows Server17 Kommentare

Hi, ich möchte auf mehreren W2016 Servern einem bestimmten User das Recht zum Installieren von Programmen geben. Er soll ...