Linux und Internet

Mitglied: Ghostman27185

Ghostman27185 (Level 1) - Jetzt verbinden

23.07.2011, aktualisiert 18.10.2012, 3621 Aufrufe, 11 Kommentare

Hallo,

eine kurze frage bitte,

wie ist es möglich das ich meinen Linuxrechner mit CentOs 6 als NAT benützen kann, ich aber auf dem Rechner selber kein Internet habe ?

Konfiguration:

eth0 - 192.168.0.254 - hängt am Internet bzw. Router 192.168.0.1
-I-

LINUX Rechner mit CentOS 6 als NAT mit Firewall

-I-
eth1- 10.10.10.254 - CoreLan für Virtuelle Netzwerkumgebung



subnetz 1 #10.10.10.2 - Router 1 - 192.168.100.0 => DC - FS - EX


subnetz 2 #10.10.10.3 - Router 2 - 192.168.200.0 => -DHCP WIRLESS für CLIENTS-


ps: ich schreibe geradeaus einem der subnetze... also hab ich ja I-net
Mitglied: Ghostman27185
24.07.2011 um 12:04 Uhr
Das hilft mir leider auch nicht weiter! ich weis was ich konfigurieren muss ich hab nur das komische Phänomen das ich im Netzwerk dahinter internetzugriff habe aber nicht vom Linux/NAT aus selber!
Ich habe die beiden datein in /etc/sysconfig/network-scripts/ifcfg-eth0 und eth1 mit BOOTPROTO="static" ; GATEWAY=192.168.0.1; IPADDR=192.168.0.254 für eth0 und 10.10.10.254.für eth1
in der resolv.conf habe ich beide DNS Server eingegeben intern und extern vom anbieter!
in der sysctl.conf wurde der parameter auf 1 gesetzt
die iptables wurden zur packet weiterleitung konfiguriert!
ich kann zb. die 213.153.32.129 pingen...... komm aber nicht ins inet
Bitte warten ..
Mitglied: aqui
24.07.2011 um 12:24 Uhr
Kannst du denn den Internet Router an der 192.168.0.1 anpingen ?
Was sagt ein Traceroute und ein Ping auf eine nackte IP Adresse im Internet z.B. heise.de mit der 193.99.144.85 ??
Bitte warten ..
Mitglied: Ghostman27185
24.07.2011 um 13:00 Uhr
Hallo,

ja kann ich alles anpingen

httpd dienst laüft auch er meldet zwar "Could not reliably determine the server´s fully quallity domain name, using ::1 for server name" aber das dürfte egal sein....
ich kann von meinem Virtuellen router der auf der IP 10.10.10.2 steht die IP 192.168.0.1 anpingen aber nicht die 193.99.144.85...
und ich kann vom linux aus also 192.168.0.254 die 193.99.144.85 anpingen nathürlich auch die 192.168.0.1

Danke schon mal in voraus...
Bitte warten ..
Mitglied: aqui
24.07.2011 um 16:22 Uhr
OK, wenn du das alles anpingen kannst ist das keinesfalls ein Netzwerkproblem, hat also mit der IP Connectivity rein gar nichts zu tun sonst könntest du diese Internet IP nicht erreichen !
Ins Internet kommst du also...in so fern ist deine o.a.Behauptung "...ich kann zb. die 213.153.32.129 pingen...... komm aber nicht ins inet" also schlicht falsch bzw. Unsinn, denn du kommst ja ins Internet wie man an den öffentlichen Internet IPs ganz klar sehen kann !
Wenn du von den 10er Subnetzen bzw. mit einen 10er Absender IP nicht pingen kannst, dann werden die 10er Adressen vermutlich im NAT ignoriert. Oder...wenn du kein NAT im Linux machst durch fehlende statische Routen im Internet Router (siehe Tutorial !)
Die Frage ist jetzt ob du nativ routest auf dem Linux Rechner ohne NAT oder ob du dort am 192.168.0.254er Interface auch NAT machst für alle lokalen Subnetze, damit der Internet Router rein gar nichts von diesen Subnetzen sieht.
In der Beziehung ist deine Beschreibung sehr schwammig... :-( face-sad
Machst du NAT am 192.168.0.254er Interface am Linux Host, dann musst du in den IP tables natürlich logischerweise das Masquerading für alle diese Subnetze die hinter dem 192.168.0.254er Interface liegen aktivieren, sonst wird das ignoriert und nativ geroutet.
Wenn du dann am Internet Router 192.168.0.1 keine statischen Routen in diese Subnetze mit dem Next Hop 192.168.0.254 eingetragen hast (siehe Tutorial) gehen deine Pakete aus diesen Subnetzen ins Nirwana mit dem Effekt den du siehst....
Wie gesagt...die Kardinalsfrage ist NAT oder nicht NAT aktiviert am Linux Rechner ??
Im Zeifelsfall einen Wireshark Sniffer in das 192.168.0er Segment zum Internet Router klemmen und die Pakete aus diesen 10er Absender Subnetzen ansehen wenn die da durch laufen !
Dann siehst du es sofort schwarz auf weiss !
Bitte warten ..
Mitglied: Lochkartenstanzer
24.07.2011 um 17:17 Uhr
  • Routingtabellen überprüfen.
  • NAT-regeln checken.
  • iptables durchchecken. Eventuell ist da alles bis auf die Grundfunktionen (z.B. ICMP) geblockt.
Bitte warten ..
Mitglied: Ghostman27185
24.07.2011 um 18:11 Uhr
Tut mir leid das meine Beschreibung Mist ist, ich arbeite noch nicht lange auf Linux.... dahinter (hinter 10.10.10.254 also im Servernetzwerk befinden sich an den Subnetzknoten jeweils 2 virtuelle Server die als Router fungieren, diese verständigen sich untereinander mit RIP v2, am LINUX NAT selber wurde die datei route-eth1 erstellt in der die 2 subnetze beschrieben sind und ja es steht ne 1 in der ip_forward.....
Und was ich mit ich komm nicht ins internet gemeint habe ist "Über meinen Webbrowser läuft nichts" !!!
Bitte warten ..
Mitglied: Lochkartenstanzer
24.07.2011 um 21:30 Uhr
Zitat von @Ghostman27185:
Und was ich mit ich komm nicht ins internet gemeint habe ist "Über meinen Webbrowser läuft nichts" !!!

Was passiert, wenn Du
oder
eintippst? Klappt die Verbindung, oder was gibt nmap aus?
Bitte warten ..
Mitglied: aqui
26.07.2011 um 15:39 Uhr
Sind mit 99%ider Sicherheit die NAT (Masquerading) Regeln die in den iptables fehlen für diese Subnetze !
Bitte warten ..
Mitglied: Ghostman27185
27.07.2011 um 15:41 Uhr
Hallo,

ich hatte 3 nameserver in der resolv.conf stehn.
ich habe den internen gelöscht - und momentan ging es!

komisch das er da einen routing fehler macht?

Danke für die guten tipps.
Bitte warten ..
Heiß diskutierte Inhalte
LAN, WAN, Wireless
8 Geräte - verteilen oder auf einen Switch?
DoKi468Vor 1 TagFrageLAN, WAN, Wireless13 Kommentare

Hallo liebe Admins, eine kurze Frage: Ich habe hier eine FB 6190 Cable stehen sowie einen noch unmonitored switch mit 8 Anschlüssen. Momentan sieht ...

Microsoft
Mitteilung an alle bei Störungen in der IT
gelöst David.B2D45Vor 5 StundenFrageMicrosoft18 Kommentare

Hallo Forum, ich bin auf der Suche nach einem Programm / Tool mit dem ich Text (Laufschrift) auf allen (gewünschten) PC's / Benutzer im ...

LAN, WAN, Wireless
"Ethernet verfügt über keine gültige IP-Konfiguration"
gelöst archITVor 1 TagFrageLAN, WAN, Wireless18 Kommentare

Moin, folgendes Problem: Jedes mal, wenn ich meinen PC an mache, muss ich die Problembehandlung auf der Ethernet schnittstelle ausführen, dass ich Internet habe. ...

Microsoft
PDF editor mit spezieller exportfunktion
FlorianHeVor 1 TagFrageMicrosoft10 Kommentare

Hi leute. Ich habe eine Frage. Bei uns in der Instandhaltung kommt es oft vor das wir änderungen an den Elektrischen Anlagen oder Mechanichen ...

TK-Netze & Geräte
Umstellung von ISDN auf VoIP, 4 Sprachkanäle über 2 DSL-Anschlüsse
Gohla2019Vor 21 StundenFrageTK-Netze & Geräte14 Kommentare

Hallo, ich brauche einmal etwas Hilfestellung bei einer geplanten Umstellung einer Telefon-Installation von ISDN-Technik auf VoIP. Vor Ort gibt es zurzeit 2 ISDN-Leitungen, so ...

Switche und Hubs
Ist bei einem kleinen Switch Rackmount Kit dabei?
CubeHDVor 1 TagFrageSwitche und Hubs5 Kommentare

Hallo, ich möchte den "HPE OfficeConnect 1420 16G Switch" kaufen. Der Switch hat 16 Ports und ich möchte diesen in einen Standard 19 Zoll ...

LAN, WAN, Wireless
Verbindung 10GB mit Switch
Heimerdinger1000Vor 1 TagFrageLAN, WAN, Wireless4 Kommentare

Hallo, ich habe ein merkwürdiges Problem, welches ich mir nicht erklären kann. Ausgangssituation: Ich habe 2 Rechner mit 10GB-Netzwerkkarten über einen 10GB-Switch angebunden. Kopiere ...

Backup
Ich suche ein cloudbasiertes Backup für Linux-Web-Server mit zentraler Verwaltung und Deduplizierung
EDVMan27Vor 1 TagFrageBackup4 Kommentare

Hallo, ich suche für eine handvoll Web-Server eine 2. Datensicherung. Die Server sind gemischt, meist aber Ubuntu. Ich habe über Vollzugriff per SSH als ...