backara
Goto Top

Mails werden immer und immer wieder versandt

Mails kommen anscheinend immer und immer wieder an obwohl nur einmal versandt wurde

Hallo Gemeinde und einen guten Morgen

Ich habe hier massiv Emailprobleme.

Erstmal den Weg den unsere Mails nehmen.
Clientrechner versendet per Outlook 2007 (IMAP) mails an unseren internen Mailserver (MDaemon) dieser wiederum gibt die Mails weiter an Hosteurope Virtual Server per SMTP Dienst.
Der MDaemonserver selbst ist auch der Proxy und das Gateway.

Soweit so gut.

Jetzt das Problem:

ich habe ein seltsames Phänomen dem ich gedanklich nicht folgen kann und somit auch keine Lösung weiß. Ich habe vor mehreren Wochen eine email mit meinem Outlok 2007 an ca 30 Empfänger BCC versandt. Diese mail scheint bei den meisten Empfängern 5 - 30 mal angekommen zu sein.
Jetzt scheint das wieder aufzutreten. Mit einem Unterschied: Der SMTP Dienst auf Hosteurope ist nicht aktiv wegen einem Fehler. Unser MDaemon kann daher keine Mails versenden. Dennoch werden mails die direkt vor dem Ausfall noch versendet wurden zig Mal beim Empfänger zugestellt die das mittlerweile nicht mehr lustig finden.

Hat jemand einen wertvollen Tipp?

Dankend im Voraus.

Gruß Andreas

Content-Key: 179985

Url: https://administrator.de/contentid/179985

Printed on: March 3, 2024 at 01:03 o'clock

Member: SlainteMhath
SlainteMhath Feb 03, 2012 at 09:41:17 (UTC)
Goto Top
Moin,

lass dir eine dieser "Massenmails" inkl. der Kompletten Header zurueckschicken, dann siehst Du welche SMTP Server am Versand beteiligt waren.

lg,
Slainte
Mitglied: 90857
90857 Feb 03, 2012 at 09:45:07 (UTC)
Goto Top
Kenne ein ähnliches Problem, allerdings ging das dort nicht vom Outlook an einen internen Mailserver, sondern direkt raus. Dort hing das mit großen Anhängen zusammen. Die Mail wurde so lange immer wieder gesendet, bis man sie von Hand aus dem Postausgang gelöscht hat. Auf Grund des großen Anhangs, der langsamen Internet-Verbindung und des eingestellten Time-out, hat Outlook wohl immer geglaubt, dass die Mail nicht rausgegangen ist und daher immer wieder versucht, sie zu senden, was auch jedesmal erfolgreich war.
Guck doch auch mal in den Postausgang, ob die Mail da noch drin liegt, und lösch sie raus. Falls das passt, google mal nach "Mails mit großen Anhang werden immer wieder verschickt". Da findet man einiges zu.
Member: backara
backara Feb 03, 2012 at 10:57:33 (UTC)
Goto Top
Nein damit hängt es nicht zusammen.
Die Mail wurde definitiv nur einmal versandt.
Im Postausgang war sie nicht mehr vorhanden und unter gesendete normal einmal abgelegt.

[Zwischenstand]
Da Hosteurope mittlerweile 26 Stunden für die Bearbeitung braucht komme ich nicht umhin selbst einwenig weiter zu testen.
Der SMTP Dienst fällt immer wieder aus. Sletsamerweise kann ich einzelene Mails über den MDaemon rausschicken indem ich sie von der Wiederholungsposition auf die Externe Warteschlange lege.
Sollte es möglich sein das mein Interner Server den Externen SMTP Dienst irgendwie zum Verabschieden bringt?
Member: AndiEoh
AndiEoh Feb 03, 2012 at 12:15:15 (UTC)
Goto Top
Hallo

du solltest die Logfiles der beteiligetn SMTP Stationen prüfen. Also zunächst euren internen MDaemon, dann den externen SMTP Service. Ist dieser externe SMTP Service ein angemieteter Server oder tatsächlich ein SMTP Dienst der von Hosteurope zur Verfügung gestellt wird?
Falls deine Empfänger nicht nur Outlook nutzen solltest du dir eine Mail in "Rohform" geben lassen, dann kannst du anhand der Header prüfen wer/wann die Mail weitergereicht hat.

Gruß

Andreas
Member: backara
backara Feb 03, 2012 at 13:09:24 (UTC)
Goto Top
[Endstand]
Nachdem ich nun sowohl mit dem MDaemon Support als auch HosteuropeSupport telefoniert habe hat sich das Problem anscheinend von selbst gelöst.
Eine wirkliche Erklärung habe ich allerdings dafür nicht.
Ich habe parallel zur Supportsitzung immer wieder den SMTP Dienst gestartet wärend der MDaemon versucht hat die Mails zu versenden. Wärenddessen scheint der Hosteuropesupport nach dem Fehler gesucht zu haben konnte allerdings auch nciht wirklich etwas feststellen.
Der MDaemon versendet nun nicht mehr über das Gate sondern direkt und die Option pop3 vorher ausführen haben wir deaktiviert. Das ist die einzigen wirklichen Änderungen die durchgeführt wurden allerdings nur um den Fehler direkt vom VIrtual Server im MDaemon zu sehen.

Ich markiere also dieses Thema mal als gelöst.

Danke für eure Hinweise