Migration v. Exchange 2010 SP3 RU30 auf Exchange 2019

Mitglied: Joka2506

Joka2506 (Level 1) - Jetzt verbinden

25.01.2021 um 21:56 Uhr, 1093 Aufrufe, 26 Kommentare, 1 Danke

Hallo,

ich habe bereits die 2008R2 DCs gegen 2 2016Std. ausgetauscht, die Domänenfunktionsebene und die Gesamtstruktur v. 2003 erstmal auf 2008R2 angehoben.
Aktuelle Situation ist so, dass der Exchange 2010SP3RU30 auf einem Win Server 2008R2 läuft.
Endgültig soll die Funktionsebene u. die Gesamtstruktur auf 2016 angehoben werden und ein neuer 2019er DC dazu kommmen.

Jetzt habe ich leider festgestellt, dass BS Inplace Upgrades mit Exchange nicht funktionieren, demnach wird das alles jetzt viel umständlicher.

Kennt jemand gute Anleitungen, die schrittweises Vorgehen für mein Szenario bieten?
Hat jemand vielleicht Erfahrung in Bezug auf den Weg bis zur final Version?

Es muss ja auch die Kompatibilität mit dem AD, BS und der Exchangeversion berücksichtigt werden.

Es werden zusätzlich öffentliche Ordner, Adressbuch und OWA über rpc bzw. https genutzt.
Ist etwas bzgl. der Exchange Authentifizierung zu beachten, es wird momentan NTLM benutzt?
Evtl. Anpassung in der GPO NTLM auf v.2?
Muss am AD Schema etwas angepasst werden?

Muss ich definitiv neuen Server installieren? wohl erst 2016Std als BS, dann Exchange 2016 drauf und die Konfiguration von Exchange 2010 drauf, Postfächer usw. migrieren - und dann wieder neue VM mit 2019er BS und erst dann auf Exchange 2019 migrieren???
Oder hat jemand eine einfachere Lösung parat?
wäre suuuuper ...

Kann ich an den clients tricksen, indem ich den neuen exchange (erstmal 2016) über dns umbiege bzw. ip vom alten benutze? Oder was ist hier best practice?

Ich plane die Exchangepfade, IP und sogar zuletzt den Servernamen bei Möglichkeit zu behalten bzw. 1:1 zu übernehmen. spricht was dagegen?

Was passiert mit dem alten Exchange 2010.. und wann? Wann übernimmt der neue den Mailtransport? erst nach dem Ändern der Clients oder? wie ist da die Vorgehensweise um den alten bzw. die alten Exchange version offline zu schalten??

Ich weiss, das Thema ist sehr Umfangreich und sicherlich nicht einfach umzusetzen, dennoch würde ich es gerne angreifen und bin für jeden Tipp dankbar!

VG
Mitglied: MichaelSch83
25.01.2021, aktualisiert um 23:15 Uhr
Hallo,

Also für all deine Fragen habe ich im Prinzip antworten da ich solche Migration bei uns im Systemhaus schon oft gemacht habe. Nur leider sprengt das etwas den Rahmen des Forums. Ich würde dir eher vorschlagen dich an ein Systemhaus zu wenden. Wenn du allerdings einzelne Fragen zu einem Thema hast, kannst du mich gern anschreiben.

Direkt von 2010 auf 2019 geht nicht, du musst also zuerst zu Exchange 2013/2016 migrieren. Den alten Namen brauchst du eigentlich nicht da du über die URLs den Zugriff sauber umstellen kannst. Der neue Exchange kann im Prinzip gleich von Anfang den Mailtransport und Zugriffspunkt (Proxy) für die Clients übernehmen. Aber wie du schon bemerkt hast, es gibt da einiges zu beachten. Ein gutes Systemhaus sollte da aber keine Probleme haben :) face-smile

Mit freundlichen Grüßen

Micha
Bitte warten ..
Mitglied: mbehrens
25.01.2021 um 23:49 Uhr
Zitat von @Joka2506:

Aktuelle Situation ist so, dass der Exchange 2010SP3RU30 auf einem Win Server 2008R2 läuft.

Jetzt habe ich leider festgestellt, dass BS Inplace Upgrades mit Exchange nicht funktionieren, demnach wird das alles jetzt viel umständlicher.

Ach.

Kennt jemand gute Anleitungen, die schrittweises Vorgehen für mein Szenario bieten?

https://docs.microsoft.com

Hat jemand vielleicht Erfahrung in Bezug auf den Weg bis zur final Version?

Durchaus.

Es muss ja auch die Kompatibilität mit dem AD, BS und der Exchangeversion berücksichtigt werden.

Das ist hilfreich.

Muss am AD Schema etwas angepasst werden?

Mit Sicherheit.

Muss ich definitiv neuen Server installieren? wohl erst 2016Std als BS, dann Exchange 2016 drauf und die Konfiguration von Exchange 2010 drauf, Postfächer usw. migrieren - und dann wieder neue VM mit 2019er BS und erst dann auf Exchange 2019 migrieren???

Ja, wer so lange wartet, muss das machen.

Oder hat jemand eine einfachere Lösung parat?

Nach DSFA nach Exchange Online.

Kann ich an den clients tricksen, indem ich den neuen exchange (erstmal 2016) über dns umbiege bzw. ip vom alten benutze? Oder was ist hier best practice?

Warum sollte man?

Ich plane die Exchangepfade, IP und sogar zuletzt den Servernamen bei Möglichkeit zu behalten bzw. 1:1 zu übernehmen. spricht was dagegen?

Das spricht Bände ...

Was passiert mit dem alten Exchange 2010.. und wann?

Wenn alles fertig ist, kontrollierte Deinstallation.

Wann übernimmt der neue den Mailtransport?

Wenn man ihn in Betrieb nimmt.

erst nach dem Ändern der Clients oder?

Was hat der MUA mit dem MTA zu tun?

wie ist da die Vorgehensweise um den alten bzw. die alten Exchange version offline zu schalten??

Fragen über Fragen :-) face-smile
Bitte warten ..
Mitglied: StefanKittel
26.01.2021 um 01:11 Uhr
Hallo,

ja, es ist aufwendig.

Und ja, es gibt einen "Trick".
Postfächer als PST exportieren.
Neues AD erstellen. Clients neu einbinden, Einstellungen neu machen.

Hängt von der Anzahl der PCs und Einstellungen/Software ab. Ist aber viel einfacher.

Stefan
Bitte warten ..
Mitglied: Vision2015
26.01.2021 um 06:28 Uhr
moin...
Zitat von @Joka2506:

Hallo,

ich habe bereits die 2008R2 DCs gegen 2 2016Std. ausgetauscht, die Domänenfunktionsebene und die Gesamtstruktur v. 2003 erstmal auf 2008R2 angehoben.
oha...
wenn das alles nicht mal etewas vorschnell war!
Aktuelle Situation ist so, dass der Exchange 2010SP3RU30 auf einem Win Server 2008R2 läuft.
normal....
Endgültig soll die Funktionsebene u. die Gesamtstruktur auf 2016 angehoben werden und ein neuer 2019er DC dazu kommmen.
auch normal....

Jetzt habe ich leider festgestellt, dass BS Inplace Upgrades mit Exchange nicht funktionieren, demnach wird das alles jetzt viel umständlicher.
oha... hast du echt gegelaubt :-) face-smile
neeee, das geht so nicht, du brauch am besten ein Server 2012R2 und einne exchange 2013 als zwischen schritt!


Kennt jemand gute Anleitungen, die schrittweises Vorgehen für mein Szenario bieten?
jo... mache ich fast täglich!
Hat jemand vielleicht Erfahrung in Bezug auf den Weg bis zur final Version?
jo, geht gut- machen wir auch fast täglich.

Es muss ja auch die Kompatibilität mit dem AD, BS und der Exchangeversion berücksichtigt werden.
jo.. deswegen erst einen 2012R2 installieren, und die FSMO rollen übertragen... etc...

Es werden zusätzlich öffentliche Ordner, Adressbuch und OWA über rpc bzw. https genutzt.
jo.. das ist kein problem!
Ist etwas bzgl. der Exchange Authentifizierung zu beachten, es wird momentan NTLM benutzt?
nein, wiso?
Evtl. Anpassung in der GPO NTLM auf v.2?
Muss am AD Schema etwas angepasst werden?
ja klar.. mit jedem exchage setup komme eine schema erweiterung... ist aber kein problem :-) face-smile

Muss ich definitiv neuen Server installieren? wohl erst 2016Std als BS, dann Exchange 2016 drauf und die Konfiguration von Exchange 2010 drauf, Postfächer usw. migrieren - und dann wieder neue VM mit 2019er BS und erst dann auf Exchange 2019 migrieren???
nein... fange besser mit Server 2012R2 an...
Oder hat jemand eine einfachere Lösung parat?
wäre suuuuper ...
plant man das nicht vorher?

Kann ich an den clients tricksen, indem ich den neuen exchange (erstmal 2016) über dns umbiege bzw. ip vom alten benutze? Oder was ist hier best practice?
was willst du genau tricksen?
da braucht nix getrixt zu werden, zertifikat in den exchange rein, dns auf die neue ip gestellt fertig...

Ich plane die Exchangepfade, IP und sogar zuletzt den Servernamen bei Möglichkeit zu behalten bzw. 1:1 zu übernehmen. spricht was dagegen?
ja...

Was passiert mit dem alten Exchange 2010.. und wann? Wann übernimmt der neue den Mailtransport? erst nach dem Ändern der Clients oder? wie ist da die Vorgehensweise um den alten bzw. die alten Exchange version offline zu schalten??
hm... dir fehlt grundlegendes wissen, mach das besser nicht alleine!
der Mailtransport klappt sofort nach der Installation, warum sollte er das auch nicht?
die exchange connectorenmüssen angepasst werden....

Ich weiss, das Thema ist sehr Umfangreich und sicherlich nicht einfach umzusetzen, dennoch würde ich es gerne angreifen und bin für jeden Tipp dankbar!
dazu gibbet ja auch umfangreiche Hilfe im WWW... einfach mal nach Exchange Migration suchen

VG
Frank
Bitte warten ..
Mitglied: Vision2015
26.01.2021 um 06:32 Uhr
moin...


Zitat von @StefanKittel:

Hallo,

ja, es ist aufwendig.

Und ja, es gibt einen "Trick".
Postfächer als PST exportieren.
Neues AD erstellen. Clients neu einbinden, Einstellungen neu machen.

Hängt von der Anzahl der PCs und Einstellungen/Software ab. Ist aber viel einfacher.

Stefan

du hast vergessenzu sagen, das die restlichen server und anwendungen dann auch neu gemacht werden müssen...

Frank
Bitte warten ..
Mitglied: radiogugu
26.01.2021, aktualisiert um 08:25 Uhr
Hallo.

Es gibt dutzende Anleitungen, wie das gemacht werden kann, wie schon geschrieben.

Ich konnte mit Hilfe von Frankys sehr gutem Tutorial auch so eine Migration selbst durchführen:

https://www.frankysweb.de/migration-von-exchange-2010-zu-exchange-2016-t ...

Allerdings sollte das besser geplant werden, wie auch schon geschrieben. Denn erst etwas anfangen und dann in einem Forum zu fragen ist nicht der richtige Weg.

Du fährst ja auch nicht mit deinem Auto in die Werkstatt, um dort dann zu sagen: "Ich habe schon mal das Öl abgelassen, jetzt klappt was nicht mehr, bitte Hilfe."

Wenn man sich da unsicher ist, baut man sich kurzerhand eine Testplatform mit Backups der betreffenden Systeme und spielt dann damit herum oder, wie ebenfalls schon geschrieben, holt sich in diesem Bereich externe Kompetenz dazu.

Gruß
Marc
Bitte warten ..
Mitglied: Joka2506
26.01.2021 um 12:58 Uhr
.. danke erstmal für eure Kommentare.

Ist mir schon klar, dass es geplant werden muss - das tue ich ja gerade. Ich habe noch nicht mit der Migration agefangen.
Lediglich die alten DCs rausgeschmissen und die Gesamtstruktur auf kompatibles Level angehoben.
Jetzt plane ich - deswegen wollte ich ja wissen ob ich bei der Überlegung evtl. etwas übersehe - und jemand der
sich auskennt dabei helfen kann.

@mbehrens
echt jetzt? hättest du dir auch sparen können ..

@StefanKittel
danke für den Vorschlag alles neu zu machen, ist in diesem zusammenhang aber keine option.

@Vision2015
warum war ich da vorschnell?
https://docs.microsoft.com/de-de/exchange/plan-and-deploy/supportability ...

@radiogugu
Den Artikel von FrankysWeb kenne ich - danke dafür.
Evtl. kennnt ihr noch mehr gute Artikel zu dem Thema.

Ich frage mich was besser wäre von 2010 auf 2013 und dann auf 19 oder erst auf die 16er.
Ich bin da mit Franks Vorschlag zuerst auf 2013 zu migrieren, konform.
Was meint Ihr, wer hat welche Erfahrunge gemacht?

Evtl. kann mir jemand der es schon gemacht hat seine Erfahrungen dabei mitteilen -
gabs Probleme bei der Migration und welche?

Bei der Migration von öffentlichen Ordnern/Systemordner und dem Adressbuch bin ich noch planlos.
Wieviel Zeit müsste ich da einplanen pro Version für die Migration. Es sind knapp 100 Postfächer - durchschnittlich 500-600MB pro.

Für ernst gemeinte und seriöse Beiträge bin ich echt dankbar ..
Bitte warten ..
Mitglied: Vision2015
26.01.2021 um 13:27 Uhr
Moin...
Zitat von @Joka2506:

.. danke erstmal für eure Kommentare.

Ist mir schon klar, dass es geplant werden muss - das tue ich ja gerade. Ich habe noch nicht mit der Migration agefangen.
Lediglich die alten DCs rausgeschmissen und die Gesamtstruktur auf kompatibles Level angehoben.
Jetzt plane ich - deswegen wollte ich ja wissen ob ich bei der Überlegung evtl. etwas übersehe - und jemand der
sich auskennt dabei helfen kann.

@mbehrens
echt jetzt? hättest du dir auch sparen können ..

@StefanKittel
danke für den Vorschlag alles neu zu machen, ist in diesem zusammenhang aber keine option.

@Vision2015
warum war ich da vorschnell?
https://docs.microsoft.com/de-de/exchange/plan-and-deploy/supportability ...
nicht alles was MS so schreibt, ist auch sinnvoll.....

@radiogugu
Den Artikel von FrankysWeb kenne ich - danke dafür.
Evtl. kennnt ihr noch mehr gute Artikel zu dem Thema.

Ich frage mich was besser wäre von 2010 auf 2013 und dann auf 19 oder erst auf die 16er.
nutze als erstes die 2013, das läuft problemlos...
Ich bin da mit Franks Vorschlag zuerst auf 2013 zu migrieren, konform.
dann mach das...
Was meint Ihr, wer hat welche Erfahrunge gemacht?
Erfahrungen... viele... weo soll ich da anfangen?

Evtl. kann mir jemand der es schon gemacht hat seine Erfahrungen dabei mitteilen -
gabs Probleme bei der Migration und welche?
das ist unterschiedlich.... Fehler sind unterschiedlich- wir machen das aber fast schon im schlaf :-) face-smile

Bei der Migration von öffentlichen Ordnern/Systemordner und dem Adressbuch bin ich noch planlos.
das adressbuch ist nicht das Problem, die öffentlichen Ordner auch nicht...
Wieviel Zeit müsste ich da einplanen pro Version für die Migration. Es sind knapp 100 Postfächer - durchschnittlich 500-600MB pro.
hm.. das hängt von vielen faktoren ab, was leistet dein server?
dir kannst die migration mit dem Parameter -priority emergency machen, das geht schneller...
mach für den Anfang 5er pakete.... und schau die auslastung an...
natürlich kannst du noch mehr leistung rausholen, da gibbet noch mehr zu machen, aber für dich als anfänger sollte das reichen.


Für ernst gemeinte und seriöse Beiträge bin ich echt dankbar ..
Internet und seriös.... :-) face-smile

Frank
Bitte warten ..
Mitglied: radiogugu
26.01.2021 um 13:29 Uhr
Zitat von @Joka2506:
Ich frage mich was besser wäre von 2010 auf 2013 und dann auf 19 oder erst auf die 16er.
Ich bin da mit Franks Vorschlag zuerst auf 2013 zu migrieren, konform.

Ist der gleiche Aufwand, daher egal, welchen Zwischenschritt man unternimmt.

Was meint Ihr, wer hat welche Erfahrunge gemacht?

Ich habe auf 2016 migriert, weil 2019 keine Option war, daher war für mich da das Ende.

Bei meinem Vorhaben gab es das Problem, dass ein Postfach (natürlich des Geschäftsführers) zwar migriert wurde, aber warum auch immer keine Synchronisation via Active Sync möglich war.

Die Ursache war, dass jemand im SBS diesem Benutzer die Gruppen Domänen-, Organisation- und Schema-Admins zugeordnet hatte. Aufgrund der bei diesen Gruppen deaktivierten Vererbung von Berechtigungen auf verknüpfte Geräte (vereinfacht dargestellt), ging das nicht. Erst als der Benutzer neu erstellt wurde ging es. Das manuelle Setzen (anhand eines anderen Benutzer-Objekts) hat leider nichts gebracht.

Bei der Migration von öffentlichen Ordnern/Systemordner und dem Adressbuch bin ich noch planlos.

Das wird hier ja wunderbar beschrieben:

https://www.frankysweb.de/migration-von-exchange-2010-zu-exchange-2016-t ...

Wieviel Zeit müsste ich da einplanen pro Version für die Migration. Es sind knapp 100 Postfächer - durchschnittlich 500-600MB pro.

Zu Fuß sicherlich ein ganzes Wochenende und vor allem nicht alleine. Wenn du die Migration via ECP durchführst, dann werden es bestimmt acht bis zehn Stunden sein.

Bei meinem Kunden waren es nur knapp zwei Stunden, aber da waren es gerade mal fünf Postfächer. Das Größte hatte keine drei GB.

Gruß
Marc
Bitte warten ..
Mitglied: Joka2506
27.01.2021 um 13:37 Uhr
alles klar - danke euch!

Ich werde es am Wochenende mal wagen, erstmal die Migration auf Windows Server 2012 R2 mit Exchange 2013 zu starten.

Ich lese immer wieder dass es Probleme mit den Zertifikaten geben kann .. ?
ich hab eigentlich nur ein Wildcard Zertifikat für alle Dienste.

Sagt mal, wiederherstellen eines Snapshots mit VMware vom Exchange 2010 SP3 im ausgeschalteten Zustand, sollte etwas schief gehen,
dürfte kein Problem sein oder?
Was heisst - ich könnte jederzeit den Ursprungszustand vor der Migartion herstellen, ohne Risko etwas kaputt zu schießen. richtig?
..oder gibt es da doch etwas zu beachten?
Ich würde die VM vorher ausschalten und das Emailrouting an Exchange von unserem externen Mailserver (SEG) anhalten.
Ich mein, auch wenn ein paar Emails verloren gehen, sollte nicht weiter tragisch sein.

Ich check ehrlich gesagt nur immernoch nicht wie die Verbdinung der Clients zum neuen Exchange und vor allem wann umgestellt wird.
Angeblich soll es ab einer gewissen Outlook Version automatisch geschehen - was ich mir nicht vorstellen kann. Ich müsste ja zumindest
den DNS-EIntrag anpassen oder wie ist das? Kann das mal jemand genau erklären?

Danke nochmal .. &

Wünscht mir Glück :) face-smile
Bitte warten ..
Mitglied: Vision2015
27.01.2021 um 13:44 Uhr
moin...
Zitat von @Joka2506:

alles klar - danke euch!

Ich werde es am Wochenende mal wagen, erstmal die Migration auf Windows Server 2012 R2 mit Exchange 2013 zu starten.
ok...

Ich lese immer wieder dass es Probleme mit den Zertifikaten geben kann .. ?
ich hab eigentlich nur ein Wildcard Zertifikat für alle Dienste.
kein problem...

Sagt mal, wiederherstellen eines Snapshots mit VMware vom Exchange 2010 SP3 im ausgeschalteten Zustand, sollte etwas schief gehen,
dürfte kein Problem sein oder?
arrrrrrggg... ein Snapshot ist kein Backup!
Was heisst - ich könnte jederzeit den Ursprungszustand vor der Migartion herstellen, ohne Risko etwas kaputt zu schießen. richtig?
..oder gibt es da doch etwas zu beachten?
jo.... ein Snapshot ist kein Backup! und das kann schön in die hoste gehen... also mach doch eben ein offline image!
Ich würde die VM vorher ausschalten und das Emailrouting an Exchange von unserem externen Mailserver (SEG) anhalten.
Ich mein, auch wenn ein paar Emails verloren gehen, sollte nicht weiter tragisch sein.
oha... ob das " tragisch" ist oder nicht, kann dir bestimmt dein Chef sagen :-) face-smile
ich würde dir dafür die murmel abdrehen...

Ich check ehrlich gesagt nur immernoch nicht wie die Verbdinung der Clients zum neuen Exchange und vor allem wann umgestellt wird.
Angeblich soll es ab einer gewissen Outlook Version automatisch geschehen - was ich mir nicht vorstellen kann. Ich müsste ja zumindest
den DNS-EIntrag anpassen oder wie ist das? Kann das mal jemand genau erklären?
ja... das mit dem DNS ist schon richtig!

Danke nochmal .. &

Wünscht mir Glück :) face-smile

viel glück....

Frank
Bitte warten ..
Mitglied: Joka2506
27.01.2021 um 14:01 Uhr
..zum Glück bist du nicht mein Chef Frank :) face-smile

zum Snapshot > ok, also Snapshot nicht zu empfehlen. Wegen inkonsistenter db oder was ist da das Problem?
Ich hätte altenativ die Veeam-Sicherung samt der Guest processing Option und der Transaktionslogs.
Ich kann auch die ganze Festplatte der VM weg sichern /kopieren - das wäre praktisch das gleiche wie ein Image - oder?
Ich mein wenn ich doch den Server herunterfahre sollte wiederherstellen doch kein Problem sein - meinst nicht?

Sorry, aber ich musste nochmal nachfragen.
Ich will mich so unbedingt absichern für den Fall der Fälle.


viel glück....

Frank

danke!

VG
Bitte warten ..
Mitglied: Vision2015
27.01.2021 um 14:23 Uhr
moin...
Zitat von @Joka2506:

..zum Glück bist du nicht mein Chef Frank :) face-smile
na ja... sach ich mal nix zu.... :-) face-smile

zum Snapshot > ok, also Snapshot nicht zu empfehlen. Wegen inkonsistenter db oder was ist da das Problem?
ja auch.....
Ich hätte altenativ die Veeam-Sicherung samt der Guest processing Option und der Transaktionslogs.
eine Veeam-Sicherung klingt ja schon brauchbar.
Ich kann auch die ganze Festplatte der VM weg sichern /kopieren - das wäre praktisch das gleiche wie ein Image - oder?
neion, das wäre kein Image, sondern eine kopie....
Ich mein wenn ich doch den Server herunterfahre sollte wiederherstellen doch kein Problem sein - meinst nicht?
du meinst eine offline sicherung? oder?!?!?`!?!?

Sorry, aber ich musste nochmal nachfragen.
Ich will mich so unbedingt absichern für den Fall der Fälle.
dan ruf mal bei der Alianz an.... Hoffentlich Allianz versichert... Träller Flööt :-) face-smile
eine ordentliche absicherung wäre ein offline image... zur not mit Clonzilla oder dergleichen...


viel glück....

Frank

danke!

VG

Bitte warten ..
Mitglied: Joka2506
27.01.2021 um 15:02 Uhr
eine ordentliche absicherung wäre ein offline image... zur not mit Clonzilla oder dergleichen...

wie siehts mit "OVF Vorlage Exportieren" als backup / offline image??

vg
Bitte warten ..
Mitglied: Vision2015
27.01.2021 um 15:08 Uhr
moin...

Zitat von @Joka2506:

eine ordentliche absicherung wäre ein offline image... zur not mit Clonzilla oder dergleichen...

wie siehts mit "OVF Vorlage Exportieren" als backup / offline image??

Kerl...... ab ins Körchen und ein Ordentliches Backup erstellt!
keine Experimente

vg
Frank
Bitte warten ..
Mitglied: Joka2506
31.01.2021 um 13:03 Uhr
Hallo,

also die Umstellung hat soweit ganz gut funktioniert. Postfächer / virtuelle Pfade / OWA / Autodiscover bzw. Clientzugriff .. funktioniert soweit gut.

Allerdings sende / empfange ich noch Emails wohl über den alten exchange 2010.

Der Sendeconnector wurde übernommen, wenn ich den neuen ex2013 als Quellsever in den vorhandenen übernommenen Connector eintrage und den alten Exchnage dafür raus nehme, bleiben die mails in der Warteschlange.
Neuen Connector wenn ich anlege - das selbe - Fehler beim Connection Aufbau.

Ausgehende Mails sollen wie beim alten auf einen weiteren externen host weitergeleitet werden - dieser ist so konfiguriert, dass alles was aus Firmennetz kommt annimmt. Hat jemand eine Idee ?

Sobald ich auf den alten exchange(2010) wieder umstelle funktioniert es wieder.
Bitte warten ..
Mitglied: Vision2015
01.02.2021 um 20:20 Uhr
moin...
Zitat von @Joka2506:

Hallo,

also die Umstellung hat soweit ganz gut funktioniert. Postfächer / virtuelle Pfade / OWA / Autodiscover bzw. Clientzugriff .. funktioniert soweit gut.

Allerdings sende / empfange ich noch Emails wohl über den alten exchange 2010.
warum? Connectoren löschen, und gut ist!

Der Sendeconnector wurde übernommen, wenn ich den neuen ex2013 als Quellsever in den vorhandenen übernommenen Connector eintrage und den alten Exchnage dafür raus nehme, bleiben die mails in der Warteschlange.
Fehlermeldung.... also 4.XXXXX was?
Neuen Connector wenn ich anlege - das selbe - Fehler beim Connection Aufbau.
sind die daten richtig? TLS?

Ausgehende Mails sollen wie beim alten auf einen weiteren externen host weitergeleitet werden - dieser ist so konfiguriert, dass alles was aus Firmennetz kommt annimmt. Hat jemand eine Idee ?
hat dein smarthost auch zugangsdaten, und TLS... zugangsdaten richtig?

Sobald ich auf den alten exchange(2010) wieder umstelle funktioniert es wieder.
hm.... schau die dir daten der Connectoren gut an, und sei sicher das dei passwort richtig ist!


Frank
Bitte warten ..
Mitglied: Joka2506
02.02.2021, aktualisiert um 18:04 Uhr
danke Frank!

Lag an der utm9 Firewall, hab übersehen dass der neue exchange nicht im erlaubten IP Bereich war.

Soweit so gut, alles scheint zu funktionieren.
Hab heute die Connectoren vom alten Exchange erstmal deaktiviert und den Server heruntergefahren. Es gab Probleme mit den Verteilerlisten, nach neu Anlegen hats funktioniert.

Ich wollte jetzt bis morgen abwarten ob Beschwerden kommen, Server hochfahren, connectoren löschen, db überprüfen ggf. demonten und löschen, dann exchange 2010 deinstallieren, server aus Domäne und das wars, hoffe ich.
Hab bisschen Panik davor, aber wird wohl passen wenns soweit alles gut, während er offline ist.
Gibts irgendwie eine sicherere Möglichkeit den alten Server zu entfernen? :) face-smile
nicht, dass er mir irgendwas löscht .. kaputt schießt beim Deinstallieren.
Im Log meldetet der Exchange 2013, dass die getaktete Kommunikation mit dem Primär Server nicht möglich ist. Ist das normal, dass er den alten als Primär sieht??

Naja, ich werds morgen mal wage, die Zeit drängt, ich hoffe die Migration von 2013 auf 2019 geht auch so gut???

Also wenn morgen alles nach dem Entfernen weiterhin ok ist, müsste ich erstmal die Funktionsebene und Gesamtstruktur von 2008r2 auf mindestens 2012 anheben oder sogar gleich auf 2016. Den 2019 DC kamm ich glaube ich jetzt dann mit Exchange 2013 problemlos installieren, oder? Müsste ich nochmal prüfen.

Dank Frank, bist n Top Mann hier !

VG
Bitte warten ..
Mitglied: Joka2506
02.02.2021 um 18:07 Uhr
noch was .. evtl. weisst du das;

Auf dem alten exchange hatte ich in der Verwaltungskonsole bei den öffentlich Ordner, öffentliche Systemordner gesehen, die ich nicht migriert hab bzw. nicht weiss ob die benötigt werden. Hab im Netz nichts darüber finden können. Wir nutzen öffentliche Ordner nicht produktiv. Danke !
Bitte warten ..
Mitglied: Vision2015
02.02.2021 um 20:07 Uhr
moin...
Zitat von @Joka2506:

danke Frank!

Lag an der utm9 Firewall, hab übersehen dass der neue exchange nicht im erlaubten IP Bereich war.
:-) face-smile

Soweit so gut, alles scheint zu funktionieren.
gut
Hab heute die Connectoren vom alten Exchange erstmal deaktiviert und den Server heruntergefahren. Es gab Probleme mit den Verteilerlisten, nach neu Anlegen hats funktioniert.
ok... die connectoren können sofort gelöscht werden...

Ich wollte jetzt bis morgen abwarten ob Beschwerden kommen, Server hochfahren, connectoren löschen, db überprüfen ggf. demonten und löschen, dann exchange 2010 deinstallieren, server aus Domäne und das wars, hoffe ich.
was genau willst du an der db prüfen?
zertifikat eingerichtet? URLs?
DNS richtig eingestellt?
hast du die Arbitration MB übertragen?
flott noch mal ein:
was ist mit dem discovery postfach? Systempostfächer etc... ?
Migrationbatches alle abgeschlossen und gelöscht? also abfragen mit
Hab bisschen Panik davor, aber wird wohl passen wenns soweit alles gut, während er offline ist.
keine angst...
Gibts irgendwie eine sicherere Möglichkeit den alten Server zu entfernen? :) face-smile
ja.. setup exe :-) face-smile
vorher alle alten datenbanken löschen... und zu 80% wirst du die offentlichen mit adasi breinigen müssen...
nicht, dass er mir irgendwas löscht .. kaputt schießt beim Deinstallieren.
hm... eigentlich nix... also nix was nicht von hand zu rettenn wäre....
Im Log meldetet der Exchange 2013, dass die getaktete Kommunikation mit dem Primär Server nicht möglich ist. Ist das normal, dass er den alten als Primär sieht??
hm.... RPC-Verschlüsselung macht wohl probleme... erst mal abwarten

Naja, ich werds morgen mal wage, die Zeit drängt, ich hoffe die Migration von 2013 auf 2019 geht auch so gut???
ist einfach...

Also wenn morgen alles nach dem Entfernen weiterhin ok ist, müsste ich erstmal die Funktionsebene und Gesamtstruktur von 2008r2 auf mindestens 2012 anheben oder sogar gleich auf 2016. Den 2019 DC kamm ich glaube ich jetzt dann mit Exchange 2013 problemlos installieren, oder? Müsste ich nochmal prüfen.
Funktionsebene und Gesamtstruktur nach der migration vom exchange 2010 auf 2016 anheben..

Dank Frank, bist n Top Mann hier !
Danke

VG
Frank
Bitte warten ..
Mitglied: Vision2015
02.02.2021 um 20:11 Uhr
moin..
Zitat von @Joka2506:

noch was .. evtl. weisst du das;

Auf dem alten exchange hatte ich in der Verwaltungskonsole bei den öffentlich Ordner, öffentliche Systemordner gesehen, die ich nicht migriert hab bzw. nicht weiss ob die benötigt werden. Hab im Netz nichts darüber finden können. Wir nutzen öffentliche Ordner nicht produktiv. Danke !
dann nur systempostfacher übertragen..

Frank
Bitte warten ..
Mitglied: Joka2506
02.02.2021 um 20:43 Uhr
was genau willst du an der db prüfen?
zertifikat eingerichtet? URLs?
DNS richtig eingestellt?
hast du die Arbitration MB übertragen?

was sich noch so in der db befindet ..
hab n wildcard zertifikat für alle Dienste die benötigt werden importiert und zugewiesen.
bei owa zeigts das richtige cert an, sieht also gut aus.
DNS ist eingestellt, weiss nicht ob der autodiscover im dns nötig ist, SRV eintrag im dns habe ich manuell erstellt. ich möchte die url für autodiscover eigentlich auf https://rpc.domain.de setzen, damit die clients von aussen den richtigen server im Outlook drin stehen haben. oder nicht empfehlenswert?
Ich werd einen dns Record beim Provider die Tage mal setzen lassen, aber bis dahin hat Outlook 2016
ein problem sich zu verbinden, weil eingeben nicht mehr möglich, über vpn dann zieht er sich dann aber den Hostnamen.

discoverpostach müsste ich nochmal prüfen, ich hab eigentlich alles was über Empfäger/Migration möglich war verschoben. oder wo finde ich das?

>Primär Server nicht möglich ist. Ist das normal, >dass er den alten als Primär sieht??
>hm.... RPC-Verschlüsselung macht wohl >probleme...

ne , mit primärserver meint er den alten exchange, stand noch der hostname nach primär server. aber das ist wahrscheinlich weil halt noch in coexistenz und eben erreichbar weil off. oder?

Kann ich also die Funktionsebene, Gesamtstruktur gleich auf 2016 anheben, meinst?

Danke & schönen abend
Bitte warten ..
Mitglied: Vision2015
03.02.2021 um 15:59 Uhr
Moin...

wie ist die lage?

Frank
Bitte warten ..
Mitglied: Joka2506
03.02.2021 um 16:27 Uhr
Probleme beim Löschen der öffentlichen Standardordner " Internet Newsgroup" - und somit der öffentlichen db.

Konnte ich aber gerade lösen - die öffentliche Ordner db löschen.
Es läuft noch alles :) face-smile
Connectoren / Offlineadressbuch .. gelöscht.

Die Mailbox db ist leer .. und wird jetzt gelöscht,
dann exchange 2010 deinstallieren und mit adsi editor Verweise entfernen.

Das sollte es gewesen sein ..

ich gebe noch endgültig Bescheid ...
Bitte warten ..
Mitglied: Joka2506
04.02.2021 um 14:52 Uhr
So .. die Migration auf Exchange 2013 ist durch. Alles funktioniert gut und die Deinstallation vom alten Exchange 2010 ist auch sauber durch.

Im Nachhinein muss ich sagen, war es keine große Sache ;)

Allerdings steht mir jetzt noch die Migration auf Exchange 2019 bevor, ich hoffe es klappt genuso gut.

Vorschläge, Anregungen, Hinweise für die 2019er Migration sind willkommen :) face-smile

Danke nochmal für die Unterstützung!
Bitte warten ..
Mitglied: Joka2506
09.02.2021 um 10:04 Uhr
Hallo,

ich habe Probleme bei der Migration auf Exchange 2019.

Die Koexistenz mit Exchange 2013 funktioniert.

Nach der Installation wollte ich erstmal das Migrationspostfach auf den Exchange 2019 Server verschieben. Muss man ja als erstes tun.
Leider hat sich der Task dabei aufgehangen. Also versuchte ich es über den Powershell Befehl - diesmal alle Systempostfächer.
Das hat auch funktioniert.
Nun wenn ich versuche den Migrationspunkt im ECP aufzurufunfen erhalte ich folgenden Fehler:

"Fehler
Das Postfach /o=Haas/ou=Exchange Administrative Group (FYDIBOHF23SPDLT)/cn=Configuration/cn=Servers/cn=EXCHANGE/cn=Microsoft System Attendant kann nicht geöffnet werden."
Ich habe das MIgrationspostfach schon mal neu Erstellt indem ich es aus dem AD gelöscht hatte und setup /prepareAD auf dem exchange 2019 ausgeführt habe. Das hat auch geklappt - anschlißend konnte ich auch das Migrationsmenü im ECP wieder aufrufen.
Jedoch beim Versuch ein Benutzerpostfach zu migrieren - kam der Fehler wieder.

Im ADSI -Editor steht beim Exchange Server kein Wert im homeMDB und homeMTA. Beim alten Server ist nur ein Wert im homeMTA.
Ich weiß nicht ob das so in Ordnung ist. Evtl. ist beim Aufhängen des Verschiebungstasks etwas schiefgelaufen, wobei die Werte jetzt nicht sauber da stehen. Hat jemand eine Idee wie ich das Problem in Griff bekomme??`

Mir ist aufgefallen das beim neu erstellen des Migartionspostfachs - dieser auf dem alten Exchange erstellt wurde. Evtl. ist das ein Hinweis.

Ich überlege die ganzen Systempostfächer zu löschen bzw. neu anzulegen. Die Frage ist mache ich das auf dem alten Server (2013) oder dem Neuen 2019.
Meine Überlegung ist auch, die Systempostfächer von neuen Exchange erstmal wieder zurück auf den alten Exchange zu verschieben um zu prüfen wie das Verhalten dann ist.
Bitte warten ..
Heiß diskutierte Inhalte
MikroTik RouterOS
Simples VLAN bringt mich zur Verzweiflung
gelöst Daniel26Vor 1 TagFrageMikroTik RouterOS30 Kommentare

Moin, ich bin sehr neu im Mikrotik-Bereich, aber schon dabei, aufzuegeben. Wir verbauen in unserer Hardware Switche von Mikrotik. Bisher waren da Netgear-Teile drin, ...

LAN, WAN, Wireless
Switch läuft, ist aber nicht erreichbar
gelöst AndiPeeVor 1 TagFrageLAN, WAN, Wireless19 Kommentare

Hallo zusammen, mein Problemfall einleitend kurz umrissen: Privates Netzwerk Es funktioniert grundsätzlich, allerdings habe ich immer mal ein paar Ausfälle im WLAN-Netzwerk und bin ...

Microsoft
STRG + ALT + ENTF
TezzlaVor 1 TagAllgemeinMicrosoft12 Kommentare

Mahlzeit zusammen, wir haben gerade im Kollegenkreis über Sinn und Unsinn der Sperrbildschirmentriegelung STRG + ALT + ENTF unter Win10 diskutiert. Mich würde hierzu ...

Video & Streaming
Streamingplattform mit eigenen Servern
gelöst icegetVor 1 TagFrageVideo & Streaming5 Kommentare

Hallo liebe Community, ich würde gerne via Amazaon AWS (oder andere Cloudanbietern) mehrere Serverinstanzen (Streaming) starten, um z.B. 2000 Personen den selben Stream den ...

E-Mail
Alternative zu horde webmail
fisch56Vor 1 TagFrageE-Mail6 Kommentare

Hallo, ich habe das horde webmail auf meinem Server, macht allerdings Probleme. Suche daher eine Alternative. Das Postfach hat viele Unterordner, die z.B. bei ...

Windows Server
Nutzer als lokaler Admin in Windows Server 2019
hanheikVor 1 TagFrageWindows Server6 Kommentare

Hallo, in SBS 2011 konnte ich ganz einfach einen Nutzer als lokalen Admin einstellen. Windows fragte dann, für welchen Rechner; Rechner auswählen; fertig! In ...

Switche und Hubs
Zwei Lancom GS-315XP Switche VLAN verbinden
wieoderwasVor 1 TagFrageSwitche und Hubs14 Kommentare

Hallo zusammen, wir haben zwei neue Lancom GS-315XP Switche bekommen. An einem dieser Switche sind Lancom Accesspoints angeschlossen. Ich verzweifel gerade an der Verbindung ...

TK-Netze & Geräte
Beantragung Telekom Glasfaseranschluss beschleunigen
RoadmaxVor 1 TagFrageTK-Netze & Geräte4 Kommentare

Hallo Zusammen, wir benötigen relativ kurzfristig für eine neue Niederlassung in Duisburg einen 1GBit symetrischen Glasfaseranschluss. Der Vormieter hatte bereits einen 1GBit Anschluss der ...