Mikrotik - Wireguard restart

visucius
Goto Top
Hallo in die Runde,

jetzt habe ich vor ein, zwei Wochen groß rumgetönt, dass man - jetzt endlich - auch über das aktualisierte Winbox die Dyn-DNS-Namen der Wireguard-Gegenseiten in ROS7.4 hinterlegen kann. Nun die nächste "Hürde":

Bei mit steigt die Wirguard-Verbindung offenbar beim täglichen IP-Wechsel aus. De(&aktiviere) ich den Peer am nächsten Morgen, läufts wieder.

Wie würdet ihr so einen täglichen "Restart" des Interfaces denn am einfachsten umsetzen?

Viele Grüße

Content-Key: 3398490794

Url: https://administrator.de/contentid/3398490794

Ausgedruckt am: 07.08.2022 um 10:08 Uhr

Mitglied: colinardo
Lösung colinardo 21.07.2022 aktualisiert um 13:33:18 Uhr
Goto Top
Servus.
DNS-Cache am Mikrotik aktualisieren mittels MK-Skript
In der Regel braucht man das aber nur wenn die TTL des DynDNS Anbieters höher wäre, aber bei den meisten DynDNS Anbietern steht die meistens eh auf 1 Minute. Der Mikrotik sollte also rechtzeitig innerhalb einer Minute die Verbindung wiederherstellen. Checke also mal die TTL deines dyndns Anbieters.

Alternativ eben Skript fürs Interface auf dem MK
Den Peer zu (de-)aktivieren ist aber nur in seltenen Ausnahmefällen nötig. Du solltest nur dafür sorgen das die TTL der DynDNS Domain entsprechend kurz ist. Ganz ohne kurze Unterbrechung geht es bei dynamische IP ja eh nicht. Wireguard ist hier ja schon sehr flexibel was das anbelangt.

Grüße Uwe
Mitglied: Visucius
Visucius 21.07.2022 aktualisiert um 13:50:51 Uhr
Goto Top
Langsam sollte ich Screenshots machen. Du änderst ja die Lösung laufend face-wink

Also, zur Erläuterung:
Auf der einen Seite ne Fritze (goip.de) und dahinter nen Wireguard/MT-AP
auf der anderen Seite
MT-CRS mit WG an nem gebridgtem Router (Vodafone) mit WAN-Adresse und "MT Cloud"

Und so wie es scheint, unterbricht die Verbindung wenn der DSL-Anschluss (Fritze) ne neue IP bekommt. Die TTL steht dort im Standard auf 40 Sekunden. Was ich aber mal testen könnte: Auch den heimischen WG-AP an die Cloud hängen und damit auf beiden Seiten die MT-eigenen DynDNS-Services zu nutzen. (PS: habe ich gerade gemacht).

Danke für das Script. Bestimmt ne doofe Frage: Wo hinterlege ich das denn? Du hattest vorhin einen Screenshot bei nem DHCP-Client eingestellt? Da habe ich aber nru meine WAN-Ports und nichts was mit Wireguard zu tun hat? Könnte ich das nicht auch irgendwie unter System > Scripts ... ablegen udn dann evtl. über System > Scheduler täglich aufrufen?! Oder bin ich da auf dem Holzweg?
Mitglied: colinardo
Lösung colinardo 21.07.2022 aktualisiert um 14:39:21 Uhr
Goto Top
Zitat von @Visucius:

Langsam sollte ich Screenshots machen. Du änderst ja die Lösung laufend face-wink
Ja sorry, hatte den Beitrag am Anfang falsch interpretiert (andere Baustelle) face-confused deswegen die Änderungen.
Danke für das Script. Bestimmt ne doofe Frage: Wo hinterlege ich das denn? Du hattest vorhin einen Screenshot bei nem DHCP-Client eingestellt?
Ja aber das würde aber nur gelten wenn der Mikrotik welcher die Verbindung initiiert direkt an seinem WAN eine externe IP beziehen würde und das scheint ja zumindest auf der Seite mit der Fritze nicht der Fall zu sein.
Kontext-Fehler sorry, vergess das mit dem DHCP-Client.
irgendwie unter System > Scripts ... ablegen udn dann evtl. über System > Scheduler täglich aufrufen?! Oder bin ich da auf dem Holzweg?
Ja kannst du so machen. Das neu auflösen über ":resolve" sollte aber vollkommen reichen, der MK macht das aber auch selbst wenn von deiner Seite Anfragen an die Remote-Party einlaufen und die TTL abgelaufen ist.
Mitglied: Visucius
Visucius 21.07.2022 um 14:03:08 Uhr
Goto Top
Ja aber das würde aber nur gelten wenn der Mikrotik welcher die Verbindung initiiert direkt an seinem WAN eine externe IP beziehen würde und das scheint ja zumindest auf der Seite mit der Fritze nicht der Fall zu sein.

Er zeigt mir die WAN-Adresse aber trotzdem an, obwohl er hinter der Fritze liegt. Ich teste das jetzt mal - Skript kann ich dann ja immer noch nachschieben, wenn das Problem weiter bestehen bleibt.

Vielen Dank erstmal für Deine Mühen!
Mitglied: colinardo
colinardo 21.07.2022 aktualisiert um 14:39:44 Uhr
Goto Top
Zitat von @Visucius:
Er zeigt mir die WAN-Adresse aber trotzdem an, obwohl er hinter der Fritze liegt. Ich teste das jetzt mal - Skript kann ich dann ja immer noch nachschieben, wenn das Problem weiter bestehen bleibt.
Vergess das mit dem DHCP-Client, das war bei mir eine Baustelle und hier in deinem Kontext fehl am Platz sorry.
Mitglied: Visucius
Visucius 29.07.2022 aktualisiert um 17:30:01 Uhr
Goto Top
So, jetzt habe ich ein wenig getestet:

Also die Cloud-Funktion scheint irgendwie problematisch. Aber es war definitiv - ich sehe ja den letzten Handshake - der Moment, wenn meine Fritze zu Hause ne neue WAN-IP bekommt. Das ist auch unabhängig ob ich das über goip.de oder MT-cloud abfrage.

Wenn ich dann jedoch
a) :resolve myhost.dyndns.org

und danach

b) /interface wireguard peer {
:local peer [find interface=wg0 && endpoint-address="myhost.dyndns.org"]
disable $peer
enable $peer
}

morgens um 6.00 Uhr laufen lasse (System > scheduler), dann läuft das wieder face-wink

Danke @colinardo