lord-icon
Goto Top

Netzwerkprobleme nach Umstellung auf 10GB

1 Client mit 2 Netzwerkkarten:
1x 1GB
1x 10GB

1 Server mit 2 Netzwerkkarten
2x 1GB


Am Client war VORHER die 10GB mit dem Internet per DHCP über ein Switch verbunden.
Die 1GB-Karte per manueller IP (192.168.100.250/255.255.255.0) direkt mit dem Server verbunden.
= klappte.

Da ich eh nur 50.000er Internet habe und zukünfig die Backups schneller fahren möchte = ändernung auf:

Client:
1 GB per DHCP
10 GB manuell auf 192.168.100.250/255.255.255.0

Am Server hat sich erstmal nichts geändert, da die 10GB Karte bestellt ist, aber noch nicht angekommen ist.
Ubunto-Server

enp2s0f0: Internet
enp2s0f1: Crossover (normales Patchkabel)
enp2s0f0: flags=4163<UP,BROADCAST,RUNNING,MULTICAST>  mtu 1500
        inet 192.168.2.181  netmask 255.255.255.0  broadcast 192.168.2.255
        inet6 fe80::ec4:7aff:fe12:c16  prefixlen 64  scopeid 0x20<link>
        inet6 2003:d7:7f2b:fd00:ec4:7aff:fe12:c16  prefixlen 64  scopeid 0x0<global>
        ether 0c:c4:7a:12:0c:16  txqueuelen 1000  (Ethernet)
        RX packets 2377  bytes 200516 (200.5 KB)
        RX errors 0  dropped 734  overruns 0  frame 0
        TX packets 751  bytes 140942 (140.9 KB)
        TX errors 0  dropped 0 overruns 0  carrier 0  collisions 0
        device memory 0xdfa20000-dfa3ffff

enp2s0f1: flags=4163<UP,BROADCAST,RUNNING,MULTICAST>  mtu 1500
        inet 192.168.100.150  netmask 255.255.255.0  broadcast 192.168.100.255
        inet6 fe80::ec4:7aff:fe12:c17  prefixlen 64  scopeid 0x20<link>
        ether 0c:c4:7a:12:0c:17  txqueuelen 1000  (Ethernet)
        RX packets 100  bytes 8251 (8.2 KB)
        RX errors 0  dropped 0  overruns 0  frame 0
        TX packets 680  bytes 50072 (50.0 KB)
        TX errors 0  dropped 0 overruns 0  carrier 0  collisions 0
        device memory 0xdfa00000-dfa1ffff  

Der ping ist ab und zu mal da
From 192.168.100.150 icmp_seq=516 Destination Host Unreachable
From 192.168.100.150 icmp_seq=517 Destination Host Unreachable
From 192.168.100.150 icmp_seq=518 Destination Host Unreachable
64 bytes from 192.168.100.250: icmp_seq=521 ttl=128 time=0.907 ms
From 192.168.100.150 icmp_seq=586 Destination Host Unreachable
From 192.168.100.150 icmp_seq=587 Destination Host Unreachable
From 192.168.100.150 icmp_seq=588 Destination Host Unreachable
From 192.168.100.150 icmp_seq=589 Destination Host Unreachable
From 192.168.100.150 icmp_seq=590 Destination Host Unreachable
From 192.168.100.150 icmp_seq=591 Destination Host Unreachable
From 192.168.100.150 icmp_seq=592 Destination Host Unreachable
From 192.168.100.150 icmp_seq=593 Destination Host Unreachable
From 192.168.100.150 icmp_seq=594 Destination Host Unreachable
From 192.168.100.150 icmp_seq=595 Destination Host Unreachable
From 192.168.100.150 icmp_seq=596 Destination Host Unreachable
From 192.168.100.150 icmp_seq=597 Destination Host Unreachable
64 bytes from 192.168.100.250: icmp_seq=609 ttl=128 time=1.07 ms

Am Server habe ich keinerlei änderungen vorgenommen. Da lief es ja vorher.
An Windows halt nur die beiden Kabel ausgetauscht und die IP-Adressen geändert.

In Windows hab ich nun auch schon die netzwerkadpater einstellungen zurückgesetzt + den benötigten Neustart durchgeführt. LEider ohne Änderung

Was mach ich hier falsch?
Braucht eine 10GB doch ein Crossover Kabel ?
Die 1GB karte hingegen nicht.

10 GB => Marvell AQtion 10Gbit Network Adapter
1 GB => Intel(R) Ethernet Controller (3) I225-LM

Content-Key: 62114996458

Url: https://administrator.de/contentid/62114996458

Printed on: April 22, 2024 at 06:04 o'clock

Member: Boomercringe
Solution Boomercringe Mar 30, 2024 at 12:35:35 (UTC)
Goto Top
Was für eine Verbindungsgeschwindigkeit handeln denn die 10gbe karte und der Server aus?
Member: lord-icon
lord-icon Mar 30, 2024 at 13:40:00 (UTC)
Goto Top
der Client/Windows zeigt 1,0 Gbit/s an
Linux auch. (txqueuelen 1000 (Ethernet)"
Member: ruebenmaster
Solution ruebenmaster Apr 01, 2024 at 08:48:27 (UTC)
Goto Top
Das ist schwierig heraus zu lesen, da die 10GB Karte im Bild keine Drops oder andere Errors anzeigt.

Ich hätte mal versucht, mit dem arp Befehle heraus zu finden, ob in der MAC Adressen Tabelle des jeweiligen Rechners die Einträge noch stimmen. Also passt die MAC Adresse zur zugeteilten IP Adresse. Bei solchen direkten Verbindungen "reden" die Hosts über die MAC Adresse miteinander.
Falls ubuntu, da kenne ich mich nicht so aus, den "arp" (bei Windows arp -a) nicht mehr inne hat, dann kann man sich mit "ip neigh" aushelfen.
Eventuell hat auch die Netzwerkkarte beim Windows Rechner (1GB) mit der ihr nun zugeteilten 10G Karte im Ubuntu Server ein Thema. Per Autosensing ist die 10G Karte nun gezwungen 1G zu fahren. Durch das ständige "Nachfragen" der Verbindungsgeschwindigkeit kann das zu Paketverlusten führen.

Hier wäre ein managable Switch dazwischen sinnvoll. Wenn man den von MikroTik nimmt, kostet er nicht viel Geld und ich kann alle Verbindungen analysieren.

Viel Erfolg
ruebenmaster
Member: MrNetman
Solution MrNetman Apr 01, 2024 at 10:36:43 (UTC)
Goto Top
Was ist dein Ziel?

erstens:
Dein Server hat nur 2Gbit/s wenn du ihm in seiner Konfiguration qualifiziert vorgeben kannst, dass er das machen kann UND wenn die zugehörigen Switchports das auch noch unterstützen und entsprechenden konfiguriert werden. (z.B: LAG) Also nur managebare Switche. Welchen Typ hast du im Einsatz?
zweitens:
Die IP Adressen, die du hier aufschreibst, sind alle gleich, was eine Grundfunktionalität schon recht sicher verhindert.
drittens:
Crossoverkabel gibt es in zwei Varianten. Eine kann funktionieren, die andere tut es sicher nicht. Zumindest nicht seit es Gigabit Ethernet gibt - und das sind schon über 20 Jahre. Also Niemals mehr über Crossover Kabel nachdenken. Ausnahme Uraltgeräte, die maximal Fast Ethernet können und Switches ohne Gigabit.