blu3scr33n
Goto Top

Office Dokumente werden beim 2. Öffnen als Schreibgeschützt angezeigt

Hallo liebe Administratoren,

ich habe folgendes Problem:

Ich bin Administrator bei uns in der Firma (12 Rechner, 15 User)
Letztens kam ein User auf mich zu und sagte mir, dass er Probleme mit Office Dokumenten hätte.
Es würde häufiger vorkommen, dass Office beim öffnen die folgende Fehlermeldung ausgibt:
"Dokument" wird von "xy" benutzt und lässt sich deshalb nur schreibgeschützt öffnen.
User "xy" hat diese Datei aber garantiert nicht offen. Teilweise passiert dies auch, wenn grade vom User frisch angelegte Dokumente gespeichert werden und sofort danach wieder geöffnet werden.
Das Problem tritt auch auf, wenn der PC garnicht ans Firmennetzwerk angeschlossen ist.

Unser Server ist ein SBS 2003 und der User, bei dem das Problem auftritt, läuft auf Windows 7 64 bit.

Ich bin dankbar für Tipps und Ratschläge.

MFG
Der Blu3Scr33n

Content-Key: 163548

Url: https://administrator.de/contentid/163548

Printed on: April 21, 2024 at 03:04 o'clock

Member: Phalanx82
Phalanx82 Mar 29, 2011 at 10:31:19 (UTC)
Goto Top
Hallo,

bei Windows XP als Client hätte ich behauptet der User hat die Datei noch offen,
wenn Office die Datei nur schreibgeschützt öffnet, das wäre dann normal.
Da dein Client aber Windows 7 ist, vermute ich ein ähnliches Problem/Phenomen
wie bei Netzwerkfreigaben auf die man mit falschen Userdaten (oder Userdaten mit
zu wenig Rechten zugreift):

Bei Windows 7 habe ich bemerkt das es Netzwerkverbindungen zu Shares teilweise
bis zu 15mins locked wenn man sie nicht als Netzlaufwerk eingebunden hat und diese
Verbindung somit richtig trennen kann.

Als Beispiel:

VPN User hat andere Anmeldedaten als der Domänenuser und greift aus Netzwerkshares
zu, die teilweise für jeden lesbar aber nicht schreibbar sind mit einem Windows 7 Client.
Dann merkt man, das man nicht auf das Share schreiben kann und möchte sich mit anderen
Login Daten verbinden -> geht nicht, da Windows die Session bis zu 15mins locked.
Also entweder wartet man 15 mins und verbindet sich danach neu auf das Share bzw.
verbindet ein Netzlaufwerk, oder man rebootet die Kiste, dann gehts sofort wieder...

Ich denke hier hast du ein ähnliches Problem, das die Datei bzw. die Share noch so halb
offen in Windows 7 gemountet ist und daher alles schreibgeschützt ist.

Probier mal folgendes:

Kiste rebooten, das Share als Netzlaufwerk einbinden, deine Datei öffnen/bearbeiten und
schließen+speichern. Danach trennst du das Share wieder im Explorer und versuchst das
öffnen auf dem 2. Client. Wahrscheinlich wirds dann problemlos gehen, allerdings wird
dann User 3 wieder das gleiche Problem haben wenn du das Share nicht richtig als Netzlaufwerk
mountest und wieder trennst ;)


Mfg.
Member: Blu3Scr33n
Blu3Scr33n Mar 29, 2011 at 10:50:12 (UTC)
Goto Top
Danke schonmal für die Umfassende Antwort.
Ich denke ich habe das Prinzip was du ansprichst verstanden, stolpere aber leider momentan über den von dir Verwendeten "Share"-Begriff. Was genau verstehst du darunter?

Zu dem 15 Minuten Intervall:
Ich kann mir nicht vorstellen, dass es damit zusammenhängt, da das Problem auch innerhalb einer Sitzung auftritt.
Beispiel: Excel wird geöffnet und gespeichert und direkt danach wieder aufgerufen. Während des gesamten Vorgangs hängt der rechner am Netz. D.h. die Netzwerkverbindung bleibt während des gesamten Prozesses die Selbe.
Member: Phalanx82
Phalanx82 Mar 29, 2011 at 11:14:51 (UTC)
Goto Top
Mit "Share" meine ich eine normale Netzwerkfreigabe unter Windows.

Und ja, dein Windows 7 mountet diese Freigabe im Hintergrund wenn
Du sie z.B. im Explorer über \\deineFreigabe\ eingibst und speichert die
Logindaten über 15 mins. Versuchst du innerhalb dieser Zeit das gleiche
Share als Netzlaufwerk zu mounten (weil du ggf. mehr Rechte brauchst),
wird das nicht gehen und du bekommst eine Fehlermeldung, meist irgendwas
in die Richtung das die Verbindung schon in Benutzung ist oder kein Zugriff
besteht und du dich an deinen Admin wenden sollst ;)


Mfg.
Member: Blu3Scr33n
Blu3Scr33n Mar 29, 2011 at 12:14:58 (UTC)
Goto Top
Ok, danke.

Dann mach ich jetzt mal meinen User ausfindig (grade nicht im Office) und versuche dann deinen Vorschlag umzusetzen.
Ich gebe Rückmeldung, wie es gelaufen ist.

MFG

Blu3Sr33n
Member: Blu3Scr33n
Blu3Scr33n Apr 19, 2011 at 12:14:57 (UTC)
Goto Top
Update:
Ich glaube es liegt an unserer Virensoftware (Trend Micro) dies ist eine veraltete Version und wird demnächst upgedated. Falls das Problem danach weiter bestehen sollte werde ich mal auf dem Server nachschauen, wer die Datei momentan noch benutzt.

Ich geb euch dann ein Update
Member: Blu3Scr33n
Blu3Scr33n Jun 20, 2012 at 12:47:25 (UTC)
Goto Top
Es lag an unserer alten Virensoftware.
Trend Micro ist geupdatet worden und das Problem ist passé.

MFG

Blu3Scr33n
Member: baldur
baldur Aug 21, 2012 at 15:02:27 (UTC)
Goto Top
Von wo nach wo habt Ihr geupdated?
Member: Blu3Scr33n
Blu3Scr33n Aug 22, 2012 at 14:57:58 (UTC)
Goto Top
Wir haben von TM Security irgendwas auf Trend Micro Worry Free Business geupdated.

Beste Grüße,

Blu3Scr33n
Member: baldur
baldur Aug 22, 2012 at 21:40:27 (UTC)
Goto Top
Danke für die Info.

Ich hab' unseren TM mal deaktiviert und auf einer Testmaschine deinstalliert, selber Fehler:
- 1. Öffnen der Datei OK, 2. Öffnen nur schreibgeschützt möglich (obwohl keine '~$<irgendwas>'-datei angelegt wurde.

Wird wohl nicht an TM liegen..

Gruss,
Baldur
Member: Blu3Scr33n
Blu3Scr33n Aug 23, 2012 at 09:14:34 (UTC)
Goto Top
Hallo Baldur,

welches Betriebssystem steht denn dahinter?
Wir hatten zum Zeitpunkt der Threaderöffnung noch MS SBS 2003. Es kann auch sein, dass die Ordner dadurch noch gesperrt waren.,
Jetzt laufen wir auf MS SBS 2011 und alles läuft ohne gesperrte Dateien/Bereiche.

AM besten wäre es, wenn du dafür einen neuen Thread erstellst. Da wird dir glaub ich besser geholfen, als in einem so alten Thread.

Beste Grüße,

Blu3Scr33n
Member: baldur
baldur Aug 23, 2012 at 12:55:55 (UTC)
Goto Top
Hmm. da könntest Du recht haben..
Danke..
Member: baldur
baldur Aug 27, 2012 at 20:44:44 (UTC)
Goto Top
Hab' den Fehler gefunden
Im Explorer MUSS die Vorschau und die Detailansicht (früher: Statuszeile) deaktiviert sein, da sonst Office nicht EXKLUSIV auf die Datei zugreifen kann