PC / Domaincontroller in ein Active Directory einbinden über VPN nicht möglich?

sunnyrxs
Goto Top
Hallo zusammen

Ich habe ein Problem und suche schon seit Stunden nach einer Lösung

Ich möchte ein Client (PC) über eine VPN Verbindung (Zyxel Firewall) in ein Active Direcctory einbinden.
Dazu habe ich beim Client als DNS den Domain Controll Server angegeben und kann somit auch den AD Namen auflösen. Jedoch kommt jedesmal nach dem eingeben des Benutzername und Passwort beim einbinden ein Fehler dass die AD nicht sichtbar sei.

Ich frage mich nun ob ich dem Client noch irgendwie sagen muss, unter welcher Ip der Domaincontroller und die Active Directory zu finden ist. Die Frage ist nur wo?

Kann mir dabei jemand helfen?

Hat das jemand schon gemacht?

Schlussendlich möchte ich über VPN einen zweiten Domaincontroller in ein Active Directory über VPN einbinden, aber solange ein Client nicht mal geht, muss ich das wohl nicht probieren.

Content-Key: 49084

Url: https://administrator.de/contentid/49084

Ausgedruckt am: 17.08.2022 um 07:08 Uhr

Mitglied: DaSam
DaSam 17.01.2007 um 21:35:20 Uhr
Goto Top
Hola,

wenn Dein VPN richtig aufgebaut ist (HW-VPN), dann bekommen deine Clients eiegtnlich gar nichts davon mit. Wir haben eine Zweigstelle mit einem VPN angebunden, dort geht das alles.

Wegen der IP des DC: Die sollte sich der Client vom DNS Server des DC holen, da muss nichts eingetragen werden. Bist Dir sicher, dass auf dem DNS des DC alles korrekt konfiguriert ist?

Sind die beiden VPN Endpunkte per Zyxel realisiert?

cu,
Alex
Mitglied: sunnyrxs
sunnyrxs 17.01.2007 um 22:17:49 Uhr
Goto Top
danke für deine schnelle Antwort..

ja ich bin mir fast sicher, dass ich alles richtig konfiguriert habe.

wegen der ip des dc:

mir ist klar, dass der client die ip beim dns vom zusätzlichen dc holen wird.
da das einbinden des zusätzlichen domanicontrollers nicht funktionierte probierte ich über vpn einen pc in das active directory (von der arbeitsgruppe in die domain) einzubinden.
Dabei existierte der dns jedoch noch nicht auf dem zusätlichen dc und dehalb hatte ich auf dem pc den dns selbst angegeben damit er auch die domain.local in die ip auflösen kann.

komisch ist eben, dass ich mit nslookup die domain.local auflösen kann, ich den server am anderen ende des tunnels anpingen kann und somit alles richtig geroutet wird. somit sollte es funktionieren oder?

ich sollte somit auch einen pc über vpn über den dc am andere ende des tunnels in die domain einbinden können. das ist ja eigentlich das selbe oder?

cya ralph
Mitglied: sunnyrxs
sunnyrxs 17.01.2007 um 22:18:12 Uhr
Goto Top
danke für deine schnelle Antwort..

ja ich bin mir fast sicher, dass ich alles richtig konfiguriert habe.

wegen der ip des dc:

mir ist klar, dass der client die ip beim dns vom zusätzlichen dc holen wird.
da das einbinden des zusätzlichen domanicontrollers nicht funktionierte probierte ich über vpn einen pc in das active directory (von der arbeitsgruppe in die domain) einzubinden.
Dabei existierte der dns jedoch noch nicht auf dem zusätlichen dc und dehalb hatte ich auf dem pc den dns selbst angegeben damit er auch die domain.local in die ip auflösen kann.

komisch ist eben, dass ich mit nslookup die domain.local auflösen kann, ich den server am anderen ende des tunnels anpingen kann und somit alles richtig geroutet wird. somit sollte es funktionieren oder?

ich sollte somit auch einen pc über vpn über den dc am andere ende des tunnels in die domain einbinden können. das ist ja eigentlich das selbe oder?

cya ralph
Mitglied: Randyman
Randyman 17.01.2007 um 23:20:26 Uhr
Goto Top
Hi,

kenn jetzt leider die Zyxel-Router nicht, aber ich weiß z.B. von Sonicwall dass man hier das "Windows-Gerödel" (sorry) extra fürs VPN freischalten muss. D.h. bestimmte Windows-Ports werden standardmäßig nicht ins VPN geroutet, man hat also genau den Effekt den Du auch hast ... Ping geht, DNS passt, aber z.B. eine Domain-Anmeldung scheitert... erst man die entsprechenden Häckchen setzt funkt es. Vielleicht ist es ja bei Zyxel ähnlich ?!?

Grüsse
Rainer
Mitglied: sunnyrxs
sunnyrxs 18.01.2007 um 12:39:22 Uhr
Goto Top
hmm.. wenn ich das nur wüsste.. bis jetzt habe ich nichts gelesen was in diese richtung geht...

ich habe hier einmal den fehler welcher ich beim einbinden eines clients über vpn erhalte.

http://www.rxs.ch/fehler.jpg

und andererseits der nslookup der domain

http://www.rxs.ch/nslookup.jpg

ist das normal dass darin steht: "non-existent domain" und "der standardserver ist nicht verfügbar"?
Mitglied: DaSam
DaSam 18.01.2007 um 17:46:15 Uhr
Goto Top
Hi,

versuch doch mal ein "net view \\servername" - was passiert denn da?

Wird eventuell irgendwas NetBIOS mässig oder RCP auf dem VPN-Teilchen gesperrt?

cu,
Alex
Mitglied: Randyman
Randyman 20.01.2007 um 13:43:25 Uhr
Goto Top
Hi,

kannst Du mal nen Screenshot von Deinem DNS auf der 192.168.16.3 schicken? Ich glaub da stimmt was nicht. Wenn der DNS auf der 192.168.16.3 sauber läuft sollte der Client auch rückwärts die IP zum Namen auflösen können.
Beim Screenshot wären die Forward- und die Reverse-Lookup-Zonen interessant.

Gruss
Rainer
Mitglied: sunnyrxs
sunnyrxs 22.01.2007 um 12:38:38 Uhr
Goto Top
Hallo zusammen

inzwischen funktioniert es...

es war daran gelegen, dass das NetBios nicht über VPN aktiviert ist.

danke für eure super hilfe

cya ralph

ps. auf dem dns habe ich den reverse lookup eintrag hinzugefügt, somit funktioniert auch der nslookup einwandfrei
Mitglied: Randyman
Randyman 22.01.2007 um 21:14:18 Uhr
Goto Top
Hi,

Glückwunsch!

Grüsse
Rainer
Mitglied: Kessl
Kessl 23.01.2008 um 08:55:16 Uhr
Goto Top
Hallo Rainer,
kannst du das Vorgehen mit einer Sonicwall bitte genauer beschreiben, denn genau das habe ich demnächst vor mir!

Gruß
Kessl
Mitglied: Randyman
Randyman 23.01.2008 um 22:48:24 Uhr
Goto Top
Hi,

an zwei Stellen musst Du netbios im VPN einschalten.

- in der Tunnelkonfig selbst.
- unter den allgemeinen VPN-Einstellungen.

Gruss
Randy
Mitglied: Kessl
Kessl 24.01.2008 um 08:57:28 Uhr
Goto Top
Danke für die schnelle Antwort!

Also muss ich nur bei "Enable Windows Networking (NetBIOS) Broadcast" den Haken setzen und es müsste gehen?

Wir wollen eine Site-to-Site Verbindung mit 2 Sonicwalls aufbauen und wollen auf der entferneten Seite keinen zusätzlichen Server einsetzen.

Gruß
Kessl