PC mit Windows 10: Netzlaufwerk verbinden mit XP-Freigabe klappt nicht

rightall
Goto Top
Seit einiger Zeit gibt es im heimischen Netzwerk Probleme mit Netzwerkverbindungen zu Freigaben. Die FritzBox im Keller ist mit mehreren PCs und einem NAS von Netgear vernetzt, 4 PCs haben Windows 10, alle Version 1803, 3 noch XP Professional (wegen meiner Medientransfer-Aktivitäten), das NAS hat die Firmware 6.9.3 . Den Rechnern habe ich aus einem anderen Grund feste IP-4 Adressen der Form 192.168.178.x zugewiesen, bei den XP Rechnern ist im Feld Standardgateway nichts eingetragen, um sie vom Internet abzuschotten. Ich nutze das Netzwerk viel, um Dateien zwischen den Rechnern auszutauschen. Daher ist es hinderlich, wenn Rechner im Netzwek nicht sichtbar und nicht erreichbar sind. Ping ist ok von jedem Rechner zu jedem Rechner.
Nur bei einem W10 Rechner sind im Dateiexplorer unter Netzwerk alle Rechner aufgelistet. Bei den XP Rechnern sind in der Netzwerkumgebung unter der gemeinsamen Arbeitsgruppe alle Rechner gelistet, bis auf den gerade genannten W10 Rechner, der alle sieht. Zu diesem habe ich auf den XP Rechnern Netzwerverbindungen definiert, die haben einen Laufwerkbuchstaben bekommen. Auf den anderen W10 Rechnern steht unter Netzwerk nur der NAS von Netgear. Von diesen 3 W10 Rechnern komme ich auf die anderen W10 Rechner mittels \\Name oder \\IP-4 . Versuche ich das von einem der 3 W10 Rechner zu einem der XP-Rechner kommt die Meldung: "auf \\Name bzw. \\IP-4 konnte nicht zugegriffen werden". Einmal zeigte W10 beim Verbindungsversuch folgende Fehlermeldung "Windows; Das Netzlaufwerk konnte nicht verbunden werden, da der folgende Fehler aufgetreten ist: Sie können keine Verbindung mit der Dateifreigabe herstellen, weil sie unsicher ist. Diese Freigabe erfordert das veraltete SMB1-Protokoll, das unsicher ist und Ihr System angreifbar machen könnte. Ihr System erfordert mindestens SMB2. Weitere Informationen dazu, wie Sie das Problem beheben, finden Sie unter https://go.microsoft.com/fwlink/?linkid=852747.; . Der dort angegebene Link funktioniert nicht, mehrere Stunden Internetrecherche haben mich nicht weitergebracht, weder der Vorschlag: "Geben Sie in der PowerShell (mit Adminrechten) folgenden Befehl ein:

Enable-WindowsOptionalFeature -Online -FeatureName smb1protocol

noch

https://www.administrator.de/forum/netzwerkkommunikation-windows-10-frei ...

Immer wieder ist von veralteten Protokollen, die bei W10 nicht mehr verwendet werden, die Rede, das steht aber im Gegensatz zu meiner Beobachtung, dass ein W10-Rechner im Dateiexplorer alle Rechner unter Netzwerk auflistet.
Was hilft?

Content-Key: 378035

Url: https://administrator.de/contentid/378035

Ausgedruckt am: 20.05.2022 um 09:05 Uhr

Mitglied: Lochkartenstanzer
Lösung Lochkartenstanzer 23.06.2018 aktualisiert um 14:10:22 Uhr
Goto Top
Zitat von @rightall:

Immer wieder ist von veralteten Protokollen, die bei W10 nicht mehr verwendet werden, die Rede, das steht aber im Gegensatz zu meiner Beobachtung, dass ein W10-Rechner im Dateiexplorer alle Rechner unter Netzwerk auflistet.

Das ist kein Gegenssatz. Die Rechner sehen sich, könne aber nicht miteinander "sprechen", weil die einen nur SMB-v1 und der andere nur v2 udn v3 kann.

Wenn ich einem Chinesen gegenüberstehe, sehe ich den auch, aber ob ich mit dem reden kann, hängt davon ab, ob er außer Mandarin noch Englisch, Deutsch, Spanisch, Italienisch, Französisch, Griechisch, Türkisch oder Latein kann. :-) face-smile

Was hilft?

Auf aktuelle Betriebssysteme wechseln. :-) face-smile

lks
PS: Siehe auch:

https://www.administrator.de/forum/netzwerkkommunikation-windows-10-frei ...
https://www.mcseboard.de/topic/213251-programme-in-netzlaufwerken-nicht- ...
https://www.borncity.com/blog/2018/06/09/kommt-ein-smbv1-fix-fr-windows- ...
Mitglied: rightall
rightall 24.06.2018 um 21:50:26 Uhr
Goto Top
Die Aktivierung von SMB1 bringt schon die Lösung, allerdngs nicht in der Form, wie ich es zuerst versuchte:

Geben Sie in der PowerShell (mit Adminrechten) folgenden Befehl ein: Enable-WindowsOptionalFeature -Online -FeatureName smb1protocol

Das hatte ich von hier:

https://www.heise.de/ct/hotline/SMB1-unter-Windows-10-aktivieren-3838098 ...

SMBv1 wieder über Windows Features aktivieren, wie in

https://www.borncity.com/blog/2018/06/09/kommt-ein-smbv1-fix-fr-windows- ...

beschrieben, führt dagegen zum Ziel.
Weitere Wege zur Aktivierung von SMB1finden sich hier:

https://www.tenforums.com/tutorials/107605-enable-disable-smb1-file-shar ...