spirit-of-eli
Goto Top

PfSense DNS-Resolver langsam nach "reconnect"

Moin zusammen,

gibt es hier im Forum noch jemanden der den DNS-Resolver der PfSense einsetzt?

Ich habe hier ein Thema sobald die Internetverbindung weg bricht und nach kurzer Zeit wieder da ist.
An diesem Punkt braucht der Resolver bestimmt 3-4min um dann komplett wieder einsatzbereit zu sein.
Vorher finden folglich keine Namensauflösungen statt.
Ein Reconnect dauert nur ein paar Sekunden, daher ist dieser Umstand ärgerlich.

Kann dieses Phänomen jemand bestätigen?
Gibt es hierzu eine Lösung und ich war jetzt zwei Jahre nicht im Stande dies im Netz zu finden?


Ich bin auf Feedback gespannt.

Gruß
Spirit

Content-Key: 366422

Url: https://administrator.de/contentid/366422

Printed on: March 2, 2024 at 07:03 o'clock

Member: chgorges
chgorges Feb 28, 2018 at 12:17:33 (UTC)
Goto Top
Den 127.0.0.1-DNS-Server als Primär-DNS hast du gekillt und nur die Provider-DNS eingetragen?
Member: Spirit-of-Eli
Spirit-of-Eli Feb 28, 2018 updated at 12:24:40 (UTC)
Goto Top
Ne das macht ja keinen Sinn, die FW soll ja als erste bei sich selbst schauen.
Oder habe ich das falsch verstanden?

Edit: Ich wüsste auch gerade nicht wo ich die Loop Adresse rauskicken sollte.
Member: aqui
aqui Mar 01, 2018 updated at 08:16:48 (UTC)
Goto Top
Habs hier gerade mal mit einer 2.3.5p1 und einer 2.4.2p1 versucht nachzustellen.
Nach Abziehen und wiederaufstecken des Internet Ports ist auch 2 Sekunden später DNS wieder da.
Lässt sich irgendwie nicht reproduzieren weder mit einem direkten Ethernet WAN Port noch mit PPPoE.
Member: Spirit-of-Eli
Spirit-of-Eli Mar 01, 2018 updated at 15:19:40 (UTC)
Goto Top
Bei mir scheint der Resolver, nach dem die Verbindung wieder da ist, komplett neu zu starten.

Ich habe ein paar Screenshots der relevanten Konfig-Bereiche gemacht. Vielleicht fällt euch etwas auf.

Ich habe mir schon gedacht, dass es nicht normal ist. Allerdings ist die Konfiguration wohl nicht außergewöhnlich.
Ich habe nur noch nicht verstanden warum ich zwingend das "DNS Query Forwarding" aktivieren muss. Eigentlich fragen die Clients doch explizit den Resolver an.
Gibt es hierfür eine Erklärung?

@chgorges die Loopback Adresse habe ich mal rausgenommen, allerdings macht es keinen unterschied in dem Schema.

rs-1
rs-2
rs-3
Member: ChriBo
ChriBo Mar 01, 2018 at 17:53:03 (UTC)
Goto Top
Hi,
ich kann es hier auf einer Version 2.4.1p1 nicht nachvollziehen.
Deine Einstellungen sind etwas anders als die Defaults, ich habe deine Einstellungen teilweise nachgestellt, kann aber auch dabei den Fehler nicht nachvollziehen.

Wen du de Fehler schon seit zwei Jahren hast:
Welche Version hast du aktuell installiert ?
Ist dies eine frische Installation oder ist dies ein Upgrade ?
Wenn du immer wieder nur geupgraded hast kann dies der Fehler sein und eine frische Installation mit Restore deiner Konfiguration wird den Fehler wahrscheinlich beheben.
In der pfSense sind in den letzten Jahren einige Änderungen im DNS Forwarder und Resolver durchgeführt worden. Da bei einem Upgrade häufig alte Leichen in den Konfigurationsdateien übernommen werden behebt eine Neuinstallation häufig Fehler.

CH
Member: aqui
aqui Mar 02, 2018 updated at 08:25:13 (UTC)
Goto Top
Ich habe ebenfalls die Defaults und nichts verändert. Lässt sich auch nach mehrfachen Versuchen nicht reproduzieren.
Vielleicht wirklich mal Werksreset und mit den Defaults versuchen...?!
Member: Spirit-of-Eli
Spirit-of-Eli Mar 06, 2018 at 18:06:57 (UTC)
Goto Top
Moin zusammen,

ich habe zwar noch nicht getestet alles einmal neu zu installieren. Aber ist es korrekt, dass mit der Default Konfiguration der DNS Struktur, also ohne jegliche Anpassung gar keine DNS-Auflösung möglich ist?

Unter dem Umstand, dass ich selbst einen DNS Server definiere und nicht den über PPPoE nutze, findet ohne "DNS Query Forwarding" keine Auflösung statt.

Sollte dies nicht normal sein, würde ich vermuten das noch mehr im agen liegt.

Vielleicht hab ihr ja noch eine Idee.
Member: aqui
aqui Mar 07, 2018 updated at 10:36:09 (UTC)
Goto Top
dass mit der Default Konfiguration der DNS Struktur, also ohne jegliche Anpassung gar keine DNS-Auflösung möglich ist?
Nein, das ist falsch !
In der Default Konfig rennt die FW immer als DNS Proxy und dabei ist es egal ob du einen DNS statisch definierst oder den per DHCP oder PPPoE automatisch übermittelt bekommst.
Du musst im Setup nur den "Override" Haken entfernen sonst hat die automatisch übermittelte DNS IP immer Vorrang:
overr
Scheint doch noch mehr im Argen zu liegen...?!
Member: Spirit-of-Eli
Spirit-of-Eli Mar 07, 2018 at 19:08:57 (UTC)
Goto Top
Der Witz ist, die Option ist gar nicht gesetzt.
Nehme ich das Forwarding im Resolver raus, läuft nix mehr.

Magst du mir einmal deine Konfig des "DNS-Resolvers" und unter "General Setup" zeigen?
Member: aqui
aqui Mar 08, 2018 updated at 11:09:39 (UTC)
Goto Top
Hier mal 2 Screenshots von einer 2.4.latest die einmal...
direkt an einem Provider Router hängt:
dns2

und einmal mit einem NAT Router in einer Kaskade:
dns1

Mehr oder minder Standard Konfig wo es bei einem Leitungsausfall und recovery zu keinerlei Verzögerung kommt.
Hardware einemal APU1 einmal APU2.
Member: Spirit-of-Eli
Spirit-of-Eli Mar 15, 2018 at 20:37:48 (UTC)
Goto Top
Moin,

So, ich schätze das Problem konnte ich mehr oder weniger Identifizieren.
Nebenbei, die schnellste DNS-Auflösung kommt bei mir zu Stande, wenn kein DNS Server hinterlegt ist und unter dem Resolver das Forwarding deaktiviert ist.

@aqui in diesem Fall werden tatsächlich die DNS-Rootserver angesprochen. Der Resolver nutzt wirklich erst die hinterlegten DNS Server wenn das Forwarding manuell aktiviert wird.

Das Problem bei mir besteht anscheint darin, dass ich in jeglich Konfiguration erstmal ein paar Minuten warten muss bevor eine Auflösung stattfindet. Diese Zeit ist ohne DNS Server sogar noch länger aber als Entschädigung ist danach keinerlei Verzögerung mehr merkbar.

Da ich dieses Phänomen hier ebenfalls in einer VM nachstellen kann schätze ich, dass es an meiner Anbindung liegt.


Euch auf jeden Fall besten Dank für die Unterstützung!

Sollte wer Konfig Details wollen, einfach bescheid sagen.

Gruß
Spirit