Top-Themen

Aktuelle Themen (A bis Z)

Administrator.de FeedbackApache ServerAppleAssemblerAudioAusbildungAuslandBackupBasicBatch & ShellBenchmarksBibliotheken & ToolkitsBlogsCloud-DiensteClusterCMSCPU, RAM, MainboardsCSSC und C++DatenbankenDatenschutzDebianDigitiales FernsehenDNSDrucker und ScannerDSL, VDSLE-BooksE-BusinessE-MailEntwicklungErkennung und -AbwehrExchange ServerFestplatten, SSD, RaidFirewallFlatratesGoogle AndroidGrafikGrafikkarten & MonitoreGroupwareHardwareHosting & HousingHTMLHumor (lol)Hyper-VIconsIDE & EditorenInformationsdiensteInstallationInstant MessagingInternetInternet DomäneniOSISDN & AnaloganschlüsseiTunesJavaJavaScriptKiXtartKVMLAN, WAN, WirelessLinuxLinux DesktopLinux NetzwerkLinux ToolsLinux UserverwaltungLizenzierungMac OS XMicrosoftMicrosoft OfficeMikroTik RouterOSMonitoringMultimediaMultimedia & ZubehörNetzwerkeNetzwerkgrundlagenNetzwerkmanagementNetzwerkprotokolleNotebook & ZubehörNovell NetwareOff TopicOpenOffice, LibreOfficeOutlook & MailPapierkorbPascal und DelphiPeripheriegerätePerlPHPPythonRechtliche FragenRedHat, CentOS, FedoraRouter & RoutingSambaSAN, NAS, DASSchriftartenSchulung & TrainingSEOServerServer-HardwareSicherheitSicherheits-ToolsSicherheitsgrundlagenSolarisSonstige SystemeSoziale NetzwerkeSpeicherkartenStudentenjobs & PraktikumSuche ProjektpartnerSuseSwitche und HubsTipps & TricksTK-Netze & GeräteUbuntuUMTS, EDGE & GPRSUtilitiesVB for ApplicationsVerschlüsselung & ZertifikateVideo & StreamingViren und TrojanerVirtualisierungVisual StudioVmwareVoice over IPWebbrowserWebentwicklungWeiterbildungWindows 7Windows 8Windows 10Windows InstallationWindows MobileWindows NetzwerkWindows ServerWindows SystemdateienWindows ToolsWindows UpdateWindows UserverwaltungWindows VistaWindows XPXenserverXMLZusammenarbeit

gelöst Probleme Namensauflösung Windows SBS 2003 Domain - Clients xp - 7

Mitglied: NetzFuchs

NetzFuchs (Level 1) - Jetzt verbinden

06.09.2011 um 18:23 Uhr, 5354 Aufrufe, 7 Kommentare

Hallo,
Wir haben einen SBS 2003 im Einsatz und ca. 30 Clients mit Windows xp oder Windows 7.
Der SBS 2003 ist "alleiniger Platzhirsch" für Exchange, AD, DNS, etc.
Die Clients haben als DNS Server unseren SBS eingetragen und als Gateway den Router.
Mehrmals am Tag kommen wir auf einmal nicht mehr auf unsere Website.
Hier die harten Fakten:
Die Website ist extern gehostet.
Von unserem externen DSL Anschluß kommen wir zu jederzeit auf unsere Website.
Die Clients kommen zu unterschiedlichen Zeiten und von einander scheinbar völlig unabhängig nicht mehr auf die Website. Es kann also sein das Client A nicht drauf kommt, während Client B ohne weiteres auf der Website surft.
Es kann auch sein das der SBS 2003 selbst gerade auf die Website zugreifen kann, während ein beliebiger Client keinen Zugriff hat (das kann auch andersherum so sein: Client hat Zugriff, SBS nicht)
Mit einem nslookup kriege ich die zugehörige IP Adresse der Website zu jeder Zeit. Auch wenn ich zu diesem Zeitpunkt über einen Browser nicht auf die Website surfen kann.
Wenn ich die Website nicht an surfen kann und parallel versuche die Website an zu pingen schlägt dies mit der Meldung fehl dass der Name nicht gefunden werden kann (Obwohl nslookup die richtige IP zum Namen zu jederzeit ausspuckt!!!)

Zusammengefasst kommen wir aus dem Firmennetzwerk nur sporadisch auf unsere Website. Und ich hab keinen Plan warum.
Hat jemand vielleicht eine Idee wie ich den Fehler weiter eingrenzen könnte?

Danke für’s lesen!
Mitglied: dog
06.09.2011 um 20:06 Uhr
Obwohl nslookup die richtige IP zum Namen zu jederzeit ausspuckt!!!)

nslookup macht direkt ein DNS-Lookup beim DNS-Server, alles andere schaut erstmal im rechnerinternen DNS-Cache nach, bevor irgendwas anderes passiert.

Der erste Schritt wäre also beim Auftreten des Problems mal ipconfig /flushdns auszuführen.
Bitte warten ..
Mitglied: NetzFuchs
07.09.2011 um 10:45 Uhr
Hallo.

habe ich soeben erledigt. ipconfig /flushdns Das Resultat ist das gleiche wie vorher:
Pingversuch:
Ping request could not find host. Please check the name and try again.
Websitebesuch:
Internet Explorer cannot display the webpage

ein paar Minuten später klappt sowohl das pingen als auch der Websitebesuch.
Wo kann ich denn noch suchen nach möglichen Fehlern? Irgendwelche Caches die ich am Client auslesen kann oder ähnliches?
Bitte warten ..
Mitglied: goscho
07.09.2011 um 11:29 Uhr
Hi Netzfuchs,
hast du das mit verschiedenen Browsern versucht?
Passiert das dann auch?

Lösche mal den Cache/Verlauf/etc. des Browsers, vielleicht hilft das ja schon.

Edit:
Sah jetzt erst, dass auch ein Ping fehlschlägt. Dann ist mein Beitrag eher keine Hilfe mehr.
Bitte warten ..
Mitglied: NetzFuchs
07.09.2011 um 13:36 Uhr
Trotzdem danke .

Ich habe jetzt mal Wireshark mitlaufen lassen:
Wenn das pingen und der Website Besuch NICHT funktionieren, versucht der Client den Namen über WINS aufzulösen und scheint bei unserem SBS 2003 nach zu fragen. Der wiederrum antwortet "Requested name does not exist".

Wenn pingen unf Website Besuch funktionieren, versucht er den Namen über DNS bei unserem SBS 2003 auf zu lösen. Der antwortet brav und ich kann auf der Website surfen.

Warum versucht der Client manchmal mit WINS eine Website aufzulösen und scheitert dann?

Argz!
Bitte warten ..
Mitglied: dog
07.09.2011 um 15:18 Uhr
WINS versucht Windows nur, wenn DNS kein Ergebnis bringt.
Das heißt der Client hat bereits einen Fehler im DNS-Cache.

Welche Weiterleitungen sind auf dem DNS-Server eingestellt?
Bitte warten ..
Mitglied: NetzFuchs
07.09.2011 um 15:27 Uhr
Für "all other DNS domains" steht die IP des Routers als einziger "Forwarder" drin.

Wenn ich allerdings über nslookup am Client ne Namensauflösung der Website mache kriege ich immer die richtige IP Adresse zur Website, auch wenn er gleichzeitig nicht in der Lage ist die Website auf zu rufen oder an zu pingen (siehe oben).
Es scheint so als ob der DNS Server nicht das Problem ist.
Bitte warten ..
Mitglied: NetzFuchs
08.09.2011 um 15:48 Uhr
Ok,
ich hab das Problem jetzt "enttarnt", aber noch nicht gelöst: Unser Gateway (Router) hängt in einem riesigen Netzwerk einer großen Firma dran. Im Gateway sind 2 DNS Server dieser Firma eingetragen.
Wir hatten vor Jahren wohl mal die Website hier gehostet und die hatten (warum auch immer) hier im internen DNS Server des Netzwerks manuelle Einträge vorgenommen. Da die jetzt keine Gültigkeit mehr haben kriegen wir auch keine korrekte Antwort auf unsere DNS Requests und können unsere eigene Website nicht mehr aufrufen.
Warum es allerdings von Zeit zu Zeit funktioniert muss ich noch herausfinden. Vielen dank für die Tipps.
Bitte warten ..
Ähnliche Inhalte
Windows 7
Windows 7 RDP Client Problem
Frage von 90584Windows 715 Kommentare

Ich habe folgendes Problem. Ein Rechner baut eine Verbindung per RDP zu einem anderen Wiindows 7 Rechner auf. Das ...

Samba

Windows 7 Client findet Samba Domain nicht

Frage von bolle01Samba2 Kommentare

Moin, ich wollte aus Spaß mal einen DC auf Linux aufsetzen als OS habe ich CentOS7 gewählt. Die Installation ...

Microsoft

RDP-Client Version 7 für Windows XP gesucht

gelöst Frage von SarekHLMicrosoft8 Kommentare

Hallo zusammen, weiß jemand, wo es den aktuellsten RDP-Client für Windows XP noch gibt? Bei Microsoft ist er zwar ...

Windows Server

Windows 2008 R2 Client Windows 7 kann nicht in der Domain angemeldet werden

Frage von GasaiDKWindows Server8 Kommentare

Hallo, bei dem Versuch meinen Windows 7 Client in meine Domain aufzunehmen, kommt diese Fehlermeldung an (Siehe Anhang) Hat ...

Neue Wissensbeiträge
Windows Mobile

Support für Windows Mobile endet im Dezember 2019

Information von transocean vor 7 StundenWindows Mobile

Moin, MS empfiehlt als Alternative den Umstieg auf IOS oder Android, wie man hier lesen kann. Gruß Uwe

Internet

Kommentar: Bundesregierung erwägt Ausschluss von Huawei im 5G-Netz - Unsere Presse wird immer sensationsgieriger

Information von Frank vor 2 TagenInternet5 Kommentare

Hier mal wieder ein schönes Beispiel für fehlgeleiteten Journalismus und Politik zugleich. Da werden aus Gerüchten plötzlich Fakten, da ...

Windows 10

Netzwerk-Bug in allen Windows 10-Versionen durch Januar 2019-Updates

Information von kgborn vor 2 TagenWindows 101 Kommentar

Nur ein kurzer Hinweis für Admins, die Windows 10-Clients im Portfolio haben. Mit den Updates vom 8. Januar 2019 ...

Windows 10

Windows 10 V1809: Rollout ist gestartet - kommt per Windows Update

Information von kgborn vor 3 TagenWindows 102 Kommentare

Eine kurze Information für die Admins, die Windows 10 im Programm haben. Microsoft hat die letzte Baustelle (die Inkompatibilität ...

Heiß diskutierte Inhalte
TK-Netze & Geräte
TAPI auf einem Win2016Server installieren und einrichten
Frage von wstabelTK-Netze & Geräte32 Kommentare

Hallo liebe Admins, ich habe folgende Situation: 1 Windows Server 2016 Standard als DC 1 SNOM 710 IP-Telefon 1 ...

Off Topic
Darf ich ein Forum erstellen das Produkte eines Herstellers betrifft?
Frage von cyberwallOff Topic8 Kommentare

Hallo Community, ich habe da eine "rechtliche" bzw. allgemeine Frage zum erstellen von Foren. Darf ich als "normale Person" ...

Router & Routing
Unbekannte IPv4 Adresse im Routerprotokoll(Portweiterleitung)
gelöst Frage von tklustigRouter & Routing6 Kommentare

Hallo Leute, folgender Screenshot(ScanVersusPortForwarding.jpg) zeigt die im Routerprotokoll aufgezeigten Portweiterleitungen und alle von einem IPScanner eruierten IPv4 Adressen in ...

Monitoring
Netzwerk bzw VPN wird lahm
Frage von HenereMonitoring5 Kommentare

Servus zusammen, Netzwerk (bzw die Verbindung) sieht so aus: VM-Daten -> 1GBe -> Zyxel USG60W -> VLAN 1GBe -> ...