netzer2021
Goto Top

Proxmox node restore

Hallo Leute,

ich wollte mir just diese Woche ein Proxmox Cluster einrichten und was passiert da, richtig mein aktueller Single Node geht kaputt. Warum? Aus eigener Dummheit! Ich habe wohl versehentlich beim Umbennen des nodes einen typo in meinen Befehlen gehabt was dummerweise dazu führ das mein /etc/pve leer ist , ja leer nichts mehr da…

ich habe ein altes backup des Ordners ausfindig machen können und mal „rüber kopiert“. damit komme ich aber irgendwie nicht mehr per Web auf den Node, ssh funktioniert noch. Was sonst noch oder nicht mehr geht weiß ich aktuell nicht. Jedenfalls schmeißt das ausloggen nicht mehr sekündlich errors. LXC oder VM laufen aber nicht. Denke mal, dass liegt daran das der ZFS Storage nicht gelesen werden kann.

Die Frage ist wie ich nun am besten weiter vorgehe. Alle meine VMs, LXC und Disk habe ich per PBS gesichert. Des Weiteren liegen diese auch noch auf der zweiten Platte mit ZFS Verschlüsselung vor, keys alle zugreifbar. Hosts ist auf einer eigenen Platte.

Ich würde ganz gerne die Daten auf der zweiten Disk direkt wieder nutzen wollen. Spare ich mir sehr viel copy time vom PBS. Meine Idee ist den Node neu zu installieren - ist vielleicht für die Cluster Konf. auch nicht verkehrt und im Grunde auch kein großes Problem.

Frage ist nur wie bekomme ich dann den ZFS Storage wieder eingebunden damit ich die Daten weiter verwenden kann? Muss ich vorher die VM neu erstellen und dann ein Backup einspielen? Config des Stoarves habe ich aus dem /etc/PVE backup noch. Stehe da gerade etwas auf dem Schlauch wie die. Wage rangehensweise ist.

Danke euch für Rat.

Content-Key: 7433501609

Url: https://administrator.de/contentid/7433501609

Printed on: May 22, 2024 at 03:05 o'clock

Member: netzer2021
Solution netzer2021 Jul 11, 2023 at 20:51:35 (UTC)
Goto Top
simpler restore der daten von PBS hat alle Probleme und BEdenken gelöst