PXE Server: Ubuntu ISO bindet sich nicht unter mnt ein

matze2090
Hallo,

ich baue mir einen eigenen PXE Server unter CentOS.
Ich habe jetzt das Problem wenn ich eine ISO Mounten möchte kommt diese medlung:
mount: /var/lib/tftpboot/ISO/ubuntu-18.04.3-desktop-amd64.iso: failed to setup loop device: No such file or directory
Unter /var/lib/tftpboot/ISO liegt meine Ubuntu ISO.

capture

Mache es nach dieser Anleitung: YouTube-Link
An der stelle 9:50 bleibe kommt dann bei mir die Fehlermeldung.

Ich habe es auch mit einer CentOS ISO ohne Erfolg versucht.
Ich nutze ein CentOS 7.
Einen DHCP-Server läuft darauf nicht, dass soll meine pfSense übernehmen. Einen PXE-Server mit dnsmasq kommt bei mir nicht in Frage, da der DNS-Dienst 53 schon Pi-hole nutzt.

MfG

Content-Key: 530746

Url: https://administrator.de/contentid/530746

Ausgedruckt am: 20.01.2022 um 21:01 Uhr

Mitglied: LukasD
LukasD 03.01.2020 um 18:43:17 Uhr
Goto Top
Hi,

wurde denn das Verzeichnis "/mnt/iso" zuvor mit mkdir erstellt und passt die Schreibweise?
Mitglied: matze2090
matze2090 03.01.2020 um 18:57:27 Uhr
Goto Top
Ja das Verzeichnis wurde erstellt. Die Schreibweise sollte sowei auch passen.
Mitglied: LukasD
LukasD 03.01.2020 um 19:17:07 Uhr
Goto Top
einmal sprichst du von /var/lib/tftp/ und im befehl steht dann /tftpboot/. Sicher, dass die Pfade korrekt sind?
Mitglied: aqui
aqui 03.01.2020 aktualisiert um 19:36:27 Uhr
Goto Top
einmal sprichst du von /var/lib/tftp/ und im befehl steht dann /tftpboot/. Sicher, dass die Pfade korrekt sind?
Genau das fällt auch sofort auf ! Da stimmt ja was mit den Pfaden nicht ?!
Wäre für einen zielführende Antwort auch mal sehr hilfreich zu wissen welcher der zahllosen TFTP Server denn unter Ubuntu verwendet wurde und die entsprechende config und ggf. Default Datei dazu unter /etc. (Ohne sich zweifelhafte YouTubes ansehen zu müssen) Hier ist der TO ja leider mehr als oberflächlich in der Beschreibung. :-( face-sad
Mitglied: matze2090
matze2090 04.01.2020, aktualisiert am 05.01.2020 um 01:17:57 Uhr
Goto Top
@LukasD @aqui
Das war ein schreibfehler von mir. Ich habe gerade nochmals in meinem LXC geschaut. Der Pfad lautet: /var/lib/tftpboot/ISO wo das Ubuntu Image liegt.
Ich nutze das ganze unter Proxmox und unter einem LXC Container. Kann es sein das es mit einem LXC Conainer nicht funktioniert?

Hier ein Screenshot:
1
Heiß diskutierte Beiträge
question
Windows XP: IE 8 zeigt keine Seiten mehr an :-) gelöst altmetallerVor 1 TagFrageWindows XP21 Kommentare

Huhu, ich habe hier tatsächlich noch einen Dell Dimension 9100 (Pentium IV, 3Ghz) stehen, den ich mit einer NVIDIA Quadro FX 540 und 4GB RAM ...

question
Datensicherung nach Geschäftsaufgabefboy33Vor 1 TagFrageBackup8 Kommentare

Guten Tag liebe (ex) Kollegen, nun nach 50 Jahren EDV, habe ich meine Firma abgemeldet und bin in den Ruhestand gegangen. Mein Problem, was mache ...

question
Zu lange Glasfaserkabel in Netzwerkschrank - wie organisieren? gelöst HerrITVor 1 TagFrageNetzwerke7 Kommentare

Hallo liebe Administratoren, ich hätte eine Frage an euch Experten, für die ich - selbst nach stundenlanger Suche - keine richtige bzw. zufriedenstellende Antwort gefunden ...

question
Ethernet über Telefonleitung gelöst Net-ZwerKVor 1 TagFrageLAN, WAN, Wireless8 Kommentare

Moin! Ich suche einen Konverter, mit dem ich auf eine Telefonleitung (2 Draht) ein Netzwerksignal legen kann. Geht darum, dass ich beim einem Kunden einen ...

question
PLEX bricht im HEIMNETZ nach 1 Minute Film abStrahlemann-69Vor 1 TagFrageUbuntu9 Kommentare

Hallo an alle, ich hab mir den Plexserver auf Proxmox installiert und mein NAS eingebunden. Er ließt auch alles ein und funktioniert. Nun laß ich, ...

question
O365 Outlook + Teams sperren gelöst sraL91Vor 18 StundenFrageMicrosoft Office15 Kommentare

Hallo Zusammen, wir haben in unserer Firma Office 365 ausgerollt und ich stehe nun vor folgendem Problem. Unsere Firma sind in 50 Standorte unterteilt und ...

question
Image auf zweiten Laptop kopierenmario28Vor 1 TagFrageWindows Installation5 Kommentare

Hallo zusammen, ich habe mir für daheim zwei Mal den gleichen Laptop bestellt (Schenker Via 15 Pro M20) und nach Erhalten mit dem ersten begonnen, ...

question
MFA mit Microsoft?cseVor 15 StundenFrageWindows Userverwaltung5 Kommentare

Hi Leute, ich hoffe ihr könnt mir ein wenig helfen. Von unserer Gruppe (central IT im Ausland) verlange ich (im Zuge TISAX Audit) auf unseren ...