philipkurz
Goto Top

Rechner bedingt im Netzwerk

Der Rechner ist im Netzwerk eingebunden, erkennt aber keinen weiteren PC in der Arbeitsgruppe

Hallo und zunächst ein gesundes neues Jahr.

Auf folgendes Problem bin ich während meiner Eskapaden mit Windows XP und Netzwerkverbindugen via WLAN noch nicht gestoßen. Während ich hier also noch am "basteln" bin, schreibe ich diesen Beitrag -- vielleicht könnt ihr mir ja auf die Sprünge helfen.

Ich betreibe ein kleines Netzwerk mit 4 PCs und 3 Laptops. Über einen WLAN Router teilen sich alle Rechner die Internetverbindung und es findet (via WLAN) regelmäßiger Datenaustausch statt. Vor einer Woche musste ein System neu aufgesetzt werden und (natürlich) ergaben sich ein paar Probleme:

Nachdem der WLAN-Adapter für den Rechner installiert wurde, konnte dieser ohne Probleme eine Verbindung mit dem Router aufbauen und eine Internetverbindung herstellen. Um auch wieder Daten austauschen zu können wurde der Rechner der entsprechenden Arbeitsgruppe zugewiesen. Das eigentliche Problem ist nun, dass ohne Außnahme jeder Rechner auf die freigegebenen Ordner des neu aufgesetzten Systems zugreifen kann. Allerdings kann ich von dem neu aufgesetzten PC nicht "nach draußen gucken" -- jedenfalls nicht über die Windows Netzwerkumgebung. Die weiteren Rechner in der Arbeitsgruppe anpingen stellt kein Problem dar. Sobald ein Rechner auf einen freigegebenen Ordner zugreift wird mir unter den Sitzungen in der Computerverwaltung auch der Benutzer und der Computername angezeigt. Wenn ich jetzt bspw. diesen Computernamen direkt in die Suche eingebe bzw. unter "Ausführen" "\\COMPUTERNAME" eingebe, wird der Computer im Netzwerk angeblich nicht gefunden. Bei einer direkten Suche nach der IP Adresse eines Computers aus der Arbeitsgruppe verhält es sich gleich.

Also: Computer 1 ist im Netzwerk eingebunden; alle weiteren Rechner können auf ihn zugreifen; Computer 1 kann alle weiteren Rechner anpingen aber nicht "direkt" auf sie zugreifen (weder über die Netzwerkumgebung, noch über die "Ausführen"-Konsole oder eine Suche nach den IP Adressen).

Installiert ist übrigens nur die Windows Firewall, die ich auch schon in mehreren Versuchen deaktiviert und wieder hochgefahren habe (sowohl auf dem neu aufgesetztn System als auch bei den weiteren Rechnern) -- keine Veränderung.

Wie gesagt, ich bin hier mit einem Tässchen Kaffee weiter am probieren, aber evtl. hat jemand eine zündende Idee. Vielen Dank und Grüße aus Berlin.

Philip

Content-Key: 105107

Url: https://administrator.de/contentid/105107

Printed on: June 21, 2024 at 11:06 o'clock

Member: Fatboy
Fatboy Jan 03, 2009 at 16:10:46 (UTC)
Goto Top
Hast du Datei- und Druckerfreigabe auf dem LAN / WLAN Interface aktiviert? Ansonsten versuche es mal mit dem Netzwerkassistenten, da fragt er dann auch, ob du die Freigaben im Netzwerk machen möchtest.

Edit: Sorry, du kannst ja auf die anderen Rechner nicht zugreifen. Hatte mich verlesen.

Hast du XP Professional oder Home? Hast du auf allen Rechnern ein identisches Benutzerprofil (gleicher Name und Passwort)?
Member: philipkurz
philipkurz Jan 03, 2009 at 16:28:13 (UTC)
Goto Top
Ja, die Freigabe ist aktiviert. Prinzipiell besteht das Problem auch nicht bei der Freigabe -- alle Computer können auf die freigegebenen Ordner gucken. Vielleicht sollte ich auch erwähnen, dass das Netzwerk zwischen den restlichen Computern kein Problem ist. Dort liegt der Fehler also auch nicht.

Den Weg über den Netzwerkassistenten bin auch schon gegangen nachdem ich das neu aufgesetzte System "spaßenshalber" mit einem neuen Netzwerknamen in eine vollkommen neue Arbeitsgruppe gesteckt hatte -- auch hier kein Erfolg.

Aber schon einmal vielen Dank für die Hilfe.

/edit

Hehe, jetzt habe ich deinen bearbeiteten Beitrag gelesen.

Im Netzwerk hat jeder Rechner einen unterschiedlichen Benutzernamen/Computernamen und ist nicht mit einem Passwort geschützt. Überall läuft Windows XP Home Edition.
Member: aqui
aqui Jan 04, 2009 at 14:59:51 (UTC)
Goto Top
Hast du Rechnernamen und IP einmal statisch in die Datei lmhosts eingetragen ??

Die findest du unter c:\windows\system32\drivers\etc und sie ist selbsterklärend wenn du sie editierst !
In der Regel reicht der Computername und die IP.
Member: philipkurz
philipkurz Jan 04, 2009 at 16:56:02 (UTC)
Goto Top
Danke für den Tipp. Ich werde die Datei mal entsprechend bearbeiten und euch berichten.

Philip

/edit

Leider hat die Veränderung der lmhosts nicht gegriffen. Ich habe den selben Lösungsvorschlag auch noch von einer anderen Person durchführen lassen, um Rechtschreibfehler o.ä. auszuschließen.

Vielleicht hilft euch noch eine der Fehlermeldungen weiter. Wenn ich unter Ausführen den gewünschten Computernamen eingebe (z.B. "\\LAPTOP_EINS") wird mir folgendes ausgegeben: "Der angegebene Netzwerkpfad wurde von keinem Netzwerkdienstanbieter angenommen." Bei allen restlichen Systemen -- ohne Ausnahme -- führt die gleiche Eingabe zur Öffnung der entsprechenden Netzwerkressource. Das verhärtet meiner Meinung nur weiter den Verdacht, dass bei dem neu aufgesetzten System bestimmte Konfigurationsdaten fehlen. Kann es sein, das dem Betriebssystem bestimmte Algorithmen fehlen, um die Netzwerkressource auszulesen? Das er prinzipiell die Computernamen/Benutzer im Netzwerk erkennt zeigt mir wie gesagt die Sitzunganzeige in der Computerverwaltung.

Weiterhin vielen Dank für eure Bemühungen. Philip
Member: aqui
aqui Jan 05, 2009 at 09:09:36 (UTC)
Goto Top
Was passiert denn wenn du statt des Namens von LAPTOP_EINS einmal seine nackte IP Adresse nimmst ??
Also Ausführen -> \\172.16.1.100 z.B. ???

Die aktuelle IP bekommst du raus wenn du einmal ipconfig in der Eingabeaufforderung von LAPTOP_EINS eingibst !

Du kannst testen ob die lmhosts sauber gelesen wird auf dem PC wo du sie eingerichtet hast.
Steht dort z.B. in einer Zeile:

172.16.1.100 LAPTOP_EINS

Kannst du dort in der Eingabeaufforderung einmal ping LAPTOP_EINS eingeben.
Dann sollte er sagen:

Ping LAPTOP_EINS [172.16.1.100] mit 32 Bytes Daten:

Anhand der richtigen Namens zur IP Auflösung in der eckigen Klammer kannst du dann sehen das die lmhosts sauber gelesen und ausgeführt wurde !!!
Member: philipkurz
philipkurz Jan 05, 2009 at 11:50:31 (UTC)
Goto Top
Wie ich eingangs erwähnt hatte, stellt das anpingen von allen restlichen System im Netzwerk kein Problem dar -- das ist es ja, was mich ein wenig an meinem Verstand zweifeln lässt. ;)

Irgendwie scheint der "Problemrechner" über das anpingen Pakete an die weiteren Rechner zu senden und von ihnen zu empfangen. Wenn ich aber die entsprechende Netzwerkressource öffnen möchte (auch über eine direkte Eingabe der IP Adresse in der Eingabeaufforderung), will er sie auf einmal nicht mehr kennnen.
Member: aqui
aqui Jan 05, 2009 at 12:43:58 (UTC)
Goto Top
Das kann dann nur ein Firewall Problem sein oder Reste einer vormals installierten Firewall...andere Ursachen bleiben nicht mehr übrig...
Member: rs----
rs---- Feb 27, 2009 at 16:32:22 (UTC)
Goto Top
um mich hier nochmal fatboy anzuschließen ! mal ganz oll gefragt .. du hast bei diesem rechner schon die datei und drucker freigabe aktiv ?
siehe interface - eigenschaften ? schau doch einfach nochmal nach ... ich tendiere schwer hierzu
was ist wenn du auf diesem computer \\diesercomputer eingibst ?


;)

grüsse