Routing unter Debian

samsx87
Hallo zusammen

Ich habe ein Problem mit dem routing unter debian.
Mein Netzwerk sieht wie folgt aus:

WAN
|
|
Router 192.168.1.1
(Routet das 10.0.0.0 Netz nach 192.168.1.5) ------------------ Windows XP PC (192.168.1.2)
|
|
Netz 1:
Netmask: 192.168.1.0
Subnetzmask: 255.255.255.0
Standartgateway 192.168.1.1
|
|
eth0 (192.168.1.5)
Debian (welcher als Router fungieren soll)
eth1 (10.0.0.1)
|
|
Netz 2:
Netmask: 10.0.0.0
Subnetmask: 255.0.0.0
Stabdartgateway: 10.0.0.1
|
|
Windows 2003 Server (10.0.0.2)

Wie kann ich nun den Debian Rechner als Router (inkl. NAT) konfigurieren?

Das pingen von 192.168.1.2 nach 10.0.0.1 sowie umgekehrt funktioniert
Das pingen von 10.0.0.2 nach 10.0.0.1 funktioniert, jedoch NICHT umgekehrt
Das pingen von 10.0.0.2 nach 192.168.1.2 funktioniert in beide Richtungen NICHT

Die routing Tabelle auf dem Debian Rechner sieht wie folgt aus:

192.168.1.0 * 255.255.255.0 U 0 0 0 eth0
10.0.0.0 * 255.0.0.0 U 0 0 0 eth1
default 192.168.1.1.loc 0.0.0.0 UG 0 0 0 eth0

Content-Key: 67331

Url: https://administrator.de/contentid/67331

Ausgedruckt am: 08.12.2021 um 23:12 Uhr

Mitglied: Dani
Dani 28.08.2007 um 19:02:09 Uhr
Goto Top
Hallo samsx87,
also hier gibts n prima Tutorial von aqui dazu. Funktioniert sowohl unter Linux als auch unter Windows.


Grüße
Dani
Nächstes mal bitte die Suche benutzen!!
Mitglied: samsx87
samsx87 28.08.2007 um 20:47:01 Uhr
Goto Top
Vielen Dank für die Antwort!
Habe das Tutorial durchgelesen, jedoch bin ich immer noch gleich weit wie am Anfang :-( face-sad

Kann mir jemand helfen?
Mitglied: aqui
aqui 02.09.2007 um 16:25:59 Uhr
Goto Top
...Das pingen von 10.0.0.2 nach 10.0.0.1 funktioniert, jedoch NICHT umgekehr t

Das hat natürlich mit deinem Debian Router rein gar nichts zu tun, denn das ist mit Sicherheit eine Firewall Einstellung a.) unter Windows und/oder b.) unter Linux.
Lokale Firewalls musst du für ICMP Echo Packete (Ping) öffnen. Wie man das unter Windows macht ist einfach:
Eigenschaften LAN Verbindung -> Erweitert -> Windows Firewall Einstellungen -> Erweitert -> ICMP Einstellungen -> Hier den Haken setzen bei Eingehende Echoanforderungen zulassen !!!

Bei Linux dürfte es analog sein obwohl Ping dort in der Regel per Default geht.

Ggf. ist das das Problem aller deiner Ping Tests, deshalb macht es am meisten Sinn erstmal das funktionierende Routing des Routers zu verifizieren indem man die Interface des Routers pingt (Debian) aus dem jeweiligen anderen Netz und nicht gleich 2 Endgeräte mit unkalren Firewall Settings :-( face-sad.
Also folgendes solltest du zuerst machen:
  • Ein Ping auf eth0 (192.168.1.5) aus dem 10er Netz
  • Ein Ping auf eth1 (10.0.0.1) aus dem 192.168.1er Netz
  • Ein Ping aus dem 10er Netz auf den DSL Router 192.168.1.1

Das muss auf alle Fälle beidseitig funktionieren und damit hätte man dann grundsätzlich das funktionierende Routen der Debian Maschine geprüft !!!

Wenn du dir das Tutorial durchgelesen hast wird dir nicht entgangen sein das du zwingend eine statische Route auf dem DSL Router benötigst die da lautet:
Zielnetz: 10.0.0.0, Maske: 255.0.0.0, Gateway: 192.168.1.5

Das ist zwingend erforderlich sonst kann der DSL Router keine Packete ins 10er Netz routen.

Das du natürlich den Debian Rechner in der sysconfig auf IP Forwarding gesetzt hast bzw. diesen Parameter aktiviert hast mit einem anschliessenden Reboot sei hier mal vorausgesetzt, denn sonst routet der Debian Rechner nicht !!!
Mitglied: samsx87
samsx87 02.09.2007 um 16:37:46 Uhr
Goto Top
Vielen Dank für deine Antwort!
Das Problem wart tatsächlich die Windows Firewall :( face-sad
Mitglied: aqui
aqui 02.09.2007 um 16:39:18 Uhr
Goto Top
Ist es hier im Forum in 98% aller Fälle bei Verbindungsproblemen....du bist also in guter Gesellschaft ;-) face-wink
Heiß diskutierte Beiträge
question
Software für Echtzeit-BenachrichtigungGregor81Vor 1 TagFrageMicrosoft16 Kommentare

Hallo zusammen, bin auf der Suche nach einer Software wo man auf die Client`s Benachrichtigungen verschicken kann, z.b. wenn der Exchange nicht geht oder wenn ...

question
Telekom Glasfaser mit Mikrotik RB4011iGS-RM Lan ohne Internet gelöst schmidtz78Vor 1 TagFrageLAN, WAN, Wireless23 Kommentare

Hallo und viele Grüße an alle, ich möchte gerne von meinem OPNsense Router auf Mikrotik umsteigen und bekomme es leider nicht hin das ich mit ...

question
Ich wünschte, ich wäre Magenta. 2-3 Tage Urlaub - ohne Angabe der Rückkehrvafk18Vor 1 TagFrageCloud-Dienste20 Kommentare

Als ich vor eingen Tagen die Werbung vernahm, daß Magenta-Kunden ein 100GB-Datenvolumen geschenkt kriegen, das sie allerdings bis Ende des Jahres verbrauchen müssen, es ansonsten ...

question
Backupkontrollkonzept überarbeiten( von Papier auf digital ) gelöst truustyyVor 1 TagFrageBackup16 Kommentare

Hey Leute, ich bräuchte mal eure Hilfe. Und zwar kontrolliere Ich täglich Backups von mehreren Kunden von uns. Ich kriege täglich Mails von verschiedenen Backupsoftwares ...

question
VmWare VSphere 7 Essentials gelöst Ueba3baVor 1 TagFrageSonstige Systeme13 Kommentare

Hallo, ich bin auf dieses Angebot gestoßen: Hat jemand damit schon Erfahrung? Ich finde dieses Angebot sehr günstig und ziehe es in Erwägung, es zu ...

general
Chatbox in dem ForumITghostVor 1 TagAllgemeinWünsch Dir was19 Kommentare

Hey Liebe Administratoren von Administrator.de :) ! Wie wäre es mit einer Chatbox hier im Forum? Falls man mal schnell was ansprechen möchte, dass keinen ...

question
OEM Rechner verlieren teilweise Windows10 AktivierungLaBombaVor 1 TagFrageWindows 107 Kommentare

Hallo, wir haben hier einige Dell Rechner die ihre Windows Aktivierung verlieren, leider kann ich keinen Grund dafür finden. Von heute auf Morgen meldet sich ...

question
OPNsense + Cisco SG250 + IGMP Proxy für Magenta TV nur IGMPv2pppeddVor 1 TagFrageNetzwerke9 Kommentare

Hallo, ich bekomme MagentaTV mit der OPNsense und Cisco Switches nicht zum Laufen. Die Switches zeigen mir mit nachfolgender Konfiguration alle Multicast-Ports im IGMP Compatibility ...